Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

Style & CSS


Accueil

Accueil CHM


Préfixes du Système international d'unités

Un article de Wikipédia, l'encyclopédie libre. Aller à : navigation, rechercher

Préfixes courants

Préfixes du Système international d'unités et noms des nombres correspondants
1000m | 10n | Préfixe français | Symbole | Depuis [note 1] | Nombre décimal | Désignation [note 2]
10008 | 1024 | yotta | Y | 1991 | 1 000 000 000 000 000 000 000 000 | Quadrillion
10007 | 1021 | zetta | Z | 1991 | 1 000 000 000 000 000 000 000 | Trilliard
10006 | 1018 | exa | E | 1975 | 1 000 000 000 000 000 000 | Trillion
10005 | 1015 | péta | P | 1975 | 1 000 000 000 000 000 | Billiard
10004 | 1012 | téra | T | 1960 | 1 000 000 000 000 | Billion
10003 | 109 | giga | G | 1960 | 1 000 000 000 | Milliard
10002 | 106 | méga | M | 1960 | 1 000 000 | Million
10001 | 103 | kilo | k | 1795 | 1 000 | Millier
10002/3 | 102 | hecto | h | 1795 | 100 | Centaine
10001/3 | 101 | déca | da | 1795 | 10 | Dizaine
10000 | 100 | (aucun) | — | — | 1 | Unité
1000−1/3 | 10−1 | déci | d | 1795 | 0,1 | Dixième
1000−2/3 | 10−2 | centi | c | 1795 | 0,01 | Centième
1000−1 | 10−3 | milli | m | 1795 | 0,001 | Millième
1000−2 | 10−6 | micro | µ | 1960 [note 3] | 0,000 001 | Millionième
1000−3 | 10−9 | nano | n | 1960 | 0,000 000 001 | Milliardième
1000−4 | 10−12 | pico | p | 1960 | 0,000 000 000 001 | Billionième
1000−5 | 10−15 | femto | f | 1964 | 0,000 000 000 000 001 | Billiardième
1000−6 | 10−18 | atto | a | 1964 | 0,000 000 000 000 000 001 | Trillionième
1000−7 | 10−21 | zepto | z | 1991 | 0,000 000 000 000 000 000 001 | Trilliardième
1000−8 | 10−24 | yocto | y | 1991 | 0,000 000 000 000 000 000 000 001 | Quadrillionième
  1. ↑ Le système métrique fut introduit en 1793 avec huit préfixes (deux n'ont pas été conservés). La date inscrite dans la colonne est celle à laquelle l'unité a été reconnue par une résolution de la CGPM .
  2. ↑ L' échelle longue utilisée ici est la référence dans les pays francophones, notamment en France, au Canada, ainsi que généralement en Europe (sauf en Grande-Bretagne). L' échelle courte est utilisée avant tout par les États-Unis d'Amérique, le Brésil, la Grande-Bretagne et les autres pays de langue anglaise (sauf le Canada).
  3. ↑ La reconnaissance en 1948 du micron par la CGPM a été abrogée en 1967. Les anglophones utilisent souvent le u minuscule au lieu du µ, par exemple dans les schémas électroniques (où on trouve uF/uH au lieu de µF/µH pour micro Farad/micro Henry), le clavier qwerty étant dépourvu de ce caractère.

Exemples

5 cm = 5×10–2 m = 5 × 0,01 m = 0,05 m

3 MW = 3×106 W = 3 × 1 000 000 W = 3 000 000 W

Étymologie

Telle qu'elle a été relevée sur le Wiktionnaire.

  • yotta- : du grec ὀκτώ, okto, « huit », et par déformation, car 1024 = 10008.
  • zetta- : de la lettre grecque ζ zeta (du grec ζῆτα, sept [1]), car 1021 = 10007. Un préfixe de la même valeur, hepta-, avait été introduit de façon non officielle avant l'adoption de zetta-. Formé sur le grec ἑπτά, hepta, « sept », il est maintenant obsolète.
  • exa- : du grec ἕξ, hex, « six » (avec omission du h initial), car 1018 = 10006.
  • péta- : du grec πέντε, pente, « cinq », et par déformation, car 1015 = 10005.
  • téra- : du grec τέρας, teras, « monstre » ;
  • giga- : du grec γίγας, gigas, « géant » ;
  • méga- : du grec μέγας, megas, « grand » ;
  • kilo- : du grec χίλιοι, chilioi, « mille » ;
  • hecto- : du grec ἑκατόν, hekaton, « cent » ;
  • déca- : du grec δέκα, deka, « dix » ;
  • déci- : du latin decimus, « dixième » ;
  • centi- : du latin centum, « cent ».
  • milli- : du latin mille, « un millier » ;
  • micro- : du grec μικρός, mikros, « petit » ;
  • nano- : du grec νάνος, nanos, « nain » ;
  • pico- : de l'italien piccolo, « petit » ;
  • femto- : du danois femten, « quinze », car 10−15 ;
  • atto- : du danois atten, « dix-huit », car 10−18 ;
  • zepto- : du latin septem, « sept », et par déformation, car 10−21 = 1000−7 ;
  • yocto- : du grec ὀκτώ, okto, « huit », et par déformation, car 10−24 = 1000−8.

Cas de l'informatique

Article connexe : préfixe binaire.

En informatique, les capacités mémoires sont en général des multiples de puissances de 2. Pour cette raison, les informaticiens de la première heure avaient l'habitude d'utiliser les préfixes kilo, méga, etc. comme des puissances de 210, soit 1 024. Toutefois la Commission électrotechnique internationale préconise, dans sa norme 60027-2, qui date de 1998, l'usage de préfixes binaires, afin d'éviter tout malentendu, même entre informaticiens[note 1]. Il est donc préférable d'utiliser ces préfixes (kibi = Ki = 1024, mébi = Mi = 10242, gibi = Gi = 10243, etc.), et de laisser aux préfixes SI leur sens recommandé (kilo = k = 1000, méga = M = 10002, giga = G = 10003, etc.).

Les fabricants et vendeurs de supports informatiques ne s'y sont pas trompés : ils préfèrent l'usage des préfixes SI, ce qui leur permet d'afficher des capacités apparemment plus importantes. Ainsi un disque dur d'une capacité de 1 téraoctet correspondrait, avec les préfixes binaires, à une capacité de 931 gibioctets, qui serait moins impressionnante pour le profane (contrairement aux mémoires RAM, les capacités des disques durs ou flash ne présentent pas d'intérêt électronique à être des puissances de 2)

Anciens préfixes

Certains préfixes ont été utilisés dans d'anciennes versions du système métrique, mais ne font plus partie du Système international officiel.

Les préfixes myria (ma et alternativement myrio, pour 10 000, mo) viennent du grec μύριοι (mýrioi) dix mille [2] .

Ces préfixes, adoptés en 1793, n'ont pas été retenus lorsque les préfixes furent fixés une première fois par la 11e CGPM de 1960.

Anciens multiples et sous-multiples [3]
10 N | Préfixe | Symbole | Multiplicateur
104 | myria | ma | Dix mille
10−4 | décimilli | dm | Dix-millième

Notes et références

Notes

  1. ↑ Confusion entre le Mo des informaticiens (1 024 × 1 024 octets) et le Mo/MByte des spécialistes réseau (1 000 × 1 000 octets/bytes).

Références

  1. ↑ Dans la numération grecque, la lettre Z valait 7, même si c'est la sixième lettre de l'alphabet. En effet la valeur 6 était représentée soit par le stigma (ϛ), soit par le digamma (ϝ).
  2. ↑ http://www.littre.org/definition/myriamètre [ archive ]
  3. ↑ Edinburgh Encyclopedia [ archive ].

Voir aussi

Articles connexes

  • Nom des grands nombres
  • Unité en aviation
  • Bureau international des poids et mesures
  • Préfixe binaire

Lien externe

  • Liste officielle du BIPM [ archive ]
[afficher] v · m Préfixes du Système international d'unités
Sous-multiples
Préfixe | yocto - | zepto - | atto - | femto - | pico - | nano - | micro - | milli - | centi - | déci -
Symbole | y | z | a | f | p | n | μ | m | c | d
Facteur | 10−24 | 10−21 | 10−18 | 10−15 | 10−12 | 10−9 | 10−6 | 10−3 | 10−2 | 10−1
Multiples
Préfixe | déca - | hecto - | kilo - | méga - | giga - | téra - | péta - | exa - | zetta - | yotta -
Symbole | da | h | k | M | G | T | P | E | Z | Y
Facteur | 101 | 102 | 103 | 106 | 109 | 1012 | 1015 | 1018 | 1021 | 1024

[afficher] v · m Système international d'unités
Unités de base | ampère · candela · kelvin · kilogramme · mètre · mole · seconde
Unités dérivées | becquerel · coulomb · degré Celsius · farad · gray · henry · hertz · joule · katal · lumen · lux · newton · ohm · pascal · radian · siemens · sievert · stéradian · tesla · volt · watt · weber
Préfixes | yocto · zepto · atto · femto · pico · nano · micro · milli · centi · déci · déca · hecto · kilo · méga · giga · téra · péta · exa · zetta · yotta
Nouvelles définitions du Système international d'unités · Ordre de grandeur
[afficher] v · m Principaux systèmes d'unités
Système international | Unités de base · Unités dérivées · Préfixes du Système international d'unités · Nouvelles définitions du Système international d'unités
Système CGS centimètre · gramme · seconde
Système astronomique unité astronomique · masse solaire · jour
Système d'unités naturelles Système d'unités géométriques · Unités de Planck
 · Analyse dimensionnelle · Grandeur sans dimension · Effet d'échelle
Systèmes de mesure anciens
Systèmes désuets | Unités de mesure chinoises · Unités de mesure dans l'Égypte antique · Unités de mesure romaines · Unités françaises de mesure anciennes · Unités espagnoles de mesure anciennes · Unités maltaises de mesure anciennes
Systèmes traditionnels | Unités de mesure anglo-saxonnes · Unités de mesure américaines · Unités de mesure thaïlandaises
Systèmes spécifiques | Système des apothicaires
Grandeur physique · Constante physique · Ordre de grandeur · Unité de mesure · Unité fondamentale · Unité réduite · Conversion des unités · Métrologie
[afficher] v · m Ordres de grandeur
Concentration · Densité surfacique · Données · Énergie · Fréquence · Longueur · Masse · Masse volumique · Monétaire · Nombres · Pression · Puissance · Superficie · Température · Temps · Vitesse · Volume
Préfixes du Système international d'unités · Système d'unités naturelles


Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Type/InventGr.htm

CLASSIFICATION DES NOMBRES

Diagramme de Venn

Graphe avec exemples de nombres

Voir Définition de chacun / Nombres décimaux / Développement décimal

Précisions sur le bas de ce tableau

1) Rationnel est un autre mot pour dire fractions. Toutes sortes de fractions :

* positives (3/2) ou négatives (- 1/3);

* que l'écriture décimale soit finie (1/2 = 0,5) ou infinie (1/3 = 0,333…);

* réduites (3/7) ou non simplifiées (9/21 = 3/7);

* explicites (4/5) ou implicites (3 = 3/1 = 9/3 = …).
Dit-autrement: les entiers sont des fractions;

* écrites sous forme de fractions (1/7) ou en utilisant leur développement décimal (0,142857142857142857…).
Note: alors le développement décimal est toujours fini (1/8 = 0,125) ou infini répétitif (1/9 = 0,111…).

2) Justement, parmi les rationnels , les fractions au sens large, on peut distinguer:

* les nombres entiers (positifs et négatifs, appelés relatifs); ce sont de "fausses fractions" en N = N/ 1 , et

* les "vraies" fractions avec un dénominateur autre que 1 .

3) Finalement, les entiers relatifs , les nombres peuvent être

* positifs : ceux qui servent à compter les objets, ou

* négatifs : ceux qui servent à compter les objets que l'on a prêtés.
Note sur les nombres relatifs, ceux servant à donner une mesure, à exprimer une grandeur:

* -10°C est un entier relatif, mais

* -10,3°C est un rationnel négatif (= -103/10 °C).

Autre façon de les présenter

D'après une présentation de Norbert Verdier

Un autre ensemble particulier de nombres

est l'ensemble des nombres complexes de module 1 (sur le cercle unité).

C'est le groupe des unités de [image] .


Linear - Logarithmic frequency Audio

Notes Musicales sur 6 Octaves

                /* Include C

                 MUSIQUE NOTE (Audio fréquence en Hertz) sur 6 octaves 	(Valeur nummérique sans décimles)

                 A la    B si    C do    D re    E mi    F fa    G sol

                 */

                #define   DO8   4186

                #define   SI7   3951
                #define  LA#7   3729
                #define   LA7   3520
                #define sol#7   3332
                #define  sol7   3136
                #define  FA#7   2960
                #define   FA7   2793
                #define   MI7   2637
                #define  RE#7   2489
                #define   RE7   2349
                #define  DO#7   2217
                #define   DO7   2093

                #define   SI6   1976
                #define  LA#6   1865
                #define   LA6   1760
                #define sol#6   1661
                #define  sol6   1568
                #define  FA#6   1480
                #define   FA6   1397
                #define   MI6   1319
                #define  RE#6   1245
                #define   RE6   1175
                #define  DO#6   1109
                #define   DO6   1047

                #define   SI5    988
                #define  LA#5    932
                #define   LA5    880
                #define sol#5    831
                #define  sol5    784
                #define  FA#5    740
                #define   FA5    698
                #define   MI5    659
                #define  RE#5    622
                #define   RE5    587
                #define  DO#5    554
                #define   DO5    523

                #define   SI4    494
                #define  LA#4    466
                #define   LA4    440     // diapason LA 440Hz
                #define sol#4    415
                #define  sol4    392
                #define  FA#4    370
                #define   FA4    349
                #define   MI4    330
                #define  RE#4    311
                #define   RE4    294
                #define  DO#4    277
                #define   DO4    262

                #define   SI3    247
                #define  LA#3    233
                #define   LA3    220
                #define sol#3    208
                #define  sol3    196
                #define  FA#3    185
                #define   FA3    175
                #define   MI3    165
                #define  RE#3    156
                #define   RE3    147
                #define  DO#3    139
                #define   DO3    131

                #define   SI2    124
                #define  LA#2    116
                #define   LA2    110
                #define sol#2    104
                #define  sol2     98
                #define  FA#2     92
                #define   FA2     87
                #define   MI2     82
                #define  RE#2     78
                #define   RE2     73
                #define  DO#2     69
                #define   DO2     65

Sound MIDI


noms des petits et des grands nombres

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Nombre/Gdnombre.htm

Préfixes MULTIPLICATEURS & DIVISEURS

Tous les noms et notations des

PETITS & GRANDS NOMBRES

L'argent, chez Yumimoto , dépassait l'entendement humain. À partir d'une certaine accumulation de zéros , les montants quittaient le domaine des nombres pour entrer dans celui de l'art abstrait.

Amélie Nothomb

NOMS des petits & grands NOMBRES
Valeur | Puissance | Nom français | Préfixe | Symbole | Particulier | Étranger | Voir
 |  | – Infini |  |  |  |  | >>>
 | 10 – Ngrand |  |  |  |  |  | >>>
 | 10 -24 |  | yocto | y |  |  |
 | 10 -21 |  | zepto | z |  |  |
 | 10 -18 |  | atto | a |  |  | >>>
 | 10 -15 |  | femto | f | fermi |  | >>>
 | 10 -12 |  | pico | p |  |  | >>>
 | 10-10 |  |  |  | Anström |  | >>>
 | 10 -9 | Un milliardième | nano | n |  |  | >>>
0,000 001 | 10 -6 | Un millionième | micro |  |  |  | >>>
0,000 01 | 10 -5 |  |  |  | centimilli |  |
0,000 1 | 10 -4 |  |  |  | decimilli ou dimi |  |
0,001 | 10 -3 | Un millième | milli | m |  |  | >>>
0,01 | 10 -2 | Un centième | centi | c |  |  | >>>
0,1 | 10 -1 | Un dixième | déci | d |  |  | >>>

0 |  | Zéro |  |  |  |  | >>>
1 | 10 0 | Un |  |  |  |  | >>>
5 |  | Cinq |  |  | lustre (5 ans) |  | >>>
10 | 101 | Dix | déca | da | décade (10 jours) décennie (10 ans) |  | >>>
20 |  | Vingt |  |  |  | score | >>>
100 | 102 | Cent | hecto | h | hécatombe quintal (100kg) siècle (100 ans) |  | >>>
1 000 | 103 | Mille | kilo | k |  |  | >>>
1 024 | 210 |  |  |  | kilo ( info ) |  | >>>
10 000 | 104 |  |  |  | myriade | ban , wan sahasram |
100 000 | 105 |  |  |  | hectokilo | lack |
1 000 000 | 106 | Million | Méga | M |  | million baiwan | >>>
1 048 576 | 220 |  |  | M | méga (info) |  | >>>
 | 107 |  |  |  |  | crore |
 | 108 |  |  |  | octade | yi |

109 | Milliard | Giga | G |  | Billion | >>>
230 |  |  | G | giga ( info ) |  | >>>
1012 | Billion | Téra | T |  | Trillion zhao | >>>
1015 |  | Péta | P |  | Quatrillion | >>>
1016 |  |  |  |  | jing |
1018 | Trillion | Exa | E |  | Quintillion | >>>
1021 |  | Zêta | Z |  | Sextillion | >>>
1024 | Quatrillion | Yotta | Y |  | Septillion | >>>
1027 |  |  |  |  | Octillion |
1030 | Quintillion |  |  |  | Nonillion | >>>
1033 |  |  |  |  | Decillion | >>>
1036 | Sextillion |  |  |  | Undecillion |
1039 |  |  |  |  | Duodecillion |
1042 | Septillion |  |  |  | Tredecillion |
1045 |  |  |  |  | Quattuordecillion |
1048 | Octillion |  |  |  | Quindecillion |
1051 |  |  |  |  | Sexdecillion |
1054 | Nonillion |  |  |  | Septendecillion |
1057 |  |  |  |  | Octodecillion |
1060 | Décillion |  |  |  | Novemdecillion |
1063 |  |  |  |  | Vigintillion |
1066 | Undécillion |  |  |  |  |
1072 | Duodécillion |  |  |  |  |
1078 | Trédécillion |  |  |  |  |
1084 | Quatuordécillion |  |  |  |  |
1090 | Quindécillion |  |  |  |  |
1096 | Sexdécillion |  |  |  |  |

10100 |  | Gogol |  | >>>
10102 | Septendécillion |  |  |
10108 | Octodécillion |  |  |
10114 | Novemdécillion |  |  |
10120 | Vigintillion |  |  |
10140 |  |  | Asankhyeya |
10144 | Quattuorvigintillion |  |  |
10303 |  |  | Centillion |
10 600 | Centillion |  |  | >>>
10 6 000 | Millillion |  |  | >>>
10 35 659 ! | 1 000 ! ( factorielle 1000) | = 2, 846 10 35 659 |  |
10 60 000 | Myrillion |  |  |
10 456 573 | 10 000 ! |  |  |
10 6 000 000 | Millimillillion |  |  |
10 gogol |  | Gogolplex |  | >>>
10 gogolplex |  | Gogolplexplex |  |
10Ngrand |  |  |  | >>>
 | Infini |  |  | >>>
 | Aleph |  |  | >>>
 | Infinitésimaux |  |  | >>>

Français et étranger

Le système utilisé par les Français est le système à échelle longue utilisée aussi par la plupart des pays latins. Alors que le système étranger est en fait le système à échelle courte utilisé par les anglo-saxons.

Pour éviter les confusions, mieux vaut préciser le nombre par sa puissance de dix. Demeure le cas source d'erreur du billion américain qui vaut un milliard français (109).

OBSERVATIONS

Notation de milliard

* Scientifique | G | pour giga
* Informatique | G | pour giga et un peu plus
* Financière | mM mrds | pour mille millions pour milliards
* Littéraire | Md | pour milliard

Dommage pour l'harmonisation!

* Le mot " milliard " a été introduit par Pelletier vers 1550.

* Les n. millions ont été construits au XVIe siècle.

Note:

* Pelletier est aussi l'auteur de " discours sur l' ortografe ".

Qui a bien pu passer derrière pour compliquer l'orthographe?

Milliasse

* M. Barrême , qui a donné son nom au barème, introduisit un autre mot qui n'a pas résisté au temps: " milliasse " qui valait mille milliards (1012). Il faut bien dire que, même les dictionnaires entretenaient la confusion entre billion synonyme de milliard ou de mille milliards ou de million de millions.

Normalisation

* En 1948, la Conférence des Poids et Mesures a conseillé d'utiliser la notation donnée dans le tableau ci-dessus pour la France.

* Celà est rappelé dans le Journal Officiel de 1961: on met un petit point à chaque paquets de 6 chiffres et on donne le nombre de fois millions, autant que de paquets: billion, trillion...

Baptême en illion

(106) n | n. millions
(106) 2 | bi million => billion

Attention aux étrangers

 | France | GB | EU*
Milliard | 109 | 109 | -
Billion | 1012 | 1012 | 109
Trillion | 1018 | 1018 | 1012
Qua t rillion | 1024 | 1024 | 1015

* aussi, Italie et quelques autres pays

Notez: quatri et non quadri (cependant mentionné dans certains dictionnaires, mais pas dans le Larousse).

SPÉCIFIQUES

 | Occidental | Inde | Japon | Chine | Sanskrit
5 | lustre (années) |  |  |  |
7 | pléiade |  |  |  |
12 | douzaine |  |  |  |
20 | score |  |  |  |
144 | grosse |  |  |  |
10² | hécatombe |  |  |  |
104 | myriade |  | ban | wan shiwan | Sahasram
105 |  | lack * |  |  |
106 |  |  |  | baiwan |
107 |  | crore * |  | qianwan |
108 |  |  |  | yi |
1012 |  |  |  | zhao |
1016 |  |  |  | jing |
1044 |  |  |  | zai ( usuel ) |
1053 |  | Tallakshana |  |  |
10100 | gogol |  |  |  |
104096 |  |  |  | zai ( originel ) |
10 gogol | gogolplex |  |  |  |
10 140 |  | Asankhyeya |  |  |

ÉTYMOLOGIE

Atto

1964

Atten

= 18

danois

Centi

1793

centum

= 100

latin

Déca

deka

= 10

grec

Déci

décimus

= 1/10

latin

Exa

hexa

= 6

grec

Exa

hex

= 6

grec

Femto

1964

femten

= 15

danois

Giga

1960

gigas

= géant

grec

Hecto

hekaton

= 100

grec

Kilo

khilioi

= 1 000

grec

Méga

1919

megas

= grand

grec

Micro

mikros

= petit

grec

Milli

mille

= 1000

latin

Nano

1960

nannos

= nain

grec

Péta

penta

= 5

grec

Pico

1960

piccolo

= petit

italien

Téra

1960

teras

= monstre

grec

Yocto

1991

= 24

invention

Yotta

1991

= 24

invention

Zepto

1991

= 21

invention

Zetta

1991

= 21

invention

* Les quatre derniers préfixes commencent par les lettres de l'alphabet latin, mais en commençant par la fin (Conférence Générale des poids et mesures - Sèvres).

* Cette même conférence a décidé que ces préfixes désignent des puissances de 10 et non, comme en informatique, les puissances de 2 voisines.

ENGLISH CORNER

* Large numbers ( parfois big numbers).

* Zillions pour désigner tous les nombres en – illion .

* American value: short scale pour les noms à l'américaine.

* European value: long scale pour les noms à l'européenne.

Leçon d'arithmétique avec Eugène Ionesco (1950)

Écrire ce nombre avec la notation américaine :

19 1018 390 1015 2 1012 144 109 219 106 164 103 508.

Ce qui donne en nombre classique.

19 390 002 144 219 164 508.

Qui se lirait en français:

19 trillions 390 002 billions 144 milliards 219 millions 164 mille 508.

Ou en toutes lettres:

Dix-neuf- trillions -
trois-cent-quatre-vingt-dix-mille-deux- billions -
cent-quarante-quatre- milliards -
deux-cent-dix-neuf- millions -
cent-soixante-quatre- mille -
cinq-cent-huit .


Vu dans ... http://www.positron-libre.com/cours/electronique/resistances/serie-resistance.php

Les valeurs normalisées des séries de résistances

Les valeurs normalisées des résistances les plus utilisées se situent entre 10 ohms et 1 mégaohm. On utilise néanmoins des valeurs inférieures à l'ohm (résistances de mesure de courant) et des valeurs supérieures au mégaohm (résistances dans les montages haute tension ou à haute impédance).

La Série Renard formule d'une valeur n

Avec n le nombre total d'éléments et m le rang d'un élément ( m de 1 à n ). Et pour raison géométrique 10^(1/n).

Une partie de la normalisation s’est effectuée en utilisant des séries de Renard : Charles Renard, officier du génie, spécialiste des aérostats (dirigeables, montgolfières) avait constaté en 1870 que l’armée utilisait 425 câbles de divers diamètres pour l’attache et la construction de ces appareils. Il calcula que 17 devaient suffire ; les diamètres étant en progression géométrique qu’il s’agirait de définir par classes. Il créa alors les séries portant son nom : Ra5 (ou encore R5), Ra10, Ra20, etc.
La série R5, par exemple, définit la progression géométrique de 1er terme u0=1, de dernier terme u5=10 ; sa raison est donc racine cinquième de 10.
On obtient les termes de R5 en multipliant par 10 et en arrondissant à l'entier le plus proche : 10, 16, 25, 40, 63, 100.
La série R10 intercale un terme moyen géométrique entre deux termes consécutifs de la suite R5. Sa raison est donc racine dixième de 10 : 10, 13, 16, 20, 25, 32, 40, 50, 63, 79, 100.
La série R20 s’obtient de la même façon : 10, 11, 13, 14, 16, 18, 20, 22, 25, 28, 32, 35, 40, 45, 50, 56, 63, 71, 79, 89, 100.
Au delà, les séries suivantes utilisent le multiplicateur 100 pour augmenter la précision et distinguer les termes.

De telles séries géométriques ont alors été établies plus tard pour les jauges de câbles électriques, les canalisations, la robinetterie, la puissance des moteurs, les formats de papier, etc. D’autres séries à progression linéaire les ont complété notamment pour l’outillage et la visserie et la miniaturisation croissante des produits de l’industrie, ou le changement d’échelle des productions et le besoin de précision accrue a conduit à étendre ces séries à la fois vers le haut et vers le bas, en même temps que se développaient des normes relatives à la sécurité, puis à l’organisation du travail, le contrôle comptable, le contrôle de qualité, et les procédures de collaboration inter-professionnelles ou avec l’État initiateur de nombreuses normes pour ses appels d’offres, afin d’améliorer la concurrence et la diversité des fournisseurs, puis pour certifier leurs compétences.

Organisation des valeurs des résistances

Etant donné la diversité des applications, la précision des valeurs des résistances varie en fonction des dites applications.
C'est la raison pour laquelle la fabrication des résistances est organisée en série à l'intérieure d'une décade.

Série et décade

Une décade est un ensemble de valeurs dont les valeurs de résistance sont comprises entre un multiple de 1 et un multiple de 10 de l'unité considérée.
Exemple : 1 à 10 ohms ; 10 à 100 ohms; 10 à 100 kiloohms…

Une série représente le nombre de valeurs différentes que l'on dispose à l'intérieur d'une décade.
Pour la série E3, par exemple, nous avons trois valeurs possibles dans la décade : 1,0 2,2 et 4,7.
Soit les valeurs ohmiques possibles suivantes : 1,0 ohm ; 2,2 ohms ; 4,7 ohms ; 10 ohms ; 22 ohms ; 47 ohms ; 100 ohms ; 220 ohms…

Pour la série E12 nous avons 12 valeurs possibles par décade : 1,0 ; 1,2 ; 1,5 ; 1,8 ; 2,2 ; 2,7 ; 3,3 ; 3,9 ; 4,7 ; 5,6 ; 6,8 ; et 8,2.
Dans cette série E12 et pour les résistances dont la valeur est comprise entre 10 kΩ et 100 kΩ (décade 10kΩ à 100kΩ) , nous aurons :
10 kΩ ; 12 kΩ ; 15 kΩ ; 18 kΩ ; 22 kΩ ; 27 kΩ ; 33 kΩ ; 39 kΩ ; 47 kΩ ; 56 kΩ ; 68 kΩ et 82 kΩ.

Remarque : la série E12 n'étant plus fabriquée, elle est extraite de la série E24.

Série | n/décade | n√10 | Tolérance | Observation
E3 | 3 | 2,15 | ±50 % | N'est plus utilisée
E6 | 6 | 1,47 | ±20 % | Vieux postes à lampes
E12 | 12 | 1,21 | ±10 % | Extraite de la série E24
E24 | 24 | 1,10 | ±5 % | Electronique grand public
E48 | 48 | 1,05 | ±2 % | Prototypage
E96 | 96 | 1,02 | ±1 % | Filtres BF et précision
E192 | 192 | 1,01 | ±0,5 % | Instrumentation

La progression des valeurs des résistances

La progression des valeurs dans une série est géométrique.
La valeur de rang m de la série En est obtenue en posant n√10m
formule d'une valeur n

Par exemple, 4ème valeur de la série E12 (12√104) :
formule d'une valeur de rang 4 de la série E12
Ce qui donne : 2,1544 arrondi à 2,2, qui est aussi le 8ème élément de la série E24 (24√108) :
formule d'une valeur de rang 8 de la série E24

Cas spécifique ou n= m

La dernière valeur d'une série sera toujours égale à 10. Nous avons n= m

12√1012= 24√1024= n√10n= 10
formule d'une valeur de rang n de la série En
Dans la pratique nous classerons cette dernière valeur comme valeur de début de chaque décade.

Comment retrouver une valeur proche dans une série normalisée

Quand on calcule la valeur théorique d'une résistance, lors de la conception d'un circuit électronique, il peut être intéressant de retrouver la valeur pratique de la résistance à mettre en œuvre dans une série donnée.

Exemple

Le résultat «x» d'un calcul donne 6,73 ohms comme valeur de résistance.
Quelle est la valeur la plus proche dans la série «n» E24 ?

Il faut d'abord retrouver à quel rang «m» proche appartient cette valeur dans la série E24.
Avec x= 6,73,
n= 24,
m= ?

Calculons le rang : m= log xn
m= log(6,7324)= 19,87 ; nous arrondissons à 20.

La valeur la plus proche appartient au rang 20 de la série E24.

Calcul de la valeur : 24√1020= 6,81 soit 6,8 Ω.

Précision ou tolérance

En augmentant le nombre de valeurs possibles dans une décade (3, 6, 12, 24, 48, 96), les valeurs de résistance se rapprochent de plus en plus.
Pour obtenir de plus en plus de valeurs proches les unes des autres, les constructeurs ont amélioré leurs procédés de fabrication et employé des matériaux fiables et stables dans le temps.
C'est de cette manière que nous avons obtenu des précisions différentes en fonction de la série utilisée.
La série E12 offre des valeurs de résistances précises à ±10 % et la série E96 à ±1 %.
Nous parlerons alors de tolérance à 10 %, 5 %, 1 %, etc.

Exemples de résistances de grande précision

résistance de précision cms résistance de puissance réseau de résistances

Valeurs normalisées E3 à E96

Tous les tableaux au format text/html sont disponibles à la page des tableaux des séries normalisées E3 à E96

Tableau des séries de résistances


ASM Mode Reel

A copier dans le CHM .... R3_Composants Radio Technologie Atelier

Vu dans ... https://fr.wikipedia.org/wiki/Norme_et_standard_techniques

Une partie de la normalisation s’est effectuée en utilisant des séries de Renard : Charles Renard, officier du génie, spécialiste des aérostats dirigeables, montgolfières) avait constaté en 1870 que l’armée utilisait 425 câbles de divers diamètres pour l’attache et la construction de ces appareils. Il calcula que 17 devaient suffire ; les diamètres étant en progression géométrique qu’il s’agirait de définir par classes. Il créa alors les séries portant son nom : Ra5 (ou encore R5), Ra10, Ra20, etc.

  • La série R5, par exemple, définit la progression géométrique de 1er terme u0=1, de dernier terme u5=10 ; sa raison est donc racine cinquième de 10. On obtient les termes de R5 en multipliant par 10 et en arrondissant à l'entier le plus proche : 10, 16, 25, 40, 63, 100. soit 10^((1 à 5)/5) pour une décade
  • La série R10 intercale un terme moyen géométrique entre deux termes consécutifs de la suite R5. Sa raison est donc racine dixième de 10 : 10, 13, 16, 20, 25, 32, 40, 50, 63, 79, 100.
  • La série R20 s’obtient de la même façon : 10, 11, 13, 14, 16, 18, 20, 22, 25, 28, 32, 35, 40, 45, 50, 56, 63, 71, 79, 89, 100.
  • Au delà, les séries suivantes utilisent le multiplicateur 100 pour augmenter la précision et distinguer les termes.

De telles séries géométriques ont alors été établies plus tard pour les jauges de câbles électriques, les canalisations, la robinetterie, la puissance des moteurs, les formats de papier, etc. D’autres séries à progression linéaire les ont complété notamment pour l’outillage et la visserie et la miniaturisation croissante des produits de l’industrie, ou le changement d’échelle des productions et le besoin de précision accrue a conduit à étendre ces séries à la fois vers le haut et vers le bas, en même temps que se développaient des normes relatives à la sécurité, puis à l’organisation du travail, le contrôle comptable, le contrôle de qualité, et les procédures de collaboration inter-professionnelles ou avec l’État initiateur de nombreuses normes pour ses appels d’offres, afin d’améliorer la concurrence et la diversité des fournisseurs, puis pour certifier leurs compétences.

C'est lors de la Première Guerre mondiale que naissent en France les premiers organismes de normalisation nationaux avec une Commission permanente de standardisation (CPS), puis avec l'Association française de normalisation (Afnor) créée en 1926. La période de Seconde Guerre mondiale redonneront du poids à l'Afnor.

Cependant on note qu’en France au XX e siècle, le développement des normes a d’abord surtout été d’initiative publique par l’État (avec une forte composante réglementaire ou législative), ce qui est aujourd’hui de moins en moins le cas, l’industrie, le commerce et les consommateurs étant eux-mêmes demandeurs et producteurs de ces normes pour rendre les offres comparables entre les différents fournisseurs de produits et services, ou pour mieux les différencier. Ainsi on a assisté à une explosion des labels et certifications privées, qui au lieu de faciliter la concurrence et la comparaison des offres, en a accru la complexité, l’État (et aujourd’hui de plus en plus les normalisateurs ou législateurs européens) n’intervenant plus qu’en dernier ressort pour légaliser et protéger certains labels sélectionnés.

Vu dans ... https://fr.wikipedia.org/wiki/Norme_et_standard_techniques


Les bases du calcul

Vu dans ... http://stefladino.free.fr/maths/Algebre/bases%20de%20calcul.htm

LES BASES DU CALCUL

Je retourne à la liste des cours

Cette première fiche traite des règles fondamentales du calcul : en effet, le calcul est basé sur des opérations entre des nombres, ou des termes de nature différente, chaque opération et chaque terme étant soumis à ses propres règles, qui bien sûr sont souvent méconnues.

Rappels

Le calcul numérique s'effectue grâce à 4 opérations :

Opérations

représentation écrite

se lit

opération inverse

L'addition

signe +

plus

la soustraction

La soustraction

signe -

moins

l'addition

La multiplication

signe [image] , ou absence de signe :
l'absence d'un opérateur entre deux nombres ou deux valeurs implique obligatoirement la présence d'une multiplication :

Exemples:
5 (10 + 2) correspond à 5 [image] (10 + 2)
5 [image] correspond à 5 [image] [image] : (termes en [image] )
5 [image] 3 correspond à 5 [image] [image] 3 (les racines carrées)

multiplié par ou facteur de

la division

La division

signe ÷ / ou barre de fraction

divisé par

la multiplication

entre des termes de nature différente :

Il existe :

  • Les Nombres

    Ils peuvent être :

    entiers : Ce sont les nombres ou chiffres "ronds" (s'arrêtent aux unités) :

    ex : 10 ; 30 ; 350 ; 5656 ....

    décimaux : ce sont les nombres à virgule :

    ex : 10,25 ; 256,4 ; 5698,589....

    les fractions : ce sont des nombres présentés sous la forme d'une division (forme rationnelle)
    (voir fiche     les fractions)

    ex :     - [image] .....

    relatifs : ce sont les nombres précédés d'un signe + ou - : un nombre relatif peut être entier, décimal, une fraction, mais aussi un terme en x ou une racine carrée (voir fiche les nombres relatifs)

    ex : (- 12,54) ; (+ [image] 5) ; (+15). ; (- 5/7)....

  • Les termes en [image] , où [image] représente un nombre dont la valeur est inconnue :

    ex :     2 [image] ; [image] [image] .....
    Certaines fois, on me donne la possibilité de trouver la valeur de [image] ; dans ce cas, le terme en [image] devient un nombre, entier, décimal ou une fraction (voir fiche     les termes en [image] )

    Cas des puissances de [image] : un [image], s'il est multiplié plusieurs fois par lui même devient une puissance de [image] (voir fiche les puissances)

    ex :     4 [image] 2 ; [image] 3 ...... :

    Si tel est le cas, on différenciera alors les termes en x et les puissances de x (termes de nature différente)

  • Les racines carrées : dans certains cas, je peux remplacer une racine carrée par un nombre : je la remplace si et seulement si le nombre correspondant est un nombre entier (voir fiche les racines carrées )

    ex : 2 [image] 2 ; [image] 4 .....

    A partir de ces rappels, je dois connaître différentes règles de calcul :

    Règle N° 1: opérations entre termes de nature différente

    Règle générale     :

    Je ne peux pas additionner soustraire, multiplier ou diviser deux termes de nature différente ensemble (nombres, termes en     [image] et puissances de [image] , racines carrées), à moins que les [image] , et les racines carrées correspondent à des nombres.

    ex : 3 - 4 [image] + [image] 2 = 3 - 4 [image] + [image] 2
    Je ne peux rien calculer car j'ai 3 termes de nature différente (+ je ne peux calculer la valeur de [image], et [image] 2 n'a pas d'équivalent en nombre entier)

    Pour la multiplication par contre, je peux me servir de la propriété d'absence de signe pour "associer" des termes de nature différente :

    exemples :
    2 [image] [image] ; je peux écrire :     2 [image] [image] 2 [image] devient un terme en [image] (mêmes propriétés)

    2 [image] [image] 2 ; je peux écrire : 2 [image] 2 [image] 2 [image] 2 devient une racine carrée (mêmes propriétés)

    2 ; je peux écrire :     2 [image] [image] [image] 2 devient un terme en [image] (mêmes propriétés)

    Cette propriété est très importante : j'aurai l'occasion de la retrouver dans les différentes fiches sur l'activité numérique.

    Règle N° 2 : Les opérations sont associatives

    Cette propriété concerne l'addition, la soustraction et la multiplication : elle me permet de faciliter mon calcul en présence de termes de nature différente :

    Règle     :
    Je sais qu'il existe dans le calcul des termes de nature différente, nombres, inconnues ( [image] ; .....), racines carrées, et que je n'ai surtout pas le droit de les additionner, soustraire, multiplier ou diviser ensemble : la propriété d'association va me permettre de regrouper les termes de même nature entre eux, afin de les calculer plus facilement

    Exercice n° 1 : Association de l'addition et de la soustraction :

    Je dois calculer l'expression A = 5 + 2 [image] + 10 [image] - 4 + 2 - 4 [image] - 3

    L'addition et la soustraction étant associatives, je peux regrouper les termes de même nature ensemble, et les calculer ; je peux écrire :

      2 [image] + 10 [image] - 4 [image] = 8 [image] ; j'utilise les propriétés de calcul des termes en x voir fiche
       5 - 4 + 2 - 3 = 0 ; j'utilise les propriétés de calcul avec des signes voir fiche
        A = 8

    Exercice n° 2 : Association de la multiplication :

    Je dois calculer l'expression A = 5 [image] 2 [image] [image] 3 [image] 4

    La multiplication étant associative, je peux regrouper les termes de même nature ensemble, et les calculer ; je peux écrire :

      5 [image] 3 [image] 4 [image] 2 [image] = 60 [image] 2
      2 [image] = 2 [image] x : je peux écrire : 60 [image] 2 [image] [image] = 120 [image] [image] = 120
        A = 120

      Et voilà, le tour est joué : l'association est une propriété bien utile, vous ne trouvez pas vous ???

    Règle N° 3 : Certaines opérations sont prioritaires

    Règle générale     :

    Dans un calcul avec plusieurs opérateurs, j'effectuerai dans l'ordre :

    1. Les multiplications
    2. Les divisons
    3. Les additions et les soustractions (dans l'ordre qui me plaît, les 2 opérations n'ayant aucune propriété de priorité l'une sur l'autre)

    Exercice N° 1 : Je dois calculer l'expression E = 10 [image] 5 + 12 - 2 + 6 [image] 3

    Méthode :

    Je dois effectuer les multiplications avant de calculer le reste :

      10 [image] 5 = 50
      6 [image] 3 = 18

    J'inclue les résultats de mes multiplications dans mon calcul : mon expression devient :

      50 + 12 - 2 + 18

    Je peux maintenant calculer mon expression, l'addition et la soustraction n'ayant pas d'odre de priorité :

      50 + 12 - 2 + 18 = 78

      Exercice n° 2 : Je dois calculer l'expression E = 10 [image] 5 + 36 ÷ 6 [image] 3 - 2

    Priorité N° 1 : les multiplications :

    10 [image] 5 = 50 ; 6 [image] 3 = 18

    E =     50 + 36 ÷ 18 - 2

    Priorité N° 2 : les divisions :
    36 ÷ 18 = 2

    E =     50 + 2 - 2
     Je peux maintenant calculer mon expression, l'addition et la soustraction n'ayant pas d'odre de priorité :

      50 + 2 - 2 = 50

      E = 50

    ATTENTION : Les calculs contenant des puissances :

    Les puissances étant des multiplications, (voir     fiche les puissances) je les effectuerai en priorité sur les divisions, additions et soustractions

      Ex : 22 + 5 - 3 = 4 + 5 - 3 = 6

    Puissances et multiplications : lorsque je suis en présence d'une multiplication de puissances, j'effectue en priorité le calcul des puissances. Ensuite, seulement, j'effectue la multiplication.

      Ex : 22 [image] 5 - 3 [image] 32= 4 [image] 5 - 3 [image] 9 = 20 - 27 = - 7

    Règle N° 4 : opérations et parenthèses

    Dans certains calculs (et c'est même souvent le cas en classe de 4è et 3è), je peux trouver à l'intérieur d'une expression des calculs entre parenthèse : j'apprends par coeur la règle concernant les parenthèses :

    Règle générale     :

    Dans une expression contenant des calculs entre parenthèse, j'effectuerai le calcul des parenthèses avant tout le reste (même avant la multiplication)

    Exemples :
    2 +     (5 - 3) = 2 + 2 = 4
    2 [image]     (5 - 3) = 2 [image] 2 = 4

    Lorsque je suis en présence d'un calcul avec des parenthèses dans des parenthèses : mes parenthèses extérieures deviennent des crochets [.....(.......).......] ; j'effectuerai en premier les parenthèses les plus intérieures.

      Ex : 10 + (5 + (5 - 3) - 2); je réécris : 10 + [5 + (5 - 3) - 2]

    J'effectue d'abord (5 - 3), car c'est la parenthèse la plus intérieure : 5 -3 = 2
    Je remplace le résultat de ma 1ere parentèse, et je calcule mes crochets : (5 + 2 - 2) = 5
    [5 + (5 - 3) - 2] = 5 ; 10 + 5 = 15

    Propriétés des opérations avec des parenthèses :

    Parenthèses et soustraction

      Exercice : : Je dois calculer l'expression E = 10 [image] 5 + 12 + 6 - (3 - 2)

    1ere étape : J'effectue les opérations prioritaires : calcul dans la parenthèse et multiplication :

       Parenthèse : 3 - 2 = 1

       Multiplication : 10 [image] 5 = 50

    2ème étape : je remplace les résultats de ma parenthèse et de ma multiplication dans mon expression :

      E = 50 + 12 + 6 - (1)

    ATTENTION : je conserve les parenthèses après avoir effectuer mon calcul , car pour enlever des parenthèses je dois connaître la règle suivante :

    Si j'ai un signe + devant la parenthèse     : j'enlève les parenthèses sans problème

     Si j'ai un signe - devant la parenthèse : pour enlever les parenthèses, je dois changer les signes des termes de ma parenthèse

    E = 50 + 12 + 6 - (1) : je regarde le signe devant ma parenthèse : -

    Conformément à la règle que je viens de voir, pour enlever les parenthèse autour de 1, je suis obligée de changer son signe 1 devient -1

    E = 50 + 12 + 6 - 1

      E = 67

    Autre méthode : je peux aussi enlever les parenthèses avant de faire mon calcul : la règle est la même :

      E =       10 [image] 5 + 12 + 6 - (3 - 2)

    1ère étape : j'enlève les parenthèses avant de faire mon calcul : j'applique la règle que je viens d'apprendre :

      Signe - devant la parenthèse [image] je change les signes de 3 et de (-2)

      3 devient (-3) et (-2) devient (+2)

      E =       10 [image] 5 + 12 + 6 - 3 + 2

    2ème étape : ainsi, je n'ai plus de parenthèses : il ne me reste plus qu'une opération prioritaire : la multiplication :

      10 [image] 5 = 50

       E = 50 + 12 + 6 - 3 + 2

      Il ne me reste que des additions et soustractions de nombres : je peux effectuer le calcul comme je veux

      E = 67

    Deux méthodes différentes = même résultat : mes calculs sont justes !!!

    Remarque : je préfère toujours calculer au maximum ma parenthèse (1ère méthode), avant d'enlever mes parenthèses : en effet, en cas de signe - , j'aurai moins de signes à changer - cela limitera je pense mes possibilités d'erreur.

    Parenthèses et multiplication

    Etant donné que le calcul dans les parenthèses constitue la priorité des priorités, je vais effectuer les calculs entre parenthèses avant d'effectuer la multiplication :

      Exercice N° 1 : Calculer l'expression E = 10 [image] 5 + 12 + 6 [image] (3 - 2)

    J'effectue les opérations prioritaires :

    1. Multiplication : 10 [image] 5 = 50

    2. Parenthèses + multiplication : je calcule ma parenthèse avant d'effectuer la multiplication :

      3 - 2 = 1

    J'ai alors : 6 [image] 1 = 6

     E = 50 + 12 + 6

      E = 68

    Exercice N° 2 Calculer l'expression E = 10 [image] 5 + 12 + 6 [image] (2 [image] + 7)

    J'effectue les opérations prioritaires :

    1. Multiplication : 10     [image] 5 = 50

    2. Parenthèses + multiplication : je calcule ma parenthèse avant d'effectuer la multiplication : le seul problème dans cet exercice, c'est que je ne peux rien calculer dans ma parenthèse, car je n'ai pas le droit d'additionner des termes en     x et des nombres entiers : je vais donc effectuer ma multiplication ;
    Je me retrouve en situation d'un nombre qui multiplie une parenthèse : je dois alors utiliser une propriété spécifique de la multiplication qui est     la distributivité

    Que dit cette propriété ?

    Règle : Si un nombre multiplie une parenthèse, ce nombre se distribue (se multiplie avec) chacun des termes de la parenthèse.

    Principe :

    Reprenons notre exercice :

      6 [image] (2 [image] + 7)

    Selon la règle de la distributivité de la multiplication, je vais multiplier 6 par chacun des termes de ma parenthèse, comme suit :

      6 [image] (2 [image] + 7) = 6 [image] 2 [image] + 6 [image] 7 = 12 [image] + 42

    Pour reprendre mon calcul : je remplace les résultats de mes calculs dans mon expression :

     E = 50 + 12 + 12 [image] + 42
     J'utilise la propriété d'association de l'addition (voir ci-dessus), et regroupe mes termes de même nature pour les calculer :
     E = 50 + 12 + 42 + 12
    50 + 12 + 42 = 104

    Je ne peux plus rien calculer car je ne peux additionner des termes en x et des nombres entiers

      E = 12 [image] + 104
      (conformément à l'ordre de présentation des différents termes)

    Mon conseil : Je simplifierai toujours au maximum le calcul dans mes parenthèses avant d'appliquer la multiplication. Cela m'évitera bien des erreurs lorsque j'appliquerai la distributivité !!

    IMPORTANT : Je simplifierai toujours au maximum le calcul dans mes parenthèses avant d'appliquer la multiplication et sa distributivité. Cela m'évitera bien des erreurs croyez-moi !!!

      Exercice N° 3 : Calculer l'expression A = 5 (10 [image] + 3 - 2 + 5 [image])

      C'est parti !!!

    1ère étape : je regarde les opérations que j'ai à effectuer : une multiplication + un calcul dans une parenthèse : je calcule ma parenthèse avant d'effectuer la multiplication :

      10 x + 3 - 2 + 5 [image] : j'utilise la propriété associative de l'addition et soustraction, et je regroupe les termes de même nature : 10 [image] + 5 [image] + 3 - 2 [image] 15 [image] + 1

    Je remplace ma parenthèse simplifiée dans mon expression :

    A = 5 (15 [image] + 1)

    2ème étape : J'effectue la multiplication : je vois que je suis en situation d'appliquer la distributivité de la multiplication (un nombre 5 multiplie une parenthèse) : conformément à cette propriété, je vais multiplier 5 par chacun des termes de la parenthèse :

    5 (15 [image]     + 1) = 5 [image] 15 [image] + 5 [image] 1 = 75 [image] + 5

    Je ne peux plus rien calculer car je n'ai pas la droit d'additionner des termes en [image] et des nombres entiers

    A = 75 [image] + 5

    ATTENTION : Distributivité et signes :

    Règle     : le signe du nombre à distribuer se multiplie avec les signes de chacun des termes de la parenthèse

      Exercice : Calculer l'expression : A = - 7 (-15 [image] - 8)

    1ère étape : je regarde la parenthèse et vérifie qu'elle est sous sa forme la plus simple : je ne peux rien calculer car je n'ai pas la droit de soustraire des termes en x et des nombres entiers : la parenthèse est bien sous sa forme la plus simple

    2ème étape : J'effectue la multiplication : je vois que je suis en situation d'appliquer la distributivité de la multiplication (un nombre (-7) multiplie une parenthèse) : conformément à cette propriété, je vais multiplier (-7) par chacun des termes de la parenthèse :

    Je regarde les signes de chaque nombre :
    -7 (-15 [image] - 8) = (-7) [image] (-15 [image] ) - (-7) [image] 8 = 105 [image] - (-56) = 105 [image] + 56
    conformément aux opérations avec des nombres relatifs et la règle des signes

    ou encore :

    (- 7) [image] (-15 [image]) = 105
    (-7) [image] (-8) = 56

    105 [image] est positif ; 56 est positif ; A = 105 [image] + 56

    Je ne peux plus rien calculer car je n'ai pas la droit d'additionner des termes en x et des nombres entiers

    A = 105 [image] + 56

    Cas d'une parenthèse multipliant une autre parenthèse :

    Souvent, dans des exercices de développement, c'est toute une expression entre parenthèse qui multiplie une autre parenthèse : le principe de distributivité est le même :     je distribuerai chacun des termes de la 1ère parenthèse sur chacun des termes de la 2è, en incluant les signes qui accompagne chacun de ces termes

      Exercice : Calculer l'expression : A = (10 [image] - 3) (5 [image] + 4)

    1ère étape : je regarde les opérations que j'ai à effectuer : une multiplication + des calculs dans deux parenthèses : je calcule mes parenthèses avant d'effectuer la multiplication : dans la 1ère je ne peux rien calculer, et pas d'avantage dans la 2è : mes parenthèses sont sous leur forme la plus simple

    2ème étape : J'effectue la multiplication : je vois que je suis en situation d'appliquer la distributivité de la multiplication (une parenthèse multiplie une autre parenthèse) : conformément à la propriété, que je viens d'énoncer, je vais multiplier chacun des termes de la 1ère parenthèse par chacun des termes de la 2è :

      a. Je distribue 10 [image] sur 5 [image] et 4

    10 [image] [image] 5 [image] = 10 [image] [image] [image] 5 [image] [image] = 10 [image] 5 [image] [image] [image] [image] = 50 [image] [image] 2 = 50 [image] 2
    10 [image] [image] 4 = 10 [image] [image] [image] 4 = 10 [image] 4 [image] [image] = 40 [image] [image] = 40

    (*) Rappel : un nombre multiplié 2 fois par lui même est un nombre à la puissance 2 : "au carré" (voir rubrique les puissances)

      b. Je distribue -3 sur 5 [image] et 4

    -3 [image] 5 [image] = -3 x 5 x [image] = -15 [image] [image] = -15
    -3 [image] 4 =     -12

    Je réecris mon expression avec mes résultats

      A = 50 [image] 2 + 40 [image] -15 [image] - 12

      c. J'utilise la propriété associative de l'addition et soustraction, et je regroupe les termes de même nature pour les calculer : je n'ai rien à modifier car le regroupement est déjà fait

    Je calcule les termes en [image] : 40 [image] - 15 [image] = 25

    Je ne peux plus rien calculer car je n'ai pas la droit d'additionner ou soustraire des termes en [image] 2 en [image] et des nombres entiers.

    A = 50 [image] 2 + 25 [image] - 12
    (conformément à l'ordre de présentation des différents termes)

    ATTENTION : Si j'avais eu un signe - devant ma première parenthèse, j'aurais surtout fait attention de calculer mon expression en gardant la parenthèse :

      (10 [image] - 3) (5 [image] + 4) = 50 [image] 2 + 25 [image] -12

    MAIS : - (10 [image] - 3) (5 [image] + 4) = - ( 50 [image] 2 + 25 [image] -12)
    Pourquoi je garde mes parenthèses ? Parce que je dois tenir compte de la règle pour enlever les parenthèses avec un signe - devant : pour enlever les parenthèses, je dois changer les signes de chacun des termes de ma parenthèse ; le résultat de mon calcul va donc devenir :

      - (10 [image] - 3) (5 [image] + 4) = - 50 [image] 2 - 25 [image] + 12

    Je retiens : Chaque fois que j'ai un signe - devant deux parenthèses qui se multiplient entre elles :

      schéma : - (...........) [image] (............)
      1/Je ne prends pas en compte le signe - dans mes calculs, mais je fais bien attention de réécrire mes calculs dans une parenthèse

      2/ Ensuite, et dès que ma parenthèse est simplifiée au maximum, je peux enlever mes parenthèses : c'est à ce moment là que je prends en compte le signe - : celui-ci me fait changer le signe de chacun des membres de ma parenthèse.

    J'aurai l'occasion de revoir ce type de calcul dans la fiche : développer une expression


Factorielles

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Compter/SixFact.htm

FACTORIELLES

Index et introduction

La somme des entiers consécutifs conduit aux nombres triangulaires; leur produit aux factorielles.

Factorielle n, avec n un entier naturel, est notée n! (1808 – Christian Kramp). Sa valeur est le produit de tous les entiers de 1 à n.

n! = 1 x 2 x 3 x … x n

5! = 1 x 2 x 3 x 4 x 5 = 120

Extraordinaire:

40 585 = 4! + 0! + 5! + 8! + 5!

Trouvé en 1964

À partir de 2!, tous les nombres factoriels sont pairs.
Et, évidemment n! + 1 est impair, tout comme (n – 1)! + 1 pour n > 2.

La quantité de permutations de n objets est égale à factorielle n.

Il existe de nombreuses variantes impliquant le produit des nombres successifs d'une suite: factorielle de premiers, de Fibonacci …

Relation fondamentale: 10! = 10 x 9! => n! = n (n – 1)! ou (n + 1)! = n + 1) n!

Vocabulaire

Une factorielle (nom féminin): nombre notée n!

Un nombre premier factoriel, une valeur factorielle (adjectif).

Anglais: factorial; Espagnol: factorial; Italien: fattoriale; Allemand: Facultät.

FACTORIELLE – Approche

* Quelle est la quantité de façons de placer trois personnes sur un banc?

* Je place d'abord l'un des personnages: Lucky Luck ou Tintin ou Donald. Soit trois possibilités.

* Maintenant que j'ai choisi l'un d'eux, je choisis le suivant parmi les deux qui restent. Soit deux possibilités.

* Ultime étape, je place le dernier. Étant tout seul, il ne reste plus qu'une seule possibilité.

* Bilan, il ya 3 x 2 x 1 possibilités.

* Ce produit des nombres successifs jusqu'à 3 est appelé factorielle 3 et noté: 3!

Quantité de permutations sur un banc: n!

* Quelle est la quantité de façons de placer trois personnes autour d'une table ronde?

* Beaucoup moins que sur un banc.

* Une fois le premier personnage positionné, il reste deux possibilités pour les deux autres.

* À la différence du banc, le premier personnage peut se mettre dans l'une des trois positions sans que cela change le voisinage de chacun.

* Bilan, il n'y a que deux possibilités. Ce sont les 3 x 2 x 1 possibilités du banc, divisés par les 3 positions indifférentes du premier personnage. Soit 3 x 2 x 1 / 3 = 2 x 1possibilités

Quantité de permutations autour d'une table ronde: (n – 1)!

* Ne pas confondre
Il serait différent de trouver le nombre de cas possibles, avec trois personnes qui peuvent être : soit gaies (G), soit tristes (T).

* C'est le dénombrement de trois objets pouvant prendre deux états.

* Deux possibilités pour le premier

* Deux pour le deuxième, et

* Deux pour le troisième.

* Bilan: 2 x 2 x 2 = 23 = 8 possibilités.

Voir Dénombrement – vue générale / Problème des places assises autour d'une table

Illustration avec choix de quatre fruits

Voir Brève de maths - Factorielles

VALEURS

* Avant les ordinateurs, les factorielles étaient connues jusqu'à 300!, plus quelques autres rares cas.

Exemples de valeurs

* Avec les trois lettres A, B et C, il y a 3! = 6 permutations possibles

* Avec les trois lettres A, B, C et D, il y a 4! = 24 permutations possibles

* Avec 12 personnes à table midi et soir, la permutation de tous les convives autour de la table prendra 546 siècles pour 11! = 39 916 800 repas.

* Avec 52 cartes, la quantité de permutations s'élèvent au nombre énorme de 52 ! = 80 658 … un nombre de 68 chiffres.

Valeurs de transition en puissances 10

* Limite de calcul de la calculette Windows: 3 248!

Merci à Denis Bertin pour cette remarque

* Factorielles décimales: généralisation des factorielles aux nombres non-entiers via la fonction gamma d'Euler.

Suite en Table des factorielles / Calcul des factorielles / Quantité de permutations des nombres/

Nombre 69 / Nombre 449

Le zéro qui donne 1

Comment montrer logiquement que 0! = 1

Autre méthode: (x + 1)! = (x + 1) x!

Avec x = 0: (0+1)! = (0 + 1) 0!

1! = (1) 0!

1 = 0!

Voir Nombre0

Amusement

Amusement avec des factorielles:

En effet, soustraction de fractions:

Or 100! = 99! x 100:


Simulateur de portes logiques | Christian Pc

Vu dans ... http://christianpc.fr/simulateur-de-portes-logiques

Symboles et tables de vérités de portes logiques
Type Symbole américain Symbole européen Opération
booléenne 		Table de vérité
ET { A . B}
Entrée |  | Sortie
A | B | A ET B
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
OU { A+B}
Entrée |  | Sortie
A | B | A OU B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1
NON {A}
Entrée | Sortie
A | NON A
0 | 1
1 | 0
NON-ET (NAND) ! {A . B}
Entrée |  | Sortie
A | B | A NAND B
0 | 0 | 1
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
NON-OU (NOR) ! {A+B}
Entrée |  | Sortie
A | B | A NOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 0
OU exclusif (XOR) {A xor B}
Entrée |  | Sortie
A | B | A XOR B
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
ET-inclusif ou
OU-exclusif complémenté (XNOR) ou
Identité ou
NON-OU exclusif 		! { A xor B}
Entrée |  | Sortie
A | B | A XNOR B
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1


Le Simulateur Logique, Comment effectuer un bon Câblage

Vu dans ... http://www.electronique-et-informatique.fr/Electronique-et-Informatique/Digit/Pratique/Digit_1P.php

Le Simulateur Logique, Comment effectuer un bon Câblage ? :

NOTA :

Du plus grand ordinateur à la plus petite calculatrice de poche, la technique numérique est là. Elle se développe chaque jour davantage et intervient dans chacun des domaines de votre vie moderne dans lequel l'électronique est présente.

Le but des expériences pratiques de technique numérique et de vous permettre, au moyen de manipulations, d'étudier les principes fondamentaux de cette technique.

A travers une série d'exercices pratiques programmés de façon progressive, vous pourrez assimiler facilement les notions exposées dans la théorie ; vous apprendrez à connaître en même temps la fonction et l'emploi des différents composants électroniques couramment utilisés dans l'industrie, en effectuant les montages expérimentaux.

La connaissance que vous aurez acquise des circuits de base, pourra être étendue ultérieurement, vous offrant la possibilité de vous spécialiser dans cette technique ; dans le but de construire, réparer et contrôler tout appareil faisant appel à la technique numérique.

Vous trouverez tous les composants électroniques, résistances, condensateurs, circuits intégrés, transistors, etc... dans n'importe quel commerce électronique. Il suffira de bien choisir les composants mais nous vous donnerons toutes les caractéristiques à chaque pratique, c'est-à-dire les valeurs des résistances avec marquage ainsi que les condensateurs et bien d'autres encore afin de vous faciliter pour vos travaux pratiques.

Une partie seulement du matériel de cette première pratique sera utilisé immédiatement pour les exercices ; le reste sera employé par la suite, avec le matériel complémentaire de la série suivante c'est-à-dire la 2ème pratique, la 3ème, etc. ...

Il est donc conseillé de séparer les composants dont l'utilisation n'est pas immédiate et de les placer en lieu sûr.

Pour l'exécution des montages, suivez scrupuleusement au fur et à mesure des indications fournies, même si parfois certaines peuvent vous sembler superflues ; dans ce domaine, les contrôles ne sont jamais trop nombreux et encore moins inutiles.

NOTE IMPORTANTE :

Ne pas enlever les circuits intégrés de la mousse antistatique (ou de l'étui antistatique) avant leur utilisation immédiate car ils pourraient s'endommager irrémédiablement.

Par commodité, nous tracerons les schémas électroniques partiellement à chaque pratique afin de mieux comprendre et nous vous expliquerons sur leur fonctionnement divers et enfin pour simplifier vos travaux ainsi que les montages expérimentaux.

Toute similitude en rapport à notre projet, nous serions tenu irresponsable. En revanche, le simulateur logique ne doit pas être commercialisé sans notre accord sous peine de sanction car ce site est totalement gratuit.

1. - LE SIMULATEUR LOGIQUE

Dans cette pratique, vous commencerez le montage du pupitre du simulateur illustré dans la figure 1 intitulé "DIGILAB" qui permettra le déroulement du programme des expériences pratiques prévues dans notre projet.

Vous aurez l'occasion d'apprécier en fin de montage l'utilité et la commodité d'emploi du "Digilab" dans la vérification du fonctionnement de différents types de circuits intégrés ou dans l'expérimentation d'un circuit électronique. En effet, dans un but didactique ou simplement pour le plaisir, il permet d'effectuer rapidement des montages expérimentaux relativement compliqués, sans nécessiter l'emploi du fer à souder et en évitant les difficultés généralement rencontrées lorsque l'on ne dispose pas d'un support approprié pour le circuit que l'on désire réaliser.

Enfin, rendant possible la réalisation de circuits d'essais de toutes sortes, le simulateur logique peut se transformer en un appareil de contrôle et d'essai, utile pour la vérification individuelle des circuits intégrés dont sont constitués les appareils basés sur la technique numérique.

1. 1. - CARACTÉRISTIQUES GÉNÉRALES DU SIMULATEUR

Il se présente sous la forme d'un coffret dont la face supérieure comprend 2 zones (figure 1).

Sur la zone de droite sont disposés les éléments suivants :

Ensemble d'affichage hexadécimal

C'est ensemble est formé par deux afficheurs hexadécimaux à matrice 4 x 7 points avec circuit décodeur et mémoire incorporée permettant la visualisation de signaux numériques codés en hexadécimal dont nous parlerons ultérieurement.

Ensemble indicateur à LED

Formé par 8 LED et leur circuit de commande, cet ensemble permet d'obtenir une indication visuelle des niveaux logiques présents en différents points des circuits étudiés.

Groupe de connecteurs

Cet ensemble de connecteurs est constitué de 42 contacts permettant l'accès à toutes les fonctions du simulateur par simple insertion (sans soudure) des fils rigides constituant les liaisons.

Double oscillateur d'horloge

Il s'agit de deux circuits oscillateurs à résistance et capacité (RC), indépendant l'un de l'autre, en mesure de fournir des signaux rectangulaires ayant les fréquences suivantes :

  • premier oscillateur : 1 Hz, 10 Hz, 100 Hz

  • second oscillateur : 1 kHz, 10 kHz, 100 kHz.

Comme les deux oscillateurs sont indépendants, deux signaux de fréquences différentes : l'un fourni par le premier oscillateur et l'autre par le second seront simultanément disponibles sur le groupe de connecteurs.

La commutation des fréquences de chaque oscillateur se fait par la sélection de résistances de valeurs appropriées.

Détecteur de changement d'état

Ce circuit permet d'effectuer des contrôles sur les signaux numériques, il permet, plus précisément, de vérifier l'instant où un signal passe d'un état à l'autre.

Ensemble d'inverseurs mécaniques

L'ensemble d'inverseurs est constitué de quatre interrupteurs à 2 positions permettant de disposer d'autant de variables de commande logique ; en les actionnant, on peut en effet faire changer l'état logique de chaque variable en commutant un état haut (1) ou un état bas (0).

Ensemble de boutons-poussoirs

Cet ensemble est équipé d'un système anti-rebond, permettant de disposer sur le groupe de connecteurs, de fronts de montée ou de descente exempts du phénomène de rebondissement dû à l'élasticité mécanique des contacts dont nous parlerons ultérieurement.

Support pour circuits intégrés

Ce support, à 14 broches pour circuit intégré, raccordé aux connecteurs, permettra de réaliser les premières expériences sur circuits logiques par lesquelles vous pourrez concrétiser les explications théoriques.

Sur la zone de gauche sont placées les commandes relatives au circuit d'alimentation dont le simulateur est muni, ainsi que la matrice à contacts pour montages expérimentaux.

Matrice à contacts

Sur cette platine, on peut effectuer le montage et les essais de circuits électroniques sans avoir à effectuer de soudure. Il est ainsi possible de modifier le circuit ou de récupérer les composants après l'expérience. Si l'on avait employé un fer à souder, la fiabilité des composants aurait pu être compromise.

Prise haut-parleur

Cette prise donne accès à un haut-parleur placé à l'intérieur du coffret.

Interrupteur de marche / arrêt

Cet interrupteur permet d'appliquer la tension secteur sur le circuit d'alimentation du simulateur placé à l'intérieur du coffret.

Les caractéristiques électriques de l'alimentation sont les suivantes :

  • Tension d'entrée : 220 V

  • Tension de sortie : 5 V

  • Intensité du courant maximum de sortie : 1,5 A

  • Protection de la sortie contre les court-circuits

  • Protection interne contre les surcharges thermiques.

Nomenclature pour la construction du simulateur logique est la suivante :

  • 1 circuit imprimé 17 x 18 cm et bandes adhésives de 1,5 mm (environ)

  • 1 pile de 4,5 V

  • 10 résistances 220 W - 1 / 4 W tolérance ± 5 % (rouge - rouge - marron - or)

  • 9 résistances 15 kW - 1 / 4 W tolérance ± 5 % (Marron - vert - orange - or)

  • 6 résistances 4,7 kW - 1 / 4 W tolérance ± 5 % (jaune - violet - rouge - or)

  • 1 résistance 12 kW - 1 / 4 W tolérance ± 5 % (marron - rouge - orange - or)

  • 2 résistances 150 kW - 1 / 4 W tolérance ± 5 % (marron - vert - jaune - or)

  • 2 résistances 1,5 MW - 1 / 4 W tolérance ± 5 % (marron - vert - vert - or)

  • 1 condensateur électrolytique au tantale de 0,33 µF - 10 V

  • 1 condensateur céramique disque de 330 pF

  • 8 LED de 6 mm

  • 10 transistors BC 238B

  • 3 supports type standard pour circuits intégrés (14 broches)

  • 3 supports type professionnel pour circuits intégrés (14 broches) 2 pour l'afficheurs + 1 pour ICX

  • 1 circuit intégré MM 74C74

  • 1 circuit intégré MM 74C14

  • 1 circuit intégré MM 74C00

  • 2 afficheurs hexadécimaux à matrice 4 x 7 points du type TIL 311 ou son équivalent

  • 2 connecteurs à 32 contacts en ligne

  • 2 pinces crocodiles avec capuchon (1 noir et 1 rouge)

  • 1 tresse de fils souples rouge - noir (environ 30 cm chacun)

  • 8 vis f 3 x 6 mm

  • 4 entretoises hexagonales filetées

  • 1 rouleau de soudure

  • 4 interrupteurs à deux positions (inverseurs)

  • 2 boutons-poussoirs (inverseurs)

Les composants sus-évoqué sont réservés uniquement pour le montage du circuit imprimé, en ce qui concerne pour l'alimentation, transformateur, fusible, régulateur, coffret, etc... vous seront donné dans les pratiques suivantes y compris certains circuits intégrés pour les expériences numériques.

2. - COMPOSANTS UTILISÉS DANS LA PRÉSENTE PRATIQUE

  • 1 circuit imprimé 17 x 18 cm et bandes adhésives de 1,5 mm de largeur (approximatif)

  • 1 pile de 4,5 V

  • 8 résistances 220 W - 1 / 4 W tolérance ± 5 % (rouge - rouge - marron - or)

  • 6 supports pour circuits intégrés 14 broches (3 standards + 3 du type professionnel)

  • 2 connecteurs à 32 contacts en ligne

  • 2 pinces crocodiles avec capuchons (1 noir et 1 rouge)

  • 8 LED (diodes électroluminescentes)

  • 1 tresse de fils souples rouge - noir (environ 30 cm)

  • 4 vis f 3 x 6 mm

  • 4 entretoises hexagonales filetées

  • 1 rouleau de soudure

Vous devez disposer d'un tournevis, pince brucelle, pince coupante, fer à souder et d'un contrôleur universel.

Nous avons mesuré le pour et le contre de concevoir le projet du simulateur logique sur plusieurs pratiques ainsi que les montages expérimentaux ; car nous sommes conscient que certaines personnes ne pourront pas ce permettre de tracer les pistes avec bandes adhésives sur le circuit imprimé ou d'acheter pratiquement tous les composants. Mais cependant, nous avons tout fait pour en faciliter les tâches.

Vous pouvez également visiter les sites qui sont spécialisés dans le domaine de fabrication de circuits imprimés en simple ou en double face (pistes avec bandes adhésives), en leur demandant un devis par l'intermédiaire des moteurs de recherche en tapant dans la zone "Circuit imprimé".

En fait, ce circuit imprimé n'est pas bien compliqué car en regardant de plus près comme vous pouvez le voir dans les figures 2 et 3, ce même circuit porte sur la face supérieure (ou côté sérigraphie) des indications sur l'emplacement des composants (figure 2) tandis que la figure 3 représente les tracés des bandes adhésives ou cuivré à laquelle nous avons volontairement espacé les pastilles et bandes adhésives afin de mieux distinguer de façon à pouvoir les tracer correctement sur un circuit imprimé de dimension 17 x 18 cm. C'est bien évident, entre deux bandes adhésives a une séparation de 2 à 3 mm et ceci, pour éviter tout court-circuit.

Pour celles ou pour ceux que vous eûtes l'attention de faire faire les circuits imprimés du Digilab, vous pouvez leur demander à cette adresse, en demandant un devis : Demande devis

La figure 2 représente l'emplacement des composants et l'aspect dimensionnel.

La figure 3, quant à elle, illustre les tracées des bandes adhésives ou cuivrés sur un circuit imprimé, il suffit de retracer ces derniers pour usage à des fins personnels.

La figure 3-bis, représente le schéma électronique général du Digilab, afin que vous puissiez faire votre typon qui est déjà tracé, "figures 2 et 3".

L'utilisation des supports pour les circuits intégrés offre l'avantage de pouvoir utiliser ces derniers sans avoir à les souder, ainsi, le cas échéant leur remplacement sera facile et rapide.

Il faut savoir qu'il existe deux types de supports. Ils diffèrent entre eux par la technique de réalisation des broches, représentée dans la figure 4.

Trois des supports que vous allez utiliser dans cette pratique sont de type professionnel (figure 4-a) à contacts tulipe obtenus par tournage. Ils sont particulièrement adaptés aux circuits intégrés ayant des broches assez fines et fragiles. Ce type de contact est en mesure d'assurer une meilleure liaison du point de vue électrique, même après de nombreuses insertions du composant.

Les trois autres supports sont de type standard (figure 4-b) adaptés à un usage courant.

Pour un montage correct de ces supports, consultez attentivement les remarques concernant leur orientation, car selon les constructeurs, le système de repère de la broche 1 diffère quelque peu (figure 4).

Les diodes LED sont pourvues de deux électrodes (anode et cathode) devant être correctement identifiées au moment des montages : dans le cas contraire, les LED peuvent être endommagées.

La figure 5 vous montre comment distinguer la cathode de l'anode d'une LED.

2. 1. - COMMENT EFFECTUER UN BON CÂBLAGE

Avant de commencer le travail du montage, il est bon d'attirer votre attention sur quelques remarques qui vous permettront de réaliser de bonnes soudures.

Comme vous avez pu le noter en observant la face inférieure du circuit imprimé (côté piste de cuivre, figure 3), les pastilles sur lesquelles vous devez effectuer les soudures sont dans la plupart des cas très rapprochées. Il est donc nécessaire d'utiliser un fer à souder avec une panne très fine ; de plus, la puissance du fer à souder doit être comprise entre 15 et 25 Watts afin de ne pas endommager les pastilles ou les composants à souder. Le fer sera muni d'un transformateur d'isolement ou sera débranché pendant la soudure.

Il est également indispensable d'utiliser de la soudure à l'étain de bonne qualité et dont le diamètre ne dépasse pas 0,75 mm.

Le matériel que vous avez à votre disposition ou acheter récemment doit répondre parfaitement à ces exigences ; en aucun cas, vous ne devez utiliser de la soudure ou un fer à souder ne répondant pas aux exigences indiquées ci-dessus.

Après chaque point de soudure (figure 6), ayez soin de nettoyer la pointe de la panne du fer à souder avec une éponge (ou avec un chiffon de coton) maintenue constamment humide.

Pour effectuer une bonne soudure, pratiquez comme suit :

appuyez la panne du fer à souder de manière à ce que la pointe touche simultanément la borne du composant et la pastille de cuivre à souder.

mettez l'extrémité de l'étain au point précis où la borne à souder est en contact avec la pointe de la panne et maintenez-la dans cette position jusqu'à ce qu'une quantité suffisante d'étain ait fondu pour former une goutte de la dimension de la pastille.

maintenez le fer à souder en contact avec la pastille et la borne le temps nécessaire pour que l'étain se répande bien sur la pastille et enrobe la borne à souder ; ce temps peut varier de 3 à 5 secondes.

Évitez de garder trop longtemps le fer à souder en contact avec le point de soudure car autrement vous risquez d'endommager la piste de cuivre ou le composant.

Pendant ces opérations, il est bon de déplacer légèrement la panne autour du point à souder pour favoriser le dépôt d'étain fondu et pour recouvrir la totalité de la pastille de cuivre de manière uniforme.

Dès que la soudure ne sera refroidie (ne soufflez jamais dessus pour la refroidir), vous pourrez couper, si nécessaire, la partie excédentaire de la borne soudée au moyen de la pince coupante.

Une bonne soudure doit paraître brillante, lisse et la couleur argentée. La pastille de cuivre du circuit imprimé et la borne du composant doivent former un seul bloc comme illustré dans la figure 7-a).

Si par contre, la soudure a un aspect irrégulier et granuleux, ou se présente comme une boule de mercure (figure 7-b), il s'agit d'une soudure froide due à la fusion incomplète de l'étain sur les parties à assembler. Ceci est causé soit par une température trop faible de la panne du fer, soit par une mauvaise application de la panne sur les éléments à souder ne permettant pas la diffusion de la chaleur. Il est possible de remédier à une soudure froide, en chauffant de nouveau et en apportant, si besoin est, un peu de soudure et en s'assurant qu'elle diffuse bien.

Dans tous les cas, rappelez-vous que pour chaque soudure, il convient d'utiliser une quantité correcte d'étain en prenant le maximum de précautions pour qu'elle ne déborde pas sur une pastille ou une piste voisine non reliée créant ainsi un court-circuit comme illustré dans la figure 7-d.

Le vernis protecteur recouvrant les pistes de cuivre n'ayant pas à être soudées devrait empêcher cette éventualité qui n'est cependant pas exclue et peut se produire en raison des inévitables tolérances de fabrication.

Dans la figure 7-c, on peut voir comment se présente une bonne soudure dont l'exécution nécessite une attention particulière en raison de la présence de deux pistes de cuivre côtoyant le point à souder et qui doivent en rester isolées.

Si, par excès d'étain, vous vous trouviez dans l'un des cas représentés figure 7-d, il serait nécessaire d'éliminer cet excès de soudure qui déborde de la pastille en vous servant de la tresse à dessouder.

Dans la figure 8, on peut voir comment cette opération est effectuée : la tresse est posée sur l'étain à enlever, et en appuyant la pointe de la panne du fer à souder sur la tresse, celle-ci s'échauffe, fait fondre l'étain qu'elle absorbe. Il est souvent nécessaire de reprendre la soudure en question en évitant cette fois de déborder.

Avant de commencer les travaux, rappelez-vous de la nécessité de procéder avec le maximum de précautions et de soin au cours des phases de travaux prévus, en raison de la complexité (bien que progressive) des circuits à réaliser et de l'emploi de composants miniaturisés.

Il vous faudra donc, avant de commencer un montage, toujours lire avec attention toutes les phases du travail sans négliger aucune, vous pourrez ensuite passer à l'exécution de chacune des opérations indiquées en respectant scrupuleusement les instructions données.

Dans chaque cas, évitez de passer à l'expérience suivante avant d'avoir mené à bien la précédente jusqu'à son terme.

En suivant ces conseils, vous vous assurerez d'un maximum de succès dans la réalisation de vos travaux pratiques et vous tirerez le maximum de profit de ces expériences.


Câblage 9° partie : Commande des signaux lumineux SNCB en modélisme ferroviaire HO - Technique train miniature HO

Vu dans ... http://www.ho-ptit-train.be/Html/cablage_09.html

Câblage 9° partie : Commande des signaux

La signalisation installée sur ce réseau s'inspire de la signalisation SNCB.
C'est en fait une version simplifiée de la signalisation réelle utilisée par les chemins de fer belges.
Simplifiée en ce sens que je ferai appel à seulement 3 positions des signaux :
vert rouge
Feu vert
Marche 		Feu rouge
Stop 		Feux rouge et blanc
petit mouvement
Vu la petite taille du réseau et donc des tronçons de "pleine voie", il ne sera pas fait appel aux signaux avertisseurs.
Pour rappel, petit mouvement permet de passer le rouge sous certaines conditions :
marche à vue (la voie peut être occupée), manoeuvres, vitesse max = 40Km/h.
Il est bien entendu que les automatismes présentés ici sont utilisables pour toute autre version de la signalisation (SNCF, etc . . .)

Comme précisé dans les chapitres précédents, sur ce réseau, le DCC sera utilisé uniquement pour piloter les trains.
Divers TCO seront répartis tout autour du réseau pour commander et visualiser la position des aiguillages.
Il est mis en oeuvre divers automatismes qui, pour fonctionner correctement, doivent connaître la position des trains.
Dans ce but, le réseau est découpé en 24 morceaux appelés cantons.
Chaque canton sera équipé d'un système permettant de détecter la présence d'un train.
En combinant ces détections de présence (détecteurs de courant ou détecteurs infrarouge) avec la position des aiguillages,
des automatismes assez simples permettent de commander les signaux lumineux.
De cette manière, il sera possible, en respectant la signalisation, de rouler "a vue" sur toutes les parties visibles du réseau
alors que les parties cachées seront entièrement automatisées.
Pour faciliter la compréhension des automatismes développés ici, voici d'abord une introduction à la logique combinatoire.

1 : Introduction à la l'algèbre de Boole

Le calcul booléen ou algèbre de Boole est une manière mathématique de représenter une fonction logique
et ainsi de la mettre en équation de manière à en simplifier son écriture et sa résolution.
Ne craignez rien, loin de moi la prétention de vous faire un cours de math, je suis nul en maths.
Il est question ici d'exprimer une idée sous forme de formule pour en simplifier son écriture.
La logique que nous étudions ici est appelée "logique combinatoire" car la sortie d'un bloc dépend uniquement des états des entrées.

Si on ajoute la notion de temps et donc de synchronisation des signaux entre eux on introduit une fonction mémoire
qui fait que les états des sorties sont non seulement dépendants des entrées mais également de l' instant ou on les observe,
c' est alors de la "logique séquentielle ".

Les fonctions logiques

La fonction ET ( AND )

Pour que la sortie soit à 1, il faut que A = 1 ET B = 1

La fonction OU ( OR )

Pour que la sortie soit à 1, il faut que A = 1 OU B = 1

La fonction NON ( NOT ) ( appelée aussi inverseur )

La sortie est l'inverse de l'entrée

La fonction NON-ET ( NAND )

Pour que la sortie soit à 1, il faut que A = 0 OU B = 0

La fonction NON-OU ( NOR )

Pour que la sortie soit à 1, il faut que A = 0 ET B = 0

La fonction OU EXCLUSIF ( XOR )

Pour que la sortie soit à 1, il faut A différent de B

La fonction NON-OU EXCLUSIF ( XNOR )

Pour que la sortie soit à 1, il faut A égal B
Les tables présentées ici sont extraites de la page "Fonction logique" du site www.wikipedia.org

La logique exposée ci-dessus correspond à ce qu'on appelle la logique positive,
c'est à dire que dans ce cas, c'est l'état 1 qui est actif.

Toutefois, il est possible d'établir un schéma de fonctionnement en logique négative, c'est dans ce cas l'état 0 qui sera actif.
Par exemple, si on prend le détecteur de courant présenté au chapitre 3, lorsque le canton est occupé, la sortie du détecteur = 0.
Il en est de même pour le détecteur infrarouge présenté au chapitre 4, en cas de détection, la sortie = 0.

Exemple :

Fonction ET en logique positive
sortie = 1 si entrées A ET B = 1

devient en logique négative :
sortie = 0 si entrées A OU B = 0 		and

Exemple pratique
Si nous prenons pour référence le plan de cantonnement du réseau : plan_canton_sup_1d.pdf

Prenons, par exemple le signal lumineux S1
En logique positive cela donnera : 		Pour que le signal soit vert il faut =>

que le canton SUB 21 soit libre (état = 1)
ET que l'aiguillage A20 soit positionné "en haut" (led rouge éteinte) (état = 1)

Reprenons l'exemple du signal lumineux S1
En logique négative cela devient : 		Pour que le signal soit rouge il faut =>

que le canton SUB 21 soit occupé (état = 0)
OU que l'aiguillage A20 soit positionné "en bas" (led rouge allumée) (état = 0)

Comme vous le voyez, il existe plusieurs manières d'exprimer la même chose.
Etant donné qu'une simple combinaison de diodes nous permet de réaliser facilement une porte OU en logique négative,
j'utiliserai cette fonction pour commander les signaux.
Les détecteurs de courant et les détecteurs infrarouge ont été conçus suivant cette logique (libre = 1 - occupé = 0).
Il reste donc à convertir l'allumage des LED de position des aiguillages en 1 ou 0 (éteint = 1 - allumé = 0).

2 : Détection de position des aiguillages

Il est préférable de prendre l'information de position des aiguillages sur les LED de visualisation qui sont le reflet de la position moteur plutôt que sur la commande moteur. Le moteur étant mécaniquement lié à l'aiguillage, c'est l'information électrique la plus fiable dont nous disposons.
Néanmoins, si vous ne disposez pas de cette visualisation, vous pouvez récupérer les signaux de commande.

Le problème c'est que les LED sont alimentées en 12V AC et la logique de commande s'attend à une information 1 ou 0 (+12V ou 0V DC).

Il sera donc nécessaire de traiter cette information pour qu'elle soit compréhensible par la logique de commande des signaux.

Le filtre AC - DC
Les entrées (IN_1 - IN_2) se connectent entre 1 et 8 (LED verte) ou entre 1 et 7 (LED rouge) du moteur représenté ci dessus.
Le principe de ce circuit est relativement simple :
le signal AC est redressé (D1 à D4) et filtré (C1).
La tension DC ainsi obtenue va saturer le transistor d'un optocoupleur qui garantira l'isolation entre entrée et sortie du circuit.
Nous obtenons ainsi en sortie (OUT) :
si 0V AC en entrée => OUT = +12V (état 1)
si 12V AC en entrée => OUT = 0V (état 0).
La diode D5 permet de coupler plusieurs circuits sans perturbation l'un de l'autre.
Alimentation : 12 V DC entre + 12V et REF 		filtre

Voici un triple filtre AC - DC installé sur le module K.

Ci dessous vous trouverez le schéma électrique, le schéma d'implantation des composants et le circuit imprimé de ce circuit.
A propos du circuit imprimé, imprimez d'abord sur papier, vérifiez après impression que les dimensions du circuit sont bien 160 x 100 mm.
Il se peut que votre programme d'impression effectue une correction d'échelle.
Si tout est correct, vous pouvez imprimer le slide qui servira à réaliser le circuit imprimé.

Le circuit imprimé proposé ici est constitué de 12 filtres AC - DC.
pdf
Schéma électrique 		pdf
Implantation 		pdf
Circuit imprimé

3 : Fonctionnement d'une diode

La diode est composée de 2 électrodes appelées Anode et Cathode.

Elle est représentée par une flèche qui nous indique dans quel sens elle laissera passer le courant.
Le symbole même de la diode en dit long sur son fonctionnement, c'est un peu comme un interrupteur qui est fermé dans un sens (polarisation en direct) et ouvert dans l'autre ( polarisation en inverse).

Toutefois, contrairement à un interrupteur, lorsque la diode conduit, il existe une légère chute de tension à ses bornes (0.6 à 0.7 V pour une diode silicium).

Nous utilisons d'ailleurs cette caractéristique dans le détecteur d'occupation par mesure de courant.

Les caractéristiques principales d'une diode sont :
le courant direct max I f
la tension inverse max V r 		diode

Utilisation de la diode en logique

Considérons maintenant que pour allumer les feux de signalisation, nous utilisons un relais inverseur.

A partir de ces diodes, nous pouvons facilement réaliser une fonction logique telle que :

Si A et B ne sont pas connectés ou sont à + 12V,
le relais n'est pas alimenté.

Si une des entrées A ou B passe à 0V,
le relais est alimenté.

Il est bien entendu que nous pouvons ajouter d'autres diodes de commande en fonction des besoins.

and

Le problème de ce système est que le courant consommé par le relais doit être absorbé par les entrées A et (ou) B.

En fonction du relais utilisé et de son courant de bobine, cela pourrait perturber les circuits situés en amont (par exemple des détecteurs de courant) qui ne sont pas forcément conçus pour cela.
Cela est d'autant plus vrai si les détecteurs situé en amont doivent piloter plusieurs circuits logiques de ce type.

Pour palier ce problème, il suffit d'installer un ampli (Buffer) sur chacune de ces entrées.

Oui mais . . . . et si je veux inverser le signal de commande pour respecter une équation logique ?

Dans ce cas, il suffit de remplacer le buffer de commande par deux buffers inverseurs.

Suivant la position du pontage :

en position 1, le relais est commandé avec 0 (0V)

en position 2, le relais est commandé avec 1 (+12V)

3 : Circuit de commande des signaux lumineux
Sur base du schéma précédent, voici un circuit de commande qui peut être utilisé pour les signaux lumineux,
les signaux et barrières de P.N. ainsi que tout automatisme se basant sur l'occupation de canton ou la position des aiguillages.
Il a été conçu avec trois entrées, ce qui suffit à la plupart des cas, sur base du CD4049 comportant 6 inverseurs.

Les entrées A1 - B1 - C1 recevront les signaux d'occupation de canton ou de position d'aiguillage.
Attention : les entrées non utilisées devront êtres connectées à la masse (0V) afin d'éviter l'oscillation du CD4049.
Les relais utilisés ici sont de type Zetler AZ830-2C-12DSE ou équivalent.
Les sorties du relais marquées NO1 - COM1 - NF1 seront utilisées pour commander les signaux.
Les pontages JP 1 - 2 - 3 définissent la polarité de chaque commande :
pontage en 1 - 2 commande inversée
pontage en 2 - 3 commande non inversée
La diode D5 est une "diode de roue libre" qui élimine la pointe de tension engendrée par la bobine du relais.
L'ensemble D4 - R1 est une visualisation de l'état de sortie ( ON si relais activé).

Correspondant au schéma ci-dessus, voici, dans le rectangle rouge, la partie du circuit logique qui commande le signal S1.

Sur le module K, voici les 6 circuits de détection de cantons (rectangle bleu) ainsi que le circuit de commande des signaux S1, S3, S7 (rectangle rouge).

Ci dessous vous trouverez le schéma électrique, le schéma d'implantation des composants et le circuit imprimé de ce circuit.
A propos du circuit imprimé, imprimez d'abord sur papier, vérifiez après impression que les dimensions du circuit sont bien 160 x 100 mm.
Il se peut que votre programme d'impression effectue une correction d'échelle.
Si tout est correct, vous pouvez imprimer le slide qui servira à réaliser le circuit imprimé.

Le circuit imprimé proposé ici est constitué de 2 x 3 commandes à 3 entrées, c'est à dire assez pour commander 6 signaux lumineux.
pdf
Schéma électrique 		pdf
Implantation 		pdf
Circuit imprimé

Reprenons l'exemple du signal S1 :

Pour que le signal soit rouge il faut que le canton SUB 21 soit occupé (état = 0)
OU que l'aiguillage A20 soit positionné "en bas" (led rouge allumée) (état = 0)

Voici le schéma complet de câblage du signal S1.
Cela inclut le détecteur de présence du canton SUB21, le filtre AC-DC de l'aiguillage A20 et le circuit de commande du signal.
Notez que l'entrée B1 non utilisée est connectée à la masse afin d'éviter l'oscillation du CD4049.
En effet, les blocs logiques CMOS ont une sainte horreur des entrées "en l'air" !

Si toutefois les trois entrées de ce circuit ne suffisaient pas, il est tout à fait possible d'ajouter des entrées suivant ce petit artifice :
Il est bien entendu que si on inverse l'entrée C1 (pontage JP3 en 1 - 2) les entrées 3 - 4 - 5 - . . . seront toutes inversées.
La résistance de polarisation R = 10 K Ohms et les diodes = 1N4148

Les signaux installés sur ce réseau sont des B-models disponibles chez Van Biervliet

Ils sont de bonne apparence (après peinture du socle) mais relativement fragiles.

Je regrette néanmoins la disparition des signaux SNCB de marque Henckens bien moins fragiles.


Vu dans ... https://forums.futura-sciences.com/electronique/69060-c-assembleur.html

Selon vous quels sont les avantages et inconvénients de la programmation de pic en C ou en assembleur ? Que préférez-vous ?

Re : C ou assembleur ?

Salut,
certain te diront moi je préfère le C, d'autre l'assembleur, alors qu'en fait de nos jour la question ne se pose plus en termes de "préférence".
L'assembleur est purement indigeste et tu ne peux pas connaitre tout les assembleurs de la planète.
Donc des gens pas bête on inventé le langage de haut niveau, non pas qu'il soit de haute voltige mais plus accessible au pékin moyen et surtout facilement transportable d'un µP, ou µC, à l'autre.
C'est le compilo qui se charge de transformer la mixture en 0 et 1.
Dans certain cas précis quand ta besoin d'un chausse pieds pour entrer ton code, certain veulent te faire croire que seul un prog en assembleur peut le faire.
Pipo car si t'as pas assez de place tu prend la taille au dessus et comme ça tu évites que ton programmeur s'endorme sur sa feuille à trop vouloir rentrer le dernier bit.
Je ne te parles pas du coût d'une éventuelle mise à niveau du soft quand celui qui a pondu le "super" programme est partit ailleurs.
Alors qu'en C ou Pascal et autres d'ailleurs, est bien plus facile à manipuler.

Pour finir rappel toi bien qu'un bon programme est avant tout un programme parfaitement commenté.
Ce qui se conçoit bien s'énonce clairement.

Re : C ou assembleur ?

Bonjour,
Regarde en bas de la page http://www.lextronic.fr/mikro/PP2.htm, tu trouveras 3 compilateurs Basic, C et Pascal pour PIC.
Tu essayes et tu choisis en fonction de tes préférences.
Il existe d'autres compilateurs que ce soit C ou Basic, perso, j'utilise Proton+ (Basic).

Re : C ou assembleur ?

Dans leur début, les compilateurs de langage évolué avait tendance à génerer un code machine envahissant. Les microcontroleurs étaient souvent à cours de place pour loger les programmes
Avec le temps, la place mémoire dans les microcontroleurs a augmenté d'une part, et d'autre part les compilateurs ont suffisamment évolué pour génerer des codes de tailles raisonnables, tailles bien souvent comparables à ce qu'on obtient par l'utilisation de l'assembleur.
Rien ne justifie plus vraiment l'utilisation de l'assembleur sauf qq exceptions... mais l'utilisation de l'assembleur dans le corps d'un projet ne le justifie plus en 2006.
Comme l'écrit un des membres du Forum l'essentiel ce sont les commentaires.


L'automate "Joueurs d'échecs" de Van Kempelem : 64 ans de mystères ..... - ECHECS Mag

Un automate jouant aux échecs au XVIIIe était une arnaque

Vu dans ... https://secouchermoinsbete.fr/45992-un-automate-jouant-aux-echecs-au-xviiie-etait-une-arnaque

Le Turc mécanique est un célèbre automate construit en 1770 jouant aux échecs. Un mannequin se trouvait devant un jeu d'échecs posé sur un meuble contenant des portes masquant des engrenages complexes. Il s'agissait en réalité d'une supercherie : le meuble avait un compartiment secret permettant à une personne de petite taille de se cacher et de manipuler le mannequin. Napoléon Bonaparte et Benjamin Franklin se firent battre par "l'automate".

La supercherie ne fut révélée qu'au début des années 1820.

Vu dans ... http://www.echecsetpatrimoine.org/

L'automate "Joueurs d'échecs" de Van Kempelem : 64 ans de mystères .....

Publié le 19 août 2006 par Marius, rédacteur d'ECHECS et PATRIMOINE

Le baron Wolfgang Van Kempelem naît à Presbourg ( Brastilava ) en 1734. Ses 3 passions sont les poèmes, la création de pièces de théâtre et la mécanique. Dans ce dernier domaine, il réalise " L'Automate parlant " et " L'Automate Joueurs d'Echecs " qu'il présente en 1770 à Marie Thérèse d'Autriche, à la cour de Vienne.

Cette automate était une poupée de taille de humaine, richement vêtue à la manière d'un sultan des 1001 nuits. Un splendide turban lui surmontait la tête. On baptisa aussitôt la créature du nom de " Turc ". Le " Turc " était assis derrière un échiquier, coiffé d'un truban et drapé de soieries.

Avant de le " mettre en action ", le baron ouvrait successivement les portes du meuble en éclairant l'intérieur à l'aide d'une bougie afin que tout le monde puisse l'examiner et exclure toute supercherie.

Des roues, des leviers et des poulies étaient visibles. Après avoir refermé le meuble, le baron tournait une clé pour "remonter" sa mystétieuse mécanique qui était, selon lui, en mesure de battre n'importe quel adversaire ...

En 1800, Van Kempelem vend "L'Automate" à Johann Nepomuk Maelzel (né en 1772), mécanicien de son état, et à qui l'on doit en particulier l'invention du métronome pour son ami Beethoven. Maelzel perpétue ainsi l'attraction de Van Kempelem à la cour des Princes.

C'est ainsi qu'en 1809, Napoléon Bonaparte, affronte " L'Automate " au Palais de Schönbrün (Vienne) avec les Blancs. Voir la partie :

" L'Automate " est bien sur entendu une supercherie : un champion d'échecs de petite taille, caché à l'intérieur, observe la position à l'aide d'une sorte de périscope et manipule les pièces à l'aide d'un bras articulé. A plusieurs reprises, Van Kempelem et Maelzel frôlent l'emprisonnement pour escroqueries. Très intriqué par l'engin, le prince Eugène de Bavière, achète " L'Automate" pour 30.000 francs afin d'être mis au parfum. Comme le secret n'en est plus un pour lui, il le revend quelques jours plus tard à Maelzel qui peut encore en faire son profit ... En 1825, Maelzel traverse l'Atlantique pour se rendre à New-York, Boston et Cuba.

Le succès est toujours énorme au point que l'écrivain Edgar Poe lui consacre une Nouvelle " Le joueur de Maelzel " dans laquelle il démontre que la machine a un comportement humain ...

A la mort de Maelzel en 1832, son frère Leonhard, hérite de " L'Automate " et il faut attendre finalement 1834 pour voir la supercherie mise à jour par le joueur français Mouret qui aurait crié " Au feu " pour faire sortir le champion apeuré caché à l'intérieur.

A l'issue d'une ultime tentative d'escroquerie en Colombie, " L'Automate " est exposé au musée chinois de Philadelphie. Puis il sera détruit dans un terrible incendie en 1854. "Le Turc" fut donc manipulé plus de 60 ans par des joueurs de haut niveau.

Il n'en reste pas moins que les machines, les vraies, ont désormais gagné la partie. Même l'immense Kasparov a mordu la poussière en mai 1997 dans un match en 6 parties contre " Deep Blue ", une machine d'IBM aussi grosse et sexy qu'un congélateur. On disait des échecs que c'était le "Jeu des Rois" et le roi des jeux. Est-il, lui aussi, déjà passé à la guillotine ? Or, après la récente démonstration des nouveaux programmes Junior, Fritz et Hydra face à 3 ex-champions du monde, Khalifman, Ponomariov et Kasimdzanov (2004), la question se pose !

href="http://www.echecsetpatrimoine.org/"......... Site officiel d'Echecs et Patrimoine


Vu dans ... https://www.getplanet.eu/stories1/mechanical-turk

L'histoire d'une supercherie star des cours d'Europe -- et qui nous pousse à repenser notre humanité.

L'AUTOMATE QUI BATTIT NAPOLÉON AUX ÉCHECS

Dans l’esprit de Napoléon, l’issue de l’affrontement ne fait plus aucun doute.

Son flanc droit est en lambeaux, et les maigres forces qui lui restent sont insuffisantes pour contrer l’offensive qui se prépare. Cette fois-ci, nulle unité de vaillants grognards, nulle canonnade ou charge de dragons ne pourra lui sauver la mise.

Nous ne sommes pas à Waterloo, mais dans le palais de Schönbrunn, à Vienne, en 1809.

L’empereur n’a pas les yeux rivés sur un champ de bataille, mais sur un plateau d’échecs. Impérieux, son adversaire déplace sa dame, portant le coup de grâce.

Échec et mat.

À cette époque, Napoléon règne sur l’Europe et le monde grâce à son génie militaire et diplomatique. Mais sur l’échiquier, c’est la correction. Le comble, c’est que l’impudent qui a mis une rouste au général n’est pas un humain.

C’est un simple automate.

Surnommé « Le Turc mécanique », il sème depuis des années la terreur dans toutes les cours d’Europe, battant impitoyablement les meilleurs joueurs du monde. C’est également à Vienne, cinquante ans avant la rencontre avec Napoléon, que démarre son histoire.

L'AUTOMATE PRÉFÉRÉ DE L'IMPÉRATRICE

1769. Nous sommes à la cour de l’impératrice Marie-Thérèse d’Autriche, où l'illusionniste français François Pelletier est invité pour faire la démonstration de ses talents.

Inspiré par ses tours de magie, et convaincu de pouvoir faire encore mieux, l’inventeur Wolfgang von Kempelen propose à l’impératrice de lui construire une machine qui fera passer les subterfuges de Pelletier pour de vulgaires tours de passe-passe.

Après un congé de six mois gracieusement accordé par Marie-Thérèse, Kempelen débarque à Schönbrunn escorté d’un imposant automate représentant un joueur d’échecs installé devant son échiquier.

Affublé de deux yeux verts émeraude et d’une épaisse barbe noire, fumant un long narguilé, l’automate est drapé dans une robe ottomane et porte un turban, autant d’accessoires qui lui vaudront le nom de « Turc mécanique ».

Avant de faire sa démonstration, Kempelen ouvre le large compartiment situé sous le plateau d’échecs, révélant un complexe assemblage de rouages et de pistons qui régissent le fonctionnement de l’automate.

Ces vérifications effectuées, l’inventeur propose aux joueurs d’échecs les plus chevronnés de la cour de défier sa création. Le comte Ludwig von Cobenzl s’avance le premier, et ne tarde pas à aller se rasseoir, battu à plate couture. Curieux, d’autres joueurs lui succèdent jusqu’à la tombée du jour.

Tous sont défaits par le mystérieux Turc mécanique.

AVEC SES EXPLOITS, LE TURC DEVIENT UNE SUPERSTAR

L’automate continue alors d’amuser la cour d’Autriche durant quelques années, avant de prendre sa retraite en 1774.

Mais en 1783, sous l’impulsion de Joseph II, successeur de Marie-Thérèse, le Turc reprend du service et entame une tournée triomphale parmi les différentes cours d’Europe. C’est à cette époque-là qu’il grimpe rapidement en popularité, devenant un véritable objet de fascination pour le public.

La tournée démarre à Paris, où le Turc perd de justesse contre François-André Danican Philidor, meilleur joueur d’échecs au monde, et bat Benjamin Franklin, futur président des États-Unis. À Londres, il affronte et bat à deux reprises Charles Babbage, ingénieur considéré comme le grand-père de l’informatique moderne.

Viennent ensuite l’Allemagne, où le Turc est présenté au roi Frédéric II de Prusse, la Hollande, puis retour en Autriche où, quelques années plus tard, l’automate affronte Napoléon Bonaparte, avec l’issue que vous connaissez.

Après la mort de Kempelen, le musicien Johann Nepomuk Mälzel reprend alors le flambeau de son prédécesseur.

Le nouveau propriétaire apporte même quelques améliorations : désormais, à la grande stupeur de l’adversaire, une boîte vocale s’écrie « échec ! » chaque fois que l’automate menace le roi ennemi.

La réputation du Turc mécanique s’exporte bientôt au-delà du vieux continent, et c’est auréolé de gloire qu’il traverse l’Atlantique et débarque à New York en 1826.
MAIS LA SUPERCHERIE FINIT PAR ÉCLATER AU GRAND JOUR

À New York, Boston, puis Philadelphie, l’automate affronte de nombreux joueurs américains, gagnant la plupart de ses parties.

C’est à Richmond, en Virginie, que le jeune Edgar Allan Poe assiste à l’une de ses performances. Malgré son penchant pour le surnaturel et la fascination qu’exerce sur lui la machine, le jeune poète ne se laisse pas prendre au piège. Dans un article de journal, il affirme que l’automate ne peut qu’être opéré par un humain.

L’écrivain américain a raison : le Turc mécanique est un canular bien rodé. Les engrenages qui se trouvent sous l’échiquier, et que l’opérateur prend soin de montrer au public avant chaque démonstration, sont en réalité factices, et camouflent un second compartiment dans lequel un joueur humain est dissimulé.

Un ingénieux dispositif lui permet de voir les coups joués par l’adversaire et de riposter en manipulant l’automate. Plusieurs grands joueurs d’échecs se relaient ainsi à l’intérieur du compartiment secret, tout au long de sa carrière.

Edgar Allan Poe n’est pas le premier à voir le subterfuge : dès l’apparition de l’automate, de nombreux observateurs soupçonnent un stratagème. Tous les spectateurs ne sont pas aussi perspicaces : ainsi, lors d’une démonstration, une femme multiplie les prières, convaincue que la machine est contrôlée par quelque force démoniaque.

En 1838, après la mort de Mälzel, le Turc est acquis par un groupe de fans avides d’en percer le mécanisme secret. Une fois celui-ci mis au jour, l’automate prend une retraite bien méritée dans un musée de Philadelphie.

C’est là, le 5 juillet 1854, que sa glorieuse existence s’achève : le musée prend feu, et le Turc mécanique périt dans les flammes. Plusieurs copies ont depuis été réalisées. L’une des plus récentes, celle du magicien John Gaughan, est exposée à Los Angeles. En 2005, Amazon lui rend hommage en donnant son nom à sa plateforme Mechanical Turk, qui recrute des humains en ligne pour accomplir des petits boulots sur la toile.

QUAND LA MACHINE BAT L'HOMME À SON PROPRE JEU

Il faut attendre près de deux siècles après la rencontre entre le Turc mécanique et Bonaparte pour qu’une vraie machine soit capable de battre un humain aux échecs.

Ce moment historique a lieu à New York, en mai 1997, lorsque Deep Blue, un ordinateur conçu par IBM, bat Garry Kasparov, l’un des meilleurs joueurs d’échec de tous les temps.

<>Kasparov quitte le match battu par Deep Blue, supercalculateur de 1,4 tonne capable d'analyser 100 milliards de situations à chaque coup.

La performance de Deep Blue est alors si impressionnante que Kasparov, convaincu de déceler un cerveau humain derrière le jeu de l’ordinateur, se demande si, tout comme le Turc mécanique, Deep Blue n’est pas un canular !

Depuis, grâce aux progrès effectués en intelligence artificielle, les ordinateurs sont devenus capables de battre les joueurs humains à d’autres jeux. Il y a d’abord eu, en 2011, la victoire très médiatisée, de Watson, un autre superordinateur conçu par IBM, au jeu télévisé américain Jeopardy!, face à deux champions humains.

Mais la performance la plus impressionnante revient sans doute à AlphaGo, l’ordinateur conçu par Google pour maîtriser le jeu de Go, un jeu chinois millénaire réputé pour sa complexité. Il y a ainsi plus de parties différentes possibles que d’atomes dans l’univers (soit plus de... 10^80). Une complexité qui n’a pas empêché AlphaGo d’écraser Lee Sedol, l’un des meilleurs joueurs du monde, en mars 2016.

Le prochain grand chantier se trouve sur le terrain des jeux vidéo. Starcraft II et Dota (un mode multijoueur de Warcraft III), sont notamment utilisés par des entreprises comme Facebook ou Google pour entraîner leurs algorithmes d’intelligence artificielle. Les meilleurs joueurs humains conservent pour le moment l’avantage sur les ordinateurs.

Pourquoi faire jouer l’IA à des jeux ? Explications de Greg Brockman, qui a cofondé OpenAI avec Elon Musk et Sam Altman : « La recherche en intelligence artificielle vise à résoudre des problèmes de plus en plus difficiles. En s’attaquant à des jeux toujours plus complexes, on se rapproche progressivement de problèmes que l’on est susceptibles de rencontrer dans le monde réel. »
REGARDONS-NOUS PLUTÔT DANS LE MIROIR

Si le Turc mécanique préfigure les récentes avancées spectaculaires de l’intelligence artificielle, il offre surtout une réflexion sur la manière dont celle-ci nous amène à repenser notre humanité.

L’une des raisons pour lesquelles le Turc a tant fasciné est sans doute que les échecs sont considérés comme un exercice ardu, où l’intelligence humaine est à sa quintessence. Que dire alors d’une machine capable de jouer aux échecs aussi bien que nous ? Renferme-t-elle une part d’humanité ? La joueuse de Tympanon, automate capable de jouer de la musique, autre activité humaine par excellence, a en son temps posé des questions similaires.

Discipline née à Dartmouth en 1956, l’intelligence artificielle est au départ un domaine réservé à un petit groupe de chercheurs informatiques, comme John McCarthy ou Marvin Minsk.

Elle est ensuite devenue très populaire : au fil de ses exploits, on ne compte plus les articles et couvertures de magazines consacrés aux progrès de la discipline et à ce qu’ils impliquent pour l’humanité, avec un ton souvent très alarmiste (et peu réaliste).

On ne compte plus les articles (souvent creux) annonçant le remplacement des humains par l'intelligence artificielle. Il est d’ailleurs amusant de noter qu’à l’époque du Turc mécanique, certains commentateurs voyaient déjà dans l’automate le signe que les machines allaient bientôt rendre l’homme obsolète en faisant tout mieux que lui.

Mais si l’intelligence artificielle nous fascine à ce point, c’est sans doute parce qu’elle nous amène surtout à redéfinir l’humain à l’aune de ses progrès.

Car si elle peut jouer aux échecs aussi bien qu’un humain, cela ne signifie certainement pas que cette machine ait quoi que ce soit d’humain, mais plutôt que notre définition de l’intelligence humaine est lacunaire.

L’intelligence est une notion complexe, qui comprend bien d’autres facteurs que les simples compétences nécessaires pour bien jouer aux échecs. L’intelligence artificielle nous tend ainsi un miroir déformant qui, loin de nous déshumaniser, nous amène surtout à repenser notre identité. À philosopher, en somme.


Analyse de verbatims : y a-t-il un pilote dans l'automate ? - Proxem

Vu dans ... https://www.proxem.com/analyse-de-verbatims-y-a-t-il-un-pilote-dans-lautomate/

Plus précisément, lorsqu’on analyse des textes écrits par des humains, il faut bien se mettre d’accord sur le sens de ces textes, sur ce que ces humains veulent dire. L’analyse automatique de verbatims a donc besoin d’avoir un référentiel sur ce qu’elle doit trouver dans un texte et ce qu’il faut en comprendre. Pour construire ce référentiel, le plus simple est encore de demander à des humains ce qu’ils ont compris.

La tâche étant considérable, et les textes parfois très long, les chercheurs avaient besoin d’un moyen d’interroger beaucoup de lecteurs simplement. Ce besoin explique le recours croissant au Turc Mécanique d’Amazon, une plateforme qui permet de mettre en relation un « Requester » et des « Turkers » qui vont effectuer plein de petites tâches répétitives. Les Turkers reçoivent une petite rémunération pour chaque tâche accomplie, ce qui permet au « Requester » de voir un grand nombre de tâches accomplies pour un coût raisonnable.

Pour la petite histoire, le nom de Turc mécanique est une référence à un automate d’apparence humaine, conçu au XVIIIe siècle, qui aurait été capable de battre un joueur humain aux échecs… sauf que l’automate se révéla une supercherie, le meuble contenant une personne qui jouait la partie en bougeant les bras du prétendu automate. L’image du Turc mécanique est restée pour désigner tout système qui semble automatique mais reste manuel de fait.

Cependant, l’utilisation massive du Turc Mécanique d’Amazon (AMT) soulève un certain nombre de questions, développées par une équipe de chercheurs en TAL (traitement automatique du langage) à l’occassion de la conférence TALN 2011, « Un turc mécanique pour les ressources linguistiques : critique de la myriadisation du travail parcellisé. »

Les auteurs montrent tout d’abord que le recours au Turc Mécanique pose des problèmes juridiques non négligeables, notamment en France où le travail à la tâche est interdit. Il pose également des problèmes éthiques, à la fois parce que la rémunération est ridicule et que les tâches sont souvent répétitives. D’après des sondages, entre 20 et 30% des Turkers, souvent localisés en Inde, en font une activité à plein temps : utiliser le Turc Mécanique revient ainsi à encourager une division du travail basée sur la délocalisation de tâches répétitives et faiblement rémunérées.

En plus de ces problèmes juridiques et éthiques, se pose la question de l’utilité de cette démarche. Les locuteurs natifs du français sont rares, et reviennent donc plus cher. La traduction d’un besoin en petites tâches qui peuvent être effectuées par des non-experts est souvent difficile et coûteuse – ou même impossible ! Enfin, le fait de rémunérer à la tâche n’encourage pas à produire un travail de qualité, mais plutôt à en faire le maximum le plus vite possible.

A ce stade, on est bien forcé de se dire que cette solution n’est pas si pratique qu’il y paraît et qu’il faudrait envisager des alternatives… qui existent, fort heureusement. Tout d’abord, les ressources existantes peuvent être astucieusement réutilisées et plusieurs projets internationaux ont été pensés dans ce sens :

  • Wikipédia fournit des informations très fournies sur le vocabulaire et les noms propres ;
  • WordNet est un projet de base de données lexicales conçue par des linguistes ;
  • FreeBase est une sorte de Wikipédia pour les ingénieurs du web sémantique ;
  • etc.

Référence :
Sagot, B., Fort, K., Adda, G., Mariani, J., & Lang, B. (2011). Un turc mécanique pour les ressources linguistiques : critique de la myriadisation du travail parcellisé. TALN’2011.


Origine du nombre imaginaire "i"

Vu dans ... https://www.lespritsorcier.org/blogs-membres/origine-du-nombre-imaginaire-i/

Le site de la science et de la découverte

Origine du nombre imaginaire « i »

27/10/2015 | Fractales67

Un problème bien embarrassant

Résoudre des équations du 3e degré grâce à Jérome Cardan

Un mathématicien italien du XVIe siècle appelé Jérome Cardan a formulé une formule pouvant résoudre les équations du type :

Ici, x, p et q sont chacun des nombres réels, on dit qu’ils appartiennent à l’ensemble des réels et on le note ainsi :

Cependant ce type d’équation n’était résolvable en cette époque qu’à certaines conditions; il faut en effet que :

Lorsque la condition précédente est respectée, alors les solutions sont :

On peut également écrire de cette manière (c’est équivalent) :

Bombelli, le petit futé qui travaille avec l’impossible !

En 1572, un mathématicien se nommant Bombelli décide d'utiliser la formule de Cardan en s'autorisant à utiliser des nombres considérés comme impossible, en particulier ce nombre.

En 1572, le mathématicien italien Bombelli décide d’utiliser la formule de Cardan en s’autorisant à utiliser des nombres considérés comme impossible comme sqrt(-121), sans essayer à en comprendre se sens.

PS : sqrt = « square root » en anglais, qui se traduit par « racine carrée » en français.

Nous allons maintenant vérifier que sqrt(-121) est bien solution de l’équation :

A l’aide de la formule de Cardan, on obtient :

Par la suite, on admettra que :

On aboutit donc à :

A l’aide de l’utilisation de nombre « impossible », Bombelli a réussi à trouver une solution réelle et correcte ! En effet,

Une histoire de notation

Un problème avec la notation sqrt(-1)

En 1774, le mathématicien allemand Carl Friedrich Gauss estime que la notation sqrt(-1) pose un problème car en effet :

Or pour sqrt(-1), on abouti à une contradition car :

D’un côté on obtient 1 et (-1), il y a donc un problème avec cette notation.

Une nouvelle notation apparait

En 1777, le mathématicien suisse Leonhard Euler décide de noter sqrt(-1) de cette manière :

Euler propose que sqrt(-1) est égal à i (comme imaginaire); en l’élevant au carré, on obtient :

Au final, on se retrouve avec des nouveaux nombres appelés <<imaginaires>> qui respectent :

Vers l’ensemble des nombres complexes

Un nouvel ensemble de nombre encore plus grand que les réels est alors apparu. On décide de noter cet ensemble C (pour nombres complexes).

Un nombre complexe se note souvent z et vérifie les conditions :

Ici, a et b sont des nombres réels et i est le nombre tel que :

Votre ensemble de nombre ressemble maintenant à cela :

Pour un peu plus détailler la composition de chaque ensemble, on a :

Cette illustration nous montre bien que l’ensemble des complexes C est l’association de l’ensemble des réels R avec l’ensemble des nombres imaginaires I.


Nombres imaginaires, historique

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Type/ImagHist.htm

Histoire des

NOMBRES IMAGINAIRES

D'abord révélés lors la tentative de résolution des équations du troisième degré avec la nécessité de traiter des racines de nombres négatifs.

APPROCHE

* Partant de la racine carrée de -1, on a inventé les nombres complexes. On les interprète comme des points sur le plan.

* On est ensuite passé aux quaternions qui servent en géométrie dans l'espace.

* Peut-on généraliser? On cherche à systématiser, à trouver la théorie de l'existence de ces systèmes de nombres ou algèbres.

NOMBRES COMPLEXES

D'un point de vue historique, les nombres complexes sont issus de la recherche de solutions à des équations du genre : x2 = – 1 intervenant dans la résolution des équations du troisième degré.

Il n'existe pas de nombre réel x dont le carré soit –1. Les premiers mathématiciens prétendaient donc que cette équation n'admettait pas de solution.

Cardan (1501-1576) Cependant, vers le milieu du XVIe siècle, Jérôme Cardan et ses contemporains expérimentèrent des solutions d'équations faisant intervenir des racines carrées de nombres négatifs.

Pour résoudre l'équation:

x (10 – x) = 40 [image] x² – 10x + 40 = 0

Voir Variations sur cette équation

Cardan suggéra d'exprimer le nombre réel 40 sous la forme suivante:

Voir Identités remarquables

Bombelli (1526-1572) imagine une technique de calcul avec les racines de nombres négatifs. Il se trouve confrontée à l'énigme suivante:

Leibniz, en 1702, fera part de sa découverte à Christian Huygens et à Pierre Varignon:

Jusqu'à cette époque, on cherchait à résoudre les équations du troisième degré. Ce n'est que plus tard que cette technique de calcul avec les racines négatives servira à résoudre les équations du second degré dont le déterminant est négatif (à quelques exceptions près, comme celle de Cardan indiquées ci-dessus).

Euler, quant à lui, introduisit en 1777, le symbole moderne i pour [image] . Il établit la célèbre relation:
Cette relation crée des liens entre cinq des nombres fondamentaux en mathématiques.

Voir nombre pi , nombre e

QUATERNIONS

William Rowan HAMILTON

1805 Né à Dublin.

1835 Légitime l'emploi des nombres complexes en mathématiques.

1843 Sa grande découverte: les quaternions.

1865 Mort à Dunsink

Voir Hamilton et ses contemporains / Nombres complexes

En faisant des calculs avec les nombres complexes, il s'intéresse à l'interprétation géométrique de l'addition et de la multiplication dans le plan à 2 dimensions. Il se demanda si avec des nombres hypercomplexes, on ne pourrait pas obtenir des résultats analogues dans l'espace à 3 dimensions. Ses recherches sont bien décrites par la célèbre anecdote avec son fils:

Durant de nombreuses années, HAMILTON avait espéré trouver une forme de multiplication satisfaisante pour les triplets de nombres réels avec de bonnes propriétés. En particulier: conservation de la multiplication des modules. Peu de temps avant sa mort en 1865, il écrivit à son fils: "Tous les matins, alors que descendais pour prendre le petit déjeuner, tu me demandais : 'Eh bien, papa, est-ce que tu peux multiplier les triplets ?' J'étais toujours obligé de répondre, avec un triste hochement de tête : 'Non, je peux seulement les ajouter et les soustraire'."

Finalement, HAMILTON a l'idée géniale de passer à un paramètre de plus: "Ainsi naquit l'idée en moi d'admettre une quatrième dimension pour calculer avec des triplets." (1843)

a + ib + jc

Ne marche pas.

a + ib + jc + kd

Hamilton passe à une composante de plus: une 4e dimension pour calculer les triplets

Il aboutit aux quaternions :

* en imposant de respecter la multiplication des modules,

* en conservant l'associativité,

* mais, hélas, il est obligé d'abandonner la commutativité.

C'est Frobenius qui démontrera en 1877, que les triplets ne peuvent pas exister!

Euler, bien avant Hamilton, en 1748, il connaissait la règle de multiplication des quaternions, sous la forme du théorème des quatre carrés

Gauss, lui aussi, connaissait la règle de calcul des quaternions en 1819.

À la recherche des autres ALGÈBRES

Gauss en 1831: il n'existe pas d'autre système de nombres avec les mêmes lois fondamentales que celles des nombres complexes.

Hamilton octobre 1843: découverte des quaternions par Hamilton. Encouragés par la découverte des quaternions, de nombreux mathématiciens tentèrent de trouver d'autres systèmes de nombres, d'autres algèbres hypercomplexes.

Octonions ou octavions décembre 1843, John Graves, puis indépendamment en 1845, Arthur Cayley construisent les octonions ou octaves de Cayley, algèbre non associative.

Bi quaternions: quaternions à coefficients complexes introduits par Hamilton en 1853. Ils ne forment pas une "vraie" algèbre (pas une algèbre à division).

Clifford crée les algèbres associatives qui portent son nom en 1878.

Sur le plan théorique:

Hamilton incapable de prouver qu'il n'existe pas de système à triplets (algèbre à division associative et commutative de dimension 3). Il reconnaît que Gauss et Grassmann ont été les précurseurs de la découverte des quaternions.

Frobenius en 1877: il n'existe que 3 algèbres à division associative de dimension finie: Réels (R), Complexes(C) et Quaternions (H).
Prouvé indépendamment en 1881 par Charles Peirce.

Hopf

1940: Cherche toutes les algèbres possibles

Montre que, si on exige la commutativité, il n'existe pas d'algèbre de dimension supérieure à 2

Il utilise la topologie pour sa démonstration. Un début! Largement utilisée de nos jours

Mazur et Gelfand

1938 et 1940: démontrent que R, C et H sont les seules algèbres complètes (de Banach)

Suite | * Nombres complexes – Développement * Nombres complexes – Index
Voir | * Constantes * Construction de l'heptagone * Inventaire des types de nombres * Nombre de Gauss * Nombres – Glossaire et index * Nombres d'Eisenstein * Nombres périodiques * Nombres périodiques * Nombres réels
Cette page | http://villemin.gerard.free.fr/Wwwgvmm/Type/ImagHist.htm


Nombres complexes, débutants

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Type/aaaCompl/Debut.htm

Nombres complexes - DÉBUTANTS

Quand deux nombres s'associent pour multiplier les possibilités de calculs …

Le nombre complexe, un outil indispensable pour les électroniciens et tous ceux qui veulent modéliser les ondes.

Approche

* L'histoire commence mal! On prétend qu'il existe des nombres dont la racine carrée serait négative. Ineptie !?

* Il est vrai que je sais calculer la racine carrée de 4. C'est 2, car 2 x 2 = 4.
Plus malin, je sais aussi que le produit de deux nombres négatifs donne un nombre positif. Si bien que (–2) x (– 2) = 4 et, par conséquent, la racine carrée de 4 est aussi bien –2.

Illustration

Astuces de contournement

* Est-ce nécessaire de disposer de la racine d'un nombre négatif? Nous verrons que oui et que c'est même une admirable invention.

* Alors, on utilise deux astuces:

* le nombre négatif est transformé en ma multiplication d'un nombre positif par le nombre -1;

* la racine de -1 est notée i comme imaginaire (impossible, ineptie, invention …).

Attention

Les mathématiciens n'aiment pas dire que i = racine de moins 1.

Cette notation étant bien commode, nous continuerons à l'utiliser, comme beaucoup le font. Mémorisons simplement qu'il s'agit d'une notation pratique sans vouloir lui faire dire autre chose.

Racine des nombres négatifs

Nombres imaginaires

* Voici la liste des racines carrés des premiers nombres négatifs.

Le principe est simple: c'est la même valeur que pour le nombre positif, associé au nombre imaginaire i.

Association de deux nombres

Nombres complexes

* Encore une idée! Comment est-elle née? Pourquoi ne pas associer un nombre normal (a) à un nombre imaginaire (i.b).

* L'un bien réel (a) continuerait à être représenté sur la droite des nombres réels (horizontale); et

* L'autre, imaginaire (i.b), aurait aussi sa droite, mais perpendiculaire à la précédente (verticale).

* Pratique! Je dispose d'un moyen pour désigner un point sur une feuille avec un système d'axes.

* Le nombre réel a est en abscisse et

* Le nombre imaginaire b est en ordonnée.

* Un mot à retenir:
Le nombre complexe z = a + i.b est appelé l'affixe du point M.

Calculs – Exemples

Addition

Les réels avec les réels et

les imaginaires avec les imaginaires.

Multiplication

Règle habituelle du produit de polynômes, mais avec l'effet de i² = – 1.

Produit réel

Cette multiplication de deux nombres complexes se termine par un produit réel.

Note: ces deux nombres sont appelés, l'un le conjugué de l'autre. La notion de conjugué est fort utile pour effectuer les divisions de nombres complexes.

Produits imaginaires

Ces deux multiplications donnent des produits imaginaires.

Fractales

* Aussi extraordinaire que cela vous paraisse, les dessins fractals les plus classiques sont obtenus en calculant le carré d'un nombre complexe.

* La répétition du calcul, selon le point de départ, produira deux effets:

* ou, le carré se dirige vers l'infini

* ou, le carré se stabilise sur une valeur.

* Coloriez cet effet et vous aurez le dessin d'une jolie fractale.

Suite en Fractales

Ça tourne

* Il en faut peu pour s'embarquer dans un monde nouveau!

* Dessinez le cercle qui passe par M et vous pouvez caractériser la position du point M par le rayon du cercle ( [image] rhô) et l'angle avec l'horizontale ( [image] thêta).

* Alors nous nous retrouvons dans le monde de la trigonométrie.

* la longueur a est la valeur du cosinus de [image] .

* la longueur a est la valeur du sinus de [image] .

* Surprenant!
En multipliant 1 par i, puis le résultat par i, on saute du monde imaginaire au monde réel, qu'ils soient positifs ou négatifs.

* Après quatre multiplications, on a fait un tour complet.

i2 = – 1

i3 = – i

i4 = 1

Affixe de M décrit de deux façons:

* a + i. b (cartésien)

* (polaire)

Suite en Représentation des nombres complexes / Puissance de l'imaginaire / Coordonnées polaires

Équations

* Une équation de degré 2 ou plus n'a pas toujours de solutions (racines) en nombres réels.

* Par contre, elle en toujours en nombres complexes.

English corner

* A complex number can be represented by an expression of the form a + ib, where a and b are real numbers and i is a symbol with the property that i² = -1.

* The complex number a = ib can also be represented by the ordered pair (a, b) and plotted as a point in a plane, called Argand plane.

* The real part of the complex number a + ib is the real number a and the imaginary part is the real number b.

* In mathematics we use i (for imaginary) but in electronics they use j (because "i" already means current, and the next letter after i is j).

Il a les nombres réels [image] et les nombres complexes


Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Type/Imagin.htm

NOMBRES COMPLEXES

Les tentatives pour résoudre les équations du troisième degré, faisant appel aux racines carrées de nombres négatifs, ont conduit à l'invention des nombres complexes.

Cette invention, sous ses multiples formes, se révélera très utile pour exécuter des calculs dans de nombreux domaines scientifiques, notamment l'électronique. En fait, le nombre complexe est roi dans tous les domaines où ça tourne ou ça alterne. Le complexe s'est également révélé fécond dans le monde des fractales

Sur cette illustration, le point M a pour coordonnées x = 3 et y = 2. Il représente le nombre complexe 3 + 2i

Nombres pas si complexes! Du moins au début …

La dénomination "nombre complexe" n'est pas très heureuse, car un débutant peut en éprouver un sentiment de blocage. Or, il s'agit tout simplement d'un couple de nombres classiques liés par un symbole qui indique qu'un des nombres matérialise une direction, alors que l'autre matérialise une direction perpendiculaire.

* Les nombres classiques sont des nombres-ligne ;

* Les nombres complexes sont des nombres-plan .

Il est vrai que l'utilisation avancée des nombres complexes fait appel à la trigonométrie et aux exponentielles et devient vite une affaire de connaisseurs.

Approche

Un imaginaire bien utile

* La lettre "i " est l’initiale du mot imaginaire.

Elle est utilisée pour caractériser un nombre singulier, bien utile, mais sans existence réelle.

* Par définition:

ou autrement dit i est ( symboliquement ) la racine carrée de –1:

* Avec ce simple nouveau nombre, il s’agit là, bel et bien, de la construction d’un nouveau monde de nombres aux vertus extraordinaires:

* Le monde des nombres imaginaires (purs) lorsqu'ils sont seuls (5i)

* Le monde des nombres complexes , lorsqu'ils sont deux (4 + 5i). Le nombre 4 est la partie réelle et le nombre 5 est la partie imaginaire du nombre complexe.

Note: pour ne pas confondre i intensité et i la racine de – 1, les électroniciens utilisent j pour symbole de racine de – 1. Par contre, en maths, j est l'une des racines cubiques de 1. Les logiciels de calcul utilisent le i majuscule.

De f

* Les nombres classique (1,2, 3, …5, 666… Pi …) se visualisent facilement en ligne, en les reportant sur une règle graduée.

* Avec les nombres complexes, on étend le territoire de la ligne à la surface.

* Ces nombres constituent un outil pratique pour résoudre des problèmes en électricité, en fait, partout où il y a du mouvement, des ondes.

Amusement

Familles des nombres complexes
Entiers | * Les nombres entiers sont les nombres usuels, utilisés pour compter la quantité de bêtes dans le troupeau ou toute autre chose.
Fractions | * Les Grecs pensaient que toute mesure pouvait se faire avec des fractions : les nombres rationnels.
Irrationnels | * L'école de Pythagore découvre que la racine de 2 ne peut être une fraction! * C'est une valeur incommensurable , un nombre irrationnel.
Réels | * Les nombres réels sont tous les nombres possibles: ceux vus ci-dessus, en y ajoutant d'étranges nombres dits transcendants.
Complexes | * Comment résoudre le cas des racines des entiers négatifs? On a trouvé pratique de poser: . * Les nombres complexes sont formés de deux nombres réels ajoutés dont l'un est multiplié par i. * Ils sont représentés par un point sur le plan . * Ces nouveaux nombres se sont avéré solution pratique de nombreux problèmes.
Quaternions | * Pourquoi ne pas passer du plan au volume , de la dimension 2 à 3? C'est l'invention des quaternions, formés de quatre nombres ajoutés, et de son algèbre particulière.
Autres Algèbres | * Peut-on généraliser et trouver d'autres types de nombres, d'autres types d'algèbres? * Non , répond Frobenius: il n'y a que les réels, les complexes et les quaternions si on veut conserver certaines propriétés de ces nombres (multiplication, en particulier).
Octavions | * On peut, néanmoins, former d'autres nombres, mais en laissant tomber certaines propriétés. Les octavions sont formés avec huit nombres ajoutés.
Sédénions | * Après les nombres complexes (algèbre à 2 dimensions), les quaternions (4), les octavions (8), voici les sédénions (16).
Cyclotomiques | * On a été amené à considérer la racine carrée de – 1. Et pourquoi pas la racine nième de – 1 . * C'est le monde des nombres cyclotomiques.

ALGÈBRE, GÉOMÉTRIE & TOPOLOGIE

Tout est parti de la racine carrée de – 1
pour arriver à des représentations géométriques ,

puis à des tentatives de généralisations des algèbres .

Pour culminer, au XXe siècle, à la recherche de démonstrations sur l'existence et la quantité possibles d'algèbres. Ces démonstrations faisant une incursion profonde dans un nouveau domaine ardu, la topologie.

Algèbre classique: l es opérations classiques y sont réalisées comme en arithmétique habituelle : a ddition, soustraction, multiplication, division.

En particulier, cette règle importante:

Le module du produit est égal au produit des modules.

English corner

Imaginary Numbers : numbers that when squared give a negative result.

If you square a real number you always get a positive, or zero, result. For example 3 × 3 = 9, and (-3) × (-3) = 9.

What is [image] ?

The unit imaginary numbers is [image] , the square root of minus one, and its symbol is [image] or sometimes [image] .

Then [image] and, for example: .

A complex number is a number which can be put in the form a + bi , where a and b are real numbers.

Suite | * Nombres complexes – Développement * Complexe – Index * Les 17 équations qui ont changé le monde
 | * Constantes * Construction de l'heptagone * Inventaire des types de nombres * Nombres – Glossaire et index * Nombres périodiques * Nombres réels * Pi exprimé en imaginaires
Cette page | http://villemin.gerard.free.fr/Wwwgvmm/Type/Imagin.htm


Nombres imaginaires, les complexes

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Type/ImagComp.htm

NOMBRES COMPLEXES

Est-ce que l'imaginaire est complexe?

Pour vous faire une idée, allez voir sur cette page:

* Interprétation de l'imaginaire>

* Puissance de l'imaginaire>

Je vous ai mis zéro; mais pourquoi m'avoir rendu une page blanche? – Mais, M'sieur ce sont des nombres imaginaires ...

NOMBRES COMPLEXES >

Définition

* Nombres complexes: expression de la forme z = a + ib

où a et b sont des nombres réels,

et i un "nombre imaginaire" tel que: i² = – 1 soit: i =

* a est la partie réelle du nombre complexe;
b est la partie imaginaire du nombre complexe.

Intérêt

* Les équations du deuxième> degré ax² + bx + c = 0 ont toujours deux racines qui, si elles ne sont pas réelles, sont imaginaires.

* Historiquement, les nombres complexes furent imaginés pour résoudre les équations du troisième degré>, en toute généralité.

Applications

* Les nombres complexes créent un pont avec la géométrie, notamment dans le domaine des rotations et similitudes.

* En mathématiques pure, le passage au monde des complexes permet la résolution de problèmes pratiquement insoluble sinon. C'est le cas pour le calcul de certaines intégrales. Le cas aussi de l'analyse complexe à l'aide du théorème des résidus.

* D'une manière générale, les complexes font partie de la boîte à outils des ingénieurs. Ils facilitent les calculs des formes d'onde (électronique, acoustique …), des flux (aérodynamique, hydrodynamique …). Ils sont utiles en théorie du signal (radar, sonar imagerie), en automatique (régulation, servomécanismes …).

* Les électroniciens> font grand usage des nombres complexes pour décrire le comportement des circuits électroniques en régime permanent comme en régime transitoire.

* Deux outils typiques:

* Le calcul de la transformée de Fourier> rapide (FFT: Fast Fourier Transform).

* La transformation de Joukovsky (Z = z + 1/z: transformation conforme>) est utilisée pour calculer le profil des ailes d'avions.

* En sciences, la mécanique quantique> fait usage des complexes. Équation de Schrödinger>, matrice d'Heisenberg, espace complexe de Hilbert …

LEVIER MATHÉMATIQUE

* Il est très pratique de passer dans le monde des complexes, momentanément, pour calculer et résoudre un problème. Même s'il faut traiter deux parties (réelles et imaginaires) – donc une de plus! – le calcul dans le monde des complexes est plus productif.

* En final, le retour dans le monde des réels donne la solution cherchée.

* Ce cas de changement de monde est fréquent en mathématiques: passage aux logarithmes> pour simplifier des calculs complexes, par exemple.

INTERPRÉTATION GÉOMÉTRIQUE

Rappel fondamental

Le nombre i est le nombre complexe dont le carré est égal à –1: .

Il est racine du polynôme x² + 1 = 0.

On le note symboliquement:

Illustration graphique

* Le triangle ABC en rouge est rectangle, car: l'un des côtés (BC) est un diamètre du cercle et le sommet opposé (A) est sur le cercle>.

* Propriété fondamentale> du triangle rectangle:

Ici, cette relation est évidente puisque a, b et c ont pour longueur le rayon du cercle:

* En osant utiliser les " longueurs relatives ", cette relation donnerait une longueur bien étrange:

* Le nombre imaginaire i se trouve être le nombre complexe dont le carré est égal à -1 . Son image dans le plan complexe se trouve effectivement au point A d'ordonnée y = 1, ou selon notre calcul relatif , en racine de moins 1, représentant le nombre imaginaire i.

Intuitivement

* On peut comprendre pourquoi, du monde purement imaginaire (axe vertical y), on peut se retrouver dans le monde purement réel (axe horizontal x), car avec i, on réalise une rotation de 90° vers le monde imaginaire (axe des y) et avec une nouvelle application de i (au total i² ), on repasse au monde réel (axe des x). En fait: i² = – 1 correspond à une rotation de 180°.

Notation symbolique de i = racine de -1

Racine des nombres négatifs: il semblerait que la notation> [image] ne soit pas recommandée dans l'enseignement supérieur en France, alors qu'elle est largement en usage dans les textes anglo-saxons ou même … indiens. En fait, i² = -1 ou [image] sont des abstractions absolument équivalentes. De mon expérience, la seconde étant souvent plus facile à comprendre et à retenir que la première.

Par exemple: la racine de +4 est soit +2 soit -2, bien! Par contre, comment calculer la racine de – 4? Elle n'existe pas dans le monde réel. Par contre, dans le monde des complexes, elle s'écrit simplement: .

Autres notations: en électronique> le i est remplacé par j pour ne pas confondre avec i comme intensité. En calcul symbolique> sur ordinateur, le i devient majuscule I.

Définition anglaise: a complex number is a number of the form a + ib where a, b [image] , the set of real numbers, and [image] , is called a complex number .

Quelques définitions sur Internet

Encyclopédie de référence américaine: The complex numbers are the field [image] of numbers of the form x + iy, where x and y are real numbers and i is the imaginary unit equal to the square root of -1 , sqrt(-1). Wolfram MathWorld >

Conclusion: on ne se privera pas d'employer cette notation [image] , notamment lors de l'abord des nombres complexes. Après tout, c'est comme cela que les nombres complexes ont été introduits pour la résolution des équations du troisième degré>. Je laisse le soin aux élèves des classes supérieures de mathématiques d'aborder les cas où cet usage pourrait être gênant . (Voir la référence en pied de cette case)

Quel est le problème? Le travers d'une telle notation est le non-respect de la définition du symbole " racine carrée de a>" qui désigne le seul nombre POSITIF dont le carré est a. Or i n’a pas de signe « naturel ». i et –i ont tous les deux -1 comme carré. Votre définition concerne donc deux nombres que l’on ne peut pas distinguer ou bien donne l’impression que i est positif.

Que les anglo-saxons emploient la notation "racine de -1" me surprend beaucoup. Le nombre i est largement utilisé en traitement du signal via les transformées ou séries de Fourier> (voir par exemple http://mathworld.wolfram.com/FourierTransform.html> ou http://www.thefouriertransform.com/transform/fourier.php> et sûrement bien d’autres). Cette fameuse "racine" était la notation historique utilisée par Cardan et on la trouve encore au début du XIXième siècle chez certains auteurs, même si Euler avait déjà proposé la notation i au siècle précédent.

Merci à Vincent P. Professeur de mathématique en PSI>

REPRÉSENTATION

Le plan complexe (d'Argand ou de Gauss)

* Un nombre complexe peut être représenté par un point dans le plan.

* La partie réelle a donne l'abscisse>; et

* La partie imaginaire b, l'ordonnée.

* La longueur [image] de OM est appelée: module [image] ;

L'angle [image] est l'argument

* On apprécie le côté pratique des nombres complexes du fait de leurs multiples représentations:

* géométrie,

* trigonométrie, et

* exponentielle.

Résumé

Définition des nombres complexes

Actuelle (due à Hamilton>)

* Le corps des nombres complexes [image] est l'ensemble des couples a + i b = (a, b) de nombres réels muni de deux opérations, l'addition membre à membre et la multiplication définie par (a, b) (c, d) = (ac – bd, ad + bc)

Matricielle (adoptée par la commission Lichnérowicz>)

* Un nombre complexe est défini par une matrice carrée d'ordre deux:

Polynômiale (attribuée à Cauchy: 1789-1857)

* Les nombres complexes a + i b sont constitués de l'ensemble des polynômes> réels de la forme: P(x) = a + bx + (x² + 1) Q(x) où Q est un polynôme arbitraire.

Bilan et observation

Trouvaille du "nombre" i qui permet la création du nouveau monde des nombres complexes aux applications multiples.

Vous allez découvrir comme effectuer les quatre opérations > classiques, effectuer des calculs> en utilisant de identités> remarquables, etc.

Remarquez que: i = [image] -1, alors i² = -1 mais aussi (-i)² = -1,
car (-i)² = (-1 x i)(-1 x i) = +1 x i² = -1. >>>>

Vous n'imaginez pas la puissance de l'imaginaire> …

English corner

* Complex Numbers : a combination of a real and an imaginary number in the form a + bi, where a and b are real, and i is imaginary.

* The values a and b can be zero, so the set of real numbers and the set of imaginary numbers are subsets of the set of complex numbers.


Nombres complexes, portail

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Type/aaaCompl/Aiguilla.htm

Vocabulaire
i Imaginaire unité |  | Symbole représentant la racine carrée du nombre négatif (–1). Base des nombres complexes. | i Imaginary unit
j |  | Une des racines complexes de ou i chez les électroniciens. | j
a + i b | z = a + i b | Nombre complexe. Dit sous sa forme cartésienne algébrique. | Complex number
(a , b) | z = (a, b) | Représentation d'un nombre complexe par une paire ordonnée de nombres. Dit sous sa forme cartésienne vectorielle. | Ordered pair
Partie réelle | Re(z) = a | Nombre réel classique. Deux symboles possibles. | Real number
Nombre imaginaire | Im(z) =b (z) | Nombre précédé du symbole i. Deux symboles possibles. | Imaginary number
Nombre imaginaire pur Nombre totalement imaginaire | z = i b | Nombre complexe dont la partie réelle est nulle | Purely imaginary
Nombre complexe | z | Nombre du type a + i b | Complex number
Corps des nombres complexes |  | Ensemble des nombres complexes avec a et b deux nombres réels. | Complex field
Plan complexe (de Gauss) |  | Système de coordonnées cartésien avec la partie réelle en abscisse et la partie imaginaire en ordonnée. >>> | Complex plane Gaussian plane Argand plane
Point image | M (a + i b) | Point image du nombre complexe. | Image
Image vectorielle |  | Vecteur qui part de l'origine des axes et atteint le point M. | Vector image
Affixe | a + i b | Nombre complexe caractérisant le point M. Aussi: coordonnées complexes du point M. | Affix
Conjugué | = a – i b | Nombre complexe dont la partie imaginaire est opposée. Utile pour la division. Parfois aussi noté z*. | Conjugate
Module Se lit: z barre |  | Longueur du segment OM dans le plan complexe. Norme du vecteur OM. | Modulus
Argument ou phase |  | Angle xoM dans le plan complexe. Non défini si a = 0 et b = 0. Angle défini à [image] près. | Argument or phase
Forme cartésienne | z = a + i.b | Point dans le plan complexe cartésien | Rectangular form
Forme trigonométrique Coordonnées polaires |  | Le couple module et argument suffit pour désigner un point M. | Polar coordinates Polar form
Coordonnées polaires Forme exponentielle |  | Expression découlant de la formule d'Euler: | Exponential form
Forme matricielle |  | Matrice de similitude directe. Module = rapport de la similitude. Argument = angle de la similitude. | Matrix form
Nombre zéro | 0 | Il est à la fois réel et imaginaire. Seul nombre complexe dont le module est nul. | Zero number
Image Se lit M prime; sans rapport avec la dérivée | M' image de M par l'application F | Une application complexe f (z). Un point M (a+ ib) Le point image M' (a'+ib' = f(a+ib) ) | Image under the transformation


Vu dans ... https://ljk.imag.fr/membres/Bernard.Ycart/mel/ca/node5.html

Nombres complexes

Le reste de ce chapitre est une révision du programme de terminale sur les complexes.

Les nombres complexes sont nés de la nécessité de donner un sens à la racine carrée de nombres négatifs, pour résoudre les équations algébriques. Dans l'ensemble des réels, l'équation [image] a deux solutions, $ +1$ et $ -1$ , mais l'équation [image] n'en a pas, puisque le carré de tout nombre réel est positif ou nul. On décide d'appeler " align="MIDDLE" border="0" src="./Nombres complexes_files/img133.gif" alt="$ \mathrm{i}^2=-1$">, puis d'appeler nombre complexe tout nombre de la forme [image] , où $ a$ et $ b$ sont deux réels quelconques. Leur ensemble est noté [image] .

Ainsi tout nombre complexe $ z$ a une partie réelle, notée Re $ (z)$ et une partie imaginaire, notée Im $ (z)$ .

Re [image] Im

Re $ (z)$ Im $ (z)$ On représente ces nombres par les points d'un plan muni de deux axes orthogonaux. L'axe horizontal porte les réels (qui sont les nombres complexes dont la partie imaginaire est nulle). L'axe vertical porte les nombres dits imaginaires purs, ceux dont la partie réelle est nulle. Le point correspondant au nombre [image] est placé à la verticale du réel $ a$ et à l'horizontale de l'imaginaire pur [image] (figure 2). On dit que le nombre [image] est l'affixe du point qui le représente. Le point d'affixe 0 est l'origine, et on le note $ O$ .
Figure 2: Le plan complexe.
L'addition et la multiplication des réels s'étendent aux nombres complexes sans difficulté particulière.
addition : ,
multiplication : .
Soient $ a,b,c$ trois réels. L'équation du second degré [image] admet toujours des solutions, éventuellement complexes.
  1. si [image] l'équation admet deux racines réelles,

    et

  2. si [image] l'équation admet une racine réelle «double»,

  3. si [image] l'équation admet deux racines complexes,

    et

Ce résultat n'est pas étonnant, et vous le connaissez déjà. Le miracle est que les complexes permettent de résoudre non seulement les équations du second degré, mais toutes les équations algébriques quel que soit leur degré. Le théorème suivant porte en France le nom de d'Alembert, bien qu'il ait été démontré par Gauss. Il est partout connu comme le théorème fondamental de l'algèbre.

Théorème 5 Soit $ P$ un polynôme de degré [image] à coefficients complexes. Le polynôme $ P$ est un produit de $ n$ facteurs de degré $ 1$ , à coefficients dans [image] .

En d'autres termes, l'équation [image] a toujours $ n$ solutions ; certaines solutions peuvent être multiples, et elles sont comptées avec leur ordre de multiplicité. On traduit cette propriété en disant que [image] est algébriquement clos.

Définition 1 Soit [image] un nombre complexe. On appelle
  1. module de $ z$ le nombre réel positif ou nul [image] . On le note [image] .
  2. argument de $ z$ l'angle [image] tel que Re [image] et [image] .
  3. conjugué de $ z$ le nombre complexe de même partie réelle et de partie imaginaire opposée. On le note [image] .

Voici quelques exemples.

Dans le plan complexe, le module est la longueur du segment joignant l'origine au point représentant $ z$ . L'argument est l'angle entre l'axe des réels et ce segment, orienté dans le sens inverse des aiguilles d'une montre (le sens trigonométrique). Le conjugué est le symétrique par rapport à l'axe horizontal des réels (figure 3).
Figure 3: Module, argument et conjugué d'un nombre complexe.
Observez qu'un nombre et son conjugué ont le même module et que leur produit est le carré de ce module.

Il est fréquent dans les calculs d'utiliser un conjugué pour simplifier le résultat et le mettre sous la forme [image] . Si [image] et [image] sont deux complexes, leur quotient s'écrit :

Voici un exemple.


Leçon Complexes - forme exponentielle - Cours maths Terminale

Vu dans ... http://www.educastream.com/complexes-forme-exponentielle-terminale-s

1/ Nombre complexe de module 1

Dans le plan complexe rapporté à un repère orthonormé :
Tout nombre complexe non nul peut s'écrire sous forme trigonométrique :

Récip roquement :

Or : 1>0 donc par unicité de l’écriture trigonométrique :

D’où l’é quivalence :

1/ Nombre complexe de module 1

Résultat évident d’un point de vue géométrique car :

Nombre complexe de module 1

Nombre complexe de module 1 Nombre complexe de module 1
Nombre complexe de module 1

A chaque point du cercle correspond une valeur de [image] .
balaye donc un intervalle semi-ouvert de longueur 2 [image].

Si l’intervalle sur lequel est pris [image] est d’une longueur inférieure à 2
alors M ne décrit qu’un arc de cercle.

2/ Notation exponentielle

Pour des raisons d'analogie avec la fonction exponenetielle, que nous verrons plus loin, on décide de noter :
Se lit " exponentielle de i [image] " ou encore plus simplement : " é - i - téta " .

D’où une équivalence globale :

notation exponentielle
Il faut savoir lire et utiliser ces multiples équivalences dans tous les sens et avoir compris en particulier que :
est le nombre complexe de module 1 et d’argument [image].

ou encore que :
Tout nombre complexe de module 1 peut s’écrire [image] , [image] étant son argument.

3/ Quelques valeurs de référence

est le nombre complexe de module 1 et d'argument

Donc, en particulier : est le nombre complexe de module 1 et d’argument 0.

D'où : complexe - forme exponentielle D'où [image] = 1 complexe - forme exponentielle

Par un même raisonnement graphique, on obtient :
complexe - forme exponentielle complexe - forme exponentielle

complexe - forme exponentielle complexe - forme exponentielle

complexe - forme exponentielle complexe - forme exponentielle
mais on notera plutôt avec le signe " - " devant

D'où

Resultat que l'on peut aussi retrouver par le calcul :

4/ Notation exponentielle du conjugué et de l'opposé

Nous pouvons nous aider de la configuration

5/ Propriétés algébriques de la notation exponentielle

Produit de deux exponentielles :

est le nombre complexe de module 1 et d'argument [image] donc :
Cette égalité ainsi que celle-ci : = 1
sont les deux « équations fonctionnelles » que doit vérifier une fonction pour être une fonction exponentielle.

La notation [image] se justifie donc.

Remarque :
On peut retrouver le resultat démontré géometriquement sur

Puissance d'une exponentielle :

est le nombre complexe de module 1 et d'argument [image] donc :

On peut également le déduire comme première conséquence du resultat ci-dessus en utilisant une demonstration par recurrrence.

Deuxième conséquen ce de la propriété sur le produit :

Inverse d'une exponentielle :

donc :

On peut également le démontrer en utilisant module et argument comme vu plus haut.

Remarque :
1) On peut retrouver le résultat démontré géométriquement
donc
2) On peut diviser par [image] car son module vaut 1 il ne peut être nul.

Conséquence des propriétés sur le produit et l'inverse :

Quotient de deux exponentielles :

quotient de deux exponentielles

La propriété N°2 peut aussi être écrite ainsi :
sous cette forme, elle est appellée Formule de Moivre

En résumé, la notation exponentielle a les mêmes propriétés que la notation puissance.

Ces propriétés sont donc très simples à retenir et leur manipulation est très intuitive.
Leur démonstration pourra faire l’objet d’un R.O.C.

6/ Forme exponentielle : existence

Rappel sur la forme trigonométrique :

Dans le plan complexe muni d’un repère orthonormé : et orienté dans le sens trigonométrique.

Tout nombre complexe non nul peut s’écrire :

cette écriture est appelée : forme exponentielle du nombre complexe.

Cependant, attention toute écriture qui à l’air exponentielle n’en est pas forcément une !

Par exemple :

n'est pas écrit sous forme exponentielle car -5<0 ne peut être le module de z.

Remarque :
Nous verrons dans la partie exercice comment trouver la bonne écriture exponentielle de ce nombre

7/ Forme exponentielle : unicité

Rappel :
L'écriture trigonométrique d'un nombre complexe non nul est unique .

Et d'un point de vue pratique :
est l'écriture trigonométrique de z si et seulement si

auquel cas

Donc :
L'écriture exponentielle d'un nombre complexe est unique .
et d'un point de vue pratique :
est l'écriture exponenetielle de z si et seulement si

auquel cas

Une stratégie pour mettre un nombre sous forme exponentielle pourra donc parfois consister à calculer le module, à le mettre en facteur,puis à réussir à mettre le facteur restant sous la forme :
7/ Forme exponentielle : égalité

Rappel :

Si les formes trigonométriques de z et z' sont :

alors :

donc : si les formes exponentielles de z et z' sont :
alors :

En particulier pour r = r' = 1.

7/ Forme exponentielle : résumé

Nous pouvons donc étendre notre équivalence de départ à tout nombre complexe non nul.

forme exponentielle

forme exponentielle

Remarque
Pour passer de la forme algébrique à la forme exponentielle ou inversement,il faut passer par la forme intermédiaire qu’est la forme trigonométrique.

7/ Forme exponentielle :conjugué et opposé

7/ Forme exponentielle : calculs

Du fait de ses propriétés semblables à celles d’une puissance,la notation exponentielle est idéale pour pratiquer des calculs sur les complexes.
En particulier quand ces calculs sont des produits, des puissances ou des quotients.

Exemples :
1° Montrer que [image] est un réel.
On aurait également pû faire ce calcul à l'aie de deux carrés ou de la formule du binôme de Newton.
Tout d'abord, mettons 3 + 3i sous forme exponentielle.

2° Montrer que [image] est imaginaire pur.

On pourrait tout à fait mener ce calcul de façon algébrique mais nous allons choisir la stratégie exponentielle.

forme exponentielle
Toute cette étape pouvant être faite de tête ou au brouillon

forme exponentielle

8/ Formules d’Euler

Remarque
Comme
On peut par exemple redémontrer ce résultat de la sorte :

9/ Equation paramétrique d’un cercle : démonstration

Soit C le cercle de centre [image] et de rayon R .

Or [image] admet une écriture exponentielle qui est :

De plus quand M parcourt C , [image] décrit l’intervalle

Illustration

Ce résultat est très simple à retrouver et à expliquer graphiquement :

En effet, tout cercle de rayon R est le translaté d'un cercle de centre O et de même rayon.

En résumé :

qui représente l’angle [image] est le paramètre :

à chaque valeur de [image] prise dans un intervalle de longueur [image] correspond un unique point du cercle, et inversement.


Forme trigonométrique d'un nombre complexe non nul - Site sur les nombres complexe et les Fractales

Vu dans ... https://complexe.jimdo.com/la-g%C3%A9om%C3%A9trie-complexe-2d/d%C3%A9finition/forme-trigonom%C3%A9trique/

  • Accueil
  • Introduction aux nombres complexes
  • Quelques propriétés algébriques
  • La géométrie complexe (2D)
  • Des fractales (2D) générées informatiquement grâce au logiciel Xaos
  • Pour aller plus loin avec les nombres complexes
  • Les nombres complexes en électricité
  • Les fractales
  • La théorie du Chaos
  • Les équations de Turing
  • Conclusion
  • Définition
  • Les transformations complexes
  • Principe de construction de l'ensemble de Mandelbrot
  • Représentation géométrique
  • Rappels de trigonométrique (dans R)
  • Forme trigonométrique
  • Propriétés sur le module et l'argument
  • Calcul avec les écritures exponentielles et trigonométriques d'un nombre complexe non nul
A la découverte des (Hyper)complexes, des fractales ET de la théorie du Chaos Sont-ils présents dans notre monde ?

Forme trigonométrique d'un nombre complexe non nul

Nous avons vu que tout nombre complexe admettait une forme algébrique z = a + b.i

Donc tout nombre complexe peut être repérer dans le plan complexe.

Seuls les nombres complexes non nul peuvent cependant être étudiés pour leurs propriétés trigonométriques (en effet, comment former un angle avec 1 seul point ? )

Toute cette partie n'est valable que si le nombre nombre z est non nul, ce que l'on note :

La notion de module et d'argument

On introduit Théta (en radian) et la longueur OM de cette manière :

Ainsi, dans le plan complexe, on obtient :

Vocabulaire :

  1. Dans le plan complexe, on ne parle pas en terme "d'angles" mais on appelle cela les arguments .

==> UN argument du nombre complexe z, noté arg(z) , est donc théta.

Remarque :

On dit que z admet UN argument car une même position sur le cercle trigonométrique peut correspondre une infinité de points (ceux qui ont fait des tours entiers de cercle).

C'est la fameuse histoire du modulo 2pi présenté dans le rappel de trigonométrie.

Un argument (en radian) que forme un nombre complexe z non nul avec l'axe des abscisses est donc l'argument de z.

2. La distance pour "atteindre" le nombre complexe z en partant l'origine du repère est la distance OM, qu'on appelle le module de z.

On écrit le module de z est noté |z| .

Sa valeur est :

En effet, dans le triangle rectangle ci-dessous de côtés de longueurs "a" et "b", l'hypoténuse de ce triangle vaut d'après Pythagore sqrt(a^2+b^2) !

http://homeomath.imingo.net/module.htm

Remarques sur le module :
- le module d'un nombre complexe est un réel positif.
- deux nombres complexes distincts peuvent avoir le même module.
- le module d'un nombre réel est égal à sa valeur absolue, c'est pour cela qu'on conserve la notation avec les deux barres " | x | ".

De plus, on peut noter que :

La démonstration est extrêment simple :

Pour votre culture, je vous ai mis un tableau récapitulatif des notations utilisées dans les nombres complexes, ainsi que l'auteur et la date de chaque notation :

Introduction du vocabulaire et des notations

La notion de forme trigonométrique

Tout nombre complexe peut se positionner dans le plan complexe.

Du coup, tout nombre complexe (non nul) peut se repérer dans le plan par son module et par un argument (mod 2pi).

Du coup, tout nombre complexe non nul peut s'écrire sous forme trigonométrique , c'est-à-dire :

Lien entre la forme algébrique et la forme trigonométrique

Si existe deux situations dans laquelle la forme trigonométrique peut être écrite sous la forme algébrique.

  • Cas 1 : si on connait la valeur du module |z|>0 et d'un argument de z, alors on peut tout simplement développer la formule précédente, ce qui donne :
  • Cas 2 si on ne connait que les valeurs de "a" et de "b", alors on a :

En effet,

Généralisation du module et de l'argument

Le module de deux points A(z_A) et B(z_B)

Si deux points A et B d'affixes respectis z_A et z_B sont dans un repère orthonormé, alors :

La démonstration se fait logiquement ;

On est d'accord qu'il n'existe un unique point M qui vérifie :

Cependant, on sait que :

Or par définition,

Un argument de deux points distincts A(z_A) et B(z_B)

Si deux points A et B d'affixes respectis z_A et z_B différentes sont dans un repère orthonormé, alors :

Démonstration :

Comme avant, on sait qu'il existe un unique point M tel que :

Comme nous l'avons démontré précédemment,

Si vous voulez comprendre la suite du cours et les techniques de calcul, il vous faudra avoir vu les propriétés de la fonction exponentielle que l'on voit en terminale.

Les propriétés de l'exponentielle sont semblables à ceux sur les puissance de nombres.

Il faudra donc vous renseigner sur la fonction exponentielle pour continuer la lecture sur les nombres complexes.

Vous pouvez toujours aller voir la rubrique "Fractales" si vous en l'avez pas encore fait ICI.

Sinon, continuons la lecture.

Notation exponentielle de la forme trigonométrique

Pour un nombre complexe z de module |z| = 1

Un nombre complexe z de module |z| = 1 dont un argument est théta se note désormais :

Pour un angle théta donné, on a donc l'égalité :

Cette formule est à retenir par coeur; elle est FONDAMENTALE pour les nombres complexes.

Elle est très pratique car elle lie les propriétés de l'exponentielle et de la trigonométrie pour calculer les arguments des nombres complexes .

C'est d'ailleurs pour celà que cette notation est très utilisée.

C'est le mathématicien suisse Leonhard Euler qui l'a inventé.

Démontrons cette formule :

Rappels :

Sa formule se fait exactement de la même manière que celle de l'unicité de la fonction exponenetielle.

Tout nombre complexe de module 1 s'écrit sous la forme :

Maintenant, posons la fonction f qui à tout réel théta, associe le nombre complexe :

L'idée est de démontrer que pour tous réels théta et théta', on obtient :

On remarque une ressemblance avec l'exponenetielle, non ?

Dérivons le produit des fonctions et comparons :

On obtient donc d'après les rappels :

De plus, on a que :

Ainsi, f transforme les sommes en produits et f(0) = 1, tout comme la fonction exponenetielle.

D'où l'idée de poser :

L'égalité que nous avons démontré auparavant peut donc aussi se noter :

Cette démonstration justifie le choix de la notation exponentielle.

Valeurs remarquables :

Egalité issue de Euler

Les démonstrations sont extrêmement simples :

Généralisation

On peut retenir e puissance << 2 kipi >> = 1

Je ne connaissais pas cette personnalité avant que je modifie par moi-meme cette formule.

Comme quoi, on en apprend des choses en étudiant les nombres complexes !

Les démonstrations prennent simplement en compte que le sinus et le cosinus sont 2pi-périodiques.

ATTENTION à l'écriture !!!

Il faut faire super attention aux parenthèses; en effet :

Pour un nombre complexe z non nul de module |z|

Finalement, tout nombre complexe non nul peut s'écrire sous la forme exponentielle :

Ainsi, tout nombre complexe se repère dans le plan de cette manière :

Remarque sur le conjugué d'une notation exponentielle :

La démonstration est rapide :

Les égalités d'Abraham de Moivre sont du coup facilement démontrables

Voici les formules démontrées par Moivre :

La forme exponentielle et les propriétés de la fonction exponentielle vont beaucoup nous aider ici pour les démonstrations. La trigonométrie (2pi-périodique) va aussi nous aider !

1ère démonstration :

2ème démonstration :

ATTENTION - En faisant ce sujet, j'ai découvert une énorme erreur sur Wikipédia.

C'EST ARCHI FAUX ! : (partie historique) http://fr.wikipedia.org/wiki/Nombre_complexe

Image prise le 10-06-13

Maintenant que nous savons ce qu'est un argument et le module d'un nombre complexe, alors nous pouvons maintenant analyser les propriétés sur le module et l'argument.


Nombres complexes

Vu dans ... http://www.silicium628.fr/cours/complexes

Les nombres complexes (1)

Invention:

L'idée d'un nombre imaginaire:

Nous savons que le produit de deux nombres positifs donne un nombre positif. En particulier le carré d'un nombre positif qui est égal au produit de ce nombre par lui-même donne un nombre positif. ex:

De même le produit de deux nombres négatifs donne un également nombre positif. En particulier le carré d'un nombre négatif qui est égal au produit de ce nombre par lui-même donne un nombre positif. ex: = +25

Il n'y a, à priori, pas d'autre cas de figure pour obtenir un carré, peut-on donc conclure qu'un carré est toujours un nombre positif? Non, ça montre que le carré de n'importe quel nombre réel est positif.

Mais cela ne démontre pas que tout carré est positif.

On peut imaginer que le carré de quelque chose qui ne serait pas un nombre ordinaire, pas un nombre réel, appelons le un nombre imaginaire, serait négatif. C'est de la folie? Mais non! simplement de l'imagination. Comme le fut l'invention des nombres négatifs...

Appelons ce nombre imaginaire [image] (i comme... imaginaire) et décidons que sont carré soit négatif et vaille [image].

Représentation:

Mais alors, combien vaut ce [image] ? Eh bien il vaut [image] et c'est tout! ou encore [image] . Oui mais... ça ressemble à quoi un [image] imaginaire ? A quelque chose qui multiplié par lui même vaut

Oui mais on aimerait quand même le voir ce nombre imaginaire nous! Bon d'accord, je vais le dessiner. Mais auparavant je dois vous dessiner l'image de 1, oui le nombre bien réel 1. On va le faire d'une façon géométrique. Traçons une droite horizontale pleine de points juxtaposés donc, chaque point représentant un nombre ordinaire, réel. Un de ces points représentera 0, et un autre un peu à sa droite représentera le nombre 1. Voila, avec une bonne loupe on peut voir 1.

Bon d'accord, mais [image] il est où sur cette droite? à gauche de 0 ? Non, à gauche de 0 ce sont les nombres négatifs. Le nombre imaginaire [image] n'est PAS sur cette droite! Il se trouve sur une droite perpendiculaire! Et on va voir pourquoi.

Nous avons vu plus haut que [image] vaut [image] [image] (une fois [image])

Si nous plaçons [image] sur la droite verticale à la même distance de 0 que le 1, (c'est à dire sur un cercle de centre 0 et passant par 1), on voit que le fait de multiplier 1 par [image] est l'équivalent, en partant de 1, de faire un quart de tour vers la gauche, pour trouver le résultat [image].

Dès lors qu'on connait cette astuce pour multiplier par [image], appliquons-la à [image] lui même. On part de [image] et on fait un quart de tour à gauche. On se retrouve sur la droite des nombres biens réels, sur le nombre [image]! On voit donc que ce principe opératoire de multiplication par [image] nous amène au résultat que [image] [image] c'est à dire que [image] ça correspond exactement au but recherché. On sait maintenant représenter [image].

Maintenant si partant de [image] on fait un quart de tour vers la gauche, on se retrouve à nouveau sur la droite verticale, la droite imaginaire! Et comme on peut écrire que [image] on voit que le point sur laquelle on se trouve alors, au dessous de 0 représente - [image]. Donc cette droite perpendiculaire, cette droite imaginaire ressemble fort à la droite horizontale représentant les nombres réels à par son orientation... Ses points correspondent à des nombres imaginaires, multiples de [image] [image], comme [image] ... etc ainsi que [image] [image] etc... ainsi que toutes les valeurs intermédiaires. Pour savoir où se trouve [image], il suffit de partir de [image] sur la droite des réels et de faire un quart de tour à gauche. On voit donc que par l'association de la procédure « faire un quart de tour à gauche » avec la multiplication par [image] , en partant de TOUS les points de la droite horizontale on trace en fait tous les points de la droite verticale. (tous signifie autant qu'on le désire, les réels étant en nombre infini sur tout intervalle...) C'est ce qui justifie les appellations d'axe réel et axe imaginaire «pur » pour ces deux droite. Pur ? tiens donc! Il y a autre chose? encore une complication!

Les nombres complexes:

Mais non, pire! une folie! un pas de plus pour l'imagination! On vient de représenter deux ensembles de nombres bien distincts avec nos deux droites... et qu'en est-il des AUTRES points du plan (de la feuille sur laquelle sont tracées ces droites)? Et s'ils représentaient eux aussi des nombres? Oui mais quels types de nombres? des nombres réels? non, eux ils sont tous sur la droite horizontale. Des nombres imaginaires « purs »? non plus, ils sont tous sur la droite verticale. On dira une combinaison des deux. Et on les appellera des nombres complexes.

Chaque point sera défini par ses coordonnées a et b sur les axes réel et imaginaire

et représentera un nombre complexe qui s'écrira:

Tiens nous avions appris à l'école qu'on ne peut pas ajouter des carottes et des salades? Hé bien ce n'était pas vrai! Avec un peu d'imagination on peut! Mais le résultat n'est pas carottes ni salades, mais une combinaison des deux.

Voilà, tout (enfin le principal) est dit concernant la recette des nombres complexes, le reste c'est de la cuisine.

Mais quelle cuisine! Une cuisine qui s'accommode extrêmement bien à notre plat de résistance qu'est l'électronique. Aussi elle mérite que nous l'étudions afiin de pouvoir vraiment comprendre l'électronique. C'est incontournable, l'électronique repose sur la physique, et les lois de la nature nous apparaissent essentiellement mathématiques. Feyman (et d'autres) l'avait souligné.

Autant dire, pour ceux qui sont allergiques aux math, que mes propos vont rapidement devenir désagréables... On va parler vecteurs, trigonométrie, sinus et cosinus. Puis il faudra faire un détour par la fonction logarithme néperien et sa réciproque la fonction exponentielle afiin de manier ces nombres complexes plus aisément, je dirais presque les doigts dans le nez.

Si certaines images (formules) de cette page ne s'affichent pas, voir l'autre site miroir.
Cette page (et celles qui suivent) est écrite sous Linux Ubuntu avec les logiciels libres suivants:

  • GNU TEXmacs editor (pour les formules)
  • Kig (pour les graphes)
  • Gimp (pour la retouche des images)
  • SeaMonkey composer (pour la mise en page html)
Vive le logiciel Libre!


Vu dans ... http://www.silicium628.fr/cours/complexes

Les nombres complexes (2)

Forme algébrique:

avec: ; [image] ;

est la partie réelle

est pa partie imaginaire

z est un nombre complexe

Autre notation:

Nombre complexe conjugué :

Le nombre complexe conjugué est noté [image] ou parfois

Si [image] , le conjugué de [image] a pour valeur :

Le conjugue a même partie réelle mais une partie imaginaire opposée.

Module

Le module d'un nombre complexe noté [image] est la distance entre le point de coordonnées (a, b) et l'origine (dans le cas de la représention géométrique dans le plan complexe). C'est en quelque sorte la « longueur » du nombre complexe.

Il a pour valeur :

Remarque :

Par conséquent :

Opérations:

Addition:

on additionne donc séparément et respectivement les parties réelles et imaginaires.

Multiplication

ici on oublie pas que [image] donc il faut remplacer [image] par

les calculs algébriques avec les nombres complexes se font donc comme avec les nombres réels à ceci près que lorsqu'on rencontre [image] on le remplace par [image].

revenons à notre multiplication:

C'est un peu compliqué sous la forme algébrique, aussi on va s'intéresser maintenant à la forme trigonométrique des nombres complexes.

Forme trigonométrique:

Le nombre complexe z peut être représenté par un vecteur

Remarque:

soit [image] l'angle

soit [image] = [image] = OM le module du vecteur (la «norme du vecteur » ou « longueur du segment OM »)

et [image] définissent complètement le vecteur [image] et donc le nombre complexe

On écrira:

est appelé le module de [image] on le notera aussi

est l'argument de

Les relations trigonométriques dans le triangle rectangle 0AM permettent d'écrire:

or nous avons vu que par définition OA représente la partie réelle de [image] et OB la partie imaginaire. Le nombre complexe [image] est la somme de sa partie réelle et de sa partie imaginaire.

On peut donc écrire (sans oublier [image] qui caractérise la partie imaginaire):

mais on sait aussi que:

on identifie les termes: et

On obtient ainsi la relation qui lie parties réelle et imaginaire (de la notation algébrique) au module et à l'argument de la notation trigonométrique.

Dans l'autre sens, les relations trigonométriques dans le triangle rectangle 0AM nous montrent que:

(le carré de l'hypoténuse est égal...) et donc

quant à l'argument on a:

Sous la forme trigonométrique l'addition devient une somme vectorielle. Ce n'est pratique que si on travaille graphiquement, ce qui est parfois le cas. La multiplication en revanche devient plus simple que sous la forme algébrique. Nous verrons ça sur la page suivante.


Vu dans ... http://www.silicium628.fr/cours/complexes

Les nombres complexes (3)

Opérations sous la forme trigonométrique:

Somme:

soit

en notation algébrique on obtient la somme:

Traçons [image] d'après ces coordonnées. On obtient un vecteur qui est la somme vectorielle des vecteurs représentant [image]. On aurait pu tracer ce vecteur somme par la méthode du parallélogramme.

Cette approche est utile en électronique par exemple pour comprendre la distribution spectrale d'une porteuse sinusoidale modulée en amplitude, faisant apparaitre les bandes latérales. On verra ça plus tard.

Produit:

on notera ci-dessus l'apparition du signe (-) remplaçant

une petite application des règles de trigonométrie ( [image]) donne:

On voit que:

Le produit de deux nombres complexes a comme module le produit des modules et comme argument la somme des arguments.

Quand je vous disais que la multiplication était plus simple sous cette forme...
On remarque aussi que les formules de trigo servent à quelque chose...


Vu dans ... http://www.silicium628.fr/cours/complexes

Forme exponentielle des nombres complexes

soit le nombre complexe

écrivons le

où [image] est la fonction exponentielle de base

1Justification de cette écriture:

nous avons vu que

or le produit sous la forme exponentielle donne:

ce qui est bien la représentation exponentielle de

En outre , on a:

de même

Ces propriétés justifient la notation :

En électronique, on utilisera le plus souvent les nombres complexes sous cette forme exponentielle.

Note 1. En électronique on désigne le nombre imaginaire [image] par la lettre [image] pour ne pas confondre avec le [image] de l'intensité (le nombre d'ampères)

2Représentation complexe d'une grandeur sinusoïdale

Une tension sinusoïdale [image] , de pulsation [image] , d'amplitude U et de phase

s'écrira:

c'est une valeur réelle, sera associée à la valeur complexe :

ou, sous sa forme exponentielle :

Il ne faudra pas perdre de vue que le signal sinusoïdal traité ne constitue que la partie réelle de ce nombre complexe.

Mais alors pourquoi se compliquer la vie en utilisant cette représentation complexe ? Parce que les calculs qui se feront dès lors sur cette valeur complexe se trouveront grandement simplifiés.

Note 2. On peut décomposer la valeur complexe en un produit de deux termes :

Note 3. On représente les grandeurs (tension, intensité) constantes par des lettres majuscules et les grandeurs instantanées par des lettres minuscules.

Note 4. Par comodité d'écriture, on confondra souvent la notation complexe avec sa partie réelle, ainsi on rencontrera la notation [image], sans la notation [image] devant. Elle est alors sous-entendue. Répétons ici qu'il ne faudra pas perdre de vue que le signal sinusoïdal traité ne constitue que la partie réelle de ce nombre complexe. Une fois les calculs faits sur les valeurs complexes, il suffira de reconsidérer la partie réelle du résultat afin de retouver LA valeur réelle.

Toutefois nous verrons ultérieurement qu'en physique quantique, les caractéristiques des particules se modélisent effectivement par des nombres complexes, et en faisant ainsi leurs propriétés qui parraissent mystérieuses lorsqu'on veut les représenter par des valeurs réelles ne le sont plus du point de vue mathématique. En particulier la « dualité onde-corpuscule ». Je cite Richard Feynman [DUNOD - ISBN 2 10 004934 8 page 8] : « En mécanique quantique il se trouve que les amplitudes doivent être représentées par des nombres complexes. Les parties réelles seules ne suffisent pas ».

3Impédance complexe du condensateur:

soit [image] (on considère que la phase [image])

Les lois élémentaires de l'électricité donnent:

(la quantité d'électricité (en Coulombs) dans le condensateur est égale au produit de la tension aux bornes par la valeur du condensateur (en Farads))

dérivons cette expression:

or nous savons que

(t est le temps)

donc

en en déduit:

Vous voyez tout le cheminement indispensable que nous avons du faire pour arriver à ce résultat essentiel: obtenir une représentation mathématique d'un composant électronique réactif. Le condensateur, au contraire de la résistance, est parcouru par un courant qui est en quadrature de phase avec la tension présente à ses bornes. Et c'est justement ce comportement complexe qui est compris dans cette formule.

On l'appelle impédance complexe du condensateur.

La prochaine fois nous calculerons l'impédance complexe de l'inductance puis nous les associerons pour voir comment se comporte mathématiquement l'ensemble.


Vu dans ... http://www.mathematiques-lycee.com/geometrie/2nde-03-relation-chasles.html

Relation de Chasles

Enoncé et application de la relation Chasles

La relation de chasle est un cas particulier d'addition de vecteurs, elle ne peut s'appliquer que lorsque l'extrémité du premier vecteur correspond au même point que l'origine du deuxième vecteur, dans ce cas le vecteur somme possède la même origine que le premier vecteur et a la même extrémité que le second vecteur.

Exemples :

vecteur AB + vecteur bc = vecteur ac
vecteur am + vecteur mb = vecteur AB
Vecteur cg + vecteur gn = Vecteur CN

Remarque: le vecteur somme possède des coordonnées qui ne dépendent pas du point commun au deux vecteurs ajouté.

Simplifier une expression vectorielle avec la relation de Chasles

Lorsqu'une expression consiste en une somme de plusieurs vecteurs il est parfois possible d'utiliser la relation de Chasles pour la simplifier.
Exemple d'expression simplifiable: vecteur gn + vecteur bc + vecteur AB + Vecteur cg

La première étape consiste à rassembler les vecteurs qui possèdent des point communs
Exemple: vecteur gn + vecteur bc + vecteur AB + Vecteur cg = vecteur AB + vecteur bc + Vecteur cg + vecteur gn

La deuxième étape consiste à vérifier si certains points sont communs à l'origine d'un vecteur et à l'origine de l'autre afin de pouvoir appliquer la relation de Chasles.
Exemple:
- C'est le cas de vecteur AB et vecteur bc donc : vecteur AB + vecteur bc = vecteur ac
- C'est le cas de Vecteur cg + vecteur gn donc : Vecteur cg + vecteur gn = Vecteur CN
L'expression devient donc vecteur gn + vecteur bc + vecteur AB + Vecteur cg = vecteur ac + Vecteur CN

La troisième étape consiste à vérifier si une simplification supplémentaire est possible.
Exemple: dans vecteur ac + Vecteur CN le point C est l'extrémité du premier vecteur mais aussi l'origine du deuxième, on peut de nouveau utiliser la relation de Chasle.
vecteur ac + Vecteur CN = vecteur an

Dans cet exemple la relation de Chasle permet donc de passer de la somme vecteur gn + vecteur bc + vecteur AB + Vecteur cg au vecteur unique vecteur an

Décomposition d'un vecteur en une somme de vecteurs

La relation de Chasle peut également être utilisée pour obtenir une somme de vecteurs à partir d'un seul et unique vecteur, en effet si vecteur AB + vecteur bc = vecteur ac alors on a aussi vecteur ac = vecteur AB + vecteur bc.

D'une manière générale pour un vecteur vecteur AB et tout point M quelconque: vecteur AB = vecteur am + vecteur mb

En général le point M intermédiaire utilisé pour décomposé un vecteur n'est pas choisi au hasard, on utilise souvent un point particulier qui permet de répondre à un problème, effectuer une comparaison, etc.

Si par exemple on choisit M comme le milieu du segment [AB] alors ont a vecteur am = vecteur mb ce qui conduit à vecteur AB = 2 vecteur am ou vecteur AB = 2 vecteur mb


Vu dans ... http://warmaths.fr/MATH/REPERAGE/Relation%20de%20Chasles.htm

COURS

INFO.

CHASLES Michel ( 1793 –1880)

Auteur d’importants travaux de géométrie , il est surtout connu grâce à la relation qu’il a établi et qui porte son nom :

· Quels que soient les trois points ( A ; B ; C) d’une droite :

· Quels que soient les trois points ( A ; B ; C) du plan ;

Il a enseigné la géodésie (Science qui s’intéresse à la forme et aux dimensions de la terre )à l’ Ecole polytechnique .

Ensuite il a occupé une chaire de géométrie supérieure à la Sorbonne.

Théorème 1 :

La mesure algébrique de la somme de deux vecteurs consécutifs portés par un même axe est égale à la somme des mesures algébriques de ces vecteurs.

Il s’agit de montrer que l’égalité vectorielle [image] entraîne l’égalité

Connue sous le nom de relation de Chasles

Il existe six cas possibles :

Cas 1

A

B

C

Cas 2

C

A

B

Cas 3

B

C

A

Cas 4

C

B

A

Cas 5

C

A

B

Cas 6

B

A

C

Pour le cas « 5 » on a ,

par exemple ,

D’où en transposant :

Remarque : il faut trois égalités arithmétiques pour traduire , selon les cas , la position relative de trois points A ; B ; C en ligne droite

AC = AB +BC ;

    AC = AB – BC

    ;
    ou

    ;

    AC = BC – AB

Au contraire : la relation de Châles est générale et est indépendante du sens de l’axe .

Si M , N et P , on a toujours

; ( intercaler la lettre N entre M et P qui figurent au premier membre) quel que soit le sens suivant lequel la droite MP est orientée .

Généralisation :

La relation de Chasles se généralise pour un nombre quelconque de vecteurs consécutifs . Si A ; B ; C ; et D sont alignés .

On a :

Théorème 2

Nous appliquons la formule de Chasles aux trois points O , A et B

si nous désignons par « a » et « b » les abscisses de A et de B ; nous obtenons

= b – a

O

A

B

+2

+5

= b – a ; a = + 2 ; b = + 5 ; [image] = ( + 5 ) - (+2) = +3

Exemple 2 :

B

O

- 1

+4

= b – a ; a = + 4 ; b = -1 ; [image] = ( - 1 ) - (+4) = -5

Relation de CHASLES appliquées aux mesures algébriques de plusieurs bipoints sur une droite graduée.

Quels que soient les trois points ( A ; B ; C) d’une droite ;

Les bipoints (A, B) et (B ,C ) sont appelés bipoints co n séc u tifs

On dira que :

La mesure algébrique de la somme de deux segments consécutifs est égale à la somme des deux mesures algébriques de ces segments .

Soit une droite :

Zone de Texte: A(+3,5)

RESUME : >

@ info >

Vecteurs

On appelle « vecteur » un segment de droite orientée. ; …………….. Exemple :

On représente un vecteur AB par la notation : ; « A » est l’origine du vecteur et « B » son extrémité.

@ info >

Mesure algébrique d’un vecteur .

On appelle « mesure algébrique » d’un vecteur porté sur un axe le nombre qui a:

1°) pour valeur absolue le nombre qui mesure la longueur du vecteur.

2°) pour signe « + » ou « -» suivant que pour aller de l’origine à l’extrémité du vecteur on se dirige dans le sens positif ou dans le sens négatif sur l’axe.

La mesure algébrique d’un vecteur porté sur un axe se représente par la notation :

« Relation de Chasles »

Etant donnés trois points « A » ; « B » et « C » sur un axe , quelles que soit les positions de ces points on a :

Enoncé équivalent : la mesure algébrique d’un vecteur porté sur un axe est égale à l’abscisse de son extrémité diminuée de l’abscisse de son origine.

Remarque : ( [image] )

Application : l’abscisse du milieu d’un segment porté par un axe est égale à la demi - somme des abscisses des extrémités du segment.

Généralisation : Soient « n » points « A ; B ; C ; ….H ; K ;L » d’un axe. En procédant de proche en proche on peut écrire :

INTE RDISCIPLINARITE

APPLICATIONS de la relation de Chasles :

Pour chaque cas : cliquer sur le groupe de mots « pour voir »

I ) Abscisse du milieu d’un segment

II ) Le traité vectoriel du centre de grav i t é d’un triangle

III ) Somme de deux vecteurs colinéaires opposés

Travaux auto formatifs.

CON TROLE

1. Qu'appelle t on "mesure"

2. Qu'appelle t on "longueur "

3. Qu'appelle t on "distance"

4. Pour quoi est utilisée la mesure algébrique ?

5. Compléter les phrases suivantes :

6. la mesure algébrique d ‘ un bipoint est …………… … ,

7. La distance entre deux points …………………………………

8. La longueur entre deux points …………………………………..

9. On dit que la mesure algébrique est une valeur relative : quelle est le rôle des éléments qui composent cette valeur relative ?

10. Traduire en langage littéral : xE - xO =

11. Traduire en langage mathématique :

12. La mesure algébrique d ‘un bipoint ( d ’ origine B et d ’extrémité A ) est égale à la différence de l ’ abscisse de l’extrémité A moins l ‘ abscisse de l ’ origine du bipoint B.

13. Donnez la procédure pour calculer la mesure algébrique d' un bipoint :

EVA LUATION :

Exercice n° 1: Enoncé :

Calculer [image] ( lire :...mesure algébrique...)avec A (+3) et B (+5)

Donner les deux solutions :graphique et par le calcul.

Deuxième exercice:

Enoncé : Calculer [image] ( lire :...mesure algébrique...)avec A (+3) et B (-5)

Donner les deux solutions : graphique et par le calcul.


Vu dans ... http://www.cosmovisions.com/Taylor.htm

Brook Taylor

Brook Taylor est un mathématicien, né à Edmonton ( village du comté de Middlesex, à huit milles de Londres) le 18 août 1685, mort à Londres le 29 décembre 1731. Son père, John Taylor, écuyer, était fils d'un puritain rigoureux, Nathaniel Taylor, l'un de ceux que Cromwell, par un acte du 14 juin 1653, déclara propres à représenter le comté de Bedford au parlement. John Taylor conservait à un haut degré la sévérité de doctrine que ses ancêtres lui avaient transmise; mais cette sévérité, quoique maintenue encore par l'esprit du temps, se trouva sensiblement atténuée chez Brook. De là une source fâcheuse de mésintelligence entre le père et le fils. Heureusement le premier était très sensible aux jouissances de la musique; il accueillait avec beaucoup de bienveillance et recevait très généreusement les hommes distingués par leur habileté dans cet art.

Le jeune Brook, instruit par leurs leçons, et animé du désir d'obtenir l'indulgence paternelle pour le relâchement de ses principes, devint de très bonne heure un excellent musicien. Un tableau de famille le représente, à treize ans, au milieu de ses frères et soeurs, recevant des mains des deux aînées une couronne ornée des emblèmes de l'harmonie. La date de cette scène correspond à l'an 1698 : le célèbre Haendel, qui a donné son premier opéra à Hambourg, en 1703, et qui n'est venu se fixer en Angleterre, qu'en 1710, n'était pas encore connu; Brook Taylor n'avait pu s'exercer que sur les anciennes compositions anglaises et écossaises.
-

Taylor.
Brook Taylor (1685-1731).

La musique ne fut pas le seul des beaux-arts qu'il cultiva avec succès : on conserve de lui des dessins et des tableaux dont le mérite est vanté, et qui ne seraient pas déplacés parmi les bons ouvrages des artistes de profession. Il dessinait la figure avec une pureté de trait et une grâce de pinceau remarquables; mais il avait un goût de préférence pour le paysage. Ses tableaux originaux dans ce genre, assez ordinairement peints en détrempe, rivalisent en vigueur et en beauté de coloris avec les tableaux à l'huile, et offrent surtout des modèles intéressants de l'application des règles de perspectives linéaire et aérienne.

Le même homme qui possédait à un degré si éminent les talent de la musique et de la peinture, a, comme on va le voir, traité des questions de haute théorie tenant à ces deux arts, avec une profondeur et une supériorité qui le placent dans les premiers rangs des mathématiciens de son temps. Il est naturel de conclure de ces faits, que l'éducation de Taylor n'a pas été bornée aux exercice, de peinture et de musique : ces exercices ne furent pour lui que des objets de délassement ses études sérieuses et principales étaient celles des langues, de la littérature et des mathématiques; il s'y livra avec un tel succès, qu'à l'âge de quinze ans, il était déjà désigné pour l'université, et qu'en 1701, il fut nommé membre du collège de Cambridge. A cette époque les mathématiques acquéraient une grande faveur dans l'université; les exemples de la considération accordée par le monde savant aux mathématiciens distingués excitaient puissamment l'émulation des jeunes gens capables d'une application soutenue et doués d'un esprit pénétrant.

On présume que, dès les premiers moments de son admission à l'université de Cambridge, Taylor s'élança dans la carrière ouverte par Newton à ceux qui voulaient, comme on disait alors, expliquer et calculer les phénomènes du Système du monde; c'est du moins ce qu'il est naturel de conclure des relations d'estime qui le lièrent promptement avec les savants qui s'occupaient de la mécanique céleste. Il composa, en 1708, un mémoire sur les centres d'oscillation, qui fut publié quelques années après dans les Philosophical Transactions [image] . En 1709, il obtint le grade de bachelier ès lois; et, en 1712, il fut élu membre de la Royal Society.

Pendant les quatre années qui précédèrent cette élection, il entretint une correspondance avec le professeur Keill, sur diverses questions de mathématiques; sir William Young, son petit-fils, possédait une de ses lettres datée de 1712, adressée à Méchain, et contenant une solution détaillée du problème de Kepler, avec des applications: Cette même année, 1712, il présenta à la Royal Society, trois mémoires; l'un sur l'ascension de l'eau entre deux surfaces planes, le second sur les centres d'oscillation, et le troisième sur le célèbre problème de la corde vibrante, dont nous parlerons dans la suite de cette page. Il semble, d'après sa correspondance avec Keill, qu'en 1713, il avait présenté un quatrième mémoire sur son sujet favori, la musique, qui n'est pas imprimé dans les Philosophical Transactions. Le rang distingué auquel il s'était placé parmi les hommes adonnés aux sciences exactes lui acquit beaucoup de considération dans la Royal Society, qui, en 1714, le choisit pour secrétaire, et il prit, cette même année, à Cambridge, le grade de docteur ès lois.

De grands débats existaient alors entre les mathématiciens anglais et ceux du continent; Taylor était, dans les rangs des premiers, regardé comme un auxiliaire d'une haute importance. Ces débats avaient lieu principalement sur le vaste champ de recherches, nouvellement ouvert par les découvertes mathématiques de Newton et de Leibniz; les incursions faites à l'aide du calcul infinitésimal sur un sol naguère inconnu, ou trop péniblement exploré, mettaient en évidence de grandes richesses, sources ordinaires des grandes dissensions. La priorité des inventions, le mérite tant des méthodes analytiques que des solutions de problèmes, la mesure des forces, etc., fournissaient matière à des discussions que l'amour-propre irritable et blessé rendait trop souvent aigres et partiales.

Cependant au milieu de la foule de productions publiées par les différents partis, et condamnées à l'oubli comme les circonstances qui les avaient fait naître, apparaissaient quelques conceptions originales, fécondes, et qu'on pourrait appeler monumentales : une de ces conceptions est due à Taylor; nous y reviendrons quand nous aurons achevé l'indication de ses autres ouvrages. Vers 1714, il donna, dans une lettre adressée à sir Hans Sloane, un détail d'expériences sur le magnétisme qui ont été publiées dans les Philosophical Transactions, et l'année suivante, 1715, il y ajouta un essai curieux sur les lois de l'attraction magnétique : An account of an experiment for the discovery of the laws of magnetic attraction. Cette année 1715 correspond à la date d'impression que porte une partie des exemplaires de son Methodus incrementorum, traité auquel s'applique l'expression de conception monumentale, employée ci-dessus.
Enfin la même année vit paraître un autre ouvrage de sa composition, sur la perspective, qui eut un grand succès, malgré la critique amère qu'en fit Bernoulli. Parmi les reproches que ce célèbre mathématicien faisait à Taylor, se trouvait celui de s'être approprié une méthode qui ne lui appartenait pas; et de fait, cette méthode avait été donnée longtemps auparavant (en l'an 1600), à Pesaro, par Guido Ubaldi, dans un traité bien rédigé et dont les décorateurs de théâtre se servaient fort utilement. Mais il semble bien que chacun des deux a été inventeur de son côté. L'ouvrage original de Taylor a eu trois éditions en Angleterre; et l'on en a fait une traduction française, qui a été imprimée à Lyon, en 1753. A la suite des trois éditions anglaises, a paru une publication de Kirby, intitulée Perspective de Taylor, rendue facile, « Brook Taylor's perspective made easy ». Cette publication , devenue le Vade mecum des artistes les moins instruits, levait entièrement la principale objection de Bernoulli, portant sur les difficultés qui devaient éloigner les artistes de l'étude d'un ouvrage, selon lui, trop abstrait, eu égard à leur instruction première.

Quatre mémoires composés vers 1717 : 1° Sur les équations numériques, les séries infinies; 2° Un problème proposé par Leibniz; 3° le Mouvement parabolique des projectiles; 4° enfin des recherches, publiées en 1721, sur la dilatation, par la chaleur, des liquides renfermées dans les thermomètres : An experiment made to ascertain the proportion of expansion of liquor in the thermometer, with regard to the degree of heat, paraissent être les derniers ouvrages sur les sciences mathématiques et physiques dont Taylor se soit occupé. Un traité des logarithmes, qu'il avait confié à son ami lord Paislay, n'a jamais été publié.

On cite de lui quelques productions bien différentes, quant à leur genre, de celles qui étaient les objets de ses méditations ordinaires, et dont les dates, la dernière exceptée, se rapportent aux années comprises entre 1715 et 1720: une controverse avec le comte de Montmort, sur la doctrine de Malebranche; des fragments d'un traité sur les sacrifices juifs ; une longue dissertation sur la non culpabilité de l'action de manger du sang : On the Lawfulness of eating blood; enfin un essai intitulé Contemplatio philosophica, composé vers 1730, dans les derniers temps de sa vie, à une époque où sa santé était tout à fait dérangée, et publié, en 1793, par son petit-fils William Young. Newton affectionnait aussi les études et les compositions théologiques; mais c'est à l'auteur des Principia que l'immortalité est assurée; et, quoique dans un rang bien moins éminent; l'inventeur de la célèbre formule analytique que les mathématiciens appellent Théorème de Taylor a pour toujours inscrit son nom dans les fastes de l'analyse mathématique.

Ce théorème est le principal résultat, ou plutôt le résumé du livre ci-dessus mentionné, ayant pour titre : Methodus incrementorum directa et inversa, imprimé à Londres en 1715. Lagrange semble être le premier qui ait bien mis en évidence tout le parti qu'on peut tirer du Théorème de Taylor dans la haute analyse. Les biographes n'ont pas même soupçonné le mérite du Methodus incrementorum, et Montucla lui-même ne dit rien de ce traité dans son Histoire des mathématiques. L'énonciation analytique du théorème dont il s'agit constitue ce que les mathématiciens appellent une série ou un système, une suite de termes algébriques, liés entre eux par de certaines lois, et dont le nombre, en général infini, devient fini ou limité dans des cas particuliers. Cette série est appelée convergente ou divergente, respectivement, suivant que les valeurs de ses termes successifs sont continuellement décroissantes ou croissantes.

Il faut remonter jusqu'à Archimède pour trouver le premier exemple des séries infinies, que celui-ci a employées dans le Traité des Spirales, à carrer des espaces. Cavalieri a fait de ce moyen le fondement de sa Méthode des indivisibles; seulement ces séries sont sommées par des considérations géométriques, et représentées par des figures, ou par une suite de lignes droites. Wallis, dans son Arithmetica infinitorum, publiée en 1665, a traité les séries algébriquement, et les a appliquées à la quadrature d'un système de courbes du genre de celles qu'on appelle paraboliques, lequel genre renferme, comme cas individuel, la parabole carrée par Archimède. Le même auteur dans sa Mathesis universalis, sive Arithmeticum opus integrum, ann. 1657, cap. 33, donne un exemple, le premier à ce qu'il semble, d'une série algébrique proprement dite, c'est-à-dire ordonnée suivant une suite de termes dont le nombre est en général infini, contenant chacun une puissance d'une quantité indéterminée. Mercator dans sa Logarithmotechnia, publiée en 1668, a carré l'hyperbole par un développement en série; Brounker, James Gregory, Newton et Leibniz ont ensuite apporté leur contribution; et nous leur devons des séries importantes. En 1689, 1692, 1696, 1698, et 1704, Jacques Bernoulli fit soutenir, sous sa présidence, cinq thèses ayant pour objet la doctrine des séries. Ces thèses ont été réunies à la fin de son Ars conjectandi, publié par son neveu, en 1711, et imprimées longtemps après, dans le recueil de ses oeuvres. Vers cette époque, Brook Taylor s'occupait de la méthode des incréments ou des différences auxquelles on a mal à propos ajouté l'épithète finies, lui donnait un algorithme, et embrassait le calcul inverse dans ses recherches. Newton n'a fait ni l'un ni l'autre, soit dans son livre De systemate mundi (le troisième des Principia, soit dans son Methodus differentialis (ann. 1711), où l'on trouve une méthode d'interpolation bien connue; et Taylor est arrivé au célèbre théorème qui porte son nom, en passant des incréments finis aux incréments évanouissants : ce qui est remarquable, eu égard à l'époque où il écrivait.

Voici maintenant ce que ce théorème donne immédiatement : si l'on a une expression analytique composée de plusieurs termes dans lesquels une quantité variable entre sous des formes quelconques, ce que les mathématiciens appellent une fonction de cette quantité, et que la variable subisse un accroissement ou une diminution, il en résultera un changement correspondant dans la valeur de la fonction; et c'est ce changement dont le Théorème de Taylor donne la valeur générale. Cette valeur générale se trouve exprimée par une suite de termes dans lesquels entrent les différentielles (ce que Taylor après Newton appelle les fluxions), de différents ordres, de la fonction, combinées avec les puissances successives de l'incrément de la variable.

La formule du binôme de Newton , celle de Maclaurin pour le développement des fonctions, etc., s'en déduisent comme cas particuliers. Pour avoir une idée précise du rang que la formule de Taylor doit occuper parmi les découvertes analytiques, il faut entendre Lagrange qui en a fait la base de sa théorie des fonctions analytiques :

« Dans un mémoire imprimé parmi ceux de l'Académie de Berlin, 1772, dit Lagrange, j'avançai que la théorie du développement des fonctions en série contenait les vrais principes du calcul différentiel, dégagés de toute considération d'infiniment petits ou de limites; et je démontrai, par cette théorie, le Théorème de Taylor, qu'on peut regarder comme le principe fondamental de ce calcul, et qu'on n'avait encore démontré que par le secours de ce même calcul, ou par la considération des différences infiniment petites. Depuis, Arbogast a présenté à l'Académie un beau mémoire où la même idée est exposée avec des développements et des applications qui lui appartiennent » (Journal de l'école polytechnique, 9e cahier, p. 5).
Ainsi voilà un théorème qui, établi d'abord par une certaine marche de raisonnement, conduit ensuite à la connaissance et à l'usage des plus puissants instruments connus de découverte en mathématiques, sans embarrasser l'esprit par des considérations d'infiniment petits, de limites, etc. On a étendu le théorème de Taylor à une fonction d'un nombre quelconque de variables; on a trouvé le moyen de substituer à un terme de sa série d'un rang quelconque une expression qui représente la somme de ce terme et de tous les suivants, etc.

Nous ne pouvons pas terminer la notice de ses travaux mathématiques sans mentionner un chapitre très remarquable de son Methodus incrementorum (propos. 21, probl. 17, p. 86), dans lequel il donne une solution du problème fameux de la corde vibrante, plus complète et plus approfondie que les solutions publiées avant la sienne. Nous en avons parlé à l'article Sauveur auquel nous renvoyons.

Taylor, cédant à d'instantes invitations, fit un voyage à Paris, en 1716. La philosophie newtonienne y était alors cultivée; et les savants de cette capitale avaient un grand désir de connaître le secrétaire de la Royal Society. Il y fut reçu avec les témoignages les plus flatteurs de considération et d'estime; et le charme de ses entretiens ajouta encore à l'excellente opinion que ses ouvrages et sa réputation avaient fait concevoir de lui. Les mathématiciens ne furent pas les seules personnes qui l'accueillirent: il se lia avec lord Bolingbroke, le comte de Caylus, etc. Il revint à Londres au commencement de 1717 ; et après la composition de trois des traités que nous avons cités, sa santé se trouva tellement altérée que, pour la rétablir et goûter quelque repos, il prit le parti d'aller à Aix-la-Chapelle.

Désirant s'occuper de sujets moraux et religieux, il se démit, en 1718, de sa place de secrétaire de la Royal Society. De retour en Angleterre, en 1719, il partagea son temps entre les compositions religieuses et la peinture qu'il aima toujours. On pense que la retraite à laquelle il se condamnait, a pu abréger sa vie. Vers la fin de 1720, il se rendit à l'invitation que lui fit lord Bolingbroke, d'aller passer quelque temps à la Source, maison de campagne voisine d'Orléans, que ce lord tenait de son épouse veuve d'un neveu de madame de Maintenon, le marquis de Villette. L'année suivante, Taylor épousa miss Bridges de Vallington, dans le comté de Surrey, jeune demoiselle d'une bonne famille, mais qui avait peu de fortune. Ce mariage lui occasionna une rupture avec son père, qui refusa son consentement; la mort de cette épouse, arrivée en 1723, et celle d'un enfant qu'il en avait eu et qui pouvait devenir un moyen de réconciliation, affecta vivement sa sensibilité. Cependant il passa les deux années qui suivirent ces événements malheureux dans l'habitation de son père à Bifrons. Là les soins tendres et empressés de ses soeurs, et le charme de la musique, non seulement adoucirent ses chagrins, mais le déterminèrent à se fixer sans retour à la campagne. Il contracta, en 1725, un second mariage qui eut l'entière approbation de son père et de sa famille, avec Sabetta, fille de John Sawbridge, écuyer d'Olanting, dans le comté de Kent. Son père étant mort en 1729, la propriété de Bifrons lui échut par succession. Il eut la douleur, l'année suivante, de perdre encore sa seconde femme, à la suite d'une couche. La fille dont la naissance donna lieu à ce funeste événement est devenue la mère de William Young à qui l'on doit des notes sur la vie privée de son grand-père.

A dater de 1730, la santé de Taylor déclina tellement que ses amis perdirent tout espoir de le voir se rétablir. La cessation des travaux, sérieux devenait nécessaire, et cependant c'est à cette époque, comme nous l'avons dit, que Taylor composa la Contemplatio philosophica, où l'on voit ce que peut un esprit géométrique, quoique dans un corps malade, appliqué à des questions de métaphysique. Le chagrin qui l'accablait rendait infructueux les soins de ses parents et les consolations de ses nombreux amis, dans les premiers rangs desquels il faut placer Bolingbroke. Taylor ne survécut qu'un peu plus d'un an à sa seconde épouse, et mourut le 29 décembre 1731 , à l'âge de 46 ans.. Il fut inhumé au cimetière de Saint Ann's Soho. (P-NY).


Colin Maclaurin

Vu dans ... http://serge.mehl.free.fr/chrono/Maclaurin.html

 ChronoMath , une chronologie des MATHÉMATIQUES
à l'usage des professeurs de mathématiques, des étudiants et des élèves des lycées & collèges

Brillant élève de Simson à l'université de Glasgow dont il sera diplômé à 17 ans. Il obtint à 19 ans une chaire d'enseignement des mathématiques à l'université d'Aberdeen. Ami de Newton , il fut un fervent défenseur de sa méthode des fluxions(calcul différentiel). Parrainé par ce dernier, il succède à Grégory à l'université d'Édimbourg (1725). Il conservera ce poste jusqu'à sa mort. Son ancien élève Stewart lui succédera.

Grand géomètre, très apprécié par Lagrange, il étudia toutes sortes de courbes algébriques d'ordre élevé (Geometrica organica, De linearum geometricorum proprietatibus, 1720), Maclaurin est à l'origine des développements en série entière des fonctions numériques par la méthode des coefficients indéterminés (A complet system of the fluxions, 1742), prolongement des travaux de Newton et de Taylor .

Grâce au nouvel outil différentiel, on lui doit la résolution de nombreux de problèmes de mathématiques appliquées, notamment dans le domaine de la mécanique en corrélation avec les travaux de son ami Newton (attraction de points matériels.

Formule de Maclaurin (1742) :

Ce développement n'est pas une simple application de la formule de Taylor en 0. Maclaurin l'obtint par un calcul rigoureux :

Si f est de classe Cndans un voisinage V de zéro et si f admet une dérivée d'ordre n+1 sur V, alors, il existe un réel cx de V tel que :

➔ f(n) désigne ici la fonction dérivée n-ème de f dont la définition par récurrence est :

f(o) = f et f(n) = [f(n-1)]'. C'est dire que f(1) = f ', f(2) = f '', etc. » d'Alembert

Si nous notons rn le dernier terme du second membre : une condition nécessaire et suffisante pour que la série de Maclaurin converge est que f soit indéfiniment dérivable sur V et que rn tende vers 0 pour tout x fixé dans V. On obtient ainsi un très grand nombre de développements limités au voisinage de zéro :

Exemple 1 : considérons la célèbre fonction exponentiellex → ex, identique à toutes ses dérivées. vu que e0 = 1, on a :

ex = 1 + x + x2/2! + x3/3! + ... + xn/n! + ...

Exemple 2 : considérons la fonction sinus f(x) = sin x. on a f(o) = o, puis

  • (sin x)' = cos x , (sin x)" = - sin x , (sin x)''' = - cos x , (sin x)'''' = (sin x)(4) = sin (x)

D'une façon générale (sin x)(2n) fournit un sinus, nul au point zéro. Le développement ne contiendra donc que les (sin x)(2n+1)(o) = (-1)n et par suite :

sin x = x - x3/3!+ x5/5! - x7/7! + . ..

Ce développement fut obtenu auparavant par Leibniz.

Formule de Taylor et expression des restes du développement d'ordre n : »

Formule de Maclaurin pour les polynômes :

Si P est un polynôme de degré n, toutes ses dérivées d'ordre supérieur à n sont nulles. On a alors pour tout réel x :

P(x) = P(o) + xP'(o) + x2P''(o)/2! + ... + x k P(k)(o)/k! +...+ x n P (n) (o)/n!

Un calcul de e, base des logarithmes népériens : »

Formules d'Euler-Maclaurin :

On suppose f de classe C 2 sur l'intervalle [a,b] : f est dérivable jusqu'à l'ordre 2 au moins et ses dérivées f ' et f " sont continues. Dans ces conditions :

➔ Ce résultat s'obtient très simplement au moyen de deux intégrations par parties successives de l'intégrale du second membre. En utilisant le second théorème de la moyenne ( formule de Bonnet), on obtient une approximation de l'intégrale de f sur [a,b] qui n'est autre que la méthode des trapèzesavec une erreur ne pouvant excéder M(b - a)3/12 où M désigne le maximum de |f ''(x)| sur [a,b]. Il existe donc c dans [a,b] tel que :

Lorsque f est de classe C 2n sur l'intervalle [a,b], on peut démontrer une seconde formule plus élaborée donnant une valeur approchée d'une intégrale et utilisant les nombres de Bernoulli :

On pose Δf (k) = f (k) (b) - f (k) (a), différence des dérivées k-èmes en b et a. Rappelons que les Bksont nuls si k est impair autre que 1. Dans ces conditions, il existe c dans [a,b] tel que :

On pourra trouver la preuve de cette formule dans tout cours d'analyse niveau Math Spé. En particulier (certes non récent mais incontournable par sa clarté et la précision de la pensée) : Jean Bass, Cours de mathématiques, Tome 1, Éd. Dunod, Paris - 1969/71/78.

______ ☼ ______

E xemple : On a tracé ci-dessous la courbe d'équation : y = f(x) = x4 - 2x3 - 1

L'aire hachurée correspond à l'opposée de l'intégrale de f sur [0,2]. Exprimée en unités d'aires, la mesure de cette aire est exactement 3,6. La 1ère formule d'Euler-Maclaurin fournit une valeur "très" erronée et une erreur non moins élevée puisqu'elle correspond à la méthode des trapèzes avec un pas h = 2. Cette formule prend tout son sens lorsqu'on subdivise l'intervalle. On vérifiera qu'avec 100 points (h = 1/50), on obtient 3,5997...

La seconde formule d'Euler-Maclaurin appliquée à cette fonction conduit à (n max = 2) : -2 - 2 × (1/6) × 8 - (32/24) × (-1/30) × 24 = -3,6. C'est la bonne valeur. Mais pourquoi donc ? Parce qu'ici, notre dérivée 4ème est constante, égale à 24 pour tout x : le choix de c n'influe donc pas !

Travaux sur les courbes algébriques :

Maclaurin étudia également les courbes algébriques (détermination, intersections) et, par là, les systèmes d'équations qu'il résout par la méthode des déterminants (ce dernier terme et la théorie seront dus à Cauchy ) jusqu'à l'ordre 4.

Il énonce que deux telles courbes de degrés respectifs n et p doivent se couper en au plus np points. Ce qui ne fut pas sans soulever quelques difficultés et aspects contradictoires... Ces travaux seront repris par Cramer (1750) et Euler, indépendamment semble-t-il des travaux de Maclaurin et ce sera Plücker qui en donnera une explication définitive (1839) corroborant les résultats de Euler .


Développement limité de Mc Laurin

Vu dans ... http://www.jybaudot.fr/Analysesup/mclaurin.html

Le développement limité de Mc Laurin

DL(0) usuels et exemple

Un développement limité (DL) au voisinage de zéro porte le nom de Colin Mc Laurin. Vu sous cet angle, ce grand mathématicien écossais n’aurait rien fait d’autre que d’appliquer la formule de Taylor en un voisinage particulier, ce qui est évidemment faux. Toutefois, l’objet de ce site n’est pas de rendre justice en relatant les apports des uns et des autres aux mathématiques mais d’expliquer l’usage de quelques outils. En l’occurrence, voici quelques DL usuels au voisinage de 0 (on remarque vite que ces égalités deviennent ineptes si x s'éloigne de 0), ainsi qu’un petit exercice.

DL(0) usuels

Note : le DL(0) de ln x s’obtient facilement puisqu’il suffit remplacer les x de la dernière formule par des (x – 1).

Fonctions trigonométriques :

DL de fonctions trigonométriques

Fonctions trigonométriques réciproques :

DL fonctions trigo réciproques

Fonctions hyperboliques :

DL de fonctions hyperboliques

Fonctions hyperboliques réciproques :

DL fonctions hyperboliques réciproques

Rappel de la formule générale

DL de Mc Laurin

Exercice

Trouver de deux façons différentes un polynôme d’ordre 3 qui, au voisinage de 0, présente un comportement proche de la fonction suivante :

Première technique, avec les dérivées successives (application de la formule).

1- On sait que le sinus de 0 est égal à 0. Donc, f(0) = e0 = 1

2- La dérivée d’une exponentielle a pour forme u’eu. La dérivée de sin x est cos x. donc f’(x) = cos x esin x et f’(0) = 1 × 1 = 1

3- Quelle est la dérivée seconde ? La dérivée première se présentant sous une forme u × v, la dérivée seconde a pour structure u’v + v’u avec u = cos x (donc u’ = -sin x) et v = esin x (donc v’ = cos x esin x).

Donc, f’’(0) = 1

4- Terminons par la dérivée d’ordre 3. La tâche devient rude.

Le premier terme : (-sin x esin x)’ = -cos x esin x – sin x cos x esin x, donc , en 0, -1 – 0 = -1

Le second terme : (cos² x esin x)’. Sachant que la dérivée de cos² x est 2cos x × –sin x nous avons (2cos x × –sin x)esinx + cos³x esin x = 0 + 1 = 1.

Donc, f(3)(0) = -1 + 1 = 0

Conclusion : le DL3(0) de f(x) est :

Seconde technique, utilisant les composées de fonctions usuelles :

En appliquant la formule du DL de sin x (voir haut), on obtient, à l’ordre 3 :

DL du sinus

Incorporons ce résultat au DL de ex (voir encore plus haut) :

Les calculs se poursuivent par un travail de nettoyage qui aboutit à l’expression développée d’une fonction polynomiale de degré 9 dont je vous fais grâce. Mais si l’on ne retient que les termes de degré inférieur ou égal à 3, on retrouve bien le DL3(0) auquel nous sommes parvenu avec les dérivées successives.


La décomposition en séries de Fourier - Interstices

Vu dans ... https://interstices.info/la-decomposition-en-series-de-fourier

Onde sinusoïdale Image de parameter_bond, sur Flickr.
Publié le : 29/11/2018
Par : Romain Joly
Niveau intermédiaire
Niveau 2 : Intermédiaire

La décomposition en séries de Fourier

L’idée révolutionnaire de Joseph Fourier est que les fonctions trigonométriques sinus et cosinus permettent de décomposer n’importe quelle fonction. Découvrez-la à l'aide d'exemples imagés.

Joseph Fourier
Par Jules Boilly — « Portraits et Histoire des Hommes Utiles, Collection de Cinquante Portraits, » Société Montyon et Franklin, 1839-1840. Domaine public.

Au début du XIXe siècle, Joseph Fourier étudie la propagation de la chaleur et est le premier à décrire son évolution mathématiquement par l’ équation de la chaleur. Dans le cas d’une tige, cette équation admet des solutions particulières s’exprimant à l’aide des fonctions trigonométriques sinus et cosinus. L’idée révolutionnaire de Joseph Fourier est que ces fonctions particulières permettent de décomposer n’importe quelle fonction et de décrire ainsi l’évolution de la chaleur dans n’importe quelle situation : c’est la décomposition en série de Fourier, que l’on retrouve pour la résolution de l’équation de la chaleur mais aussi dans les fichiers MP3, dans l’analyse de signaux, dans l’imagerie médicale…

Le but de cet article est de découvrir à l’aide d’exemples imagés cette décomposition introduite par Joseph Fourier.

La famille des fonctions sinus

La décomposition de Fourier que nous allons voir s’appuie sur une famille de fonctions sinus. Les sinus font partie des fonctions trigonométriques et ont donc une longue histoire. Ils apparaissent dans les problèmes géométriques utilisant des angles et ont surtout été développés pour l’astronomie, une science très importante dans l’Antiquité. Pour aboutir à leur forme actuelle, ils sont partis de la Grèce antique, allés jusqu’en Inde pour revenir par la Perse et l’Arabie et enfin en Europe à la Renaissance. L’utilisation de ces sinus par Joseph Fourier n’est pas liée à un problème géométrique mais plutôt à leurs propriétés mathématiques, comme nous l’expliquerons plus loin.

La famille des sinus qui nous intéresse ici est plus précisément définie comme suit : pour chaque entier n, on regarde la fonction qui à x entre 0 et 1 associe sin(nπx). Pour nous familiariser avec ces fonctions, traçons le graphe de quelques-unes d’entre elles.

Le premier sinus qui nous intéresse est sin(πx). Son graphe sur l’intervalle [0,1] est tracé ci-dessous. La fonction part de 0, forme une large bosse montant jusqu’à la valeur 1 pour revenir ensuite à 0.
Le deuxième sinus de cet article est sin(2πx). Son graphe sur l’intervalle [0,1] est tracé ci-dessous. La fonction part de 0, forme une bosse au-dessus de l’axe y=0 puis une autre sous l’axe pour revenir ensuite à 0.
Le troisième sinus forme lui un graphe avec trois bosses comme ci-dessous.
Sans surprise, le quatrième sinus a un graphe composé de quatre bosses entre 0 et 1.

On peut bien sûr continuer ainsi : sin(5πx) forme cinq bosses, sin(10πx) forme dix bosses… Pour diversifier les formes obtenues avec ces fonctions, on peut les combiner en sommes pondérées par des coefficients.

Ci-dessous, le graphe de la fonction sin(πx)+sin(4πx). On voit les quatre bosses du sin(4πx) mais aussi l’influence de sin(πx) qui remonte la partie centrale du graphe.
Notre deuxième exemple de combinaison de sinus est 0.4sin(πx)+0.4sin(4πx)-0.3sin(4πx). Avec trois sinus et des coefficients, le graphe est plus complexe. On obtient ainsi une forme qui s’éloigne des graphes des fonctions sin(nπx) seules.

Pour mieux comprendre comment la forme du graphe se crée grâce à la combinaison des fonctions sinus, voici en animation deux exemples de combinaisons de trois fonctions sinus. Le premier correspond à l’exemple précédent, le deuxième à -0.2sin(2πx)-0.5sin(3πx)-0.4sin(8πx).

On peut ainsi créer différentes formes en combinant ces différents sinus. Mais jusqu’où peut-on aller ? C’est là que se trouve l’idée révolutionnaire de Joseph Fourier.

La décomposition de Fourier

Nous venons de voir que les fonctions sin(nπx) engendrent différentes formes si on regarde leurs combinaisons. Avant les travaux de Joseph Fourier, on savait comment utiliser ces combinaisons pour obtenir certaines solutions d’équations. Mais l’idée révolutionnaire de Joseph Fourier est qu’on peut obtenir ainsi toutes les solutions car toutes les fonctions dans l’intervalle [0,1] peuvent être obtenues en combinant des sin(nπx). Daniel Bernoulli avait déjà utilisé ce principe, mais il semble que Joseph Fourier soit le premier à le formaliser mathématiquement.

Théorème : toute fonction f sur l’intervalle [0,1] se décompose comme une combinaison infinie des fonctions sin(nπx)
f ( x ) = a 1 sin ( π x ) + a 2 sin ( 2 π x ) + a 3 sin ( 3 π x ) + a 4 sin ( 4 π x ) + a 5 sin ( 5 π x ) + … f ( x ) = a 1 sin ⁡ ( π x ) + a 2 sin ⁡ ( 2 π x ) + a 3 sin ⁡ ( 3 π x ) + a 4 sin ⁡ ( 4 π x ) + a 5 sin ⁡ ( 5 π x ) + …
De plus, les coefficients an sont donnés par la formule
a n = 2 ∫ f ( x ) sin ( n π x ) d x a n = 2 ∫ f ( x ) sin ⁡ ( n π x ) d x

Pour rendre ce théorème mathématiquement rigoureux, il faudrait préciser ce qu’on entend par cette somme infinie (les «…» ne voulant rien dire en science) et ce que veut dire l’égalité à f (qui est plus subtile que l’on pourrait penser). Joseph Fourier avait bien compris ces problèmes et les avait résolus avec la rigueur en cours à l’époque.

Nous n’allons pas entrer dans les détails mathématiques de ce théorème et de ces formules. Pour cet article, ce qu’il nous faut retenir en pratique est que :

  1. Toute fonction f peut être approchée par des combinaisons finies de fonctions sin(nπx) avec une erreur aussi petite que voulue.
  2. Les coefficients an de cette combinaison sont donnés par une formule explicite et peuvent être calculés facilement.

Illustrons ce principe par un premier exemple. La famille des sinus ne contient que des fonctions formant des bosses lisses, de douces collines. Peut-on obtenir un graphe plus pointu en les combinant ? «Oui» nous dit le théorème ci-dessus, «il suffit de bien ajuster les coefficients de la combinaison».

Prenons un autre exemple. On regarde la fonction f dont le graphe est ci-contre. Il s’agit d’une sorte de creux qui n’occupe que la première moitié du segment. Il ne s’agit pas d’un mode sinusoïdal et en fait, il ne s’agit pas non plus d’une combinaison d’un nombre fini de sin(nπx). Pourtant, on va pouvoir approcher très précisément cette forme par des combinaisons de sin(nπx) comme l’annonce le théorème de Fourier ci-dessus. Les bons coefficients seront difficiles à trouver à la main, mais on dispose de la formule plus haut : il suffit de faire le calcul (ou de le faire faire par un ordinateur).

Dans les exemples ci-dessus, on approche petit à petit la forme voulue à l’aide de six sinus. Plus on va en ajouter, plus la forme sera approchée avec précision. Rappelons que ces approximations comprenant de plus en plus de sinus sont obtenues par des formules. Ce qu’on appelle décomposition de Fourier est donc calculable automatiquement par un ordinateur et de façon très rapide.

Avec dix sinus, cela devient difficile de faire la différence avec l’original, sauf au niveau du raccord entre le creux et la partie plate.

-0.424sin(πx)-0.5sin(2πx)-0.254sin(3πx)+0.06sin(5πx)-0.028sin(7πx)+0.016sin(9πx)-0.011sin(11πx)+0.007sin(13πx)-0.005sin(15πx)
Avec 25 sinus, on obtient une très bonne représentation de la fonction initiale. Le dessin du graphe initial contient 1000 points donc 1000 informations. Or on peut obtenir le dessin ci-dessous avec seulement 25 coefficients donc 25 informations. La qualité est très bonne avec 97,5% d’espace gagné. C’est l’idée derrière les formats compressés JPEG ou MP3.

La décomposition de Fourier permet donc de décomposer une fonction en somme de sinus. Cela ouvre la voie à des applications pratiques comme la compression d’images, en dosant le nombre de sinus utilisés, mais aussi de nombreuses autres qui seront abordées dans cette série d’articles.

Le théorème de Fourier nous dit que toute fonction peut être ainsi décomposée en sinus. Est-ce que cela fonctionne vraiment pour toutes les fonctions ? Oui, pour toutes les fonctions f, du moins celles qui représentent des données physiques pour lesquelles l’énergie ∫ f 2 ∫ f 2 est définie. Cela fonctionne même pour des fonctions qui ne sont pas continues, c’est-à-dire qui admettent des sauts. Ceci était tellement surprenant pour l’époque que certains mathématiciens ont pris cette propriété comme un argument indiquant que le résultat devait être faux : comment une fonction avec un saut pourrait-elle être approchée par des fonctions qui sont continues ?
Mais Joseph Fourier avait bien raison et a fini par imposer son point de vue. Ce type de propriété paradoxale a poussé les mathématiciens à reprendre de façon plus rigoureuse les bases de l’analyse mathématique.

Avec six sinus, il est difficile d’obtenir un saut abrupt.
Avec 30 sinus, on obtient déjà une forme de créneau.
Avec 100 sinus, on obtient bien un créneau avec un saut très abrupt. Il reste encore de petites oscillations aux endroits où le graphe varie brusquement. Il s’agit du phénomène de Gibbs que l’on peut aussi voir sur les images JPEG.

Pour finir, nous allons nous amuser avec la décomposition de deux fonctions, l’une rouge et l’autre bleue. Nous allons faire apparaître petit à petit plus de sinus de leur décomposition.

Avec un seul sinus on n’a pas vraiment d’informations.
0,19sin(πx)
-0.19sin(πx)
Avec deux sinus, on a une sorte de cacahouète.
0,19sin(πx) + 0.086sin(3πx)
-0.19sin(πx) – 0.065sin(3πx)
Avec cinq sinus… un vaisseau spatial ?
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx)

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx)
Avec dix sinus, on devine un papillon ?
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx)

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx)
Avec 20 sinus, cela se précise
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx) + …

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx) + …
Avec 80 sinus, c’est presque parfait, sauf de petites oscillations, surtout proches des endroits où le graphe varie brusquement : c’est de nouveau une manifestation du phénomène de Gibbs.
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx) + …

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx) + …
Avec 150 sinus, l’image apparaît parfaitement.
0,19sin(πx) + 0.086sin(3πx) + 0.044sin(5πx)
– 0.035sin(7πx) + 0.038sin(9πx) + 0.005sin(11πx) – 0.004sin(13πx) +
0.007sin(15πx) + 0.004sin(17πx) + 0.008sin(19πx) + …

-0.19sin(πx) – 0.065sin(3πx) – 0.05sin(5πx)
– 0.0028sin(7πx) + 0.002sin(9πx) – 0.001sin(11πx) – 0.024sin(13πx)
+ 0.005sin(15πx) – 0.003sin(17πx) – 0.001sin(19πx) + …

N’est-ce pas surprenant ? Encore une fois, c’est la puissance de la décomposition de Fourier : on peut partir de n’importe quelle fonction et tous les calculs sont donnés par des formules explicites qu’il n’y a qu’à appliquer. Le point difficile ici était d’avoir une formule pour les courbes du dessin. Ces formules semblent avoir été introduites par un professeur américain en 2011 et une de leurs premières traces se trouve sur le forum reddit. Elles sont maintenant connues sous de nom de Batcurves. On pourra consulter cette page sur Stackexchange pour des explications sur les formules. On pourra aussi trouver cette vidéo qui dramatise un peu l’application de la décomposition de Fourier à la Batcurve. Notez que dans cette vidéo, la décomposition se fait selon des cosinus à la place des sinus, mais le principe est exactement le même.

Application aux cordes vibrantes

La transformation de Fourier a été introduite dans le cadre de l’ équation de la chaleur. Comme nous n’avons pas l’habitude de « voir » la chaleur, le tracé des solutions de son équation ne nous serait pas très familier. Dans cet article, nous allons donc plutôt regarder les solutions de l’ équation des cordes vibrantes. Il s’agit de décrire les oscillations d’une corde fixée à ses deux bouts : corde de guitare, de piano, corde à sauter… Quel rapport avec la propagation de la chaleur ? C’est la magie des mathématiques ! Les deux problèmes sont physiquement très différents, mais la décomposition de Fourier est un outil mathématique suffisamment puissant pour intervenir dans les deux cas. Jean le Rond d’Alembert et Leonhard Euler avaient introduit et étudié l’équation des cordes vibrantes. Ils savaient qu’elle possède des solutions particulières décrites par notre famille des sinus.

L’animation ci-contre présente une corde vibrant selon la fonction sin(πx). Plus précisément, c’est la fonction cos(πt)sin(πx), qui dépend à la fois du temps t et de l’espace x, qui est solution de l’équation des cordes vibrantes. Cette solution est très particulière dans le sens où la forme de la corde est toujours celle du premier sinus, elle ne fait qu’osciller au cours du temps : l’amplitude du mouvement, en chaque point x, varie dans le temps selon la fonction cos(πt). On appelle cette vibration particulière le premier mode de vibration. Dans le cadre musical, c’est ce mode qui sera responsable de la note produite par la corde. On parle à ce moment-là de mode fondamental.

Si les sinus sont des fonctions importantes pour cette équation des cordes vibrantes, c’est que, comme l’équation de la chaleur, elle fait intervenir des dérivées secondes. Si on dérive deux fois de suite une fonction sinus, on retombe sur la même fonction, à un facteur près. C’est pour cela que le profil de la solution ci-contre reste en permanence celui d’une fonction sinus.

Le premier mode des cordes vibrantes

Si on regarde les autres sinus, on obtient encore des solutions particulières de l’équation des cordes vibrantes. Ces solutions ne sont que les sinus vus plus hauts que l’on fait vibrer de plus en plus rapidement. On peut facilement voir ces modes de vibration en faisant osciller une corde que l’on tient par une main. Musicalement, ces modes de vibrations de la corde de guitare (ou piano, ou violon…) sont responsables des harmoniques du son et de ce qu’on appelle le timbre de la note.

Le deuxième mode d’oscillation correspond à la solution cos(2πt)sin(2πx). Sa fréquence d’oscillation est deux fois plus rapide que celle du premier mode, aussi bien en temps qu’en espace. Pour une corde d’instrument de musique, ce mode produit un son une octave au-dessus de l’oscillation du mode fondamental vu plus haut. On parle de la première harmonique.
Le troisième mode d’oscillation correspond à la solution cos(3πt)sin(3πx). Sa fréquence d’oscillation est trois fois plus rapide que celle du premier mode. Musicalement, il est responsable de la deuxième harmonique.
Le quatrième mode d’oscillation correspond à la solution cos(4πt)sin(4πx) qui oscille quatre fois plus rapidement que le mode fondamental. Et ainsi de suite…

Source : vidéo Youtube du
Scientibus par F. Louradour, Faculté des Sciences de Limoges.
Nous avons déjà vu la fonction sin(πx)+sin(4πx) qui est la somme de deux de nos fonctions sinus. Si on lâche une corde avec cette forme, elle oscillera comme ci-contre.
La solution cos(πt)sin(πx)+cos(4πt)sin(4πx) de l’équation des cordes vibrantes est la somme des vibrations des premier et quatrième modes. On voit qu’il ne s’agit pas d’un mode propre comme les oscillations des sinus car le profil de la corde se déforme au cours du temps au lieu de simplement osciller. La corde revient quand même régulièrement dans sa position initiale, une fois que le premier mode a fait un aller-retour et donc que le quatrième a eu le temps d’en faire quatre.
Nous avons déjà vu la fonction 0,4sin(πx)+0,4sin(2πx)-0,3sin(6πx) qui est la somme de trois de nos fonctions sinus déjà vues avec des coefficients. Si on lâche une corde avec cette forme, elle oscillera comme ci-contre.
La solution 0,4cos(πt)sin(πx)+0,4cos(2πt)sin(2πx)-0,3cos(6πt)sin(6πx) de l’équation des cordes vibrantes est la somme des vibrations de trois des modes sinusoïdaux avec les coefficients associés. Il ne s’agit pas d’un mode propre puisque le profil de la corde se déforme au cours du temps.

Nous venons de voir que les fonctions sin(nπx) engendrent des solutions importantes pour l’équation des cordes vibrantes. Comme dit dans l’introduction, il en est de même pour l’équation de la chaleur. Dans les deux cas, on peut aussi obtenir de nouvelles solutions en faisant des combinaisons des solutions données par les sinus. Cette façon d’obtenir des solutions était déjà connue à l’époque de Fourier, par exemple déjà utilisée par Daniel Bernoulli.

La révolution apportée par Joseph Fourier est que sa décomposition montre que toutes les solutions de l’équation des cordes vibrantes s’écrivent comme combinaisons des solutions données par les modes en sinus. Si on reprend la forme en creux vue plus haut, on peut obtenir l’évolution d’une corde lâchée selon cette forme.

On commence par décomposer la forme en creux comme une combinaison de fonctions sinus. Nous avons déjà vu cela plus haut. Pour rappel, les coefficients sont donnés par une formule explicite et sont donc calculables facilement.
-0,42sin(πx) – 0.5sin(2πx) – 0,26sin(3πx) + 0.06sin(5πx) – 0.03sin(7πx) +…
On peut aussi utiliser la description de notre courbe initiale en fonction de sinus pour regarder comment se comporte une corde mise initialement suivant notre forme ci-contre. Il suffit de remplacer les sinus dans la décomposition par les modes de vibrations. C’est cette idée qui a poussé Fourier à étudier la décomposition qui porte son nom. Il s’agit d’une méthode efficace toujours utilisée aujourd’hui dans les simulations numériques en recherche et en industrie.
-0,42cos(πt)sin(πx) – 0.5cos(2πt)sin(2πx) – 0,26cos(3πt)sin(3πx) + 0.06cos(5πt)sin(5πx) – 0.03cos(7πt)sin(7πx) +…

Peut-être que la simulation de la vibration de la corde ci-dessus vous semble irréelle. Il est en effet difficile de voir une corde vibrer ainsi car le modèle utilisé ne tient pas compte des amortissements et de la dissipation d’énergie. Si on veut obtenir une simulation plus fine, on peut diminuer petit à petit l’amplitude des oscillations. En outre, dans la réalité, la dissipation est plus forte pour les hautes fréquences, c’est-à-dire les modes sin(nπx) avec n grand. On obtient alors une simulation comme ci-contre qui est plus réaliste. Plus on attend, plus les deux premiers modes sin(2πx) et finalement sin(πx) sont visibles. Encore une fois, cette animation est principalement basée sur la décomposition en différents modes introduite par Joseph Fourier.

Une histoire qui continue

Si les fonctions cosinus et sinus sont connues depuis l’Antiquité, ce n’est qu’au XVIIIe siècle qu’on commence à comprendre leur importance en dehors des problèmes géométriques. Vers 1810, Joseph Fourier est le premier à énoncer que toute fonction peut se décomposer comme une somme infinie de ces fonctions trigonométriques cosinus et sinus. Il montre aussi que les calculs pour obtenir cette décomposition sont simples et explicites. Il faudra plusieurs années pour que les mathématiciens s’approprient ce résultat en en comprenant toute sa profondeur et en le rendant plus rigoureux. À partir de la décennie 1980, l’avènement du numérique ouvre un vaste champ d’applications pour la décomposition introduite par Joseph Fourier et pour ses descendantes les ondelettes : traitement du signal, fichier MP3, images JPEG, simulations numériques pour l’ingénierie…

L’auteur remercie Christian Jutten ainsi que le comité éditorial d’Interstices pour lui avoir proposé le projet d’article et pour leur relecture attentive.
Les images et gif animés ont été produits par l’auteur grâce à un programme Python et au logiciel Gimp.


premiers pas avec les logarithmes

Source: premiers pas avec les logarithmes

Vu dans ... http://villemin.gerard.free.fr/Wwwgvmm/Analyse/LogaDebu.htm

Introduction aux LOGARITHMES

Nom barbare qui, comme souvent, cache des choses simples

Certes, il est possible de compliquer à loisir …

Essayons de voir le simple, d'abord!

Par exemple: 1024 = 210

Exprimé en base 2,

le logarithme de 1024 est 10

Le grand nombre 1024 est "condensé" en 10,

une valeur exigeant moins de chiffres.

On écrit: log 2 1024 = 10

APPROCHE – LA MÉTHODE ARCHIMÈDE

Utilisation en parallèle de DEUX échelles de nombres * On met en correspondance les nombres (progression Arithmétique); et les puissances de 2 (progression Géométrique).
A | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10
G | 2 | 4 | 8 | 16 | 32 | 64 | 128 | 256 | 512 | 1024
* Pour multiplier deux nombres de la ligne G: On ajoute les deux nombres parents sur la ligne A; On cherche le "fiston" correspondant à la somme trouvé. * Le tour est joué. Et c'est nettement plus simple. Exemple montrant qu'il suffit de lire la table ci-dessus * Pour effectuer 8 x 16, je prends les valeurs associées que j'ajoute (3 + 4 = 7). En face du 7, je lis 128.
A |  |  | 3 | + 4 |  | = | 7 |  |  |
G |  |  | 8 | x 16 |  | = | 128 |  |  |
Un petit bout de théorie * Aujourd'hui, on sait, en effet, que: 2 x . 2 y = 2 x + y * Bien sûr, on aurait pu prendre d'autres puissances et obtenir: a x . a y = a x + y

GRANDS NOMBRES avec des ZÉROS

Observation concernant la multiplication par 10

10 | x 10 | = 100
1 zéro | + 1 zéro | = 2 zéros
10 | x 100 | = 1 000
1 zéro | + 2 zéros | = 3 zéros
10 | x 1 000 | = 10 000
1 zéro | + 3 zéros | = 4 zéros

10 | x 10 b | = 10 b+1
1 zéro | + b zéros | = b+1 zéros

Conclusion

10 a | x 10 b | = 10 a + b
a zéro | + b zéros | = a + b zéros
En multipliant deux puissances de 10, le produit a un nombre de zéros égal à la somme des quantités de zéros des facteurs.

Facile la multiplication par 10 …

Il suffit de compter les zéros
10 000 | x 1 000 000 000 |
4 zéros | + 9 zéros | = 4 + 9 = 13 zéros
 | Résultat | = 10 000 000 000 000

<

EXPRESSION DES GRANDS NOMBRES

On peut tirer parti de cette observation

* Pour multiplier les puissances de dix entre-elles, il suffit d'additionner les quantités de zéros.

* C'est très pratique, car il est plus facile de faire des additions que des multiplications.

* Est-ce applicable à n'importe quel nombre?

On transforme

une MULTIPLICATION

en ADDITION.

Représentation des puissances de 10

1 000 = 103

10 000 = 104

10… 0 avec n zéros = 10n

L'exposant n

indique la quantité de zéros derrière le 1.

Représentation des grands nombres

1 000 = 103

2 000 = 10 x

10 000 = 104

x existe-t-il ?

Si oui,

x est situé entre 3 et 4.

Logarithme à base 10

2 000 = 10 3,3

3,3 = log (2000)

Le nombre décimal obtenu est le LOGARITHME

Exemples

1 000 | = 10 3 | 3 | = log (1000)
2 000 | = 10 3,3 | 3,3 | = log (2000)
3 000 | = 10 3,5 | 3,5 | = log (3000)
… |  | … |
10 000 | = 10 4 | 4 | = log (10 000)

<

CALCUL AVEC LES GRANDS NOMBRES

Changement de monde

Formule savante

Pour MULTIPLIER

on ADDITIONNE

les LOGARITHMES

log (a . b) = log (a) + log (b)

Pratique courante

* Le truc du passage dans un autre monde est souvent utilisé en maths. C'est aussi, par exemple, le cas avec les nombres complexes.

Le chemin de calcul direct, la multiplication est bien trop difficile | Celui avec un détour par l'addition des logarithmes est bien plus facile
Nombres normaux (ordinaires) | Nombres "compressés"

Morale de l'histoire: je n'y arrive pas directement, alors je me sers d'un outil, d'un "levier" mathématique.

Exemples

1 000 | x 1 000 |
3 | + 3 | = 6
 |  | = 1 000 000

1 000 | x 2 000 |
3 | + 3,3 | = 6,3
 |  | = 2 000 000

1 200 | x 2 55 000 |
3,07918 | + 5,40654 | = 8,48572
 |  | = 306 000 000

3 | x 4 |
0,48 | + 0,60 | = 1,08
 |  | = 12

En pratique

* La règle à calcul, utilisée avant l'avènement des calculatrices,
était basée sur cette propriété additive des logarithmes.

* Pour des calculs plus précis, on utilisait également des tables de logarithmes.

* Je possède toujours ma règle à calcul et ma table de log … avec lesquelles j'ai effectué de nombreux calculs dans ma jeunesse (les années 60) ! Soupir nostalgique… mais aucun regret …

Allure d'une règle à calcul (ici Log-Log)

Ma propre règle à calcul utilisée par ma petite-fille de 10 ans

Un autre type (américaine)

Source: Number Systems & Counting

INTRODUCTION GÉOMÉTRIQUE

À LA FONCTION LOGARITHME

* Calcul des aires des surfaces en jaune:

 | Horizontale | Oblique | Parabole | Hyperbole
S (x) = | x – 1 | 1/2 (x² – 1) | 1/3 ( x3 – 1) | Log x
S (2) = | 1 | 3/2 | 7/3 | 0, 693 = ln 2

BILAN et généralisation

CE QUE NOUS DEVONS RETENIR

* Les logarithmes permettent de se placer dans un monde plus pratique pour notamment exécuter des calculs compliqués sur des grands nombres:

* En passant à des nombres moins grands*, plus facilement manipulables; et

* En donnant la possibilité de transformer des multiplications difficiles en simples additions.

* Moins grands pour la partie entière; avec les décimales, la quantité de chiffres peut être tout aussi grande que pour le nombre d'origine (Voir exemple numérique sur illustration ci-dessous)

* En fait, les logarithmes en base 10 (tels que vus ci-dessus) ne sont pas les plus adaptés, on utilise une autre base le nombre e = 2,718. Ces logarithmes sont dits naturels (ou népériens) et sont notés ln (qui équivaut à log e )

* Voici un résumé de ce que nous venons de voir:

Note: la quantité de chiffres est obtenue avec le log base 10 (et non ln)

* Le calcul avec les logarithmes exige cependant de disposer:

* autrefois: de tables de logarithmes ou d'une règle à calcul;

* aujourd'hui: d'une calculette ou d'un ordinateur.

* Leur usage s'étend à la représentation des phénomènes physiques qui croissent exponentiellement.

C'est le cas, par exemple, du son dont l'intensité sonore s'exprime en décibel, une forme de logarithme.

Les pas de deux hommes qui marchent ne font pas beaucoup plus de bruits que ceux d'un seul marcheur. Par contre, une troupe qui marche, là oui, il y a une belle différence.

Le phénomène n'est pas simplement additif, mais plutôt multiplicatif, comme dans le monde des logarithmes.

Le fait est que, les lois physiques de ces phénomènes sont formulées par des exponentielles.

* Les logarithmes sont aussi utiles pour faciliter des représentations graphiques.

Échelle normale Échelle logarithmique

* La représentation logarithmique:

* favorise les petits en leur "relevant" la tête; et

* minimise les grands en "écrasant" leur dynamique.

Exemple pratique

* Voici la superficie comparée de quelques pays du monde.

L'échelle logarithmique (graphique du haut) fait ressortir les nuances des pays les plus petits.

Puissances de 10

Les puissances de 10 sont faciles: elles indiquent la quantité de 0 derrière le 1. Ainsi: 102 = 100 et 103 = 1000 par exemple.

Dans ce monde, pour multiplier on ajoute et pour diviser on soustrait.

102 x 103 = 100 x 1000 = 100 000 = 105 = 102 + 3

10a x 10b = 10a + b

103 / 102 = 1000 x 100 = 10 = 101 = 103 – 2

10b / 10a = 10b – a

Un tel monde où les opérations compliquées se transforment en opérations simples est le monde des logarithmes.

C'est un monde où les choses vont en se multipliant par 10.

C'est utile pour traiter les phénomènes comme l'audition. En effet, nos oreilles ne sont pas linéaires, elles sont sensibles dans ce genre de rapport. Par exemple, 2 bels (ou 20 décibels) indique un rapport 100 entre deux puissances sonores. Une puissance sonore qui double équivaut à 3 décibels.

Exemple de calcul avec logarithmes

En présence de très grands nombres, la calculette ne sait plus calculer; avec les logarithmes, on s'en sort.


Table de logarithmes — Wikipédia

Vu dans ... https://fr.wikipedia.org/wiki/Table_de_logarithmes

Table de logarithmes

Un article de Wikipédia, l'encyclopédie libre.
Sauter à la navigation Sauter à la recherche
Pour les articles homonymes, voir Table (homonymie).
Tables de Logarithmes Bouvart et Ratinet, Librairie Hachette, 1957
Table des logarithmes naturels de 0,01 à 100 avec cinq chiffres après la virgule, à « lecture naturelle » (les nombres sont indiqués en entier).

Une table de logarithmes est une représentation tabulaire des logarithmes, généralement en base 10, des nombres entiers de 1 à N. Le plus souvent N vaut 10 000, comme dans la table de Bouvart et Ratinet, très répandue en France avant l'apparition des calculatrices, ou 100 000.

La connaissance des logarithmes décimaux des nombres entiers compris entre 10n et 10n+1 suffit, puisque le logarithme des autres nombres peut être obtenu facilement ; seule la partie devant la virgule, ou caractéristique, change. Pour cette raison, la table ne donne le plus souvent que les chiffres après la virgule, appelée la mantisse.

Exemple :

  • Le logarithme de 2 est 0,301 03… ;
  • le logarithme de 20 est 1,301 03… ;
  • le logarithme de 200 est 2,301 03… ;
  • dans la table, on lira simplement 301 03.

Lorsque la table donne les logarithmes des nombres jusqu'à 10n, on dispose ainsi des logarithmes pour tous les nombres ayant au plus n chiffres significatifs. Les logarithmes des nombres ayant plus de chiffres significatifs sont calculés par interpolation linéaire. Souvent la table fournit dans la marge des tableaux facilitant l'interpolation.

Les tables logarithmiques sont des aides au calcul de produits, de quotients ou de puissances. On peut cependant aussi calculer une somme de deux nombres dont le logarithme est connu, soit à l'aide d'une table spéciale, de logarithmes additifs (fournie par exemple avec la table de Hoüel), soit à l'aide de la trigonométrie et des tables des logarithmes des fonctions trigonométriques, presque toujours fournies à la suite de la table des logarithmes des nombres entiers. La trigonométrie permet d'ailleurs de rendre bon nombre de formules calculables par logarithmes.

Sommaire

  • 1 Histoire
    • 1.1 Principe
    • 1.2 Illustration, construction de la table du logarithme décimal
      • 1.2.1 Première étape
      • 1.2.2 Deuxième étape
  • 2 Utilisation d'une table de logarithmes
    • 2.1 Lecture
    • 2.2 Calculs
  • 3 Notes et références
  • 4 Voir aussi
    • 4.1 Articles connexes
    • 4.2 Liens externes

Histoire

Article connexe : Histoire des logarithmes et des exponentielles.

Les premières tables logarithmiques apparaissent au début du XVIIe siècle dans le but de faciliter les calculs astronomiques. À une époque où tous les calculs se font à la main, elles permettent de transformer les produits en sommes. Pour exécuter le produit de a par b, il suffit de chercher le logarithme de a et celui de b. En effectuant la somme de ces deux logarithmes, on obtient le logarithme de ab. Le produit ab est alors facile à retrouver en lisant la table à l'envers. C'est John Napier (Neper) qui publie les premières tables logarithmiques qui sont des tables de logarithmes de sinus (Mirifici Loagarithmorum Canonis Descriptio - 1614). Henry Briggs qui travaille en collaboration avec Neper a l'idée d'associer au nombre 10 le nombre 1 et il construit ainsi la première table de logarithme décimal ou logarithme de base 10 (1615). Dans le même temps (1603 - 1611), l'astronome Jost Bürgi qui travaille aux côtés de Kepler élabore des tables trigonométriques et une table d'antilogarithmes qui sera publiée en 1620[1].

Ces tables numériques sont construites à l'aide du principe décrit ci-dessous en n'utilisant que des opérations simples (additions, interpolations linéaires). Les précisions obtenues, 14 décimales par exemple pour la table de Briggs, laissent imaginer la quantité de calculs qu'il a fallu effectuer pour les construire. C'est donc un outil précieux tant pour la difficulté de sa construction que pour son utilité pratique, qui se développe ainsi au cours du XVIIe siècle. Elles sont massivement utilisées pour les calculs pendant plus de trois siècles avant d'être détrônées à la fin du XXe siècle par la mise sur le marché de calculatrices performantes.

Principe

Le principe de construction consiste à associer une suite arithmétique et une suite géométrique qui progressent de concert. Neper, expliquant son principe dit en substance :

« Le logarithme d'un sinus est un nombre qui augmente également dans des temps égaux tandis que le sinus décroit proportionnellement. Les deux mouvements ayant lieu dans le même temps et commençant à la même vitesse ».

Illustration, construction de la table du

On peut présenter une version simplifiée de la construction en imaginant de construire les puissances successives de 1,01. Les calculs s'effectuant à la main à partir des opérations de base (addition, interpolation linéaire), il faut déjà beaucoup de temps pour obtenir une précision de trois ou quatre décimales.

Première étape

On détermine la suite des puissances du nombre 1,01 jusqu'à ce que le nombre 10 (la base) soit atteint : on commence avec la première puissance (1,01), puis on ajoute le nombre décalé vers la droite de deux chiffres (multiplié par 0,01) et on obtient la puissance suivante :

  • 1,01 + 0,010 1 = 1,020 1.

On continue ainsi, en arrondissant ensuite les résultats en tronquant les chiffres après la quatrième décimale :

  • La troisième puissance de 1,01 est égale à 1,030 3 ;
  • la 4e puissance est égale à 1,040 6 ; … en utilisant les règles classiques des arrondis, par exemple :
  • la 11e puissance vaut 1,115 5 ;
  • la 12e puissance est alors 1,115 5 + 0,011 2 = 1,126 7 ; …
  • enfin la 231e puissance est 9,959 ; et la 232e puissance est 10,059.

On s'arrête lorsque 10 a été dépassé. On obtient alors la table suivante :

n | 1,01n
1 | 1,01
2 | 1,020 1
3 | 1,030 3
4 | 1,040 6
… | …
11 | 1,115 5
12 | 1,126 7
… | …
231 | 9,959
232 | 10,059

L'apport de Neper est d'envisager que le mouvement est continu, c'est-à-dire que l'on peut combler les trous[1]. Puisque pour n=231, on arrive à 9,959 et que pour n=232, on arrive à 10,059, c'est entre ces deux nombres que l'on va arriver à 10. On peut alors envisager une interpolation linéaire : un écart de 1 dans la colonne de gauche correspond à un écart de un dixième dans la colonne de droite. Pour arriver à 10 en partant de 9,959, il faut ajouter 0,41 dixièmes. Il faut donc ajouter 0,41 unités dans la colonne de gauche. Au nombre 10 correspond donc 231,41. S'il l'on veut faire correspondre, au nombre 10 le nombre 1, il suffit de diviser tous les termes de la colonne de gauche par 231,41. On obtient ainsi des valeurs approchées des logarithmes décimaux de toutes les puissances de 1,01 (présentés dans la colonne de droite du tableau ci-dessous).

Deuxième étape

On construit alors un tableau de correspondances qu'il suffit de compléter pour les valeurs intermédiaires à l'aide d'une interpolation linéaire

n | a | log(a)
1 | 1,01 | 0,004 32
2 | 1,020 1 | 0,008 64
3 | 1,030 3 | 0,012 96
4 | 1,040 6 | 0,017 28
… | … | …
11 | 1,115 5 | 0,047 53
12 | 1,126 7 | 0,051 85
… | … | …
69 | 1,986 7 | 0,298 18
70 | 2,006 6 | 0,302 50
… | … | …
231 | 9,959 | 0,998 27
231,4 | 10 | 1

Pour déterminer, par exemple, le logarithme en base 10 du nombre 2, il suffit de parcourir la table des puissances de 1,01 et de lire que 2,00 se situe entre la 69e puissance (1,986 7) et la 70e puissance de 1,01 (2,006 6). D'une interpolation linéaire, 2 en ressort avec une puissance de 69,66, donc 1,01⋅69,66≈ 2, c’est-à-dire 69,66⋅log(1,01) ≈ log(2).

Pour déterminer le logarithme base 10 de 2, il ne reste plus qu'à effectuer la division 69,66 / 231,4 ≈ 0,30104 qui correspond bien à une valeur approchée de log(2) .

En réalité, les tables de logarithmes furent construites à la main avec davantage de précisions, en partant par exemple des puissances de 1,000 001. Si on affecte alors arbitrairement la valeur 0,000 001 au logarithme de 1,000 001, on obtient la valeur de 1 pour le logarithme de 2,718 28, donnant ainsi une légitimité au logarithme naturel (ou népérien) de base e.

Utilisation d'une table de logarithmes

Lecture

De simples tables de logarithmes à cinq décimales sont généralement développées de telle sorte que les nombres formés des deux premiers chiffres (de 10 à 99) forment le bord gauche du tableau, tandis que les derniers chiffres (de 0 à 9) apparaissent en tête de colonne.

Une table de logarithmes se présente sous la forme suivante :

N    0    1    2    3   …   9
10 0000 0043 0086 0128  … 0374
11 0414 0453 0492 0531  … 0756
12 0792 0828 0864 0899  … 1106
13 1139 1173 1206 1239  … 1430
14 1461 1492 1523 1553  … 1732
15 1761 1790 1818 1847  … 2014
16 2041 2068 2095 2122  … 2279
17 2304 2330 2355 2380  … 2529
18 2553 2577 2601 2625  … 2765
19 2788 2810 2833 2856  … 2989
·    ·    ·    ·    ·       ·
·    ·    ·    ·    ·       ·
·    ·    ·    ·    ·       ·
99 9956 9957 9957 9958  … 9960

Ici, le chiffre des unités et celui des dixièmes du nombre N figurent dans la colonne de gauche et le chiffre des centièmes dans la première ligne. À l'intersection d'une ligne et d'une colonne, on lit log(N).

Exemple 1 : Comment déterminer log(1,53) ?

On se place dans la ligne 15 et dans la colonne 3 et on lit 1847. On peut donc conclure que
log(1,53) ≃ 0,184 7

Exemple 2 : Comment déterminer log(0,001 53) ?

On sait que la caractéristique de ce nombre est –3 et que sa mantisse est log(1,53).
Donc log(0,001 53) = –3 + 0,184 7 ≃ –2,8153

Exemple 3 : Comment déterminer log(18,27) ?

On sait que sa caractéristique est 1 et que sa mantisse est log(1,827). On se place donc dans la ligne 18 et entre la colonne 2 et la colonne 3. Il faut alors faire une interpolation linéaire
log(1,82) ≃ 0,260 1 et log(1,83) ≃ 0,262 5 soit une différence de 24 dix-millièmes. L'interpolation linéaire permet d'approcher les logarithmes des nombres compris entre 1,82 et 1,83 de la manière suivante
log(1,821) ≃ 0,260 1 + 0,000 24
log(1,822) ≃ 0,260 1 + 0,000 48
…
log(1,827) ≃ 0,260 1 + 7 × 0,000 24 ≃ 0,261 8
log(18,27) ≃ 1,261 8

Exemple 4 : Quel est le nombre dont le logarithme est 1,208 ?

On sait que la caractéristique est 1 et que le nombre s'écrit donc N × 10 avec log(N) = 0,208
Dans la table de logarithmes, 2080 est compris entre 2068 et 2095 (différence de 27). Le nombre 2068 est dans la ligne des 16 et dans la colonne des 1 donc 0,206 8 = log(1,61). De même 0,209 5 = log(1,62). On procède donc encore à une interpolation linéaire
0,206 8 + 0,000 27 = 0,207 07 = log(1,611)
0,207 07 + 0,000 27 = 0,207 34 = log(1,612)
…
0,206 8 + 4 × 0,000 27 = 0,207 88 = log(1,614)
0,206 8 + 5 × 0,000 27 = 0,208 15 = log(1,615)
0,208 ≃ log(1,614)
101,208 ≃ 16,14


Échelle logarithmique — Wikipédia

Vu dans ... https://fr.wikipedia.org/wiki/%C3%89chelle_logarithmique

Échelle logarithmique

Une échelle logarithmique est un système de graduation en progression géométrique. Chaque pas multiplie la valeur par une constante positive. De ce fait, la position sur l'axe d'une valeur est proportionnelle à son logarithme.

Une échelle logarithmique est particulièrement adaptée pour rendre compte des ordres de grandeur dans les applications. Elle montre sur un petit espace une large gamme de valeurs, à condition qu'elles soient non nulles et de même signe.

Sommaire

  • 1 Définition
    • 1.1 Comparaison d'une échelle linéaire et d'une échelle logarithmique
    • 1.2 Unités logarithmiques
  • 2 Usage
  • 3 Construction de l'échelle
  • 4 Voir aussi
    • 4.1 Articles connexes
    • 4.2 Liens externes

Définition

L'échelle logarithmique place les valeurs sur l'axe en croissance exponentielle. Des points écartés d'une même distance représentent des valeurs dans le même rapport.

L'échelle logarithmique n'est définie que pour des valeurs strictement positives.

Comparaison d'une échelle linéaire et d'une échelle logarithmique

L'illustration ci-dessus montre les deux types d'échelles :

  • Avec l'échelle linéaire, deux graduations dont la différence vaut 10 sont à distance constante.
  • Avec l'échelle logarithmique, deux graduations dont le rapport vaut 10 sont à distance constante.

Sur l'échelle logarithmique, les grands nombres sont comprimés, rapprochés de 1 et facilement représentés, en revanche les nombres inférieurs à 1 sont dilatés et très vite renvoyés vers l'infini négatif.

Unités logarithmiques

On utilise parfois des unités logarithmiques, c'est-à-dire dont la valeur est le logarithme du rapport entre deux valeurs d'une grandeur. La base logarithmique choisie dépend des habitudes de la discipline qui les utilisent :

  • le logarithme népérien, dont la base est e, facilite certains calculs et s'évalue plus directement grâce à la série de Taylor, mais ne permet pas d'accéder intuitivement à l'ordre de grandeur décimal. Le néper est le logarithme népérien du rapport entre deux puissances.
  • logarithme décimal (base 10) donne directement une notion de l'ordre de grandeur, puisque la caractéristique, c'est-à-dire le signe et la partie avant la virgule, le donne directement. Sa lisibilité le rend utile dans de nombreux domaines technologiques, bien que sous une forme modifiée. Il sert en statistiques, et en chimie définit le pH.
  • Le décibel, couramment utilisé en télécommunications, électronique et acoustique se définit comme 10 fois le logarithme décimal du rapport entre deux puissances ; mais si les tables de logarithmes et plus tard, les calculatrices de poche n'avaient pas donné plus facilement accès au logarithme décimal, on dirait avec rigueur que le décibel est le logarithme de base 100,1 (soit environ 1,26) du rapport entre deux puissances. En effet, c'est à ce multiplicateur que correspond un décibel.
  • le logarithme de base 2 sert en informatique, avec les bits et en musique, avec les octaves.
  • De la même façon, le demi-ton de la gamme tempérée en musique, qui est la douzième partie de l'octave, est le logarithme de base 21÷12 (soit environ 1,06) de la fréquence.

Une échelle linéaire graduée dans une unité logarithmique équivaut à une échelle logarithmique, du point de vue de la grandeur considérée.

Usage

Croissance de la population de l’Angleterre tracée à l’échelle logarithmique (1,67 décennies).

La règle à calcul tire parti des propriétés de l'échelle logarithmique pour permettre d'effectuer des multiplications.

Les graphiques en repère semi-logarithmique servent à montrer l'évolution de grandeurs dont l'une a une évolution linéaire (en général, la variable indépendante sur l'axe des abscisses), et l'autre une évolution exponentielle.

Exemple : évolution des prix :

En économie, les valeurs des monnaies internationales, des actions, des matières premières et autres produits de commerce, soumis à une inflation des prix, s'inscrivent en échelle logarithmique sur l'axe des ordonnées, tandis que le temps s'inscrit en échelle linéaire sur l'axe des abscisses.

Exemple : Réponse en fréquence :

En électronique, la réponse en fréquence d'un système, et particulièrement d'un filtre, se représente généralement sur un diagramme semi-logarithmique, avec une échelle logarithmique pour les fréquences en abscisses et une échelle linéaire sur l'axe des ordonnées, graduée en décibels, par rapport à la tension obtenue à une certaine fréquence (par exemple, 1 000 Hz).

Comme les décibels sont une unité logarithmique, du point de vue de la tension électrique ou des rapports de tension, l'échelle est également logarithmique, ce qui permet, dans le Diagramme de Bode, les tracés asymptotiques, en lignes droites.

Les graphiques en repère logarithmique sur les deux axes conviennent aux grandeurs dont tant la variable indépendante que la variable dépendante peuvent prendre des valeurs extrêmement différentes. Lorsque l'une est proportionnelle à l'élévation de l'autre à une puissance, le graphique dessine une droite dont la pente est proportionnelle à l'exposant.

Construction de l'échelle

On connait les valeurs minimale xmin et maximale xmax qu'il faut représenter, et la longueur l de l'échelle entre ces deux valeurs.

La longueur l correspond à une multiplication par r = xmax ÷ xmin.

Le point placé au milieu est à la même distance de xmin et de xmax. La valeur qui correspond au point du milieu est la moyenne géométrique des valeurs extrêmes x m i n × x m a x {\displaystyle {\sqrt {x_{min}\times x_{max}}}} [image] .

Plutôt que calculer ainsi de proche en proche, on utilise la propriété fondamentale des logarithmes:

log(a × b) = log(a) + log(b)

On peut calculer les rapports de valeurs grâce à la fonction exponentielle, qui est la fonction réciproque de la fonction logarithmique.

Pour graduer l'axe selon ses besoins, on peut calculer le rapport de valeur par unité de longueur sur l'axe. Le logarithme de la progression par unité de longueur nombre s'obtient par une simple division : log(r)÷l et la valeur de la progression est r1/l.

De la sorte, si on divise la distance l en n segments égaux, le rapport de valeurs qui correspond à chaque segment est de r1/n. La longueur totale, correspondant à l'écart entre xmin et xmax, correspond ainsi bien à une multiplication par r, tandis que la longueur de chaque segment correspond à une multiplication par la même quantité.

Les points également espacés désignent des valeurs en progression géométrique.

Exemple de construction d'une échelle logarithmique :

Échelle logarithmique à trois modules décimaux

  • Valeur minimale : 0,1
  • Valeur maximale : 100
  • écart relatif : r = 100 ÷ 0,1 = 1000
  • longueur de l'axe : 588 pixels

On veut que les multiples de 10 soient indiqués. Pour le rapport 1000, il y a trois multiplications par 10, correspondant à trois modules de 588 ÷ 3 = 196 pixels de long.

À l'intérieur de ces modules, on veut indiquer l'emplacement de chaque chiffre, de 2 à 9.

  • La multiplication par 2 correspond à la distance entre 0.1 et 0,2, 1 et 2, 10 et 20. La longueur correspondante s'obtient par une règle de trois sur les logarithmes : 588 × log ⁡ ( 2 ) log ⁡ ( 1000 ) {\displaystyle {\frac {588\times \log(2)}{\log(1000)}}} [image] , ce qui donne 59 pixels.
  • De même la multiplication par 3, 588 × log ⁡ ( 3 ) log ⁡ ( 1000 ) {\displaystyle {\frac {588\times \log(3)}{\log(1000)}}} [image] donne 93,5 pixels entre 0,1 et 0,3, 1 et 3 et 10 et 30. On est obligé d'arrondir, évidemment.
  • On en tire facilement leurs multiples : la distance entre 1 et 4 est celle de deux multiplications par deux, donc 118 pixels ; entre 1 et 8, celle de trois multiplications par deux, soit 177 ; entre 1 et 6 celle d'une multiplication par trois et d'une multiplication par deux, soit 93,5 + 59 = 152,5 pixels ; et entre 1 et 9, celle de deux multiplications par 3, soit 187 pixels.
  • La graduation 5 s'obtient facilement : puisque deux fois cinq font dix, la longueur de 0,5 à 1, de 5 à 10, de 50 à 100, est de 59 pixels (on peut donc noter que la multiplication par 5 correspond à une longueur de 196 - 59 = 137 pixels).
  • Il ne reste que le 7 à placer, par le même procédé de règle de trois sur les logarithmes.
  • La longueur de ces segments vaut pour les multiplications, et aussi pour les divisions.
  • Un déplacement de un pixel vers la droite correspond à une augmentation de exp(log(1000)÷588) ≈ 1.01181716053

Chacun des modules est reproduit trois fois, la forme est invariable, seule la légende des points change.

note: La base de logarithme dans laquelle s'effectuent les calculs n'a aucune importance.

Construction sans machine à calculer

  • 2 multiplié dix fois par lui-même donne 1024. Il y a donc, à 2 % près, dix fois la longueur du segment correspondant à la multiplication par 2 entre les deux extrémités de l'échelle de 0,1 à 100, et donc ce segment mesure 588 ÷ 10 ≈ 59 pixels. Avec cette longueur, on peut placer les 2, 4, 5 et 8 comme indiqué ci-dessus.
  • 7 × 7 donne 49, soit 50 à 2 % près. La longueur pour 100 est de deux modules de 196 pixels, soit 392 pixels, on en retranche la longueur pour 2 puisqu'il faut diviser la valeur par deux, reste 333 ; et la valeur pour 7 est la moitié, soit 166,5, qu'on arrondit à 166 puisque 7 × 7 est un peu moins que 50.
  • 3 × 3 font 9. On connaît la longueur correspondant à 8, 3 × 59 = 177 pixels, celle correspondant à 10, 196 pixels, la longueur correspondant à 9 est entre les deux, (177 + 196) ÷ 2 = 186,5 ; celle correspondant à 3 est la moitié, qu'on arrondit à 93.

Quand une valeur particulière est prise pour référence (par exemple, 1), la distance d'un point représentant un nombre à celui représentant cette valeur s'appelle sa coordonnée logarithmique.


règles historiques : lenoir gravet-lenoir tavernier-gravet

Vu dans ... https://photocalcul.com/Calcul/Regles/Collection_Etienne_Sigismond/introduction.html

RÈGLES A CARACTÈRE HISTORIQUE 1825 - 1943

Essai de datation des règles à calculer

LENOIR - GRAVET-LENOIR - TAVERNIER-GRAVET

Introduction

La contribution française à l’histoire et au développement des instruments de calcul est méconnue. Pourtant elle fut importante dans le domaine numérique des machines à calculer avec les noms de Pascal, Thomas de Colmar, Léon Bollée …Elle fut même essentielle dans le domaine analogique, en particulier pour ce qui concerne les instruments de calcul basés sur les propriétés des logarithmes.

Parmi les grands concepteurs et fabricants français de règles à calcul, on peut citer les noms de Mannheim, Péraux, Beghin, Morin, Barbotheu, Marc, Damien et plus tardivement mais aussi renommé celui de Graphoplex..

Il en est un, ou, plutôt, il est une lignée de noms dont l’histoire est intimement liée aux inventions et aux développements de cet instrument : il s’agit de la Maison Tavernier Gravet (T.G.). « Tavernier Gravet furent, en effet, les premiers constructeurs de règles à calcul du monde » lit-on dans une notice et un livre T.G. Leur Société fut fondée à Paris en 1770 et a poursuivi son activité durant deux siècles jusque dans les années 1970. Sa production fut très importante, originale et variée, puisqu’elle a proposé à sa clientèle plus de 300 types de règles.

Le fondateur de cette lignée de fabricants est Etienne Lenoir (1744-1832), ingénieur du Roi, fabricant renommé d’instruments scientifiques. Lui ont succédé son fils, Paul-Etienne, puis Gravet vers 1827 et enfin Tavernier vers 1867.

Le but de cette collection est de recueillir et présenter un échantillon de ces règles , intéressantes plus sur le plan historique que sur le plan technique ou de la sophistication des échelles.

Il est évident que cette collection ne constitue qu’un embryon et que toute information, photographie ou référence sera la bienvenue.

Etienne Pommel

Essai de datation

Grâce aux informations tirées de certaines collections, il nous est apparu intéressant d’essayer d’encadrer les dates de fabrication de ces règles en les passant au crible de plusieurs critères :

1. Le nom du fabricant

2. Les adresses

3. Les médailles décernées

4. Le matériau utilisé

5. Les types de règles et d’échelles

6. Les types de curseurs

1- Le nom du fabricant.

Le fondateur de la lignée est Etienne Lenoir (1744-1832), ingénieur du Roi, fabricant renommé d’instruments scientifiques. Il conçut, en particulier, vers 1780 une première machine à diviser, puis en 1825, une seconde « utilisant une méthode toute française ». Cette machine permettait de diviser simultanément jusqu’à 8 règles de 25 cm . Il est intéressant de noter que toutes les règles conçues avec cette machine présentent 2 encoches aux 2 extrémités qui servaient à leur prise..

On peut en tirer une observation : toute règle classique en bois du 19 ème ne présentant pas ces encoches n’est pas une T.G .

La réciproque n’est pas vraie car nous possédons une Barbotheu et une Morin qui présentent, elles aussi, ces encoches (nous soupçonnons ces fabricants d’avoir, dans certains cas, confié à T.G. la division de certaines de leurs règles).

Paul-Étienne Lenoir (1776-1827, fils du précédent) a également conçu une machine à diviser dans les années 1820 : « J’ai annoncé en 1819 des règles logarithmiques propres à faire toute espèce de calcul avec promptitude et sans chiffrer. Depuis cette époque j’ai terminé mes nouvelles machines propres à la fabrication de ces règles, et notamment pour la division, ce qui offrait des difficultés, ayant plus de quatre mille divisions exactes à faire sur chacune, et toutes à des distances inégales données par de rigoureux calculs (des femmes exécutent tout ce travail)… »

Ont succédé à Etienne Lenoir et à son fils (décédé avant son père), Gravet puis Tavernier.

Un ou plusieurs de ces noms apparaissent souvent au dessus ou au dessous des échelles, au recto ou au verso de la règle. Grâce aux collections déjà citées, on peut avancer les fourchettes de dates suivantes en fonction de la présence d’un ou de plusieurs de ces noms :

c. 1820 – 1827 Lenoir (La date de 1770 semble correspondre à la date de fondation de la Maison ; 1820 au début de la fabrication des règles à calculer)

c. 1827 – 1867 Gravet Lenoir (ou Gravet successeur de Lenoir)

c. 1867 – 1972 Tavernier Gravet (ou successeur de Gravet Lenoir)

Parfois Tavernier Vinay

2 - Les adresses

Lorsqu’elles sont indiquées, elles constituent un repère facile et fiable.

Les fourchettes des dates suivantes sont approximatives :

De 1817 à 1828 : 310 puis 340 rue Saint Honoré

De 1828 à 1866 : 14 rue Cassette

De 1867 à 1881 : 39 rue de Babylone

De 1881 à 1939 : 19 rue Mayet

De 1939 à 1965 : 24 rue Héricart

De 1965 à 1972 : 130 rue de Javel

3 - Les médailles

Parmi la centaine de règles T.G. examinées, nous n’avons rencontré que les 3 médailles d’or ci-après. On peut penser que ces distinctions concernant l'ensemble de la fabrication T.G. (à l’instar de la médaille de bronze de 1844 décernée à Gravet ), ou étant jugées insuffisamment honorifiques, n’ont pas été systématiquement reportées sur les règles.

Lorsqu’une ou plusieurs de ces dates sont indiquées, elles constituent évidemment un repère facile et fiable :

1878 Médaille d’or (à l’exposition universelle de Paris)

1889 Médaille d’or (à l’exposition universelle de Paris)

1900 Médaille d’or (à l’exposition universelle de Paris)

A partir d’une certaine date (peut être entre 1908 dernière règle examinée avec médailles indiquées et 1912 première règle examinée sans médaille) ces médailles ne sont plus portées.

4 - Le matériau

- buis : seule matière utilisée jusque dans les années 1880, souvent jusque dans le premier quart du XXème siècle

- celluloid : il fait son apparition en Allemagne (chez Dennert & Pape en 1886) d’abord sous forme de plaques recouvrant le bois.

Deuxième observation toute règle comportant du plastique est postérieure à 1886

5- Quelques types de règles caractéristiques et leurs échelles

Nous indiquons les dates des premières apparitions (lorsque nous les connaissons) des types de règles T.G. les plus commercialisées, en reprenant, pour les échelles, la notation de Peter M..Hopp. Ces notations n’existaient évidemment pas au XIX ème siècle

1820 Type Soho avec les échelles A / B (1 à 100), B (1à100) / D (1 à 10)

1851 Type Mannheim A/B (1 à 100), C / D (1 à 10) // S, L, T

1882 Règle Tscherepaschinski (reprise par Beghin ci-après)

1883 Règle Péraux à 2 réglettes (double Mannheim)

1894 Règle Béghin A, CF / DF (échelles décalées), CI, C / D, K (1 à 1000) // S,L,T

1925 Règle Rietz K (1 à 1000) A / B, CI, C/D, L (logarithmes)//S, S&T, T

1934 Règle Darmstadt K, A /B, CI, C / D, Sin, Cos // LL0, LL1, LL2

c. 1938 Règle Commerciale

c. 1938 Règle d’électricien

1942 Règle Barrière

6 - Les types de curseur

6-1 Les règles de type Soho (voir paragraphe 5) n’ont pas besoin de curseur .En effet, les calculs peuvent se faire en restant sur les 2 échelles supérieures (mêmes doubles cycles logarithmiques pour effectuer les multiplications, divisions…) ou les 2 échelles inférieures (cycles logarithmiques différents car double et simple pour effectuer les carrés, racines carrées…). Elles peuvent, mais ce n’est pas obligatoire avoir un bouton poussoir permettant de faire glisser plus facilement la (ou les) réglette(s). Ce type de règle, moins onéreux à fabriquer que les règles de type Mannheim (voir paragraphe 5), se rencontre jusque dans les années 1900.

6-2 En revanche, les règles de type Mannheim dont sont issus tous les autres types de règles, nécessitent l’emploi d’un curseur pour passer des échelles supérieures (comportant les 2 mêmes cycles logarithmiques) aux échelles inférieures (comportant le même simple cycle logarithmique) et réciproquement.

Nous possédons une chronologie des différents types de curseur, extraite d’un livre publié par la Maison Dennert et Pape à l’occasion du centenaire de la Maison Aristo (1862-1962 : « la plus vieille fabrique allemande de règles à calculer »).

Troisième observation : toute règle possédant un curseur est postérieure à 1851. Là non plus, la réciproque n’est pas vraie (des règles sans curseur peuvent être postérieures à 1851).

Les règles T.G. possèdent entre 1875 ( ?) et 1925 ( ?) un curseur composé d’un cadre métallique asymétrique, entourant une vitre présentant un repère à cheveu ou gravé .

7- Conclusion

Ma génération de « jeunes retraités » a conscience d’avoir vécu une évolution extraordinaire dans le domaine du calcul. En effet nous avons connu et utilisé :

1- « l’informatique manuelle » avec en particulier le calcul au moyen d’abaques ou le calcul analogique avec les règles à calcul.

2- L’informatique lourde centralisée

3- L’informatique répartie

4- La micro-informatique

5- Le réseau planétaire (www)

Ainsi pouvons-nous avoir un rôle de transmission de mémoire et à ce titre, la règle à calcul est un instrument de choix par ses caractéristiques tout à fait intéressantes :

1- C’est un bel instrument (ah la patine du buis ancien !), peu encombrant et que l’on peut encore parfois trouver pour un prix abordable.

2- Son fonctionnement est compréhensible après un minimum de formation.

3- Il a près de quatre siècles d’histoire et était encore utilisé il y a peu.

Conscient des imprécisions et imperfections de cet essai, je formule le vœu que ce travail soit poursuivi et enrichi.

8– Bibliographie

Berché (P)et Jouanneau (Ed)« Apprenez à vous servir de la règle à calcul » 1959

Cajori (Florian) « History of the logarithmic slide rule » 1909

Daumas (Maurice) « Les Instruments scientifiques aux XVII et XVIII » 1953

Dennert & Pape « Aristo 1862-1962 » 1962

Hopp (Peter M.) « Slide rules Their History, Models, and Makers » 1999

Jezierski (Dieter von) « Slide rules A Journey through three centuries » 2000

Marguin (Jean) « Histoire des Instruments et machines à calculer » 1994

Peraux (E.) « Instructions sur la règle à calcul » 1893

Turner (A.J.) « Etienne Lenoir and…instrument-making in France 1760-1830 » 1989

Notice accompagnant une règle à calcul T.G.

Livre non daté « Instructions concernant l’usage des règles à calcul T.G . »

Journal de la Oughtred Society Vol 11 2002

Catalogue du musée du C.N.A.M. Section A Instr. et machines à calculer 1942

Marcellin Dictionnaire des fabricants français d’instruments de mesure du XV au XIX ème 2004

(Note écrite en 2005, revue en 2009) Etienne Pommel


Règles a calculer plus

Vu dans ... http://www.collections.hardy-jm.fr/regles_calcul/reglecalcul_plus.php

Les collections de Jean-Marie

Machines à Calculer

Quelques Règles à Calculer

un plateau de ma collection

un plateau présentoir d'un vendeur "Aristo"

règle "Graphoplex" modèle 1614

Vu la diversité des échelles utilisées, la plupart des règles étaient livrées avec une notice succincte


Régles à calcul

Vu dans ... http://choulik.pagesperso-orange.fr/arborescence/frames/regles_a_calcul.htm

Règles à calcul(s)

Il faut bien commencer un jour :

Aucune information concernant la marque de celle-ci, une des 3 dernières entrées en collection,
légèrement gauchie, peut-être moins à l'œil que sur la photo, réglette et curseur coulissant très bien.

Si vous cliquez sur les photos, vous obtiendrez une image de meilleur qualité mais plus lourde,
j'ai voulu éviter les artefacts du jpeg dont on ne rappellera jamais assez que c'est une compression destructrice.

recto :
recto.jpg (1015107 octets)

verso :
verso.jpg (1385941 octets)

et de profil : tranche.jpg (69491 octets) on admirera la fragilité de la liaison (bois)
la règle étant fendue -d'origine- sur toute sa longueur. Malgré les apparences, cette liaison est intacte

Puis un petit zoom sur un calcul :
Pour calculer le sinus d'un angle de 4,4° soit 4°24' zoomverso.jpg (158672 octets)

Résultat : zoomrecto.jpg (235261 octets)

On remarquera, mais les "anciens" le savent bien, qu'il n'y a pas d'indication de virgule, et qu'un rapide calcul (mental ? mais non !
il suffisait de prévoir avant la manipulation le calcul ci-dessous, vous remarquerez que Pi figure en bonne place sur la réglette 1)
s'impose :
en radians, 4°4 équivaut à 4,4/180*Pi soit 0,767 à 10-3 près ( ici par défaut). Ce que l'on doit lire est donc de cet ordre.
Pour avoir longtemps pratiqué ces outils, j'affirme que c'est ce que l'on lisait (allez ! à 0,001 près) et que seul le gauchissement
explique la position légèrement décalé de la réglette coulissante.

1 Pour ce qui est du calcul 4,4/180*Pi ( la bonne vieille règle de trois) c'est un classique de la règle (à calcul) puisqu'il se fait en
une manipulation et non deux comme on pourrait le croire : il suffit de disposer la réglette pour la division (soustraction des
logarithmes décimaux) et le curseur pour la multiplication (addition de 2 logarithmes).
regledetrois.jpg (240780 octets)
le grand age de ce vénérable objet expliquant les imperfections du calcul fait ce jour .

La position de certaines constantes permet de faire non plus 2 mais trois opérations en minimisant les déplacements, donc l'échauffement
de la règle lors d'un partiel par exemple, ce qui évitait d'avoir à la refroidir à l'aide d'un quelconque liquide....

Autre exemple : ( Merci François N.)
Après mure réflexion ( ....) on arrive au résultat suivant :

calculfrancoisav.jpg (44203 octets)

Reste à calculer M2 que l'on "prépare" un peu :

La règle n'effectuant pas les additions, elle n'est pas là pour ça, (rappelons que jusqu'à une "certaine" date (1975) l'addition ne posait aucun problème :
un papier, un crayon, voire un peu de matière grise suffisaient) on prépare les calculs intermédiaires :

Pour sin4° on fait comme ci-dessus, ce qui m'amène à mettre en scène la dernière arrivée ( graphoplex 690) :
On lit : sin4°.jpg (154525 octets) : 0,07 (moins un chouïa)

Puis pour 6/70 : avec la même précision : 6div70.jpg (150454 octets) : 0,0857

Le lecteur vérifiera -s'il veut- le total :0,155(5)

Reste la dernière division (750 / 0,1555)qui permet de lire le résultat : division.jpg (175222 octets)

on comprend qu'il faut estimer auparavant l'ordre de grandeur pour énoncer : 4825

On m'a demandé de donner le temps estimé pour ce calcul : BEAUCOUP MOINS que pour composer cette page !
15 secondes pour la dernière mise en forme et autant pour chacune des 4 manipulations mais uniquement parce que je suis rouillé,
et qu'un curseur-loupe aurait bien fait l'affaire. Je reste persuadé qu'à l'époque (moins de) la moitié du temps aurait suffi, mais on était rodés !

Et pour qui ne croirait pas au grand age de ces instruments : livre01.jpg (252963 octets)


Règle à calcul — Wikipédia

Vu dans ... https://fr.wikipedia.org/wiki/R%C3%A8gle_%C3%A0_calcul

règle à calcul

Un article de Wikipédia, l'encyclopédie libre.
Règle à calcul scolaire de 10 pouces (Pickett N902-T simplex trig).

La règle à calcul (ou règle à calculer) est un instrument mécanique qui permet le calcul analogique et sert à effectuer facilement des opérations arithmétiques de multiplication et de division par simple déplacement longitudinal d’un coulisseau gradué. Elle utilise pour cela la propriété des fonctions logarithmes qui transforment un produit en somme et une division en différence. Elle permet également la réalisation d'opérations plus complexes, telles que la détermination de racines carrées, de cubiques, des calculs logarithmiques ou trigonométriques [ 1 ] .

Du XVII e siècle jusqu'à l'apparition des premières calculatrices électroniques portables dans le dernier quart du XX e siècle, les règles à calcul sont largement utilisées par les étudiants, les scientifiques et les ingénieurs pour les calculs approchés [ 2 ] .

Simples de conception et de fabrication, bon marché, elles sont faciles d'utilisation et apportent une précision suffisante aux calculs triviaux (typiquement 2 décimales) pourvu qu'on leur consacre le soin et la rigueur d'utilisation nécessaires.

Aujourd'hui, devenues obsolètes, seules des règles à calcul circulaires restent parfois utilisées pour la navigation aérienne, ainsi que celles présentes sur les cadrans à lunette tournante de certaines montres.

Sommaire

  • 1 Composants
  • 2 Principe
    • 2.1 Détermination des différentes échelles
    • 2.2 Utilisation des échelles pour les calculs
      • 2.2.1 Multiplication et division
        • 2.2.1.1 Calculs enchaînés
    • 2.3 Carrés, cubes et racines
    • 2.4 Inverses
    • 2.5 Trigonométrie
    • 2.6 Logarithmes
  • 3 Lecture
  • 4 Précision et exactitude
  • 5 Fabrication
  • 6 Histoire
  • 7 Notes et références
  • 8 Voir aussi
    • 8.1 Articles connexes
    • 8.2 Liens externes
    • 8.3 Bibliographie

Composants

Curseur d’une règle à calcul
  • Une règle à calcul se compose en général de deux réglettes fixes solidaires graduées, dans lesquelles s’imbrique une réglette mobile, également graduée, ainsi que d’un curseur se déplaçant longitudinalement (celui-ci étant parfois équipé d'une loupe). Les plus beaux modèles sont totalement double face, étant constitués de deux règles reliées par des ponts, encadrant une réglette mobile, ce qui permet l'utilisation d'un plus grand nombre d'échelles.
  • La réglette centrale peut coulisser par rapport aux deux autres, et permet de décaler des graduations. Elle est souvent graduée des deux côtés : d’un côté X²y, X³ , 1/X, Xy et de l’autre les fonctions trigonométriques.
  • Le curseur central facilite la lecture et l’interpolation entre les graduations ; il sert surtout à mémoriser une valeur, lors de calculs enchaînés (règle de trois par exemple).
  • Il existe aussi des versions circulaires (cercle à calcul) ou hélicoïdales (hélice à calcul).

Principe

Détermination des différentes échelles

Règle proposant, sur cette face et dans l'ordre, les échelles LL1, A, B, T, S, C, D, LL2

La composition des règles à calcul est variable. Il convient donc à l'utilisateur de repérer les échelles.

  • On trouve souvent quatre échelles étiquetées A, B, C et D. A et B sont des carrés (identifiables par une graduation logarithmique de 1 à 100), C et D les unités (graduation logarithmique de 1 à 10). L'échelle B est souvent absente. Dans ce cas, on peut juste trouver les carrés et racines carrées, mais pas calculer dans les carrés. Pour reconnaître avec certitude une échelle des carrés, il s'agit de deux échelles identiques graduées de 1 à 10 mises bout-à-bout. Le premier 10 est exactement au milieu de la règle.
  • On trouve aussi presque toujours une échelle des cubes (graduée de 1 à 1000) : trois échelles logarithmiques identiques bout-à-bout.
  • On trouve généralement une échelle de logs (décimaux), graduée de 0 à 10 et qui n'est pas logarithmique, mais tout à fait régulière.
  • Un grand classique est l'échelle des inverses : elle est identique aux échelles C et D des unités, mais de droite à gauche. Souvent notée CI et graduée en rouge.
  • Encore presque toujours, les fonctions trigonométriques : S pour les sinus (gradués de 6 à 90), T pour les tangentes (graduées de 6 à 45)
  • Sur les règles modernes, les échelles Log-Log, notées LL
  • Sur les règles spécialisées (électricité, etc.), des échelles dédiées à des calculs spécifiques. On les identifiera grâce à la documentation, aux inscriptions situées dans les marges et à une bonne connaissance du domaine en question.

Utilisation des échelles pour les calculs

Multiplication et division

Multiplication de 2x3 (en fait, toute la table des 2 jusqu'à 5)
Multiplication de 2 par les nombres plus grands que 5

Pour son utilisation la plus courante (la multiplication et la division), la règle à calcul utilise des échelles logarithmiques et le principe selon lequel la somme des logarithmes de deux nombres est égale au logarithme du produit des deux nombres :

log (a) + log (b) = log (a × b).

Cela se traduit par le fait que, pour multiplier deux valeurs, il suffit d’additionner leurs longueurs représentées sur la règle, et de les retrancher pour faire une division.

Pour multiplier 2 par 3, on positionne donc le 1 de la règle mobile en regard du 2 de la règle fixe, et on lit le résultat 6 sur l'échelle fixe en face du 3 de la règle mobile.

Cette opération est très facile à effectuer, mais a l’inconvénient de ne pas donner les exposants de 10 (la position de la virgule), qui doivent être trouvés par une autre méthode (généralement un calcul mental approché).

Un autre inconvénient est que le résultat est souvent hors échelle (par exemple, 2 × 6 est impossible sur le premier exemple). Dans ce cas, on procède comme sur le deuxième exemple, en alignant le nombre à multiplier, non pas avec le 1, mais avec le 10 (deuxième exemple).

Échelles CF-DF. On constate que 1,3 × 8 tombe hors échelle, mais fonctionne si on cherche le résultat sur CF (10,4 environ)

Pour limiter cet inconvénient, certaines règles proposent un petit prolongement au bout de chaque échelle, ou bien des échelles décalées notées CF et DF, allant de racine de 10 à racine de 10, avec le 1 au milieu. Dans ce cas, on commence le calcul sur l'échelle classique C-D, et on le finit sur CF-DF.

Pour la division, la position des règles est la même que pour la multiplication. L'exemple illustré ci-dessus concerne aussi bien la division de 6 par 3 : en retranchant la longueur (log) de 3 à la longueur 6, on obtient la longueur 2.

Calculs enchaînés

Lorsque l'on vient de faire une division le 1 de l'échelle C est placé en face du résultat, et est idéalement positionné pour faire une multiplication de ce nombre par un autre.

Une fois ce nouveau nombre trouvé, on le repère grâce au curseur mobile, et on déplace la règle mobile pour placer le nouveau diviseur en face du repère pour obtenir une nouvelle division, et ainsi de suite.

On constate donc qu'on peut alterner à l'infini des multiplications et des divisions avec un minimum de déplacements des éléments de la règle.

Carrés, cubes et racines

La racine carrée de 2,1

Les règles à calcul servent aussi à trouver les carrés, les cubes, ainsi que les racines.

Le maniement est très simple. Généralement, il suffit d'utiliser le curseur et de chercher la correspondance sur l'échelle adaptée.

Pour trouver le carré d'un nombre, on place le curseur sur ce nombre sur l'échelle des unités, et on cherche son correspondant sur l'échelle des carrés. En procédant à l'inverse, on trouve, sur l'échelle des unités, la racine carrée d'un nombre lu sur l'échelle des carrés. L'exemple ci-contre montre aussi bien que la racine carrée de 2,1 (échelle A) est proche de 1,45 (échelle D), que l'inverse.

Le principal piège est de ne pas se tromper dans le choix du nombre pour une racine carrée : la racine carrée de 9 est 3, tandis que celle de 90 est d'environ 9,5. En revanche, si l'on cherche la racine de 900, on doit bien trouver 30. En pratique, il faut donc trouver combien de fois on peut retirer deux zéros pour arriver à un nombre entre 1 et 100 pour choisir la position sur l'échelle.

On procède exactement pareil pour les cubes et racines cubiques, simplement en utilisant l'échelle des cubes au lieu de l'échelle des carrés.

Inverses

L'échelle CI donne les inverses de l'échelle C (ou D). Il est facile de constater, en déplaçant le curseur que 5 est en face de 2 (1/2 = 0,5) et inversement.

Cette échelle semble faire double emploi au premier abord avec les échelles C et D. En effet, pour trouver l'inverse de 5, il suffit de diviser 10 par 5 pour trouver 2.

En fait, cette échelle permet un gain de temps notable pour les calculs à la chaîne. En effet, nous avons vu qu'il est très rapide d'alterner des multiplications et divisions avec un minimum de déplacements. Dans le cas où l'on aurait plusieurs multiplications à enchaîner, il suffit de considérer une multiplication sur deux comme une division par l'inverse.

Trigonométrie

Règle avec échelles S, ST, T1 et T2 sur la face principale

Les sinus sont de lecture simple : après repérage de l'échelle des sinus (souvent au dos de la règle mobile), on place le curseur sur l'angle désiré, et on trouve le sinus sur l'échelle D (penser à placer la virgule, en pensant qu'il s'agit d'un nombre entre 0 et 1, ce qui pose d'ailleurs un problème, puisque la règle donne des résultats de 0,1 à 1). Par exemple, le sinus de 45 devrait se trouver proche du chiffre 7.

Les sinus des petits angles (<6°, soit un sinus < 0,1, représentant le début de l'échelle D) nécessitent une échelle supplémentaire ST.

Les cosinus sont les sinus des angles complémentaires. Par exemple, le cosinus de 60° est le sinus de 30°. On se passe donc d'échelle des cosinus moyennant un calcul simple.

Les tangentes s'utilisent comme les sinus, à ceci près que l'échelle des tangentes s'arrête à 45° (la tangente de 45° est 1, ce qui est la limite de l'échelle D). N'oublions pas que les tangentes tendent vers l'infini lorsque les angles approchent de 90°. Certaines règles proposent une échelle T2 pour les grands angles

Enfin, les cotangentes sont de même valeur que les tangentes des angles complémentaires à 90°.

Logarithmes

Les règles à calcul comportent le plus souvent une échelle de logarithmes en base 10, sur la face avant ou arrière de la règle selon les cas.

Après identification de l'échelle (une échelle de 0 à 1 sur laquelle les chiffres sont régulièrement espacés et étiquetée L), on repère la correspondance entre l'échelle de base (notée D en général) avec l'échelle des logs.

Pour mémoire, le log est la partie décimale du nombre qu'il faut mettre en exposant à 10 pour obtenir une certaine valeur.

Par exemple, 100,3 vaut environ 2. Le 2 de l'échelle D doit donc correspondre au 3 de l'échelle des logs.

Lecture

La lecture des échelles est un peu déroutante pour les débutants.

En effet, le nombre de graduations entre les chiffres n'est généralement pas constant d'un bout à l'autre de l'échelle, car les espaces changent, et on ne peut tasser indéfiniment les graduations au fur et à mesure que les chiffres se resserrent.

De plus, certaines échelles se lisent de gauche à droite, tandis que les autres se lisent de droite à gauche.

Comme pour compliquer tout cela, les zéros sont souvent sous-entendus, ce qui fait que, par exemple, sur l'échelle des cubes, parfois les puissances de 10 ne sont pas notées 10-100-1000, mais 1-1-1.

Enfin, il y a peu d'indications sur l'usage des échelles.

L'utilisateur doit donc utiliser son bon sens pour

  • déterminer le sens de lecture (les inverses se lisent de droite à gauche)
  • compter les graduations pour savoir si un trait vaut 0,1 (9 graduations entre deux chiffres), 0,2 (4 graduations) ou 0,5 (1 graduation)
  • déterminer l'amplitude de l'échelle (unités de 1 à 10, carrés de 1 à 100, cubes de 1 à 1 000, par exemple), afin de ne pas confondre 2 et 20, par exemple
  • déterminer l'usage de chaque échelle (en s'aidant de l'aspect de l'échelle et des inscriptions souvent situées aux extrémités)

Précision et exactitude

La précision d’une règle dépend de sa longueur mais aussi de la qualité de la gravure.

Les règles de 30 cm donnent une précision de l’ordre de 1/200e, ce qui se traduit par deux décimales au voisinage de la valeur 2. La différence du nombre de décimales visibles en fonction de la valeur n’est qu’un simple effet d’échelle.

La qualité de gravure est primordiale pour la précision : les traits doivent être d'épaisseur identique sur toute la longueur de l'échelle, les plus fins possibles.

Certaines règles sont fausses, ce qui peut être facile à démontrer, comme dans le cas où les échelles C et D ne sont pas strictement superposables.

Avant d'utiliser une règle inconnue pour des calculs importants, il peut être utile de la tester sur quelques calculs dont les résultats sont connus et tombent juste de préférence.

Fabrication

Anciennement, les règles à calcul sont fabriquées en bois d’ébénisterie : buis, poirier, acajou ou ébène afin d'assurer la régularité du glissement, la stabilité de la forme et la longévité nécessaires à une utilisation répétée. L' os et l’ ivoire sont réservés aux versions luxueuses. Au XIX e siècle, le buis recouvert de celluloïd s'impose et le métal apparait quelquefois [ 3 ] . L’époque moderne utilise principalement des matériaux plastiques, ainsi les réglettes sont en acryliques ou en polycarbonate glissant sur des paliers en téflon. Le bambou, pour ses propriétés de stabilité dimensionnelle et de bon glissement est utilisé en Orient. Le marquage est peint, ou mieux gravé, ce qui offre une solution à la fois précise et durable mais plus onéreuse.

Histoire

Article connexe : Histoire des logarithmes et des exponentielles.
Cercle à calcul pour calcul de temps de pose pour tirage photo
Cercle à calcul sur une montre Breitling Navitimer
Cercle à calcul utilisé par les ingénieurs allemands ( musée de White Sands).

John Neper invente en 1614 les logarithmes, bases mathématiques de certaines fonctions des règles à calcul.

Edmund Gunter ( 1581- 1626) enseignait alors l’astronomie au collège de Gresham. On lui doit l’invention de plusieurs instruments géométriques, tels que le secteur à l’aide duquel on trace les lignes parfaites des cadrans solaires. Il invente l’échelle dite « de Gunter » ou règle logarithmique en 1620, qui simplifie les opérations de calcul : sur cette règle, il suffisait d'ajouter ou retirer un écart à l'aide d'un compas pour multiplier ou diviser un nombre par un facteur.

Pour simplifier cette opération, Edmond Wingate, en 1627, a l'idée de faire coulisser deux échelles séparées [ réf. souhaitée], l'une contre l'autre, donnant naissance au concept de la règle à calcul.

L’anglais William Oughtred invente en 1630 une règle à calcul circulaire, en transposant l'idée sous la forme de deux échelles logarithmiques dessinées sur deux cercles concentriques.

M. Milburne, vers 1670, trace les premières spirales logarithmiques. Une version moderne et aboutie est réalisée et commercialisée en France par Léon Appoullot vers 1930.

En 1654, Robert Bissaker fait prendre à l’instrument sa forme classique (baguette coulissante dans une forme fixe).

Certains attribuent le montage des deux règles à Seth Partridge. Une description de la version Partridge est donnée dans The description and use of an instrument called the double scale of proportion, ouvrage de Partridge, Londres, 1671, existant à la Bibliothèque Nationale.

Amédée Mannheim, officier puis professeur à l' École polytechnique lui adjoint (1850) un pointeur mobile (curseur) permettant une lecture plus aisée et de « stocker » un résultat intermédiaire. La règle de type Mannheim est la première règle moderne.

L’enroulement de deux longues échelles logarithmiques sur un cylindre permit d’obtenir une précision de calcul théoriquement supérieure - Otis King en Angleterre, A. Lafay en France, tous deux vers 1921, puis Fuller. L'aspect confus et peu lisible de ces hélices logarithmiques a été cause de leur insuccès.

Vers 1950, André Séjourné, professeur en classe préparatoire aux Arts et Métiers au lycée Voltaire à Paris, perfectionne la règle à calcul normale en lui adjoignant les échelles LL1, LL2, LL3. C'est la règle à calcul Log-Log. Il est conseil auprès de la société Graphoplex pour la création de ses premières règles.

Les échelles Log-Log étaient déjà connues dans l' entre-deux-guerres, règle « Electro » avec LL2 et LL3 dès les années 1920, règle « Darmstadt » avec LL1, LL2 et LL3 en 1935. André Séjourné diffusa l'« Electro Log Log » (Graphoplex 640), qui ne fut utilisée pratiquement qu'en France.

L'usage de la règle à calcul se généralisa en France à partir de la fin de la Seconde Guerre mondiale, les marques françaises les plus répandues étaient Tavernier-Gravet, Graphoplex et parmi les règles importées, les Nestler, Aristo et Faber-Castell allemandes, les Sun Hemmi japonaises en bambou et les Pickett américaines en aluminium. Son règne se poursuivit jusqu’au milieu des années 1980 malgré l’apparition des premières calculatrices, la règle étant le seul instrument autorisé lors des examens et concours (apparition des calculatrices à mémoire [ 4 ] ). La circulaire n°86-228 du 28 juillet 1986 , autorisant et recommandant l’emploi des calculettes pendant les épreuves des examens, la relégua finalement au fond des tiroirs. Elle est cependant toujours autorisée en 2016 au Concours commun Mines-Ponts [ 5 ] et au concours de l' École polytechnique [ 6 ] .

Les règles à calcul subsistent encore dans certains métiers, comme la navigation aérienne. Certains appareils de mesures analogiques spécialisés (par exemple les posemètres) sont également équipés d’un cercle à calcul intégré pour faciliter l’utilisation des mesures.


publicités, catalogue Tavernier Gravet

Vu dans ... https://photocalcul.com/Calcul/Regles/Collection_Etienne_Sigismond/publicite_TG/pubTavernier.html

RÉCLAMES et AUTRES DOCUMENTS

TAVERNIER-GRAVET

1851

détail de la notice ' Règle à calculs par Mannheim' (remerciements à S.Kmiecik)

1865

'La Règle à Calcul' par un Profeseur de Mathématiques

1876

'Instructions sur la Règle à Calcul' par GUY 8e édition (remerciements à Marc Thomas)

1890

1893

1895

1899

1900

1911

1911 (voir catalogue complet)

1908 1931

tampon c.1931

1908 , du livre The Slide Rule par PICWORTH (London)

1943

1952

affiche de Foré ( 1953 )

CATALOGUE MAISON L. CHARLES 1860

CATALOGUE TAVERNIER-GRAVET Mars 1906

remerciements à Etienne Pommel

CATALOGUE TAVERNIER-GRAVET JUILLET 1919

AUTRES INSTRUMENTS TAVERNIER-GRAVET

COMPAS DE PROPORTION signé Lenoir c.1800

collection E.POMMEL

COMPAS DE PROPORTION signé Tavernier-Gravet c.1900

collection John Vosserpoel

dimensions : 412 x 58 x 5 mm

GABARIT FILET DE PECHE (longueur 14 cm)

Image MISSING d'origine

Des courriers aux clients...

1904

1920

avec l'aimable permission de Otto Van Poelje

1950

1950


Vu dans ... https://www.methodemaths.fr/regle_a_calcul/#echellelog

La règle à calcul

Introduction

Si ça se trouve tu ne sais même pas ce qu’est une règle à calcul, tu n’en a peut-être jamais vu…
La règle à calcul est l’ancêtre de la calculatrice, elle a été utilisée jusqu’en dans les années 60 environs, avant que la calculette électronique ne vienne la remplacer.
Elles ne sont bien sûr plus utilisées de nos jours, et ce chapitre est donc plus pour ta culture, ça ne te servira pas à grand chose pour tes études^^
Mais au moins tu verras comment on faisait auparavant sans calculatrice

Des objets précieux
Les règles à calcul étaient en général vendues dans de beaux boîtiers, on pourait presque croire que ce sont des objets de collection !

Certaines règles étaient très détaillées, comme celle du bas sur l’image ci-dessous, tandis que d’autres indiquaient le stric minimum. Il fallait alors connaître un peu le fonctionnement pour pouvoir l’utiliser.

Echelle logarithmique
Nous parlerons souvent d’échelle logarithme et de logarithme, il est donc important de faire une petite parenthèse la-dessus.
C’est simplement un système qui permet de graduer une droite d’une certaine manière.
D’habitude on gradue tous les cm, les mm, etc…

Là ce n’est pas pareil : on va utiliser la fonction log (qui est marquée « log » sur ta calculatrice).

Le principe est le suivant : la distance séparant deux nombres a et b est log(b) – log(a).
La distance séparant 1 et 2 est donc log(2) – log(1).
La distance séparant 1 et 10 est donc log(10) – log(1).
La distance séparant 10 et 100 est donc log(100) – log(10).

Les fonctions log et ln (voir le cours sur la fonction ln) ont les mêmes propriétés, notamment :

Or 10/1 = 100/10 !!! La distance entre 1 et 10 est la même qu’entre 10 et 100 !
Au final ça donne quelque chose de ce style là :

Attention !! Après 10 ce n’est pas 11 mais 20… de la même manière qu’après 100 ce n’est pas 101 ou 110 mais 200…

Passons maintenant aux choses sérieuses 😀

Composition

Une règle à calcul est composée de deux règles, au milieu de laquelle coulisse une troisième règle :

Il y a également un curseur mobile transparent qui coulisse le long de la règle, indiqué sur la photo.

Certaines règles « de luxe » sont imprimées recto-verso, celle-ci non, mais possède une règle graduée classique sur le dessus, qui n’est pas du tout obligatoire pour une règle à calcul.

Les différentes échelles

Il y a plusieurs échelles, chacune repérée par une lettre.
A et B sont des échelles logarithmiques graduées de 1 à 100 : ce sont les carrés.
C et D sont des échelles logarithmiques graduées de 1 à 10 : ce sont les unités.
K est une échelle logarithmique graduées de 1 à 1000 : ce sont les cubes.
L est une échelle graduée « normalement », mais ce sont les logs.
Cl est la même que C et D mais de droite à gauche : c’est l’échelle des inverses. Elle est souvent rouge comme ici.
S est l’échelle des sinus, ST et T celle des tangentes.
LL2 et LL3 sont des échelles log-log, on ne les trouve pas sur chaque règle.

Bon maintenant que l’on a vu toutes ces échelles, il faut voir comment les utiliser !

Utilisation

Nous verrons les utilisations de base et ne rentrerons pas troop dans les détails.

Calcul de carrés, cubes, et racines

L’utilisation la plus simple est sûrement le calcul de carrés et de cubes !
Pour ce faire rien de plus simple : imaginons que l’on veuille calculer 42 et 43.
Et bien on place le curseurs sur 4 sur l’échelle des unités (C ou D), et on lit le carré sur… l’échelle des carrés (A ou B) et le cube sur l’échelle… des cubes (K) !!

Et pour les racines carrées et les racines cubiques, c’est l’inverse !
Pour calculer la racine carrée de 25, on place le curseur sur 25 sur l’échelle des carrés (A ou B), et on regarde le résultat sur l’échelle des unités (C ou D).

Pour calculer la racine cubique de 27, on place le curseur sur 27 sur l’échelle des cubes (K), et on regarde le résultat sur l’échelle des unités (C ou D).

Calcul d’inverses

Pour calculer les inverses, on va bien sûr utiliser… l’échelle des inverses :p
Le principe est le même, si on veut calculer l’inverse de 2, on place le curseur sur 2 sur l’échelle des unités et on regarde le résultat sur l’échelle des inverse (Cl).

Attention cependant !! Le résultat est 0.5, mais la règle indique 5 !!
En fait c’est un des problèmes de la règle à calcul, elle donne parfois les résulats à la virgule près, c’est donc à l’utilisateur de mettre la virgule là où il faut.
A ce moment-là c’est le bon sens, l’intuition ou un calcul mental rapide qui permet de déterminer l’emplacement de la virgule.
Ici ce n’est pas trop compliqué de voir que l’inverse de 2 n’est pas 5, 50, 500 ou 0.05, mais 0.5. Mais parfois c’est plus compliqué^^

Multiplication

Une fois de plus le principe est très simple : on utilise les échelles A et B.
Avec un exemple c’est toujours plus simple : supposons que l’on veuille calculer 6 x 7.
On décale le 1 de la règle centrale jusqu’au 6 de l’échelle A au-dessus, et on lit le résultat au dessus du 7 de la règle centrale : 42 !!!

Un autre exemple : 3 x 7,5. On met le 1 de la règle centrale sous le 3, et on lit le résultat au-dessus du 7,5 : 22,5.

Cela vient du fait que log(a) + log(b) = log(a x b).
L’intérêt de la fonction log est de transformer une somme en produit (ou un produit en somme), ce qui est le principe ici.
En effet, on met les chiffres que l’on veut multiplier bout à bout (ce qui revient à les additionner si c’était une échelle normale), mais le résultat est un produit : la somme s’est donc transformée en produit

Division

Le principe est quasiment le même mais dans l’autre sens.
Si on veut faire 30/4, on fait glisser le 4 de la règle centrale sous le 30, et on lit le résultat au-dessus du 1 de l’échelle centrale (7,5) :

De même pour 20/8, on place le 8 sous le 20, et on regarde le résultat au-dessus du 1 de l’échelle centrale(ici 2,5) :

Cela vient du fait que log(a) – log(b) = log(a/b).
Comme pour la multiplication, l’intérêt de la fonction log est de transformer une différence en quotient.

Calculs trigonométriques

On a vu qu’il y avait une échelle de sinus et de tangentes. C’est bien sur pour calculer… les sinus et les tangentes !
Là encore c’est très simple, on place le curseur sur l’angle que l’on souhaite sur l’échelle des sinus (pour calculer le sinus), et on lit le résultat sur l’échelle des unités !
Là aussi attention, il faut bien mettre la virgule ! Mais ici c’est beaucoup plus simple car on sait que le sinus est compris entre 0 et 1…
En plus, sur cette règle, il y a marqué « 0,1 x » qui indique qu’il faut multiplier le résultat par 0,1 pour avoir ce que l’on veut.

Et pour calculer le cosinus ?
On voit qu’il y a écrit « cos » en rouge, avec les angles en rouge également.
C’est très simple : le cosinus d’un angle est égal au sinus de son complémentaire, c’est-à-dire celui qui donne 90 si on les additionne.
Ainsi cos(20) = sin(70) car 20 + 70 = 90
Ainsi cos(35) = sin(55) car 35 + 55 = 90

Cela vient du fait que cos(x) = sin(π/2 – x) (voir le chapitre sur la trigonométrie).

Un petit exemple ne fera pas de mal : pour calculer le sinus de 40° (ou le cosinus de 50°, on a vu que c’est pareil), on place le curseur sur 40 en noir (puisque le sinus est en noir), et on lit le résultat.
Bien sûr il faut le multiplier par 0,1 comme mentionné ci-dessus :

Historique et anecdote

Les règles à calcul dateraient de l’Antiquité. Il est possible qu’ils soient d’abord apparus en forme de cercle, autrement dit des cercles à calcul.
Mais ce n’est qu’au XVIIème siècle que la règle à calcul telle que présentée ici apparaît, avec une règle coulissant entre 2 autres.
C’est également au XVIIème siècle que John Néper invente les logarithmes, qui sont un des éléments fondamentaux de la règle à calcul. Il a évidemment inventé le logarithme népérien, aussi appelé fonction ln (voir le cours correspondant), le nom de cette fonction venant du nom de ce mathématicien.

Il faut attendre la XIXème siècle pour voir apparaître le curseur mobile sur la règle, facilitant les calculs et permettant de stocker un résultat intermédiaire pour enchaîner plus facilement les calculs les uns à la suite des autres.

En France, la règle à calcul se diffuse de manière importante à la fin de Seconde Guerre mondiale. Elles étaient principalement en plastique, tandis qu’elles étaient surtout faites en bambou au Japon, et en aluminium aux Etats-Unis.

En 1986, l’usage des calculatrices électroniques est enfin autorisé, malgré leur apparition plusieurs années auparavant.
La règle à calcul fut donc définitivement abandonnée. Elle avait déjà connue une chute de popularité importante avec l’apparition des calculatrices.

La règle à calcul est cependant encore utilisée dans certains domaines spécifiques, notamment la navigation aérienne.

Anecdote amusante : les règles à calcul sont toujours autorisées dans les concours d’entrée aux Grandes écoles Mines-Ponts ainsi qu’à l’école Polytechnique (voir la notice du concours (lien à gauche) page 26


Le décibel, notions de base

Vu dans ... http://f5zv.pagesperso-orange.fr/RADIO/RM/RM23/RM23m/RM23m02.html

Le décibel

L'oreille humaine permet d'écouter des sons extrêmement faible comme le bruit d'une goutte d'eau s'écrasant sur le sol d'une grotte silencieuse aussi facilement que le vacarme épouvantable des chutes du Niagara. L'étendue des puissances de sons audibles est gigantesque : combien de gouttes d'eau s'écrasent à chaque instant dans une cataracte ? Des milliards ? Des milliards de milliards ? Inutile de faire le calcul. Pourtant on ne peut pas dire que le son d'une cataracte soit des milliards de milliards plus fort que celui de la simple goutte : c'est que l'impression de puissance d'un son n'est pas directement proportionnel à la puissance. Prenons un exemple.
Si l'on admet qu'un duo de 2 violons produit un bruit de "force" 1, il faudra un orchestre de 4 violons pour que l'oreille perçoive un bruit deux fois plus grand, que nous noterons de force 2. Avec 8 violons l'effet produit sera de force 3 et avec 16 il sera de 4, et ainsi de suite...

Dans un récepteur

Sur la bande 2m, un signal reçu S9 (un niveau considéré comme déjà très fort) représente une puissance d'environ 1pW (1 picowatt=0,000000000001W) à l'entrée du récepteur. Pour être audible confortablement, il faudra qu'il soit amplifié par le récepteur de façon à représenter une puissance de 1W dans le haut-parleur (mettons que l'OM soit un peu dur d'oreille, cela simplifie les calculs...). La puissance du signal a été amplifiée 1000000000000 de fois. Ce nombre astronomique n'a rien d'extraordinaire pour un récepteur VHF qui devra rendre audible des signaux 100000 fois plus faibles encore.
La manipulation de tous ces zéros donne le vertige et peut être la source d'erreurs dans les calculs. Heureusement que les logarithmes ont permis la naissance d'une unité de gain et d'affaiblissement plus pratique à utiliser : le décibel.

Gain en décibel d'un amplificateur

Soit un amplificateur de gain A = Ps/Pe où Ps est la puissance de sortie et Pe est la puissance d'entrée de l'amplificateur. Ces deux puissances doivent être exprimées dans la même unité.
Le gain en décibel d'un amplificateur est donné par la formule :

A étant un nombre sans unité exprimant le rapport de puissances Ps/Pe
Le décibel est le dixième du bel, ainsi nommé en l'honneur de Graham Bell, inventeur du téléphone. Le bel étant une unité beaucoup trop grande pour exprimer les niveaux et gains rencontrés usuellement, on lui préfère son sou-multiple.
Exemple :
Le récepteur évoqué ci-dessus a un gain en puissance de 1000000000000 ou 10 puissance 12 (1012), sachant que log(1012)=12 on peut calculer le gain en décibel :
G= 10 x12 = 120 dB

Gain en puissance exprimé en décibels

La formule générale est :

Le tableau ci-dessous donne quelques gains en dB pour différents rapport A=Ps/Pe.
A | G(dB) | A | G(dB)
0,10 | -10 | 10,00 | 10
1,26 | 1 | 15,85 | 12
1,58 | 2 | 19,95 | 13
2,00 | 3 | 31,62 | 15
2,51 | 4 | 39,81 | 16
3,16 | 5 | 63,10 | 18
3,98 | 6 | 100 | 20
5,01 | 7 | 158 | 22
6,31 | 8 | 251 | 24
7,94 | 9 | 1000 | 30

On voit que :
- Doubler la puissance correspond à un gain de 3 dB
- Quadrupler la puissance correspond à un gain de 6 dB
- Multiplier la puissance par 10 correspond à un gain de 10 dB
- Multiplier la puissance par 100 correspond à un gain de 20 dB
- Un gain de 10dB (A=10) est la somme de 7dB (A=5,01) + 3dB (A=2) et correspond au produit 5,01x2
Voir le tableau plus complet ci-dessous.

Gain en tension

La mesure d'une tension à l'entrée ou à la sortie d'un ampli ou d'un atténuateur est beaucoup plus facile que celle d'une puissance. C'est pourquoi on essaie toujours de caluler les gains à partir du rapport de tension A=Us/Ue. Cette méthode est valable à condition que l'entrée et la sortie aient la même impédance, par exemple 50 ohms.
La formule qui permet le calcul de G en dB est :

Comme pour le rapport de puissance, un gain en dB négatif est un affaiblissement.
Exemple :
L'amplitude d'un signal à l'entrée d'un câble coaxial est de 10 V et de 2V à la sortie, ce qui fait un rapport de 0,2.
G = 20 x log(0,2) = 20 x -0,7
G = -14 dB

Calcul de A en fonction de G en dB

Pour retrouver le rapport de puissances A en fonction du gain en dB on utilise la formule (1) et pour retrouver un rapport de tensions c'est la formule (2) qui sera employée.

Correspondance entre rapports et dB

Ce tableau permet de déterminer rapidement un gain en connaissant le rapport de puissance ou de tension ou encore de trouver le rapport correspondant à un gain en dB.
Exemple 1 :
Un amplificateur fournit 10 W quand on applique 2 W à son entrée. Le rapport Ps/Pe est égal à 5 donc le gain de l'ampli est de 7dB
Exemple 2 :
On mesure une tension maximum de 4 volts, à quelle tension correspond le niveau -3dB ?
+3 dB correspond à un rapport Us/Ue de 1,41 donc -3dB est équivalent à un rapport Ue/Us de 1/1,41 soit 0,70
la tension correspondante est 4 x 0,70 = 2,8 volts.

dB | Us/Ue | Ps/Pe | dB | Us/Ue | Ps/Pe | dB | Us/Ue | Ps/Pe
1 | 1,12 | 1,26 | 21 | 11,2 | 125,9 | 41 | 112 | 12589
2 | 1,26 | 1,58 | 22 | 12,6 | 158,5 | 42 | 126 | 15849
3 | 1,41 | 2,00 | 23 | 14,1 | 199,5 | 43 | 141 | 19953
4 | 1,58 | 2,51 | 24 | 15,8 | 251,2 | 44 | 158 | 25119
5 | 1,78 | 3,16 | 25 | 17,8 | 316,2 | 45 | 178 | 31623
6 | 2,00 | 3,98 | 26 | 20,0 | 398,1 | 46 | 200 | 39811
7 | 2,24 | 5,01 | 27 | 22,4 | 501,2 | 47 | 224 | 50119
8 | 2,51 | 6,31 | 28 | 25,1 | 631,0 | 48 | 251 | 63096
9 | 2,82 | 7,94 | 29 | 28,2 | 794,3 | 49 | 282 | 79433
10 | 3,16 | 10,00 | 30 | 31,6 | 1000,0 | 50 | 316 | 100000
11 | 3,55 | 12,59 | 31 | 35,5 | 1258,9 | 51 | 355 | 125893
12 | 3,98 | 15,85 | 32 | 39,8 | 1584,9 | 52 | 398 | 158489
13 | 4,47 | 19,95 | 33 | 44,7 | 1995,3 | 53 | 447 | 199526
14 | 5,01 | 25,12 | 34 | 50,1 | 2511,9 | 54 | 501 | 251189
15 | 5,62 | 31,62 | 35 | 56,2 | 3162,3 | 55 | 562 | 316228
16 | 6,31 | 39,81 | 36 | 63,1 | 3981,1 | 56 | 631 | 398107
17 | 7,08 | 50,12 | 37 | 70,8 | 5011,9 | 57 | 708 | 501187
18 | 7,94 | 63,10 | 38 | 79,4 | 6309,6 | 58 | 794 | 630957
19 | 8,91 | 79,43 | 39 | 89,1 | 7943,3 | 59 | 891 | 794328
20 | 10,00 | 100,00 | 40 | 100,0 | 10000,0 | 60 | 1000 | 1000000

En basse fréquence

Certains contrôleurs universels à aiguille possèdent une échelle en dB. Cette dernière permet la mesure de niveaux de signal en BF sur une charge de 600 ohms. Le niveau de référence 0dB correspond à une puissance de 1 mW, ce qui correspond à une tension de 0,775V sur une impédance de 600 ohms.
Exemple :
Un amplificateur sort 1 W sur 600 ohms, le niveau de sortie sera de +30dB. L'amplitude du signal sera alors de 24,5 volts.
Si à l'entrée de cet ampli l'amplitude du signal mesurée sur 600 ohms est de 0,5 volts, la puissance correspondante est de 0,42mW et le niveau de -3,7dB.

Utilisation du tableur

Il est facile d'utiliser un tableur pour réaliser des petits outils de calcul de gain, amplification et atténuation.


Electronic Warfare and Radar Systems Engineering Handbook - Decibel (dB) - RF Cafe

Vu dans ... http://www.rfcafe.com/references/electrical/ew-radar-handbook/decibel.htm

DECIBEL (dB)

The Decibel is a subunit of a larger unit called the bel. As originally used, the bel represented the power ratio of 10 to 1 between the strength or intensity i.e., power, of two sounds, and was named after Alexander Graham Bell. Thus a power ratio of 10:1 = 1 bel, 100:1 = 2 bels, and 1000:1 = 3 bels. It is readily seen that the concept of bels represents alogarithmic relationship since the logarithm of 100 to the base 10 is 2 (corresponding to 2 bels), the logarithm of 1000 to the base 10 is 3 (corresponding to 3 bels), etc. The exact relationship is given by the formula

[1] Bels = log(P2/P1)

where P2/P1 represents the power ratio.

Since the bel is a rather large unit, its use may prove inconvenient. Usually a smaller unit, the Decibel or dB, is used. 10 decibels make one be. A 10:1 power ratio, 1 bel, is 10 dB; a 100:1 ratio, 2 bels, is 20 dB. Thus the formula becomes

[2] Decibels (dB) = 10 log(P2/P1)

The power ratio need not be greater than unity as shown in the previous examples. In equations [1] and [2], P1 is usually the reference power. If P2 is less than P1, the ratio is less then 1.0 and the resultant bels or decibels are negative. For example, if P2 is one-tenth P1, we have

bels = log(0.1/1) = -1.0 bels

and dB = 10 log(0.1/1) = -10 dB.

It should be clearly understood that the term decibel does not in itself indicate power, but rather is a ratio or comparison between two power values. It is often desirable to express power levels in decibels by using a fixed power as a reference. The most common references in the world of electronics are the milliwatt (mW) and the watt. The abbreviation dBm indicates dB referenced to 1.0 milliwatt. One milliwatt is then zero dBm. Thus P1 in equations [1] or [2] becomes 1.0 mW. Similarly, The abbreviation dBW indicates dB referenced to 1.0 watt, with P2 being 1.0 watt, thus one watt in dBW is zero dBW or 30 dBm or 60 dBuW. For antenna gain, the reference is the linearly polarized isotropic radiator, dBLI. Usually the 'L' and/or 'I' is understood and left out.

dBc is the power of one signal referenced to a carrier signal, i.e. if a second harmonic signal at 10 GHz is 3 dB lower than a fundamental signal at 5 GHz, then the signal at 10 GHz is -3 dBc.

THE DECIBEL, ITS USE IN ELECTRONICS

The logarithmic characteristic of the dB makes it very convenient for expressing electrical power and power ratios. Consider an amplifier with an output of 100 watts when the input is 0.1 watts (100 milliwatts); it has an amplification factor of

P2/P1 = 100/0.1 = 1000 or a gain of:

10 log(P2/P1) = 10 log(100/0.1) = 30 dB.

(notice the 3 in 30 dB corresponds to the number of zeros in the power ratio)

The ability of an antenna to intercept or transmit a signal is expressed in dB referenced to an isotropic antenna rather than as a ratio. Instead of saying an antenna has an effective gain ratio of 7.5, it has a gain of 8.8 dB (10 log 7.5).

A ratio of less than 1.0 is a loss, a negative gain, or attenuation. For instance, if 10 watts of power is fed into a cable but only 8.5 watts are measured at the output, the signal has been decreased by a factor of

8.5/10 = 0.85

or

10 log(0.85) = -0.7 dB.

This piece of cable at the frequency of the measurement has a gain of -0.7 dB. This is generally referred to as a loss or attenuation of 0.7 dB, where the terms "loss" and "attenuation" imply the negative sign. An attenuator which reduces its input power by factor of 0.001 has an attenuation of 30 dB. The utility of the dB is very evident when speaking of signal loss due to radiation through the atmosphere. It is much easier to work with a loss of 137 dB rather than the equivalent factor of 2 x 10-14.

Instead of multiplying gain or loss factors as ratios we can add them as positive or negative dB. Suppose we have a microwave system with a10 watt transmitter, and a cable with 0.7 dB loss connected to a 13 dB gain transmit antenna. The signal loss through the atmosphere is 137 dB to a receive antenna with a 11 dB gain connected by a cable with 1.4 dB loss to a receiver. How much power is at the receiver? First, we must convert the 10 watts to milliwatts and then to dBm:

10 watts = 10,000 milliwatts and

10 log (10,000/1) = 40 dBm

Then

40 dBm - 0.7 dB + 13 dB - 137 dB + 11 dB - 1.4 dB = -75.1 dBm.

dBm may be converted back to milliwatts by solving the formula: mW = 10(dBm/10)

giving 10(-75.1/10)= 0.00000003 mW

Voltage and current ratios can also be expressed in terms of decibels, provided the resistance remains constant. First we substitute for P in terms of either voltage, V, or current, I. Since P=VI and V=IR we have:

P = I2R = V2/R

Thus for a voltage ratio we have

dB = 10 log[(V22/R)/(V12/R)] = 10 log(V22/V12) = 10 log(V2/V1)2 = 20 log(V2/V1)

Like power, voltage can be expressed relative to fixed units, so one volt is equal to 0 dBV or 120 dBuV. Similarly for current ratio dB = 20 log(I2/I1)

Like power, amperage can be expressed relative to fixed units, so one amp is equal to 0 dBA or 120 dBA.

Decibel Formulas (where Z is the general form of R, including inductance and capacitance)

When impedances are equal: Decibel Formulas - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe

When impedances are unequal: Decibel Formulas - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe

SOLUTIONS WITHOUT A CALCULATOR

Solution of radar and EW problems requires the determination of logarithms (base 10) to calculate some of the formulae. Common "four function" calculators don't usually have a log capability (or exponential or fourth root functions either). Without a scientific calculator (or math tables or a Log-Log slide rule) it is difficult to calculate any of the radar equations, simplified or "textbook". The following gives some tips to calculate a close approximation without a calculator.

DECIBEL TABLE

DECIBEL VALUES - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe
DECIBEL VALUES - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe

For dB numbers which are a multiple of 10

An easy way to remember how to convert dB values that are a multiple of 10 to the absolute magnitude of the power ratio is to place a number of zeros equal to that multiple value to the right of the value 1.

i.e. 40 dB = 10,000 : 1 (for Power)

Minus dB moves the decimal point that many places to the left of 1. i.e. -40 dB = 0.0001 : 1 (for Power)

For voltage or current ratios, if the multiple of 10 is even, then divide the multiple by 2, and apply the above rules. i.e. 40 dB = 100 : 1 (for Voltage)

-40 dB = 0.01 : 1

If the power in question is not a multiple of ten, then some estimation is required. The following tabulation lists some approximations, some of which would be useful to memorize.

dB RULES OF THUMB - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe
dB RULES OF THUMB - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe

You can see that the list has a repeating pattern, so by remembering just three basic values such as one, three, and 10 dB, the others can easily be obtained without a calculator by addition and subtraction of dB values and multiplication of corresponding ratios.

Example 1:

A 7 dB increase in power (3+3+1) dB is an increase of (2 x 2 x 1.26) = 5 times whereas

A 7 dB decrease in power (-3-3-1) dB is a decrease of (0.5 x 0.5 x 0.8) = 0.2.

Example 2: Assume you know that the ratio for 10 dB is 10, and that the ratio for 20 dB is 100 (doubling the dB increases the power ratio by a factor of ten), and that we want to find some intermediate value.

dB Conversions- Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe

We can get more intermediate dB values by adding or subtracting one to the above, for example, to find the ratio at 12 dB we can:

work up from the bottom; 12 = 1+11 so we have 1.26 (from table) x 12.5 = 15.75 alternately, working down the top 12 = 13-1 so we have 20 x 0.8(from table) = 16.

The resultant numbers are not an exact match (as they should be) because the numbers in the table are rounded off. We can use the same practice to find any ratio at any other given value of dB (or the reverse).

dB AS ABSOLUTE UNITS

Power in absolute units can be expressed by using 1 Watt (or1 milliwatt)as the reference power in the denominator of the equation for dB. We then call it dBW or dBm. We can then build a table such as the adjoining one.

dB AS ABSOLUTE UNITS - Electronic Warfare and Radar Systems Engineering Handbook - RF Cafe

From the above, any intermediate value can be found using the same dB rules and memorizing several dB values i.e. for determining the absolute power, given 48 dBm power output, we determine that 48 dBm = 50 dBm - 2 dB so we take the value at 50 dB which is 100W and divide by the value 1.58 (ratio of 2 dB) to get: 100 watts/1.58 = 63 W or 63,291 mW.

Because dBW is referenced to one watt, the Log of the power in watts times 10 is dBW. The Logarithm of 10 raised by any exponent is simply that exponent. That is: Log(10)4 = 4. Therefore, a power that can be expressed as any exponent of 10 can also be expressed in dBW as that exponent times 10. For example, 100 kW can be written 100,000 watts or 105 watts. 100 kW is then +50 dBW. Another way to remember this conversion is that dBW is the number of zeros in the power written in watts times 10. If the transmitter power in question is conveniently a multiple of ten (it often is) the conversion to dBW is easy and accurate.


voir

Vu dans ... http://villemin.gerard.free.fr/aScience/Physique/Decibel.htm

Décibels

Le décibel n'est pas une unité comme le mètre, mais la valeur (logarithmique) d'un rapport.

Que représentent les décibels et surtout comment les additionner. Les décibels utilisent une échelle logarithmique. Pourquoi? Parce que très souvent, une sensation ressentie par l'homme, comme le niveau sonore, varie comme le logarithme de l’excitation (loi de Weber-Fechner).

Deux sources sonores identiques ne provoquent pas une sensation double, mais la seconde ajoute un peu de bruit à la première. En décibels: 50 dB + 50 dB ne valent pas 100 dB, mais 53 dB. Cette page vous montre trois méthodes pour effectuer ce calcul: graphique, tableau ou formule.

L'oreille est capable d'entendre sur une dynamique de 130 à 140 décibels.

Décibel (dB)

Général

* Le décibel vaut 1/10 de bel (B)

Graham Bell (1847-1922), physicien américain, inventeur du téléphone (1876) mais aussi de l’audiomètre.

* Unité de mesure destinée à évaluer principalement l'intensité sonore. Elle est utilisée aussi en physique ou en électronique.

* Le décibel est une valeur logarithmique qui exprime le rapport d'une grandeur (puissance) par rapport à une grandeur de référence.

* C'est donc une unité de mesure relative. Elle n'a pas de dimension. C'est une échelle de mesure.

* L’écart, mesuré en (déci) bels, entre deux valeurs est, par définition, égal au logarithme décimal du rapport de ces deux valeurs.

Acoustique

* Le décibel est surtout utilisé en acoustique.

* L’intensité d’un son est mesurée sur une échelle dont le point de référence est la plus petite puissance sonore perceptible par l’oreille humaine:

PRéférence = 10-12 W / m2 = 1pW.m-2

* L'oreille est capable de capter des sons sur une dynamique de pression de 20 µPa à 200 000 000 µPa (rapport 107). Cette dynamique exprimée en décibels va de 0 à -140 dB (= 20 log 107)

Exemples

* 0 dB: un son à 4000 Hz commence à être audible.

* 20 dB: un son à 10 000 Hz commence à être audible.

* 45 dB: bruit d'une armoire électronique en fonctionnement.

* 70 dB: voix humaine lors d'une conversation.

* 120 dB: marteau piqueur ou avion au décollage.

* 150 dB: sirène d'alarme.

À partir de 120 dB, le bruit peut provoquer des lésions irréversibles à l’oreille interne.

Voir Son

Note: Le décibel A dB(A) : la lettre A signifie que le décibel est pondéré pour tenir compte de la différence de sensibilité de l’oreille à chaque fréquence. Elle atténue les basses fréquences.

Gain et perte d'un circuit

* Le décibel est utilisé pour comparer des grandeurs ayant de grandes dynamiques. En électricité, en acoustique, en traitement du signal, etc.

* Le décibel caractérise le rapport entre deux mesures; par exemple entre watts, volts ou ampères.

* Le décibel est la mesure d'un gain ou d'une perte entre un signal d'entrée et un signal de sortie à travers un circuit, comme typiquement un amplificateur.

Le circuit amplifie le signal d'entrée. Le rapport entre le signal de sortie et le signal d'entrée est un gain en cas d'amplification, c'est une perte dans le cas contraire.

Puissance (P en watts) et décibels

* Plaçons-nous dans le cas où nous mesurons la puissance des signaux. L'unité est le watt.

* Le raisonnement sera légèrement différent pour les tensions (volts) ou les intensités (ampères).
Un gain en décibels est égal dix fois le logarithme en base 10 du rapport des puissances.

* Ainsi avec un rapport de 100, le logarithme est égal à 2 et la valeur G en décibels est égale à 10 x 2 = 20 décibels.
Avec une perte, les valeurs en décibels sont négatives.

* Dans le cas où le rapport n'est pas une puissance de dix, la valeur du logarithme est à chercher sur sa calculette.

Exemple: rapport des puissances = 1300

G = 31,13 décibels

1 W = 1 000 milliwatts (mW)

1 kW = 1 000 watts (W)

Oreille humaine et décibel "sonore"

Seuil d'écoute: 0,000 000 000 001 W/m²

Seuil de douleur: 1 W / m²

Rapport: 1012

Soit: 12 Bels ou 120 décibels

Conversion imaginée par Graham Bell (1847-1922), inventeur du téléphone.

Pour le son, sa pression sonore est comparée à une référence qui est la pression standard de l'air (20 micropascals). On admet qu'elle correspond au seuil d'écoute.

Cas de 3 dB – Double

Exemple: PE = 10 mW et PS = 20 mW

Lorsque le rapport de puissance est égal à 2, le gain est égal à 3 décibels (valeur couramment arrondie).

Avec un gain de puissance en puissances de 2, il est facile de calculer la valeur en décibels.

Exemple:

Un amplificateur de 9 décibels, avec un signal de 10 mW à l'entrée produira un signal de sortie de 10 x 8 = 80 mW.

Si cet amplificateur est suivi d'un autre amplificateur de 3 décibels, le signal en sortie sera de 80 x 2 = 160 mW.

L'ensemble des deux amplificateurs est équivalent à un seul de 9 + 3 = 12 décibels. En effet: 10 mW x 16 = 160 mW.

Amplificateurs en série

Nous venons de voir qu'un amplificateur de X décibels suivi d'un amplificateur de Y décibels est équivalent à un amplificateur de X + Y décibels.

Ainsi trois étages à 3dB est équivalent à un seul de 9 dB. Un signal de 10 mW sortira de l'ensemble avec 80 mW.

Nous savons que 3 dB c'est multiplier par 2, et 10 dB c'est multiplier par 10.

Exemples:

Un amplificateur de 13 décibels est équivalent à deux amplificateurs en série de 10 dB et de 3dB. Soit une puissance multipliée par 10 puis par 2; au total par 20.

En effet: log 20 = 1,30103…

Quelle est la puissance de sortie d'un amplificateur de 7 dB. Dans ce cas nous faisons 7 = 10 – 3. La puissance du signal est multipliée par 10 puis divisée par 2, soit multipliée par 5.

En effet: log 5 = 0,69897000 …

Trois ampli de 3dB en série

= 1 ampli de 9 dB

Un ampli de 13dB

= ampli de 10 dB puis ampli de 3 dB.

Un ampli de 7dB

= ampli de 10 dB puis ampli de -3 dB.

Amplificateurs en parallèle

Ce cas est nettement plus délicat.

Si une puissance de 10mW est injectée à l'entrée de l'ensemble, et en supposant que les impédances d'entrée des deux amplificateurs soient identiques, chacun d'eux ne "verra" à son entrée que la moitié de ces 10mW.

En RF (radiofréquences), un tel montage est équipé, en entrée, d'un "power splitter" ou coupleur -3dB, dont le rôle est précisément de diviser la puissance d'entrée en deux puissances égales (à la moitié de la précédente), lesquelles vont attaquer les deux amplificateurs. Ainsi, l'ampli de 3dB donnera 5 x 2 = 10 mW à sa sortie, tandis que celui de 6dB donnera 5 x 4 = 20 mW.

Les puissances de sortie, additionnées dans un "power combiner" qui est l'exacte réplique du "splitter" de l'entrée, mais utilisé à l'envers, permettra d'obtenir 10 + 20 = 30 mW à la sortie de l'ensemble, dont le gain sera donc de 10 x log 3 = 4,8 dB.

Il serait alors plus efficace d'utiliser seul l'ampli de 6dB !

Grand merci à Thiery A. pour cette explication professionnelle

La suite présente trois méthodes d'additions de décibels: graphique, tableau et calcul algébrique.

Addition des décibels - Graphique

* Cette courbe s'applique à deux sources sonores. Elle donne les dB supplémentaires à ajouter à la source la plus bruyante.

* S'il y a trois sources, procédez en cascade: calculez la source équivalente des deux d'entre-elles et recommencer avec celle-ci et la troisième. Procédez de même pour n sources.

Exemples

* Trois sources de 40 chacune: 40 + 40 => 40 + 3 = 43 dB

et 43 + 40 => 43 + 1,8 = 44,8 dB.

* Trois sources de 40, 42 et 44 dB => 40 + 42 => 44,1 dB

et 44,1 + 44 => 47,1 dB

Addition des décibels - Valeurs

* Ce tableau reprend explicitement les valeurs lisibles sur la courbe ci-dessus.

* N est la différence de dB entre deux sources, et S est la somme de ces dB.

* Lorsqu'on parle de niveau sonore, les trois décimales que donne cette table sont généralement superflues: le dB ou le demi-dB suffisent amplement.

Addition des décibels - Formules

La définition du décibel

C'est le logarithme du rapport entre deux puissances:

Exemples

R = P1/P0 = 1000 => D = 10 log 1000 = 10 x 3 = 30 dB

D = 30 dB => log(R) = 3 => R =103 = 1000

Dans le cas général où le nombre n'est pas une puissance de 10, il faudra une calculette ou le tableur de votre ordinateur.

Somme des décibels

Deux sources sonores de A et B décibels:

=> RA = 10A/10

=> RB = 10B/10

Ajoutons les puissances (même dénominateur P0) et exprimons cette somme S en décibels:

Note: Il s'agit bien de la somme des puissances PA et PB.

Ne pas confondre avec la somme des logarithmes qui se traduirait par un produit:

Exemples

A = 40 dB et B = 44 dB
S = 10 log10 (104 + 104,4) = 10 x 4,54 = 45,45

Pour information:

104 = 10 000

104,4 = 25 118,86
104 + 104,4 = 35 118,86

log10 (104 + 104,4) = 4, 545540463 …

A = 40 dB, B = 40 dB et C = 40 dB
S = 10 log10 (104 + 104 + 104) = 44,77 dB

A = 40 dB, B = 42 dB et C = 44 dB
S = 10 log10 (104 + 104,2 + 104,4) = 47,07 dB

Calcul avec Mapple

Voir Programmation

Sources identiques

12 sources de 40 dB chacune

S = 10 log10 (104 + 104 +…+ 104)

= 10 log10 (12 x 104)

= 10 log10 (12) + 10 log10 (104)

= 10 log10 (12) + 40 dB
= 10,79 + 40 dB

n sources identiques créent une intensité sonore supplémentaire de 10 log10 (n) dB

De 90 dB à 180 dB

Question

Combien de sources de 90 dB pour obtenir 90 dB de plus?

Réponse

On ajoute 10 log10 (n) dB avec n sources de plus.

On vérifie bien que 10 log10 (2) pour 2 sources = 3,010299957 dB (arrondi généralement à 3 dB).

Avec 3 sources on aurait 4,77 dB en plus. Etc.

Dans le cas demandé:

10log10(n) = 90

log10(n) = 9

n = 10^9 = 1 000 000 000

Il faut donc un milliard de sources de 90dB pour obtenir 180 dB.

Électronique

* Un des problèmes de l'électronique, notamment en radio, consiste à capter un signal très faible et à la rendre suffisamment puissant pour actionner la membrane d'un haut-parleur et le rendre ainsi audible.

* L'amplification nécessaire se chiffre en puissances de 10 et le logarithme sont d'un grand secours pour ne pas avoir à manipuler de très grands nombres.

* Le coefficient d'amplification, rapport entre la puissance de sortie et celle d'entrée est le gain d'amplification qui se compte en décibels:

G = 10 log10 (PS / PE)

Exemple

Si le rapport des puissances est de 1 million (106)

Le gain est G = 10 log10 (106) = 10 x 6 = 60 dB

* En pratique:

* Puissance x 2 => gain de 3 dB

* Puissance x 4 => gain de 6 dB

* Puissance x 10 => gain de 10 dB

* Puissance x 100 => gain de 20 dB

* Etc.

Généralisation

Idée générale

Pour les spécialistes, il est courant de mesurer les tensions en entrée et en sortie, le gain est alors en 20 log. Ce nombre 20 intervient chaque fois que l'on utilise une grandeur plutôt que celle liée à son carré. C'est le cas pour U (tension) et P (puissance), liés par la relation P = U²/R. On se souvent que: 10 log (U²) = 2 x 10 log (U).

Selon les grandeurs: 10 ou 20? et quelle référence?

Formules en 10 log ou 20 log selon la grandeur (G) et indication de la grandeur de référence (Ref.). En jaune celle que nous avons indiquée pour l'intensité sonore.

ENGLISH CORNER

* In the study of acoustics, calculations are mainly performed in decibels.

* Decibel: a logarithmic unit, symbol dB, used to express ratios of power, voltage current or sound intensity.

* Sound of any kind above 120 decibels causes incurable damage to hearing if exposure is prolonged.

* 10 log(2) = 3,010299957 but most people round it off to 3.

* A difference of 20 dB between two sounds means that the more intense one has 10 times the amplitude (100 times the power) of the softer.

* The human ear responds logarithmically and it is convenient to deal in logarithmic units in audio systems. The bel is the logarithm of the ratio of two powers, and the decibel is one tenth of a bel. The Bel was the amount a signal dropped in level over a one-mile distance of telephone wire.


Décibel — Wikipédia

Vu dans ... https://fr.wikipedia.org/wiki/D%C3%A9cibel

Décibel

Un article de Wikipédia, l'encyclopédie libre.
Sauter à la navigation Sauter à la recherche
Page d'aide sur l'homonymie Pour les articles homonymes, voir Décibel (homonymie) et Décibel (bruit).

Le décibel (dB) est une unité de grandeur sans dimension définie comme dix fois le logarithme décimal du rapport entre deux puissances [1], utilisé dans les télécommunications, l'électronique et l'acoustique.

Dans le domaine de l'acoustique environnementale, on exprime couramment le niveau sonore en décibels. Cette valeur indique implicitement le rapport des puissances entre la grandeur mesurée et la valeur de référence qui correspond à un son trop faible pour être entendu.

Le décibel est un sous-multiple du bel, très rarement employé. Ni le bel, ni le décibel n'appartiennent au Système international d'unités [2].

Tous les champs de l'ingénierie peuvent utiliser le décibel. Il est particulièrement courant dans le domaine des télécommunications, dont il est originaire, dans l'électronique du traitement du signal, dans les technologies du son et dans l'acoustique.

Historique

Vers 1920, les entreprises de téléphonie mesuraient l'atténuation du signal en mile de câble standard, msc. Un dispositif équivalent à un msc atténue le signal comme un mile (1,6 km) de câble standard à la fréquence de 800 Hz. Ajouter un circuit en série, équivaut, du point de vue de l'atténuation, à ajouter une longueur de câble. Les msc s'ajoutent, alors que les atténuations exprimées en pourcentage se multiplient. De ce fait, le msc était une unité logarithmique.

Avant la diffusion des calculatrices électroniques, on se servait pour les calculs de tables de logarithmes décimaux. Pour calculer l'atténuation dans une ligne de longueur L et de coefficient d'atténuation α, il faut élever (1-α) à la puissance L. Sans calculatrice, on cherche log(1-α) dans la table, on le multiplie par L avant de reconvertir, en recourant de nouveau à la table, le logarithme en rapport. En exprimant l'atténuation par la longueur de câble équivalente, même si le circuit en question n'est pas un câble, on simplifie largement les opérations. À la même époque, on commençait à utiliser des amplificateurs pour améliorer la communication à longue distance en compensant les pertes dans le câble. On indiqua la longueur équivalente que ces répéteurs retranchaient au câble.

Des ingénieurs des Laboratoires Bell définirent une unité de transmission indépendante du câble et de la fréquence, basée sur dix fois le logarithme décimal. Cette unité s'appela d'abord TU pour (en)Transmission unit (unité de transmission). Elle présentait l'avantage d'être presque équivalente au msc (1 TU = 1,083 msc). Elle fut renommée décibel en 1923 ou 1924 en l'honneur du fondateur du laboratoire et pionnier des télécoms, Alexander Graham Bell [3].

Les Laboratoires Bell consultèrent les opérateurs téléphoniques et administrations responsables. Certaines utilisaient des logarithmes népériens, qui présentent certains avantages pour le calcul, avec une unité appelée le néper (symbole Np). Les deux unités ont coexisté, mais le néper n'a pas connu le succès du décibel[4]. « L'utilisation du néper est le plus souvent limitée à des calculs théoriques sur des grandeurs de champ, où cette unité est la plus commode, alors que, dans d'autres cas, en particulier pour des grandeurs de puissance, le bel, ou en pratique son sous-multiple, le décibel, symbole dB, est largement utilisé. Il convient de souligner que le fait que le néper soit choisi comme l'unité cohérente n'implique pas qu'il convienne d'éviter d'utiliser le bel. Le bel est accepté par le CIPM et l'OIML pour être utilisé avec le SI. À certains égards, cette situation est similaire au fait que l'unité degré (°) est utilisée couramment à la place de l'unité SI cohérente radian (rad) pour les angles plans[5]. ».

Le bel, unité de base théorique, n'est pas utilisé.

Les acousticiens ont généralement adopté le décibel. Par une coïncidence fortuite, un décibel, en puissance sonore, correspond à peu près à la plus petite variation perceptible[6]. Selon le philosophe et psychologue Gustav Fechner, la sensation ressentie varie comme le logarithme de l'excitation. Une unité à progression logarithmique semblait particulièrement pertinente dans un domaine où la perception humaine était en jeu. La loi de Weber-Fechner, datant du milieu du XIXe siècle, ne peut être démontrée rigoureusement et n'est pas valable pour les faibles niveaux de stimulus ; mais l'usage du décibel s'était établi, même dans des cas où il complique la compréhension[7].

Définition

Soient deux puissances P0 et P1, leur valeur relative en décibels vaut :

Exemples numériques :
  • Si P1 = 100 × P0, le rapport entre les deux puissances est de 100 = 102 ; ce qui correspond à 20 dB ;
  • Si P1 = 2 × P0, leur rapport est de 2 ≈ 100,3, ce qui correspond à 3 dB :

une puissance double correspond à 3 dB.

Le décibel (dB) est le dixième du bel (B), autrement dit dix décibels valent un bel ; mais cette unité n'est pas utilisée, même quand on évalue conventionnellement le logarithme décimal du rapport entre deux grandeurs, comme dans le cas de la densité optique.

Rapports des puissances et décibels
Rapport | 1 | 1,26 | 1,6 | 2 | 2,5 | ≈3,2 | 4 | 5 | 10 | 40 | 100 | 1 000
 |  |  | √10 | 22 |  |  |  |  |
dB | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 10 | 16 | 20 | 30

Grandeurs de puissance et grandeurs de champ

  • Une grandeur physique proportionnelle ou correspondant à une puissance est appelée grandeur de puissance.
  • Une grandeur physique dont le carré est proportionnel à une puissance est appelée grandeur de champ[8].
Exemples de grandeurs de puissance :

La puissance, qui s'exprime en watts dans le Système international d'unités, l'intensité acoustique, qui se calcule en watts par mètre carré.

Exemples de grandeurs de champ :

La tension électrique exprimée en volts, l'intensité électrique exprimée en ampères, la pression acoustique exprimée en pascals.

On a souvent besoin d'exprimer le rapport entre deux grandeurs de champ. On peut utiliser les décibels, mais ceux-ci doivent comparer les puissances qu'exerceraient les grandeurs de champ dans des circonstances équivalentes. Dans le cas de grandeurs de champ périodiques comme le courant alternatif, la valeur pertinente est donc la valeur efficace exclusivement. Par conséquent, les décibels expriment non pas le rapport des grandeurs de champ, mais le rapport de leurs carrés.

Exemple — Rapport en décibels de deux tensions électriques :

On désire exprimer en décibels le rapport entre une tension de 10 V et entre une tension de 100 V.

Supposons qu'elles soient appliquées à une résistance de 100 ohm (Ω). La première produira une puissance de U²/R=10²/100=1 watt (W), la seconde de U²/R=100²/100=100 W. Le rapport entre les puissances est de 100, et logarithme décimal de 100 étant 2, l'expression du rapport en décibels est 20 dB.

La multiplication par dix d'une grandeur de champ correspond à un accroissement de 20 dB.

En appliquant à une tension de 3 V et une autre de 6 V le même raisonnement, on calcule que la première produira une puissance de 0,09 W, la seconde de 0,36 W, le rapport des puissances est donc de 4, dont le logarithme décimal est d'environ 0,6, et l'expression du rapport des puissances est 6 dB.

Le doublement d'une grandeur de champ correspond à un accroissement de 6 dB.

D'une façon plus générale, soient a et b deux valeurs d'une grandeur de champ. On souhaite exprimer le niveau relatif de b par rapport à a en décibels :

Rapports de valeurs de grandeurs de champ et décibels
Rapport | 1 | 1,12 | 1,26 | 1,4 | 1,6 | ≈ 1,8 | 2 | ≈ 2,2 | 2,5 | 2,8 | 3,2 | 5 | 8 | 10 | 32 | 100 | 320 | 1 000
 |  | +12 % | ≈ 5/4 | √2 | 8/5 | 16/9 |  | √5 | 5/2 | 2√2 | √10 |  |  |  |  |  |  |
dB | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 14 | 18 | 20 | 30 | 40 | 50 | 60

Somme de grandeurs d'après les niveaux en dB

Les décibels sont des unités logarithmiques. Ils s'additionnent quand les grandeurs se multiplient.

On est souvent amené à calculer le niveau résultant du mélange de deux sources indépendantes. L'addition est légitime, dans la mesure où les systèmes sont linéaires, mais on doit ajouter les grandeurs, et non leur logarithme.

Quand les sources sont corrélées, c'est-à-dire que la valeur instantanée de l'une dépend de celle de l'autre, il faut partir de cette corrélation pour effectuer les calculs.

Quand les sources sont indépendantes, on doit faire la somme de leurs puissances. Soient deux signaux de niveaux [image] et [image] , et [image] étant la valeur de référence, le niveau [image] résultant du mélange des deux signaux s'exprime :

On peut simplifier l'expression sous la forme :

ou encore

Admettons que le niveau [image] soit supérieur au niveau [image] ; on peut construire un tableau indiquant l'augmentation du niveau résultant de l'ajout de la seconde source[9] :

Somme de deux signaux indépendants
L_1 - L_2 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 12 | 14 | 16 | > 19
Ajouter à | 3 dB | 2,5 dB | 2,1 dB | 1,8 dB | 1,5 dB | 1,2 dB | 1 dB | 0,8 dB | 0,6 dB | 0,5 dB | 0,4 dB | 0,3 dB | 0,2 dB | 0,1 dB | 0 dB
Exemple — Apport de bruit dans un atelier industriel :

On désire connaître le niveau de bruit à un nouveau poste de travail dans un atelier industriel.

  • Le niveau sonore dans l'atelier est de 78 dB.
  • Le constructeur de la machine destinée à ce nouveau poste indique que l'opérateur subit un niveau sonore de 77 dB en période d'attente et 81 dB en période de travail.

En période d'attente, le niveau de bruit de l'ambiance de l'atelier est supérieur de 1 dB à celui de la nouvelle machine ; il sert de base. On ajoute à ces 78 dB la valeur lue dans le tableau sous 1 dB, soit 2,5. Le niveau de bruit résultant sera de 80,5 dB.

En période de travail, le bruit de la machine domine de 3 dB l'ambiance. Le bruit résultant au poste de travail est de 81 + 1,8 ≈ 83 dB (il est parfaitement illusoire de considérer les décimales dans ces circonstances).

Soustraction de grandeurs d'après les niveaux en dB

Suivant le même raisonnement que pour les sommes de grandeurs indépendantes d'après leurs niveaux en dB, on peut établir la formule et le tableau de soustraction. On connaît un niveau total [image] , et on souhaite déterminer le niveau restant [image] après suppression d'une source à un niveau [image] qui ne peut évidemment qu'être inférieur au niveau total :

On peut construire un tableau indiquant la réduction du niveau résultant de la suppression de la seconde source[9] :

Soustraction de deux signaux indépendants
 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 12 | 14 | 16 | > 20
Retrancher de | 6,9 dB | 4,3 dB | 3 dB | 2,2 dB | 1,7 dB | 1,3 dB | 1 dB | 0,8 dB | 0,6 dB | 0,5 dB | 0,3 dB | 0,2 dB | 0,1 dB | 0 dB

Usage du décibel

Les décibels facilitent ainsi le travail quand :

  • les grandeurs sont de même signe (il n'y a pas de logarithme d'un nombre négatif) ;
  • et les rapports s'étalent sur une large plage (plus de un à cent) ;
  • et un rapport de 1,1 (+ 10 %) est peu de chose.

Dans le cas contraire, le calcul avec les rapports ou des pourcentages a des chances d'être préférable.

Dans les calculs pratiques, l'usage des décibels permet de se concentrer sur les problèmes du moment en évitant de mobiliser des capacités de calcul mental. Ajouter ou soustraire des valeurs en décibels équivaut à multiplier ou diviser la valeur d'une grandeur mesurable. On se contente de nombres entiers ou avec au plus un chiffre après la virgule.

Calcul d'atténuation

Article détaillé : Bilan de liaison.

En électronique, en télécommunication, en traitement du signal, le décibel est utilisé en plus des pourcentages pour exprimer des rapports. Il permet de calculer le taux de transmission global du signal électrique à travers une série de composants ou de systèmes reliés les uns à la suite des autres en ajoutant les valeurs en décibels calculées pour chacun d'eux au lieu de multiplier les rapports de transmission :

  • gain c'est-à-dire d'augmentation de l'amplitude par un amplificateur électronique, donnant des valeurs positives en décibels ;
  • atténuation, c'est-à-dire la diminution de l'amplitude dans un réseau de composants ou une ligne de transmission, donnant des valeurs négatives en décibels.

Le décibel exprime un rapport de puissance sans dimension. Il peut également être combiné avec un suffixe pour créer une unité spécifique et absolue, référencée à une valeur de grandeur physique.

Le décibel relatif à une valeur de grandeur physique

Là où une personne attachée au sens originel des mots et à l'usage du décibel selon sa définition écrirait

14 dB re 1 mW,

un technicien qui valorise plus la concision pourra se contenter de

14 dBm,

les lecteurs étant supposés savoir que dBm signifie « décibels relatifs à une puissance d'un milliwatt ».

Les normes ISO et CEI n'autorisent que la notation complète dans les publications techniques et scientifiques[10].

Dans certains domaines, il existe des valeurs de référence normalisées. Les rapports s'expriment en décibels en ajoutant, comme dans cet exemple, un symbole après dB.

Électronique

Rappel

Pour les grandeurs de puissance, le décibel est égal à dix fois le logarithme du rapport des grandeurs, pour les grandeurs de champ, à vingt fois le logarithme du rapport des grandeurs.

  • dBW : grandeur de puissance. La puissance de référence est 1 W.
  • dBm : grandeur de puissance. La puissance de référence est 1 mW. En téléphonie et en audio, la charge normale est 600 ohms, correspondant à l'impédance caractéristique des lignes de transmission. 0,775 V dans 600 ohms développent une puissance de 1 mW. En haute fréquence, l'impédance caractéristique normale est de 50 ohms.
  • dBV : grandeur de champ, valeur efficace de la tension. La tension de référence est 1 volt RMS.
  • dBμV : grandeur de champ, valeur efficace de la tension. La tension de référence est 1 μvolt RMS.

[

Article détaillé : Niveau (audio).

La technologie audio utilise les méthodes et unités des télécommunications et de l'électronique, avec des adaptations dues aux habitudes qui se sont établies progressivement. En téléphonie, la longueur des lignes de transmission oblige à les boucler sur leur impédance caractéristique fixée à 600 ohms. Dans les installations audio, on n'atteint jamais ces longueurs. Il est donc préférable d'adapter les circuits en tension, avec des impédances d'entrée élevées.

  • dBu : decibel unloaded (décibel hors charge) ; grandeur de champ, valeur efficace de la tension. La tension de référence est 0,775 V RMS (volts en valeur efficace). La référence à une impédance disparait, mais on a conservé la tension qui produit 1 mW dans 600 ohms.

Audionumérique[ modifier | modifier le code ]

En audionumérique, on traite des suites de nombres, de l'information qu'on finira par convertir en une valeur de grandeur de champ.

Article détaillé : dB FS.
Avertissement

Les décibels se réfèrent à la puissance. La puissance instantanée du signal à l'instant où sa valeur instantanée est la plus élevée n'est aucunement significative de la puissance totale, comme inversement la valeur efficace, particulièrement si elle est intégrée avec une constante de temps, n'est aucunement significative de la valeur maximale du signal.

En conséquence, les calculs sur le niveau d'un signal somme de signaux non corrélés dont on connaît le niveau en décibels (voir plus haut), qui partent de la définition du décibel comme logarithme de la puissance, sont faux pour les valeurs que donnent les indicateurs en dB FS respectant la définition de l'AES et de l'UER/EBU. Le niveau de crête de la somme de deux signaux non corrélés se situe à un niveau situé entre à peu près le niveau de crête le plus élevé des deux et la somme des deux niveaux de crête.

  • dB FS decibel Full Scale (décibel pleine échelle). Pleine échelle désigne l'amplitude maximale du signal numérique, c'est-à-dire la plus grande valeur absolue pouvant être représentée dans le code en positif ou en négatif. Les usages divergent quant à la grandeur que cette valeur désigne[11].
    • Pour l'AES et l'UER/EBU, le dB FS est le rapport de l'amplitude du signal à la plus grande amplitude que le canal digital puisse représenter[12],[13]. Comme c'est une valeur de champ, on multiplie par convention le logarithme du rapport par vingt, bien que l'amplitude n'ait pas de rapport direct avec la puissance (voir Facteur de crête). Le niveau en dB FS est nécessairement négatif, puisque la valeur de référence ne peut être dépassée dans le système.
    • Pour d'autres, le dB FS est le rapport de la valeur efficace du signal à celle d'un signal sinusoïdal d'amplitude maximale[14]. Dans ce système de mesure, un signal peut atteindre +3 dB FS.

Les deux variantes donnent des lectures identiques pour les signaux d'essai (sinusoïdes).

Le dB FS est l'unité recommandée pour les indicateurs PPM dits aussi QPPM [15],[13] et s'utilise généralement pour les indicateurs d'amplitude basés sur la valeur de chaque échantillon numérique.

  • dB FS TP : dB True Peak (décibel vraie crête) : une variante du dB FS pour laquelle l'amplitude du signal inclut les crêtes pouvant exister entre deux échantillons successifs du signal numérique[16]. Le niveau en dB TP peut dépasser le niveau de référence de quelques dB. Le but de l'évaluation du niveau en dB TP est de permettre aux opérateurs d'éviter qu'il le fasse.

Pour les appareils audionumériques, l'indication du niveau de la crête est de la plus grande importance, puisque au-delà de la pleine échelle, l'information est définitivement perdue. L'habitude a fait conserver le décibel pour évaluer le niveau relatif. Il serait cependant plus judicieux d'utiliser les pourcentages pour cet usage. Ainsi, la recommandation de ne pas laisser la modulation dépasser −1,5 dB FS TP se lirait « ne pas dépasser 85 % FS TP ». L'échelle des modulations permises, avec un niveau minimal exigé à −42 dB FS (avec une constante de temps longue) pour ne pas laisser l'auditeur sans aucun son, se situe entre 1 % et 85 %, ce qui ne justifie guère l'échelle logarithmique. L'indication du niveau intégré, (VU ou LU[17]) reflétant le niveau perçu, a en revanche toutes les raisons de s'exprimer en dB.

Unités dérivées

Des unités de mesure de la Sonie des programmes audio basées sur des échelles logarithmiques décimales comme le décibel, mais impliquant de nombreux filtrages et intégrations ont été mises en œuvre, voir Niveau (audio).

[

Articles détaillés : Décibel (bruit), Pression acoustique et Intensité acoustique.

L'acoustique se décompose, pour ce qui est de l'usage des décibels, en deux parties :

  • l'acoustique physique ;
  • la psychoacoustique.

L'acoustique physique étudie les sons dans l'espace. Elle utilise le décibel pour comparer les intensités acoustiques, une grandeur de puissance qui s'exprime en watts par mètre carré (W m−2, W/m²), ou les pressions acoustiques, une grandeur de champ qui s'exprime en pascals (Pa). Une norme[18] définit un niveau d'intensité acoustique de référence de 1 pW/m2 et un niveau de pression acoustique de référence de 20 µPa qui sont, dans certaines conditions en général à peu près remplies, équivalents[19], et sont le 0 dB[20], soit SPL (Sound Pressure Level (niveau de pression acoustique)), soit SIL (Sound Intensity Level (niveau d'intensité acoustique)).

Psychoacoustique[ modifier | modifier le code ]

Article détaillé : Sonie.

La psychoacoustique étudie la perception des sons par les êtres humains. Comme la sensation sonore dépend de nombreux facteurs, les acousticiens sont amenés à filtrer et à intégrer les valeurs de pression sonore de façon beaucoup plus diverse qu'en acoustique physique avant de convertir le résultat en dB ou en unités particulières. Des normes précisent la nature de ces traitements, indiqués par un suffixe après dB.

  • dB A « décibel du rapport pondéré en fréquence suivant la courbe A ». La courbe de pondération est adaptée à la réponse de l'oreille à des faibles niveaux de pression acoustique, autour de 40 dB SPL. Son usage est obligatoire pour certaines mesures légales du bruit.
  • dB B « décibel du rapport pondéré en fréquence suivant la courbe B ». Cette courbe a peu d'utilisation actuellement, mais elle est une composante de celle qui sert à l'analyse de la sonie des programmes de télévision[21].
  • dB C « décibel du rapport pondéré en fréquence suivant la courbe C ». C'est une courbe de pondération adaptée à la réponse de l'oreille à des niveaux élevés de pression acoustique, supérieurs à 70 dB SPL.
  • dB HL Hearing Level (Niveau d'audition), « décibel du rapport pondéré par une courbe normalisée pour les audiogrammes ».

Des unités basées moins directement sur le décibel ont été définies pour mieux représenter la perception d'un volume sonore :

  • le phone s'applique aux sons purs, on applique à la valeur en dB une correction basée sur les courbes isosoniques ;
  • le sone se calcule selon une procédure normalisée (ISO 532) à partir d'une mesure du niveau en dB re 20 μPa sur soit 10, soit 24 bandes de fréquences.

Radio transmissions

  • dB i : utilisé pour parler du gain des antennes. Le gain de référence est celle d'une antenne isotrope.
  • dB d : comme le dBi mais le gain de référence est celle d'une antenne dipôle.
  • dB c : mesure du rapport de puissance entre un signal (le bruit, souvent) et la porteuse sur laquelle il transite (c pour carrier).

Météorologie

  • dB Z : abréviation de décibel Z, indique le niveau de réflectivité (Z) des cibles radars en météorologie par rapport à celle d'une précipitation contenant 1 mm6 mm−3 de gouttes. La valeur en dB Z est proportionnelle à l'intensité des précipitations et peut être convertie en taux horaire selon un formule du type [image] , où a et b dépendent du type de précipitations[22].

Probabilités

Articles détaillés : Inférence bayésienne et Théorème de Cox-Jaynes.

En probabilités, on définit l'évidence d'un évènement comme :

où p est sa probabilité. L'usage d'une échelle logarithmique présente le même genre d'avantages de présentation que le décibel pour les rapports de puissance : meilleure lisibilité lorsque les probabilités sont proches de 1 ou de 0, remplacement de la multiplication par l'addition pour les calculs.

Dans un ouvrage de 1969, Myron Tribus choisit la base [image] pour le logarithme et exprime le résultat en décibels[23]. Des ouvrages bayésiens de référence[24] le suivent dans cet usage métonymique. Cependant, plusieurs auteurs[25] lui préfèrent les termes ban (en) et son sous-multiple déciban, inventés par Alan Turing en 1940, et publiés par Good en 1979[26]. En 2011, Stanislas Dehaene choisit cette option dans son cours au Collège de France [27].

Le décibel reste dans ce cas réservé aux rapports de puissance conformément à sa définition d'origine, le déciban exprimant l'évidence probabiliste.


Décibels Nepers Gain Atténuation

Vu dans ... http://arsene.perez-mas.pagesperso-orange.fr/signal/decibels/decibels_new.htm

En résumé

De nombreuses techniques traitent de signaux destinés à opérer finalement sur des capteurs biologiques
que sont, par exemple, les organes des sens.

C'est le cas de la téléphonie, des techniques acoustiques : amplificateurs d'audiofréquences, sonorisation.
qui ont pour objectif de sensibiliser l'oreille, capteur biologique terminal de la chaîne.

Or l'impresion physiologique d'intensité sonore [image] n'est pas proportionnelle
à la puissance du signal produisant le son.
Loin de là !
Si, par exemple, on double la puissance électrique fournie à un haut-parleur,
c'est à peine si on note une augmentation du son.

Jugez-en par vous-même.
Voici deux sons sinusoïdaux ( la3 ; 440Hz ) successifs durant chacun 1 seconde et générés par logiciel.
La puissance donnée au second est exactement la moitié de celle du premier.
Activez les haut-parleurs et double-cliquer sur la note ci-dessous :

Etonnant, non ?
Dites à votre logiciel d'écoute de vous passer la séquence en boucle : c'est encore plus remarquable.
Une expérience proposée :

Conclusion
 Dans les techniques ayant pour finalité une perception par un organisme biologique,
par exemple, le traitement du son, mais aussi de l'intensité lumineuse (vidéo),
les mesures habituelles des variations des grandeurs électriques : puissance, tension, intensité,
sont loin de refléter la réalité des variations correspondantes du son final.

C'est pourquoi, pour se rapprocher du ressenti réel,
on a été contraint d'adopter une autre échelle de mesure tenant compte de ce phénomène purement physiologique.

Comme nous allons le voir ci-dessous, l''échelle adoptée est de type logarithmique.

Fonction logarithme

Prérequis
Ceux qui ne connaissent pas très bien la fonction "logarithme décimal" et ses propriétés opérationnelles,
ont intérêt à consulter parallèlement une autre page de ce site qui expose ces notions :

Nous pouvons déjà commencer par constater empiriquement que
la fonction logarithme décimal croît peu lorsque sa variable croît beaucoup.
Ce qui confirme son aptitude à mesurer la sensation de volume sonore qui,
elle aussi, croît peu lorsque la puissance croît beaucoup.

Rappelons que le logarithme décimal est la fonction réciproque [image] de la fonction :

Rapports entre ces deux fonctions

Retenez cette relation, elle vous servira pour certains calculs.

Si vous voulez comparer visuellement les variations de x et log(x), consultez la courbe de variation ici :

Exemple de calcul : si x=3 , y=103 = 1000. Donc log(1000) = 3.
Vérifiez sur la courbe de variation.

Des calculs analogues vous permettront de dresser le tableau ci-dessous pour des valeurs simples de x.
Dont vous pouvez vérifier les valeurs sur les courbes de variation. ou

Nous constatons bien que les variations de log(x) sont faibles
par rapport aux variations correspondantes de x
Par exemple, si x varie de 1 à 1000 , log(x) varie de 0 à 3 seulement.

La fonction logarithme est donc bien apte à représenter
la sensation de faible variation du volume sonore
corrrespondant à une grande variation de la puissance nécessaire pour la produire.

Notation en vigueur (la base 10 est parfois précisée)

Base ???

Au cas où vous voudriez tracer vous-même les courbes ...
Un traceur de fonctions programmé en JavaScript par l'auteur
est disponible sur ce site en deux versions : cartésien et paramétrique.
Voici les liens :
Grapheur Cartésien
Grapheur Paramétrique
Une justification plus précise du choix de la fonction logarithme dans ce type d'applications
est exposée ici :

Définition de base des "Bels & déciBels"
A partir d'une comparaison de puissances.

Une caractéristique importante de tout signal est sa puissance P(Watt)

Par exemple, dans le quadripôle intermédiaire en bleu ci-dessous, on nomme :
Pe puissance du signal électrique d'entrée et Ps sa puissance en sortie.

On définit ordinairement
l ' Amplification de puissance : A = Ps / Pe (sans unité)

Mais comme il a été dit plus haut, on préfère souvent utiliser l'échelle logarithmique.
On définit alors le Gain de puissance , de la manière suivante :

Le gain exprimé en Bel est le logarithme décimal du rapport des puissances.:

Une formule plus courante qui se déduit de la précédente.
Comme 1 Bel = 10 déciBel (dB) :

Définition officielle !

Le Bel et le décibel (ce dernier est le plus utilisé) ne sont pas des unités au sens de la physique.
Ces symboles indiquent seulement que le nombre qu'ils accompagnent a été obtenu par les formules ci-dessus.

Vérifiez que log(10) = 1 sur la courbe visible ici :
Dès lors : si l'amplification P2/P1 = 10 alors Gain = log(10) = 1 Bel soit 10 dB

Gain ou Atténuation ?

Le quadripôle de l'exemple ci-dessus peut figurer un amplificateur, auquel cas Ps/Pe > 1

Mais il peut aussi figurer un support de transmission de signaux, un filtre, un quadripôle passif,
dont on sait qu'ils absorbent de la puissance.
Donc : Ps / Pe < 1

Dans ce cas, plutôt que de gain on préfère parler d ' atténuation.

Exemple :
Si Ps/Pe = 1/10 = 10-1
Le "gain" est -1 Bel = -10 dB

On peut écrire :

Le Gain est de -10dB
ou

L'Atténuation est de 10 dB

Quelques cas particuliers :

P2 / P1 | 0,1 | 0,5 | 2 | 10 | 100 | 1000 | 10 000
10 log (P2 / P1) | -10 dB | -3 dB | 3 dB | 10 dB | 20 dB | 30 dB | 40 dB

Exercices applicatifs

Les réponses apparaîtront dans le coin supérieur gauche de l'écran
lorsque vous passerez le pointeur de la souris sur les icônes : ci-dessous.

Exemples de calculs courants :

Question 1
Que vaut P2 d'après le schéma ci-dessous ?

Question 2
Même question avec G = -30 dB.
Question 3
Même question avec G = 48 dB.

Question 4
On double la puissance.
Quel est le gain en dB correspondant ?
Et si on la divise par deux ?

Question 5
Puissance du signal en sortie : Ps = 45 W
Puissance du signal en entrée : Pe = 3 mW
Gain en db ?

Question 6
Quelle amplification de puissance A = Ps/Pe
correspond à une atténuation de 15 dB ?

Additivité (algébrique) des Gains en dB

Exercice 7

Nous avons une suite de 3 quadripôles connectés.

En entrée et en sortie deux amplificateurs de signaux.
Entre-eux un câble de transmission dont on sait qu'il atténue la puissance du signal (Psortie/Pentrée < 1).

  • Les amplifications respectives sont A1, A2, A3
  • L'amplification du quadripole équivalent aux trois est At
  • Les gains respectifs sont G1, G2, G3
  • Le gain du quadripole équivalent aux trois est Gt

Dans cette chaîne :

  • Les amplifications se multiplient
    At = A1 [image] A2 [image] A3
  • Les gains s'ajoutent (algébriquement)
    Gt = G1 + G2 + G3
     Dans l'exemle précédent :
    Gt = 3 - 2 + 11 = 12 dB

Mais...nous n'avons jusqu'ici démontré nulle part ces formules !
Hé bien vous allez le faire !
Car il est important de bien mémoriser ce fait.

Question 7
Etablir la relation donnant Gt en fonction de G1, G2, G3
en sous servant uniquement de leurs définitions logarithmiques en fonction de P1, P2, P3
et des propriétés des logarithmes que vous pourrez éventuellement réviser en :
.
A VOUS DE TRAVAILLER !
... AVANT de regarder ci-dessous la réponse... si possible ...

Exercice 8

A1, A2, A3 sont les amplifications des trois quadripôles respectivement.
Etablir la relation At = A1.A2.A3.
At étant l'amplification totale du quadripôle considéré entre les bornes les plus à gauche et celles les plus à droite.

Décibels en électricité - Rapports de tensions, d'intensités.

Voici un dipôle résistif.

Puissance P
Relation établie en électricité

U (tension) et I (intensité)

Valable en courant continu
ou,
en courant alternatif sinusoïdal si le dipôle est résistif,.
U et I pouvant être les valeurs maximale ou efficace.

Comment mesurer, comparer des puissances ?

En électricité, le Wattmètre est d'un emploi problématique
car en plus de la tension, il doit mesurer l'intensité et pour cela se mettre en partie en série dans le circuit.
L'instrument le moins perturbateur est le voltmètre.

Peut-on alors mesurer les puissances avec un voltmètre ?

Mesurer la tension pour en déduire la puissance par la formule P=(U2) / R
exige que l'on connaisse la résistance R, qui appartient au circuit testé, et qui varie d'un circuit à l'autre.

Comparer deux puissances à partir de mesures de tension effectuées
sur deux résistances de valeur différente est INEPTE !

Par exemple :
La même tension de 1 V correspond
à 1W pour une résistance de 1 Ohm
à 100 W pour une résistance de 0,01 Ohm.

Conclusion
Si on se sert de U ou de I pour mesurer la puissance
on ne peut comparer que les résultats des mesures effectuées sur des résistances égales.

Aux bornes de deux résistance égales...

Si les tensions mesurées sont respectivement U1 et U2.
Les puissances sont respectivement :

Une explication ?

Si on mesurait les intensités :

Mais faut-il encore que les résistances
aux bornes desquelles on mesure les U1 U2 ou I1 I2
soient égales !
pour conclure que les puissances correpondantes
sont dans ce rapport là de décibels.

Cette condition est respectée dans le paragraphe qui suit.

Mesure des tensions en dB
le "dBm"

On en revient aux bons vieux téléphonistes : le poids de l'histoire est considérable sur les pratiques techniques.

La Boucle terminale d'abonné
est un terme des téléphonistes qui désigne, vu du central téléphonique,
le dipôle constitué par la paire de fils de ligne qui aboutissent à la prise téléphonique de l'abonné distant,
prise sur laquelle est supposé branché un poste téléphonique standard.

Il s'agit d'un téléphone standard vieux maintenant de près d'un siècle,
qui, du point de vue électrique, était équivalent à une résistance pure de 600 Ohm.
Mais les habitudes, même en technique, sont indélogeables !
Pas les téléphones, heureusement !

Comment vérifier que le signal sonore à l'arrivée était conforme à la norme ?
En mesurant la puissance disponible aux bornes de cet ancêtre !
Et puisque la résistance, dans le cadre de cette technique, est toujours la même : 600 Ohm.
les mesures de tension avaient donc une signification constante.
Et on pouvait déduire la puissance de la mesure de la tension.

Mais il y a encore mieux !
Les téléphonistes ont défini un standard de puissance à l'arrivée !

Puissance standard
réputée assurer un volume sonore acceptable dans l'écouteur du récepteur téléphonique .
P1 =1 mW

Il est surprenant que l'oreille se contente de ce peu de puissance, qu'elle trouve en plus, confortable !
C'est ainsi que la Nature nous a faits !
Dans ce cours, nous n'avons pas fini d'avoir des surprises sur nos talents cachés...

1 mW sur 600 Ohm !
Cela correspond à une tension de ?

Peu importe cette tension. Les techniciens retenaient surtout "1mW sur 600 Ohm"
Mais alors...porquoi est-ce que je vous en parle ?

Par ce que c'était, pour les techniciens téléphonistes,le seul moyen pour mesurer
très facilement, à l'aide d'un simple voltmètre la puisance aux bornes des téléphones standard
(Rappel : ces derniers avaient tous la même résistance : 600 Ohm)
et vérifier immédiatement si elle était suffisante ou non et de combien !

Mais que viennent faire ici les décibels ?

Pour des raisons dues à la sensibilité de l'oreille qui ont été expliquées,
la puissance en elle-même ne donne pas une bonne idée de la perception finale.

On considère plutôt le rapport : (puissance mesurée) / (puissance de référence = 1 mW),
rapport exprimé en dB !

Vous reconnaissez le 1 mW : puissance de référence sonore normalisée.
et les 0,775 V correspondant à la tension nécessaire pour produire cette puissance sur une résistance de 600 Ohm

C'est dans ce but que les voltmètres destinés à cet usage, disposaient d'une échelle logarithmique graduée en dB

.

Remarquez l'indication : OdB = 1 mW 600 Ohm 0,775 V
Et la non-linéarité de l'échelle logarithmique
graduée de -10 dB à O db puis à +2 dB

Pour préciser ces conditions spécifiques de définition,
et le différentier des autres définitions du dB
les mesures de cette catégorie s'expliment en
dBm

Aujourd'hui les appareils de mesure à affichage numérique donnent directement le résultat en dBm.

Cet type de mesure se perpétue par atavisme.
Comme le sens conventionnel du courant électrique...
Mais pour le moment, elle nous est bien utile !

Exercices

Question 9
Calculer, dans la convention "dB / tension" des téléphonistes, les tensions en Volt
correspondant à : - 5 dB , .+ 3 dB , - 3 dB.

Question 10
Calculer le niveau en dB d'un signal de 4 V.

Question 11
Un signal subit deux variations successives : 3 dB puis - 6 dB. Résultat ?

Question 12
L'atténuation maximale acceptable pour une ligne téléphonique est de 60 dB
à quelle tension terminale correspond-elle ?

Bande passante à -3 dB

Attention !
Nous allons définir ici la bande passante pour un quadripôle analogique.
Cette notion est un peu différente quand il s'adit de signaux numériques.

On trouve en électronique, toute sorte de quadripôles.

Comme celui de l'exemple précédent, ils reçoivent un signal de puissance P1 sur leur entrée
et délivrent un signal de puissance P2 à leur sortie.

Si P2 > P1 : ce sont des amplificateurs.
C'est le cas de la figure ci-dessus.
P2/P1 > 1 <=> log(P2/P1) > 0
Le gain des amplificateurs est positif.

P2/P1 < 1 est le cas général des lignes de transmission et des filtres
à cause de la déperdition de puissance interne.
Dè lors, P2/P1 <1
Pour x<1 log(x) <0 <=> log(P2/P1) < 0
Le gain est négatif.
Par exemple, si G = - 3dB
On peut dire que l'atténuation est de 3dB.

Mais pour la plupart des quadripôles
l'amplification, donc le gain, varient en fonction de la fréquence !

Voici un cas typique de "courbe de réponse", (ou "réponse" tout-court) d'un quadripôle.

En abscisses la fréquence f.
En ordonnées le "transfert de tension" T = Us/Ue
Il s'agit du rapport : (Tension de sortie) /( Tension d'enrée).
Ce que l'on appelle "Amplification de tension".

Terme malencontreux s'il s'agit d'un quadripôle passif qui atténue plutôt qu'il n' amplifie.
mis apparemment, on s'en accomode.

Bande passante à -3 dB.
Plage des fréquences pour lesquelles l'amplicifation en puissance est supérieure à 0,5 = 1/2.

Pour des raisons pratiques [image] , la bande passante est un paramètre important dans l'étude des quadripôles.

On l'appelle aussi :
Bande passante à demie-puissance
ou
Bande passante à -3dB.
Car si : P2/P3 =1/2 alors : 10 log(P2/P1) = 10log-(1/2) = - 3 dB

Or, la courbe représente le rapport des tensions sotrie/entrée,
pas des puissances Ps ni Pe !.

Mais...

Pour diviser P par deux il faut diviser U par racine carrée de 2.

Le transfert de tension correspondant à la demie-puissance est

Fréquences de coupure
Ce sont les fréquences extrêmes où la courbe de transfert croise le seuil à -3 dB
Fcb et Fch sont dites, respectivement, fréquence de coupure basse et haute .

B = Fch- Fcb
B en Hz

Une bande passante (à -3 dB, généralement sous-entendu)
se mesure naturellement en Hz ou multiples.

Pente d'atténuation
(dB/octave)

La raideur des flancs de la courbe de transfert est un paramètre important dans les filtres.
En radiodiffusion, par exemple, mais aussi en téléphonie,
Ils permettent, d'autant mieux qu'ils sont sont raides :

  • en radio de syntoniser un émetteur parmi tous les autres.
  • en téléphonie de séparer les canaux dans un multiplex.
  • en électronique d'éliminer des fréquences parasites.
  • etc.

On définit leur " raideur " par le nombre de décibels perdus ou gagnés par octave 'ou par décade.

Deux fréquences sont dites "à l'intervalle d'une octave si elles sont dans un rapport 2.
Une décade si ce rapport est 10.

Supposons deux fréquences f1 et f2 situées dans le flanc montant de la courbe de transfert.

Supposons que f2 =2xf1
(f1 est alors dit à un intervalle à l'octave supérieure df2)

Si passant de f1 à f2 le transfert croît de 2 dB
la pente d'atténuation de la courbe est de 2dB par octave.

On dirait : "de 2 dB par décade" si f2 = f1 [image] 10.

Autres applications des décibels

Toutes sont des variantes de la formule

lorsque l'on donne une valeur particulièe à P1, puissance de référence.

Cette puissance de référence P1 est généralement, suivant la technique,
la puissance considérée par consensus international et intraprofessionnel comme minima de référence de la grandeur étudiée,

Les techniques qui utilisent les décibels, sont très très diverses.
Acoustique, physiologie, etc.

On se reportera aux manuels de ces techniques les concernant

Bruit en dB :

La puissance sonore (en mW) qui correspond à 0 dB résulte d'une convention internationale.
C'est la puissance considérée comme minima de perception par un échantillon moyen de population.

Cette définition est très arbitraire et dépend à la fois des conditions de vie des personnes (campagne calme ou ville bruyante) et du type de bruit considéré (stridences, bruit sourd des autos, pétarades etc.).

Si bien que l'on dispose de diverses normes légales pour définir avec précision et sans contestation possible à la fois le 0 dB et les conditions de mesure des bruits dans chaque catégorie d'application : normes A, B, C etc.

Se reporter aux texte officiels.

Exercices
Question 13
Un avion émet 120 dB au décollage,
combien de dB émettent deux avions identiques décollant ensemble ?

Question 14
 Si on évalue la puissance sonore S d’une grosse moto à 87 dB.
Quelle est, en décibels, le niveau sonore produit par une bande de 8 motards
roulant sur des motos identiques et circulant à la même vitesse ?
Question 15
Dans le cas de exercice sur les motos précédent, quel est le rapport
de la puissance sonore P produite par la bande des potards à la puissance sonore Ps de référence ?

Antennes

Pour finir notre rapide tour d'horizon, nous citons une application d'un autre type : la mesure de l'efficacité d'un dispositif.

Une antenne (de télévision, par exemple) ne comporte primitivement aucun dispositif d'amplification.
Cependant, certains modèles peuvent fournir des tensions de capture des émetteurs plus ou moins élevée suivant sa géométrie particulière (nombre & forme des éléments).

On définit une antenne 0dB de géométrie simple et facilement reproductible (segment de conducteur rectiligne dont les dimensions sont précisées) que l'on branche sur l'impédance caractéristique (75 Ohm en France).

Cette antenne fournit une tension mesurable en on peut la comparer, en un même lieu, à tout autre type d'antenne utilisée dans les mêmes conditions.

Comme l'appareil est destiné en fin de chaîne à la perception audiovisuelle humaine, la comparaison ne se fait ni en rapports de tension, ni en rapports de puissance mais en dB.

Efficacité en dB = 20 log( UAntenneTestée / UAntenneNormalisée 0 dB)


Gain/loss as a ratio (out/in) | Gain/loss as a factor | Gain/loss in dB Field sizes (Voltage gain) | Gain/loss in dB Energy sizes (Power gain)
10,000:1 | 10,000 | +80.00 dB | +40.00 dB
1,000:1 | 1,000 | +60.00 dB | +30.00 dB
100:1 | 100 | +40.00 dB | +20.00 dB
10:1 | 10 | +20.00 dB | +10.00 dB
5:1 | 5 | +13.98 dB | +6.99 dB
4:1 | 4 | +12.04 dB | +6.02 dB ●
2:1 | 2 | +6.02 dB ● | +3.01 dB
1:1 | 1 | 0,00 dB | 0.00 dB
1:2 | 0.5 | −6.02 dB ● | −3.01 dB
1:4 | 0.25 | −12.04 dB | −6.02 dB ●
1:5 | 0.2 | −13.98 dB | −6.99 dB
1:10 | 0.1 | −20.00 dB | −10.00 dB
1:100 | 0.01 | −40.00 dB | −20.00 dB
1:1,000 | 0.001 | −60.00 dB | −30.00 dB
1:10,000 | 0.0001 | −80.00 dB | −40.00 dB

rapport deciBel
Gain en tension < > dB
Calculatrice inter-active, entrez une des valeurs .. en dB ou le rapport
rapport deciBel
Gain en Puissance < > dB
Power Ratio | dB
Pout/Pin | 10 log(Pout/Pin)
10 000 000 000 | 100
1 000 000 000 | 90
100 000 000 | 80
10 000 000 | 70
1 000 000 | 60
100 000 | 50
10 000 | 40
1 000 | 30
100 | 20
10 | 10
4 | 6
2 | 3
1.26 | 1
1 | 0
0.79 | -1
0.5 | -3
0.25 | -6
0.1 | -10
0.01 | -20
0.001 | -30
0.000 1 | -40
0.000 01 | -50
0.000 001 | -60
0.000 000 1 | -70
0.000 000 01 | -80
0.000 000 001 | -90
0.000 000 000 1 | -100

Voltage or Current Ratio | dB
Vout/Vin or Iout/Iin | 20log(Vout/Vin) 20log(Iout/Iin)
100 000 | 100
31 623 | 90
10 000 | 80
3 162 | 70
1 000 | 60
316.23 | 50
100 | 40
31.623 | 30
10 | 20
3.162 | 10
2 | 6
1.414 | 3
1.122 | 1
1 | 0
0.891 | -1
0.707 | -3
0.5 | -6
0.316 2 | -10
0.1 | -20
0.031 62 | -30
0.01 | -40
0.003 162 | -50
0.001 | -60
0.000 316 2 | -70
0.000 1 | -80
0.000 0316 2 | -90
0.000 01 | -100
Le décibel comme repère d'une grandeur

Jusqu'ici, les décibels on servi à mesurer des variations d'une grandeur.

Ils peuvent servir à repérer le niveau d'une grandeur physique par rapport à un repère appelé 0 dB et choisi par pure convention.

En téléphonie
Il est convenu que le 0 dB correspond à un signal sinusoïdal
transférant une puissance de 1 mW
à une résistance de 600 W (impédance d'un appareil téléphonique normalisé)
à une fréquence de 800 Hz.


Vu dans ... http://www.giangrandi.ch/electronics/anttool/decibel.shtml

Power and amplitude: Watts, Volts and referenced Decibels

Introduction

In radio frequency applications (but also in a lot of other application) is very common to deal with very large and very small signals. For example, a transceiver may transmit a power of 100 W and receive only 10 fW (or 0.000'000'000'000'01 W). These extremely different power levels may share the same circuits. Of course, these figures can be expressed in Watts using the engineering notation (as above) or with the scientific notation, like 1·102 W and 1·10–14 W, but they are quite difficult to pronounce and if the exponent is misspelled, the resulting error will be huge.

Another way is to take the logarithm and convert all the powers in dBm. 100 W become +50 dBm and 10 fW become –110 dBm: these figures are much easier to handle by heart and to write. Then, if attenuation and gain of different circuit blocks are also expressed in dB, to find the final power, one can simply add everything together instead of multiplying, further simplifying calculations.

Not everybody is comfortable with dB, dBm and similar (pseudo) units: there is no strict need to use them, but they are so widely used in engineering that is very difficult to avoid them.

Some theory

Decibels (dB) are used to express power ratios in a logarithmic way, so that very large and very small powers can be compared using comfortable numbers. A decibel is a dimensionless pseudo-unit because it's defined by the ratio of two powers. But since decibels are so handy, to express true power instead of just a dimensionless ratio, referenced decibels are very often used.

If we talk about power, the following equation defines the power level P in dB of the power p in W referenced to the power p0:

P = 10 log_10 (p / p_0)

The 10 factor is because decibels are "tenth of Bells". But I never heard of any measurement done in Bells, only decibels are used.

The most common unit is the dBm (pronounce "d-B-m") also known as dBmW or decibel-milliwatt: it's just the power level in dB compared to a reference power of p0 = 1 mW. Sometimes also dBW are used and they express the power ratio relative to p0 = 1 W, but they are not very common.

dBm and dBW as a function of mW

As shown in the above plot, the logarithmic effect of the decibel conversion is quite evident. As one can see on this log-lin plot, dBm and dBW are just two straight lines separated by 30 dB: to convert dBm into dBW simply subtract 30.

In some domains, like analog TV reception, it's common to measure voltage instead of power. This is not a problem as long as the impedance is known and fixed (TV receivers usually use 75 Ω).

Absolute voltages can also take advantage of the decibel logarithmic scale by using decibel-microvolt (dBμV) and decibel-volts (dBV). The most common is the dBμV which express the voltage ratio relative to u0 = 1 μV. Sometimes dBV are also used and they express the voltage ratio relative to u0 = 1 V.

U = 20 log_10 (u / u_0)

Beware that voltages use a "20" instead of a "10" in their dB formula. This is because decibels are always defined as power rations; if we only have voltages, we have to square them first to find the power. That power of two, when taken out of the logarithm will multiply the existing factor of 10 by 2.

dBuV and dBV as a function of V

As shown in the above plot and in a similar way as before, the logarithmic effect of the decibel conversion is quite evident also for voltages. As one can see on this log-lin plot, dBμV and dBV are just two straight lines separated by 120 dB: to convert dBμV into dBV simply subtract 120.

Now, if we want to convert from power to voltage and vice versa, we need to know the impedance. We just use the following equation:

p = u^2 / Z_c

This conversion is only valid when the impedance Zc is real and the load is matched to the transmission line.

If we plot the power level in dBm and the amplitude level in dBμV as a function of power in W for a given impedance (here Zc = 50 Ω) we get the following:

dBm and dBuV as a function of W, when Zc = 50 Ohms

As before, we have two parallel lines 107 dB apart.
So, to convert from dBm to dBμV, simply add 107 dB for
Zc = 50 Ω, add 109 dB for
Zc = 75 Ω, add 115 dB for
Zc = 300 Ω or add 118 dB for
Zc = 600 Ω.

Practical considerations

At first glance, one may think that because of the logarithm, a pocket calculator is absolutely necessary to deal with dBm. Actually, a rough calculation can easily be done in your head. You have to remember just three facts:

  • A power of 1 mW is 0 dBm.
  • Every time the power doubles, add 3 dB.
  • Every time the power increases by a factor of 10, add 10 dB.

Now, let's consider a few examples: suppose we have a power level of 26 dBm. We can write 26 dBm = 0 dBm + 10 dB + 10 dB + 3 dB + 3 dB, and with the previous three simples rules, we can easily find the power by doing 1 mW · 10 · 10 · 2 · 2 = 400 mW.

Another example: suppose we have –33dBm: we can write as –33 dBm = 0 dBm – 10 dB – 10 dB – 10dB – 3 dB, and we find 1 mW / 10 / 10 / 10 / 2 = 0.5 μW.

This works also in the in other way around, for example 50 mW are just 1 mW · 10 · 10 / 2. In dBm we have 0 dBm + 10 dB + 10 dB –3 dB = 17 dBm.

This requires some practice but is very easy to do. It's not as accurate as a pocket calculator because you can only be accurate at ±2 dB but, for the effort, gives a very good idea of the strength of a signal.

A similar method also works for dBμV, but the rules are different:

  • An amplitude of 1 μV is 0 dBμV.
  • Every time the amplitude doubles, add 6 dB.
  • Every time the amplitude increases by a factor of 10, add 20 dB.

You may be surprised about the calculations in decibels shown before, where dB are added to dBm, which is quite strange. This is because decibels are pseudo-units and do not behave as usual. The ratio of two powers is expressed in dB but is dimensionless: for example 3 dB only means "twice as much". The power expressed in dBm is really a power: for example 10 dBm means "10 times stronger than 1 mW", which is 10 mW.

Now, when you add decibels (dB, dBm,...), because of their logarithmic nature, you are actually multiplying the original figures together. So, if you add a gain of 3 dB to a power of 10 dBm, you obtain 13 dBm. But what you really did, is multiplying a factor of 2 with a power of 10 mW obtaining 20 mW, which is 13 dBm!

So far so good, adding is much easier to do in your head than multiplying, and this makes decibels so handy. But there is a problem: since adding decibels together correspond to multiplying the original factors, how can one add (combine) the power of two signals? Well, you can't. You can't add dBm to dBm. If, for example, you have a circuit or a device that combines the power of one signal of 10 dBm (10 mW) with the power of another signal of 13 dBm (20 mW), the result is 10 mW + 20 mW = 30 mW which is 14.8 dBm. There is no way of doing this directly in dBm, you have to convert both powers in Watts, add them together and convert them back in dBm. This is a big limitation of decibels and a common pitfall; fortunately this operation is not very common.

Power-amplitude calculator abc

Power : | p = | W
 | P = | dBm
 | P = | dBW
Impedance : | Zc = | Ω
Amplitude : | u = | V
 | U = | dBμV
 | U = | dBV

All the above calculations are automated in this simple tool: just enter one value (either in W, dBm, dB, V, dBμV or dBV) and click the "Convert" button next to it to compute the other values. To convert from power to amplitude and vice versa, the impedance must be entered. If you're just converting powers or amplitudes, you can leave the impedance blank.

An example

Let's have a look at the dial of the HP-435B power meter shown below:

The dial of an HP-435B power meter.

The range switch (not visible in the picture) is set to "1 mW / 0 dBm", so that we read –2.5 dBm and 0.56 mW. Of course, with the calculator, we find that –2.5 dBm correspond to 0.56 mW.

Bibliography and further reading

[1] P.-G. Fontolliet. Traité d'Électricité, Vol. XVIII: Systèmes de télécommunications. Presses Polytechniques et Universitaires Romandes, 1996, Chapter 2.
Home Electronics Index Page hits: 097275 Created: 09.2000 Last update: 05.2017


L’alphabet grec, une étape clé

Vu dans ... https://www.egyptos.net/egyptos/histoire/dossier-ecriture-3-alphabet-grec-une-etape-cle.php

L’apparition de l’alphabet grec est un tournant dans l’histoire de l’écriture ! Il est en effet le premier à intégrer des voyelles. C’est également à cette période que le concept de majuscule et de minuscule est apparu. L’apport non négligeable de cette culture mérite donc que l’on s’y attarde.

Comme cela a déjà été évoqué, l’alphabet grec dérive de celui employé auparavant par les phéniciens. Ce dernier est composée de 22 lettres, toutes des consonnes, et s’écrivait de droite à gauche.

Alphabet phénicien

La langue phénicienne était quasiment identique à celle des Cananéens ; un peuple qui vivait au niveau de l’Israël actuel et d’une partie de la Jordanie. Certains voient d’ailleurs le phénicien comme un dialecte du cananéen. Cela dit, les différences étant tellement infimes, beaucoup considèrent que les deux peuples parlaient et écrivaient la même langue.

Mais c’est au niveau de l’évolution de ce groupe linguistique que réside tout l’intérêt. L’araméen en est un exemple. Cette écriture a dominé toutes les autres pendant des siècles dans la région du Proche-Orient. Elle fut entre autres la langue écrite en Palestine lors des débuts du christianisme.

Livre écrit en araméen, retrouvé en Espagne et date du XIème siècle

En outre, l’araméen a été à l’origine de l’arabe, ou encore de l’hébreu. Cette dernière forme d’écriture est très intéressante car elle a conservé, sur certains points, des aspects du phénicien. Pour illustrer ce propos, voici un tableau comparatif présentant les deux premières lettres des alphabets phénicien et hébreu :

Celles-ci portent exactement le même nom en phénicien et en hébreu. Même si la graphie a légèrement évoluée entre les deux formes d’écriture, d’après le tableau, leur lien reste malgré tout très visible.

Mais revenons à la principale évolution : l’alphabet grec. Certaines lettres de la langue sémitique phénicienne d’origine ont été remplacées par des voyelles et d’autres ont été ajoutées (phi et psi par exemple). Il s’agissait en fait d’une nécessité pour retranscrire les langues européennes. Le résultat est un alphabet de 24 lettes qui inclut des majuscules et des minuscules : un concept tout à fait nouveau. Durant des siècles, cette civilisation a su adapter l’alphabet phénicien à sa convenance le rendant unique et novateur. On le voit nettement avec des lettres phéniciennes comme « beth » qui est devenue en grec « bêta » ou encore « daleph » qui est devenue « delta » et aussi « aleph » qui est devenue « alpha » etc… L’alpha qui est d’ailleurs l’héritier du célèbre « coup de glotte » des langues anciennes sémitiques ; notamment l’égyptien.

L’alphabet grec

Cet alphabet est probablement le premier à avoir été écrit de gauche à droite en Europe. Bien plus pratique et plus simple à reproduire, ce procédé s’est répandu très vite par le biais des différentes routes commerciales et a fini par être adopté, au détriment du phénicien d’origine. Suite aux conquêtes d’Alexandre le Grand, le phénomène s’amplifia encore. En effet, ce dernier apporta la culture grecque tout autour du bassin méditerranéen et même au-delà ! Cette influence culturelle, suivant l’endroit qu’elle touche, a donné lieu à l’apparition de multiples formes de langage. Par exemple :

  • En Egypte, l’influence du grec sur le démotique a donné le copte.

  • Au nord de l’Italie, le brassage a abouti à l’étrusque qui, lui-même, donnera l’alphabet latin que nous utilisons tous les jours.

    Tablette rédigée grâce à l’alphabet étrusque

    Cet alphabet comporte 26 lettres et le fait qu’il soit à l’origine du nôtre paraît assez net en regardant l’image. Comme à chaque fois, l’histoire se répète, après l’apparition du latin, l’étrusque commença peu à peu à disparaître, laissant place à sa forme plus évoluée.

  • Chez les slaves orthodoxes, le passage de la civilisation grecque permit le développement du cyrillique qui sera ensuite largement utilisé par les soviétiques..

    Exemple d’écriture utilisant l’alphabet cyrillique

    Il comporte 33 lettres et est principalement utilisé pour écrire le russe et d’autres langues slaves comme le serbe ou l’ukrainien. On pense qu’il a été élaboré par des disciples du frère Cyrille. Ce dernier aurait en fait développé la racine du cyrillique : l’alphabet glagolitique. Ce ne serait par conséquent qu'un de ses élèves qui serait à l'origine du célèbre alphabet des langues slaves. Certains pensent à Clément d'Okhrid qui est connu pour ses traductions grecques du glagolitique de Cyrille. Le cyrillique découlant du grec, le savant mélange a donné l'alphabet du même nom. Même si cela semble controversé, il est probable que, par respect pour leur maître, les disciples auraient donné son nom à ce qu’ils venaient de créer.

Vous constatez donc que le grec ancien est à l’origine des principales méthodes d’écriture de notre époque dans diverses régions du monde. Cependant, en Grèce même, il faut savoir que cet alphabet a lui aussi évolué puisque de nos jours, seul le grec moderne subsiste. Les différences sont surtout de l’ordre de la phonétique ainsi que de la grammaire. En effet, le nombre de lettres a été conservé : 24. Les différences sont plus ou moins similaires entre le vieux français et le français par exemple. Ainsi, les grecs de notre époque ne peuvent pas comprendre le grec ancien sans l’avoir étudié préalablement.

Néanmoins, l’utilisation du grec ancien n’a pas complètement disparu de nos jours. En effet, les lettres de cette langue sont toujours utilisées dans différents domaines scientifiques. Par exemple :

  • en mathématiques, on note « delta » majuscule (Δ) le discriminant permettant de résoudre des polynômes du second degré, « alpha » minuscule (α) pour la mesure d’un angle ou encore « sigma » majuscule (Σ) pour indiquer une somme…
  • en physique, on note « lambda » minuscule (λ) la mesure d’une longueur d’onde ou encore « nu » minuscule (ν) une fréquence.
  • en chimie, on note « sigma » minuscule (σ) une conductivité…

Ce ne sont bien sûr que quelques exemples, la liste étant très longue ! L’alphabet grec ancien est donc toujours largement utilisé, même s’il ne sert plus à l’expression quotidienne de tout un peuple. Il ne faut cependant pas perdre de vue que l’apport de la culture grecque dans l’écriture a permis de nombreuses évolutions, responsables de l’apparition des formes actuelles.


Alphabet grec LEXILOGOS >>

Vu dans ... https://www.lexilogos.com/grec_alphabet.htm

Alphabet grec
clavier grec ancien moderne
grec ancien > alphabet

Alphabet grec ancien

Α | α |  | άλφα | A | alpha
Β | β |  | βήτα | B | bêta
Γ | γ |  | γάμμα | G | gamma
Δ | δ |  | δέλτα | D | delta
Ε | ε |  | έψιλον | E | epsilon
Ζ | ζ |  | ζήτα | Z | zêta
Η | η |  | ήτα | Ê | êta
Θ | θ |  | θήτα | TH | thêta
Ι | ι |  | ιώτα | I | iota
Κ | κ |  | κάππα | K | kappa
Λ | λ |  | λάμβδα | L | lambda
Μ | μ |  | μυ | M | mu
Ν | ν |  | νυ | N | nu
Ξ | ξ |  | ξι | X | xi
Ο | ο |  | όμικρον | O | omicron
Π | π |  | πι | P | pi
Ρ | ρ |  | ρω | R | rhô
Σ | σ | ς | σίγμα | S | sigma
Τ | τ |  | ταυ | T | tau
Υ | υ |  | ύψιλον | U | upsilon
Φ | φ |  | φι | PH | phi
Χ | χ |  | χι | KH | khi
Ψ | ψ |  | ψι | PS | psi
Ω | ω |  | ωμέγα | Ô | ôméga
La lettre Γγ (Gamma) est transcrite par un n devant Γγ Κκ Ξξ Χχ
Il se prononce comme le -ng de parking
exemple : άγγελος [angelos] ange

La lettre Ζζ (zêta) se prononce habituellement dz (comme la prononciation de Zeus).
Cependant, cette lettre avait un son intermédiaire entre le dz et le z.

La lettre Ττ s'écrit ταυ [tau] : la diphtongue se prononce (comme l'anglais cow, vache)

La lettre Σ (Sigma) possède deux minuscules : σ en début ou milieu de mot & ς à la fin d'un mot
exemple : θάλασσα [thalassa] mer ; φάρος [pharos] : phare

Le grec ancien possédait à l'origine des e,o brefs et des e,o longs,
les voyelles brèves sont devenues à l'époque classique des voyelles fermées :
Εε se prononce é (voyelle fermée) comme été
Ηη se prononce ê (voyelle ouverte) comme être, aimant

Οο (omicron, c'est à dire petit o) est une voyelle fermée comme côte, saute
Ωω (ôméga, c'est à dire grand o) est une voyelle ouverte comme sotte
(on écrit habituellement : oméga)

Attention ! en français, la prononciation du o / ô est donc inversée.
Pour éviter les ambiguïtés, on transcrit aujourd'hui ces lettres ē et ō

Attention aux confusions possibles :
Ρρ (R) et Ππ (P, célèbre pour le symbole pi utilisé en mathématiques)
Χχ (Ch mais qui a donné le X latin) et Ξξ (X)
Ηη : le H latin est absent du grec, on trouve notamment dans Θθ (th) Φφ (ph) Χχ (kh)

La lettre Υυ se prononçait comme le u français et non comme le u latin [ou]. Ce son n'existant pas en latin, on a alors ajouté une lettre à l'alphabet latin, le y (i grec) qui se prononçait en latin comme le u français.

La prononciation scolaire du grec ancien ne respecte pas la véritable prononciation. Le h latin marque en réalité une aspiration. Ainsi, les lettres Θθ (th) Φφ (ph) Χχ (kh, transcrit en latin ch) sont des consonnes t, p, k aspirées.
Par facilité, nous les prononçons respectivement t, f, k.

La prononciation du grec moderne est différente du grec ancien. Cependant, les Grecs d'aujourd'hui prononcent le grec ancien comme ils prononcent le grec moderne.
Par exemple, pour les voyelles :
Les 3 lettres Ηη Ιι Υυ se prononcent de la même façon : i
Οο et Ωω se prononcent de la même façon : c'est un o ouvert
Εε est un e ouvert (ê).


Alphabet grec et prononciation

Vu dans ... http://oidipus.free.fr/grec/grec01.htm

Alphabet et prononciation

La langue qu'il est question d'étudier ici est le grec ancien c'est-à-dire la langue indo-européenne d'où vient, en droite ligne, le grec moderne, ou "les" grecs modernes (démotique, katharevousa, dialectes).

Les premiers documents écrits transcrivant la forme la plus ancienne du grec remontent à la seconde moitié du IIème millénaire avant notre ère, sous la forme des tablettes d'argile rédigées en linéaire B, retrouvées en Crète et dans différents sites mycéniens. Cette écriture non-alphabétique notait déjà une langue considérée comme une forme primitive du grec classique.

C'est vers le VIIIème siècle avant notre ère que l'on trouve les premiers documents écrits en grec avec l'alphabet que nous appelons "grec", adapté de celui des Phéniciens. La grande innovation de cet alphabet est de noter les voyelles, ce que le phénicien, langue sémitique, ne faisait pas.

On en arrive ainsi à un alphabet de vingt-quatre lettres, sept voyelles et dix-sept consonnes.

Ces 24 lettres considérées comme l'alphabet grec classique, ne l'ont constitué que vers la fin du Vème siècle. Jusqu'alors les valeurs de ces signes n'étaient pas exactement celles que nous leur attribuons à l'heure actuelle dans les études de lettres classiques en France. De même, certaines lettres ont appartenu à cet alphabet et en ont disparu en tant que lettres mais ont subsisté comme signes pour noter les adjectifs numéraux cardinaux.

L'usage scolaire et la pratique des éditions modernes veulent que l'on distingue majuscules et minuscules, pratique pourtant fort tardive, puisque datant, pour le grec, du début du IXème siècle ap. J.-C..

Dans le tableau suivant sont présentés dans l'ordre de l'alphabet grec, le nom donné à la lettre, sa graphie en majuscule, sa graphie en minuscule, un mot français permettant d'en restituer à peu près la prononciation, un mot grec faisant intervenir la lettre en question et dont généralement la racine se retrouve dans le mot français indiqué précédemment, et enfin la prononciation de la lettre en alphabet phonétique international. Il vous suffit de placer le pointeur de la souris au-dessus du mot grec pour en voir la traduction dans la barre d'état, en bas de votre écran.

Nom | MAJUSCULES | MINUSCULES | PRONONCIATION
Alpha | A | a | Athènes | aƒ 'AqÁnai, în | [a]
Bêta | B | b | Barbare | Ð b£rbaroj, ou | [b]
Gamma | G | g | Gorgone | ¹ Gorgè, oàj | [g]
Delta | D | d | Delta | tÕ dšlta | [d]
Epsilon | E | e | Epidaure | ¹ 'Ep…dauroj, ou | [e]
Dzêta | Z | z | Zeus | Ð ZeÚj, DiÒj | [dz]
Êta | H | h | Héraclès | Ð `HraklÁj, šouj | [E]
Thêta | Q | q | Théâtre | tÕ qšatron, ou | [th]
Iôta | I | i | Icare | Ð ”Ikaroj, ou | [i]
Kappa | K | k | Catabase | ¹ kat£basij, ewj | [k]
Lambda | L | l | Apollon | Ð 'ApÒllwn, wnoj | [l]
Mu | M | m | Minos | Ð M…nwj, woj | [m]
Nu | N | n | Nike | ¹ n…kh, hj | [n]
Xi (ksi) | X | x | Alexandre | Ð 'Alšxandroj, ou | [ks]
Omicron | O | o | Homère | Ð “Omhroj, ou | [o]
Pi | P | p | Paranormal | par£ | [p]
Rhô | R | r | Ornithorynque | tÕ ·Úgcoj, ouj | [{h]
Sigma | S | s, j | Socrate | Ð Swkr£thj, ouj | [s]
Tau | T | t | Titan | Ð Tit£n, ©noj | [t]
Upsilon | U | u | Upsilon | tÕ â yilÒn, ou | [y]
Phi | F | f | Stéphane | Ð stšfanoj, ou | [f]
Khi | C | c | Chronomètre | Ð crÒnoj, ou | [kh]
Psi | Y | y | Psychiatre | ¹ yuc», Áj | [ps]
Ôméga | W | w | Photographie | tÕ fîj, fwtÒj | []

Le grec connaît également le principe de la diphtongue et des combinaisons de voyelles pour former de nouveaux sons :

Les diphtongues
ai | [aj] | aƒ 'AqÁnai, wn | Athènes
ei | [ej] | ¹ e„kèn, Ònoj | l'image, la statue
oi | [oj] | oƒ b£rbaroi, wn | les barbares

Les bilitères vocaliques
au | [o] | ¹ aÙtonom…a, aj | l'autonomie
eu, hu | [O] | Ð 'OdusseÚj, šwj | Ulysse
ou | [u] | oÙde…j, oÙdem…a, oÙdšn | personne, aucun

La présence d'un m ou d'un n après une voyelle n'entraîne pas, à la différence de ce qui se produit en français, de nasalisation.

Par exemple :
an [an] t¾n ¹mšran

En revanche un g suivi d'un g, k, c ou x entraîne la nasalisation de la voyelle qui précède.

Par exemple
Ð ¥ggeloj, ou | [A)gelos] | le messager
¹ ¢n£gch, hj | [anA)kE] | la nécessité
¹ Sf…gx, SfiggÒj | [sfi)ks] | la Sphynge [le Sphinx]

La prononciation ici proposée est la prononciation qui a cours actuellement, en milieu scolaire, en France. Il s'agit d'une prononciation reconstituée à la Renaissance par le philologue Erasme qui lui a donné son nom, la prononciation érasmienne.

Cette prononciation est conventionnelle et ne rend compte que de manière très approximative de la manière dont les Grecs ont pu prononcer leur langue à un moment donné. En effet, par bien des aspects, la prononciation actuelle du grec moderne est beaucoup plus conforme à la prononciation que devaient déjà avoir les Grecs du IIIème siècle avant J.-C. que ne l'est la prononciation érasmienne. De nombreux chercheurs travaillent sur une restitution plus fidèle de la prononciation ancienne, mais les résultats de leurs travaux ne sont pas encore appliqués au sein de l'Education Nationale.

Le iota souscrit

Dans certains mots, et notamment pour certaines formes grammaticales (datif singulier, deuxième et troisième personnes des verbes contractes en -£w, ...), on note la présence d'un iota ( i) qui ne se prononçait déjà plus mais était resté comme marque orthographique.
Ce iota, au lieu d'être adscrit, c'est-à-dire écrit "à côté" de la lettre qui le précède, est souscrit, et donc inscrit "sous" la lettre en question. D'où les notations suivantes : v, V, J. Il s'agit en effet de l'évolution des trois diphtongues à premier élément long (a@i , hi, wi).
Lorsque la voyelle en question est une majuscule, le iota ne se prononce pas davantage, mais généralement redevient adscrit.

En résumé...

Le grec est une langue indo-européenne, notée à l'aide d'un alphabet de 24 lettres, 7 voyelles et 17 consonnes.
Certaines de ces lettres peuvent se combiner pour produire de nouveaux phonèmes.


Vu dans ... https://www.infoalfabetos.com/alfabeto/attachment/43

alfabeto-espanol-o-castellano

alfabeto-espan~ol-o-castellano "Missing"

alfabeto-braille

wsi-imageoptim

alfabeto-chino

alfabeto-cirilico

alfabeto-egipcio

alfabeto-griego

alfabeto-hebreo

alfabeto-japones

alfabeto-ruso

alfabeto-arabe

MORSE CODE Internatioal


MORSE CODE Internatioal


Vu dans ... http://mapage.noos.fr/r.ferreol/langage/mnemo.htm

ALPHABET MORSE (Mnémotechnique) E I S H t'es moche
E = .
I = ..
S = ...
H = ....
T = -
M = --
O = ---
CH = ---- Pour le reste, une syllabe sans O est courte, une syllabe avec O est longue.
A = allo (. -)
B = Bonaparte (- . . .)
C = coca-cola (- . - .)
D = docile (- . .)
F = farandole (. . - .)
G = gondole (- - .)
J = jablonovo ou jupon nouvo (. - - -)
K = koridor (- . -)
L = limonade (. - . .)
N = Noël (- .)
P = papou moche (. - - .)
Q = quoquorico (- - . -)
R = ramoneur (. - .)
U = urinoir (. . -)
V = Valparaiso (. . . -)
W = wagon-lits (. - - )
X = xtrocadéro (- . . -)
Y = yochimoto (- . - -)
Z = zologique ou Zoro est là(- - . .) :

On peut aussi retenir AUV NDB
A = .-
U = ..-
V = ...-
N = -.
D = -..
B = -...


Accueil

Accueil CHM

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Système binaire — Wikipédia

Système binaire

Un article de Wikipédia, l'encyclopédie libre.

Exemple d'informations binaires 0010111010100011011011111011011101010001101101110100011011011111011011101010001101110100011011011111011011101010001101

Le système binaire est un système de numération utilisant la base 2. On nomme couramment bit (de l'anglais binary digit, soit « chiffre binaire ») les chiffres de la numération binaire positionnelle. Ceux-ci ne peuvent prendre que deux valeurs, notées par convention 0 et 1.

C'est un concept essentiel de l'informatique. En effet, les processeurs des ordinateurs actuels sont composés de transistors ne gérant chacun que deux états.

Un calcul informatique n'est donc qu'une suite d'opérations sur des paquets de 0 et de 1, appelés octets lorsqu'ils sont regroupés par huit.

Définition

Le système binaire le plus courant est l'équivalent en base deux de la numération de position que nous utilisons en base dix dans la vie courante.

Dans ce type de codage, chaque nombre est représenté de façon unique par une suite ordonnée de chiffres. Et chaque chiffre représente une puissance de la base. Si on se limite dans un premier temps aux nombres entiers positifs, en base dix ces puissances sont : un (1), dix (représenté par 10), cent (dix fois dix, représenté par 100), mille (dix fois cent, représenté par 1000), dix mille etc. En base deux, ces puissances sont : un (1), deux (représenté lui aussi par 10), quatre (deux fois deux, représenté par 100), huit (deux fois quatre, représenté par 1000), seize (deux fois huit, représenté par 10000) etc.

On voit que la signification des représentations 10, 100, 1000, etc. dépend de la base utilisée : 10 est toujours égale à la base, c'est-à-dire dix en base dix, mais deux en base deux[1]

En base dix, on a besoin de dix chiffres, de zéro à neuf ; en base n, on a besoin de n chiffres, de zéro à n-1 ; et donc en base deux, on a besoin de deux chiffres : zéro et un.

Énumération des premiers nombres

Les premiers nombres, et chiffres de la base de numération 10, s'écrivent :

décimal | binaire | commentaire
0 | 0 | zéro
1 | 1 | un = base puissance zéro (valable pour toutes les bases, donc deux et dix)
2 | 10 | deux = deux puissance un (un zéro derrière le 1)
3 | 11
4 | 100 | quatre = deux puissance deux (deux zéro derrière le 1)
5 | 101
6 | 110
7 | 111
8 | 1000 | huit = deux puissance trois (trois zéro derrière le 1)
9 | 1001

Opérations

Les techniques des quatre opérations de base (addition, soustraction, multiplication et division) restent exactement les mêmes qu'en notation décimale, elles sont juste simplifiées de façon drastique parce qu'il n'y a que deux chiffres (zéro et un). Pour la multiplication par exemple, quelle que soit la base, la multiplication par 10 (c’est-à-dire par la base elle-même)[2] se fait en ajoutant un zéro à droite.

Seules changent d'une part la forme de la suite de chiffres qui exprime le résultat (elle ne compte que des zéros et un), d'autre part la signification de cette suite (10 signifie « deux » et non « dix », 100 signifie « quatre » et non « cent », etc.).

exemples : additions, soustractions

On passe d'un nombre binaire au suivant en ajoutant 1, comme en décimal, sans oublier les retenues et en utilisant la table ordinaire (mais réduite à sa plus simple expression) :

 0+0=0    0+1=1    1+0=1   1+1=0 avec 1 retenue
 0-0=0    0-1=1 avec 1 retenue   1-0=1   1-1=0

ainsi:

   11
+   1
 ____
  100

Détail :

1 + 1 = 10           => on pose 0 et on retient 1
1 + 1(retenue) = 10  => on pose 0 et on retient 1
0 + 1(retenue) = 1   => on pose 1 devant 00

Théorie informatique

L'arithmétique binaire (plus simplement le calcul binaire) est utilisé par les systèmes électroniques les plus courants (calculatrices, ordinateurs, etc.) car les deux chiffres 0 et 1 s'y traduisent facilement par la tension ou le passage d'un courant : 0 représentant l'état bas (tension ou courant nul) et 1 l'état haut (tension qui existe, courant qui passe).

Représentation des entiers négatifs

Pour compléter la représentation des entiers, il faut pouvoir écrire des entiers négatifs. La façon informatique de le faire est prévoir un bit de signe, placé en tête. Un bit de signe nul indique une valeur positive, un bit de signe positionné à 1 indique une valeur négative.

Les informaticiens utilisent deux représentations.

Complément à un

Ce codage, fort simple, consiste à inverser la valeur de chaque bit composant une valeur binaire.

Par exemple, pour obtenir -7 :

0111 valeur décimale 7
1000 complément à un

Dans ce système, la valeur 0 a deux représentations : « +0 » et « -0 » (dans notre exemple : 0000 et 1111), ce qui oblige à réaliser 2 tests pour tester la valeur nulle d'un résultat.

Article détaillé :

Complément à deux

Afin de pallier ce défaut, on a introduit la représentation par complément à deux. Celle-ci consiste à réaliser un complément à un de la valeur, puis d'ajouter 1 au résultat.

Par exemple pour obtenir -7:

0111 codage de 7 en binaire
1000 complément à un
1001 on ajoute 1 : représentation de -7 en complément à deux

Le zéro est représenté seulement par 0000

Ce codage a l'avantage de ne pas nécessiter de différenciation spéciale des nombres positifs et négatifs, et évite en particulier le problème d'ordinateurs anciens (Control Data 6600) qui avaient un « +0 » et un « -0 » dont il fallait faire comprendre aux circuits de tests que c'était le même nombre ! Voici une addition de -7 et +9 réalisée en complément à deux sur 4 bits :

-7        1001
+9        1001
__        ____
 2    (1) 0010     (on 'ignore' la retenue)

Avec n bits, ce système permet de représenter les nombres entre -2n-1 et 2n-1-1.

Entre les bases 2, 8 et 16

Du binaire vers octal ou hexadécimal

Les bases 8 (octale) et 16 (hexadécimale) sont des bases multiples de la base 2. Ces deux bases ont été couramment employées en informatique et pour des raisons pratiques; ces bases étant fortement liées à la base 2 et les nombres écrits dans ces bases étant plus « manipulables » (car d'écriture plus courte) par l'intellect humain. L'écriture de nombres dans ces bases est facilement obtenue par regroupement de chiffres de l'écriture du nombre en base 2.

  • Octal : base 8 { 8 = 2^3} . Il suffit de parcourir le nombre binaire de la droite vers la gauche en regroupant les chiffres binaires 3 par 3 : chaque paquet de 3 (le dernier devant être parfois complété par des 0 à gauche) est l'écriture binaire d'un chiffre en base 8 (08=000, 18=001, 28=010, 38=011, 48=100, 58=101, 68=110, 78=111).
    • 101011011102 va s'écrire 10 101 101 110 et en convertissant la valeur de chacun des blocs en un chiffre octal, on obtient le nombre octal 25568.
  • Hexadécimal : base 16 avec alt="16 = 2^4" Il suffit de parcourir le nombre binaire de la droite vers la gauche en regroupant les chiffres binaires par 4 par 4 : chaque paquet de 4 bits est la représentation binaire d'un chiffre en base 16. En base 16, il faut 16 symboles et conventionnellement, on utilise les 10 chiffres décimaux suivis des 6 premiers caractères de l'alphabet selon la règle suivante: A16=1010=10102, B16=1110=10112, C16=1210=11002, D16=1310=11012, E16=1410=11102 et F16=1510=11112.
    • 101011011102 va s'écrire 101 0110 1110 et en convertissant la valeur de chacun des blocs en décimal on obtient : 5, 6, 14 c'est-à-dire 56E16.

On pourrait facilement étendre ce principe à toutes les bases qui sont puissances de 2.

Vers le binaire

Il suffit de convertir la valeur de chacun des chiffres sous leur forme binaire.

  • 1A2F16 va s'écrire 1, 10=8+2, 2, 15=8+4+2+1 soit 0001 1010 0010 11112
  • 1568 va s'écrire 1, 5=4+1, 6=4+2 soit 1 101 1102

Table des valeurs des groupements de chiffres binaires

Binaire | Décimal | Octal | Hexadécimal
0000 | 0 | 0 | 0
0001 | 1 | 1 | 1
0010 | 2 | 2 | 2
0011 | 3 | 3 | 3
0100 | 4 | 4 | 4
0101 | 5 | 5 | 5
0110 | 6 | 6 | 6
0111 | 7 | 7 | 7

Binaire | Décimal | Octal | Hexadécimal
1000 | 8 | 10 | 8
1001 | 9 | 11 | 9
1010 | 10 | 12 | A
1011 | 11 | 13 | B
1100 | 12 | 14 | C
1101 | 13 | 15 | D
1110 | 14 | 16 | E
1111 | 15 | 17 | F

Code de Gray ou binaire réfléchi

Ce codage permet de ne faire changer qu'un seul bit à la fois quand un nombre est incrémenté ou décrémenté d'une unité.

Le code de Gray, également appelé binaire réfléchi, permet de ne faire changer qu'un seul bit à la fois quand un nombre est incrémenté ou décrémenté d'une unité. Le nom du code vient de l'ingénieur américain Frank Gray qui déposa un brevet sur ce code en 1947[3]. Monsieur Louis Gros publia, à Lyon, en 1872 un opuscule, Théorie du Baguenaudier, par un clerc de notaire lyonnais où ce code était présenté pour la première fois en lien avec un casse-tête[4]. Monsieur Gros fut clerc de notaire puis Conseiller à la Cour d'Appel de Lyon.

codage binaire classique |  | Codage Gray ou binaire réfléchi
0 | 0000 | 0 | 0000
1 | 0001 | 1 | 0001
2 | 0010 | 2 | 0011
3 | 0011 | 3 | 0010
4 | 0100 | 4 | 0110
5 | 0101 | 5 | 0111
6 | 0110 | 6 | 0101
7 | 0111 | 7 | 0100

Pour « calculer » directement le code de Gray d'un entier à partir de celui de son prédécesseur on peut procéder ainsi :

  • lorsqu'il y a un nombre pair de 1 on inverse le dernier bit
  • lorsqu'il y a un nombre impair de 1 on inverse le bit directement à gauche du 1 le plus à droite.

Le code de Gray est utilisé entre autres sur une roue codeuse.

Décimal codé binaire (« binary coded decimal », ou BCD)

Afin de concilier la logique binaire de l'ordinateur avec la logique humaine, on peut convertir en binaire, plutôt que les nombres eux-mêmes, chacun des chiffres qui les composent en notation décimale positionnelle. Chacun de ces chiffres est alors codé 4 bits :

1994 =  0001    1001   1001   0100
      1×1000 + 9×100 + 9×10 + 4×1

Avec n bits (n multiple de 4), il est possible de représenter les nombres entre 0 et 10n/4-1. Soit approximativement entre 0 et 1.778n-1. Le BCD est un code redondant, en effet certaines combinaisons ne sont pas utilisées (comme 1111 par exemple).

Cette représentation évite par construction tous les problèmes gênants de cumul d'arrondi qui interviendraient lors de la manipulation de grands nombres dépassant la taille des circuits en arithmétique entière et obligent à recourir au flottant. Il est cependant possible de manipuler des nombres à précision arbitraire en utilisant un codage plus efficace que le BCD.

Il existe des variantes du codage BCD :

  • code Aiken où 0, 1, 2, 3, 4 sont codés comme en BCD et 5, 6, 7, 8, 9 sont codés de 1011 à 1111. Il permet d'obtenir le complément à 9 en permutant les 1 et les 0.
  • codage binaire excédant 3 qui consiste à représenter le chiffre à coder + 3.
Article détaillé : Binary coded decimal.

Applications

Théorie de l'information

Article détaillé : Entropie de Shannon.

En théorie de l'information, l'entropie d'une source d'information est exprimée en bits. La théorie elle-même est indifférente à la représentation des grandeurs qu'elle utilise.

Logique 0

La logique classique est une logique bivalente: une proposition est soit vraie, soit fausse. Il est donc possible de représenter la vérité d'une proposition par un chiffre binaire. On peut par exemple modéliser les opérations de l'arithmétique binaire à l'aide de l'algèbre de Boole.

L'algèbre de Boole représente un cas très particulier d'usage des probabilités ne faisant intervenir que les seules valeurs de vérité 0 et 1. Voir Théorème de Cox-Jaynes.

Informatique

Le binaire est utilisé en informatique car il permet de modéliser le fonctionnement des composants de commutation comme le TTL ou le CMOS. La présence d'un seuil de tension aux bornes des transistors, en négligeant la valeur exacte de cette tension, représentera 0 ou 1. Par exemple le chiffre 0 sera utilisé pour signifier une absence de tension à 0,5V près, et le chiffre 1 pour signifier sa présence à plus de 0,5V. Cette marge de tolérance permet de pousser les cadences des microprocesseurs à des valeurs atteignant sans problème (hormis d'échauffement) plusieurs gigahertz.

En informatique, la représentation binaire permet de clairement manipuler des bits : chaque chiffre binaire correspond à un bit. Cependant, la représentation binaire nécessitant l'usage de beaucoup de chiffres (même pour des nombres assez petits), elle entraîne d'importants problèmes de lisibilité et donc de risques d'erreur de transcription pour les programmeurs. On préfère donc d'autres représentations : la notation hexadécimale, qui permet de manipuler l'information par paquets de 4 bits, est adaptée à la quasi-totalité des microprocesseurs actuels travaillant avec des mots de 8, 16, 32 ou 64 bits ; plus rare, la notation octale, populaire du temps des premiers mini-ordinateurs DEC à 12 ou 36 bits, qui permet de représenter l'information par paquets de 3 bits.

  • 63 (10) = 111111 (2) = 77 (8) = 3F (16)
  • 64 (10) = 1000000 (2) = 100 (8) = 40 (16)
  • 255 (10) = 11111111 (2) = 377 (8) = FF (16)
  • 256 (10) = 100000000 (2) = 400 (8) = 100 (16)